Wi-Fi isn't working anymore

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Siddhartha
Level 1
Level 1
Posts: 12
Joined: Sun Oct 07, 2018 7:22 am

Wi-Fi isn't working anymore

Post by Siddhartha » Sun Oct 07, 2018 7:38 am

Hey guys and girls,
so I used Linux Mint for quite a while now and I really like it, though I don't really have a clue about any of this "programming stuff". After I bought my Laptop I knew I had to make some fixes regarding to the Wi-Fi setup.
What I had to do was this:

Code: Select all

sudo modprobe -rv rtl8723be
sudo modprobe -v rtl8723be ant_sel=2
After this the Wi-Fi worked without a problem. Yesterday I found the Update Manager (didn't know there was such a thing ... :D) and downloaded and installed every update there was. Today my Wi-Fi isn't working anymore. Sometimes it shows some networks but the connection seems to be incredibly bad. I googled for the past hour and tried a bunch of commands, also the above and ant_sel=1 but it won't work. Anyone has a solution for this?
inxi -Fxz spits this out:

Code: Select all

System:    Host: valentin-HP-Notebook Kernel: 4.15.0-36-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.4.6 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.2 Sonya
Machine:   System: HP (portable) product: HP Notebook
           Mobo: HP model: 81E1 v: KBC Version 71.17
           Bios: Insyde v: F.23 date: 12/13/2016
CPU:       Dual core Intel Celeron N3060 (-MCP-) cache: 1024 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 6400
           clock speeds: max: 2480 MHz 1: 2138 MHz 2: 1117 MHz
Graphics:  Card: Intel Device 22b1 bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.01hz
           GLX Renderer: Mesa DRI Intel HD Graphics 400 (Braswell)
           GLX Version: 3.0 Mesa 18.0.5 Direct Rendering: Yes
Audio:     Card Intel Device 2284 driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-36-generic
Network:   Card-1: Realtek RTL8723BE PCIe Wireless Network Adapter
           driver: rtl8723be port: 2000 bus-ID: 02:00.0
           IF: wlp2s0 state: down mac: <filter>
           Card-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: 1000 bus-ID: 03:00.0
           IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 500.1GB (6.9% used)
           ID-1: /dev/sda model: TOSHIBA_MQ01ABF0 size: 500.1GB
Partition: ID-1: / size: 455G used: 29G (7%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 4.13GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 38.0C mobo: 0.0C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 171 Uptime: 5 min Memory: 1076.1/3786.8MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35
Last edited by Moem on Sun Oct 07, 2018 7:49 am, edited 1 time in total.
Reason: Adding [code] tags. They retain some formatting that makes your output easier to read.

Siddhartha
Level 1
Level 1
Posts: 12
Joined: Sun Oct 07, 2018 7:22 am

Re: Wi-Fi isn't working anymore

Post by Siddhartha » Mon Oct 22, 2018 8:24 am

Push

JeremyB
Level 19
Level 19
Posts: 9304
Joined: Fri Feb 21, 2014 8:17 am

Re: Wi-Fi isn't working anymore

Post by JeremyB » Mon Oct 22, 2018 10:36 am

It is a kernel bug, do the following in terminal one line at a time

Code: Select all

sudo apt-get install git build-essential dkms
git clone https://github.com/lwfinger/rtlwifi_new.git
sudo dkms add ./rtlwifi_new
sudo dkms install rtlwifi-new/0.6
Reboot and make sure secure boot is disabled in BIOS

Siddhartha
Level 1
Level 1
Posts: 12
Joined: Sun Oct 07, 2018 7:22 am

Re: Wi-Fi isn't working anymore

Post by Siddhartha » Mon Oct 22, 2018 12:03 pm

JeremyB wrote:
Mon Oct 22, 2018 10:36 am
It is a kernel bug, do the following in terminal one line at a time

Code: Select all

sudo apt-get install git build-essential dkms
git clone https://github.com/lwfinger/rtlwifi_new.git
sudo dkms add ./rtlwifi_new
sudo dkms install rtlwifi-new/0.6
Reboot and make sure secure boot is disabled in BIOS
I did it like that but now I don't have a Wi-Fi connection at all.
Attachments
Selection_002.jpg
Selection_002.jpg (1.94 KiB) Viewed 490 times

User avatar
trytip
Level 8
Level 8
Posts: 2400
Joined: Tue Jul 05, 2016 1:20 pm

Re: Wi-Fi isn't working anymore

Post by trytip » Mon Oct 22, 2018 1:22 pm

this would be a perfect time to restore a snapshot in Timeshift. not knowing what commands you ran or if they were permanent script or config changes no one would know how to resume your wifi, only you have that power now. that said mint updates shouldn't break things any more, so why does it?
run apt update in Terminal again and reboot first, when you get to the grub menu select the oldest kernel and boot with that to test if wifi is borken
Image

JeremyB
Level 19
Level 19
Posts: 9304
Joined: Fri Feb 21, 2014 8:17 am

Re: Wi-Fi isn't working anymore

Post by JeremyB » Mon Oct 22, 2018 1:41 pm

What happens if you

Code: Select all

sudo modprobe -v rtl8723be

JeremyB
Level 19
Level 19
Posts: 9304
Joined: Fri Feb 21, 2014 8:17 am

Re: Wi-Fi isn't working anymore

Post by JeremyB » Mon Oct 22, 2018 1:42 pm

trytip wrote:
Mon Oct 22, 2018 1:22 pm
this would be a perfect time to restore a snapshot in Timeshift. not knowing what commands you ran or if they were permanent script or config changes no one would know how to resume your wifi, only you have that power now. that said mint updates shouldn't break things any more, so why does it?
run apt update in Terminal again and reboot first, when you get to the grub menu select the oldest kernel and boot with that to test if wifi is borken
No need to do that as all they need to do is boot to an older kernel

Siddhartha
Level 1
Level 1
Posts: 12
Joined: Sun Oct 07, 2018 7:22 am

Re: Wi-Fi isn't working anymore

Post by Siddhartha » Wed Oct 24, 2018 2:50 pm

JeremyB wrote:
Mon Oct 22, 2018 1:41 pm
What happens if you

Code: Select all

sudo modprobe -v rtl8723be
This:

Code: Select all

insmod /lib/modules/4.15.0-36-generic/kernel/drivers/net/wireless/realtek/rtlwifi/rtl8723com/rtl8723-common.ko 
modprobe: ERROR: could not insert 'rtl8723be': Unknown symbol in module, or unknown parameter (see dmesg)

JeremyB
Level 19
Level 19
Posts: 9304
Joined: Fri Feb 21, 2014 8:17 am

Re: Wi-Fi isn't working anymore

Post by JeremyB » Wed Oct 24, 2018 4:53 pm

What is result for

Code: Select all

dmesg | egrep 'rtl|8723'; modinfo rtl8723be

Siddhartha
Level 1
Level 1
Posts: 12
Joined: Sun Oct 07, 2018 7:22 am

Re: Wi-Fi isn't working anymore

Post by Siddhartha » Sat Oct 27, 2018 12:23 pm

JeremyB wrote:
Wed Oct 24, 2018 4:53 pm
What is result for

Code: Select all

dmesg | egrep 'rtl|8723'; modinfo rtl8723be

Code: Select all

[   22.320354] rtlwifi: loading out-of-tree module taints kernel.
[   22.324816] rtlwifi: module verification failed: signature and/or required key missing - tainting kernel
[   22.354931] Bluetooth: hci0: rtl: examining hci_ver=06 hci_rev=000b lmp_ver=06 lmp_subver=8723
[   22.354938] Bluetooth: hci0: rtl: loading rtl_bt/rtl8723b_config.bin
[   22.389280] bluetooth hci0: Direct firmware load for rtl_bt/rtl8723b_config.bin failed with error -2
[   22.389290] Bluetooth: hci0: rtl: loading rtl_bt/rtl8723b_fw.bin
[   22.792057] rtl8723_common: Unknown symbol rtl_fw_page_write (err 0)
[   22.796287] rtl8723_common: Unknown symbol rtl_fill_dummy (err 0)
filename:       /lib/modules/4.15.0-36-generic/updates/rtl8723be.ko
firmware:       rtlwifi/rtl8723befw_36.bin
firmware:       rtlwifi/rtl8723befw.bin
description:    Realtek 8723BE 802.11n PCI wireless
license:        GPL
author:         Realtek WlanFAE	<wlanfae@realtek.com>
author:         PageHe	<page_he@realsil.com.cn>
srcversion:     1B45BB96576F0C4D6674527
alias:          pci:v000010ECd0000B723sv*sd*bc*sc*i*
depends:        rtlwifi,rtl8723-common,rtl_pci,btcoexist,mac80211
retpoline:      Y
name:           rtl8723be
vermagic:       4.15.0-36-generic SMP mod_unload 
parm:           swenc:Set to 1 for software crypto (default 0)
 (bool)
parm:           ips:Set to 0 to not use link power save (default 1)
 (bool)
parm:           swlps:Set to 1 to use SW control power save (default 0)
 (bool)
parm:           fwlps:Set to 1 to use FW control power save (default 1)
 (bool)
parm:           msi:Set to 1 to use MSI interrupts mode (default 0)
 (bool)
parm:           debug:Set debug level (0-5) (default 0) (int)
parm:           disable_watchdog:Set to 1 to disable the watchdog (default 0)
 (bool)
parm:           ant_sel:Set to 1 or 2 to force antenna number (default 0)
 (int)

JeremyB
Level 19
Level 19
Posts: 9304
Joined: Fri Feb 21, 2014 8:17 am

Re: Wi-Fi isn't working anymore

Post by JeremyB » Sat Oct 27, 2018 12:32 pm

See the wireless script link in my signature and post results, also do

Code: Select all

cd ~/rtlwifi_new && git status

Siddhartha
Level 1
Level 1
Posts: 12
Joined: Sun Oct 07, 2018 7:22 am

Re: Wi-Fi isn't working anymore

Post by Siddhartha » Sun Oct 28, 2018 4:22 am

JeremyB wrote:
Sat Oct 27, 2018 12:32 pm
See the wireless script link in my signature and post results, also do

Code: Select all

cd ~/rtlwifi_new && git status
http://termbin.com/0nyl

Code: Select all

On branch master
Your branch is up-to-date with 'origin/master'.
nothing to commit, working directory clean

JeremyB
Level 19
Level 19
Posts: 9304
Joined: Fri Feb 21, 2014 8:17 am

Re: Wi-Fi isn't working anymore

Post by JeremyB » Sun Oct 28, 2018 6:56 am

What about

Code: Select all

modinfo rtl8723_common

Siddhartha
Level 1
Level 1
Posts: 12
Joined: Sun Oct 07, 2018 7:22 am

Re: Wi-Fi isn't working anymore

Post by Siddhartha » Sun Oct 28, 2018 1:34 pm

JeremyB wrote:
Sun Oct 28, 2018 6:56 am
What about

Code: Select all

modinfo rtl8723_common

Code: Select all

filename:       /lib/modules/4.15.0-36-generic/kernel/drivers/net/wireless/realtek/rtlwifi/rtl8723com/rtl8723-common.ko
description:    Realtek RTL8723AE/RTL8723BE 802.11n PCI wireless common routines
license:        GPL
author:         Larry Finger	<Larry.Finger@lwfinger.net>
author:         Realtek WlanFAE	<wlanfae@realtek.com>
srcversion:     90DB9C652E26F4135F339B8
depends:        rtlwifi
retpoline:      Y
intree:         Y
name:           rtl8723_common
vermagic:       4.15.0-36-generic SMP mod_unload 

JeremyB
Level 19
Level 19
Posts: 9304
Joined: Fri Feb 21, 2014 8:17 am

Re: Wi-Fi isn't working anymore

Post by JeremyB » Sun Oct 28, 2018 2:14 pm

What about

Code: Select all

ls /lib/modules/4.15.0-36-generic/updates/

Siddhartha
Level 1
Level 1
Posts: 12
Joined: Sun Oct 07, 2018 7:22 am

Re: Wi-Fi isn't working anymore

Post by Siddhartha » Mon Oct 29, 2018 4:13 am

JeremyB wrote:
Sun Oct 28, 2018 2:14 pm
What about

Code: Select all

ls /lib/modules/4.15.0-36-generic/updates/

Code: Select all

btcoexist.ko    rtl8192c-common.ko  rtl8192de.ko  rtl8723ae.ko  rtl_pci.ko
ndiswrapper.ko  rtl8192ce.ko        rtl8192ee.ko  rtl8723be.ko  rtl_usb.ko
rtl8188ee.ko    rtl8192cu.ko        rtl8192se.ko  rtl8821ae.ko  rtlwifi.ko

JeremyB
Level 19
Level 19
Posts: 9304
Joined: Fri Feb 21, 2014 8:17 am

Re: Wi-Fi isn't working anymore

Post by JeremyB » Mon Oct 29, 2018 4:23 am

Try

Code: Select all

sudo cp ~/rtlwifi_new/rtl8723com/rtl8723-common.ko /lib/modules/4.15.0-36-generic/updates/

Code: Select all

sudo depmod -a
Reboot

Siddhartha
Level 1
Level 1
Posts: 12
Joined: Sun Oct 07, 2018 7:22 am

Re: Wi-Fi isn't working anymore

Post by Siddhartha » Mon Oct 29, 2018 10:14 am

JeremyB wrote:
Mon Oct 29, 2018 4:23 am
Try

Code: Select all

sudo cp ~/rtlwifi_new/rtl8723com/rtl8723-common.ko /lib/modules/4.15.0-36-generic/updates/

Code: Select all

sudo depmod -a
Reboot
The first command doesn't seem to work:

Code: Select all

sudo cp ~/rtlwifi_new/rtl8723com/rtl8723-common.ko /lib/modules/4.15.0-36-generic/updates/
[sudo] password for valentin: 
cp: cannot stat '/home/valentin/rtlwifi_new/rtl8723com/rtl8723-common.ko': No such file or directory

JeremyB
Level 19
Level 19
Posts: 9304
Joined: Fri Feb 21, 2014 8:17 am

Re: Wi-Fi isn't working anymore

Post by JeremyB » Mon Oct 29, 2018 10:37 am

Code: Select all

cd ~/rtlwifi_new
make
sudo cp ~/rtlwifi_new/rtl8723com/rtl8723-common.ko /lib/modules/4.15.0-36-generic/updates/
sudo depmod -a
I am not sure why it didn't copy that module automatically

Siddhartha
Level 1
Level 1
Posts: 12
Joined: Sun Oct 07, 2018 7:22 am

Re: Wi-Fi isn't working anymore

Post by Siddhartha » Mon Oct 29, 2018 12:53 pm

JeremyB wrote:
Mon Oct 29, 2018 10:37 am

Code: Select all

cd ~/rtlwifi_new
make
sudo cp ~/rtlwifi_new/rtl8723com/rtl8723-common.ko /lib/modules/4.15.0-36-generic/updates/
sudo depmod -a
I am not sure why it didn't copy that module automatically
Okay, the WiFi-Symbol is back but I don't see any connections. What now?

Post Reply

Return to “Wireless”