[SOLVED] Wi-Fi not working on ThinkPad SL510

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
jackerbes
Level 3
Level 3
Posts: 147
Joined: Fri Jul 03, 2015 8:37 am

[SOLVED] Wi-Fi not working on ThinkPad SL510

Post by jackerbes » Sun Nov 04, 2018 9:40 am

I recently copied my LM19 install from a Toshiba laptop to a Lenovo ThinkPad laptop. The new laptop had a W7 install on it and I used clonezilla to copy root and home images to new partitions and then running the LM19 install from a USB stick to get the grub and dual boot working. All my data appears to have been transferred to the new laptop successfully.

Both wireless and ethernet are working on the W7 install, only ethernet works on the LM19 install. I see this for networking from the terminal with inxi -Fzx

Code: Select all

Network:   Card-1: Intel Centrino Wireless-N 1000 [Condor Peak]
           bus-ID: 05:00.0
           IF: N/A state: N/A mac: N/A
           Card-2: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169 port: 3000 bus-ID: 08:00.0
           IF: enp8s0 state: up speed: 100 Mbps duplex: full mac: <filter>
I am no longer seeing any wi-fi connections being offered from the icon in the panel where I used to see and choose my home network wi-fi connection from. It only shows an ethernet connection.

I wonder if there is some way to erase and replace or update all the hardware info that relates to the wi-fi hardware in this SL510.

Any suggestions are appreciated...

Jack
Last edited by jackerbes on Sun Nov 04, 2018 12:55 pm, edited 2 times in total.
Mint 18.3 and 19, 64-bit, Cinnamon, Lenovo ThinkPad SL510 laptop, ASUS Z-97 desktop, Samsung S6 Android phone
Jack Erbes in Ellsworth, ME, USA

JeremyB
Level 19
Level 19
Posts: 9460
Joined: Fri Feb 21, 2014 8:17 am

Re: Wi-Fi not working on ThinkPad SL510

Post by JeremyB » Sun Nov 04, 2018 9:46 am

See the wireless script link in my signature and post results

jackerbes
Level 3
Level 3
Posts: 147
Joined: Fri Jul 03, 2015 8:37 am

Re: Wi-Fi not working on ThinkPad SL510

Post by jackerbes » Sun Nov 04, 2018 9:55 am

Thanks for the reply, here is the URL:

http://termbin.com/smwz

Jack
Mint 18.3 and 19, 64-bit, Cinnamon, Lenovo ThinkPad SL510 laptop, ASUS Z-97 desktop, Samsung S6 Android phone
Jack Erbes in Ellsworth, ME, USA

JeremyB
Level 19
Level 19
Posts: 9460
Joined: Fri Feb 21, 2014 8:17 am

Re: Wi-Fi not working on ThinkPad SL510

Post by JeremyB » Sun Nov 04, 2018 9:59 am

What is the result for

Code: Select all

dpkg -l | grep 4.15.0-38

jackerbes
Level 3
Level 3
Posts: 147
Joined: Fri Jul 03, 2015 8:37 am

Re: Wi-Fi not working on ThinkPad SL510

Post by jackerbes » Sun Nov 04, 2018 11:44 am

I don't see any result for that command:

Code: Select all

jack@jack-SL510:~$ dpkg -l | grep 4.15.0-38
jack@jack-SL510:~$ 
Tried it with and without su...

Jack
Mint 18.3 and 19, 64-bit, Cinnamon, Lenovo ThinkPad SL510 laptop, ASUS Z-97 desktop, Samsung S6 Android phone
Jack Erbes in Ellsworth, ME, USA

JeremyB
Level 19
Level 19
Posts: 9460
Joined: Fri Feb 21, 2014 8:17 am

Re: Wi-Fi not working on ThinkPad SL510

Post by JeremyB » Sun Nov 04, 2018 11:49 am

Try

Code: Select all

sudo apt install --reinstall linux-image-generic
reboot

jackerbes
Level 3
Level 3
Posts: 147
Joined: Fri Jul 03, 2015 8:37 am

Re: Wi-Fi not working on ThinkPad SL510

Post by jackerbes » Sun Nov 04, 2018 12:51 pm

Whoopee! You fixed it!

Got a new menu and was able to enable wifi from there, and then I got my normal menu back, connected, all is working fine.

Can you tell me, in layman's terms, what that last command did?

Jack
Mint 18.3 and 19, 64-bit, Cinnamon, Lenovo ThinkPad SL510 laptop, ASUS Z-97 desktop, Samsung S6 Android phone
Jack Erbes in Ellsworth, ME, USA

JeremyB
Level 19
Level 19
Posts: 9460
Joined: Fri Feb 21, 2014 8:17 am

Re: Wi-Fi not working on ThinkPad SL510

Post by JeremyB » Sun Nov 04, 2018 12:53 pm

It reinstalled the kernel as something must have been corrupted

jackerbes
Level 3
Level 3
Posts: 147
Joined: Fri Jul 03, 2015 8:37 am

Re: [Solved] Wi-Fi not working on ThinkPad SL510

Post by jackerbes » Sun Nov 04, 2018 12:55 pm

OK, thanks again for the help!

Jack
Mint 18.3 and 19, 64-bit, Cinnamon, Lenovo ThinkPad SL510 laptop, ASUS Z-97 desktop, Samsung S6 Android phone
Jack Erbes in Ellsworth, ME, USA

Post Reply

Return to “Wireless”