Can't find wireless card on dell 8400 mint 19

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
flackbait
Level 1
Level 1
Posts: 6
Joined: Sun Nov 11, 2018 7:24 pm

Can't find wireless card on dell 8400 mint 19

Post by flackbait » Sun Nov 11, 2018 7:36 pm

I have tried all the suggestions. I have a linksys-g 2.4 ghz wmp54gs ver 1 card. It worked in a Dell demension 3000. I can get on with a cable, but can't do wifi. Any help would be appreciated.

User avatar
karlchen
Level 19
Level 19
Posts: 9519
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Can't find wireless card on dell 8400 mint 19

Post by karlchen » Sun Nov 11, 2018 7:40 pm

Hello, flackbait.

The same request, which I have just made in this thread applies to you as well:

Please, give us an inxi -Fxz report. We need technical details. Else giving advice will not really be possible.
Please, open a terminal window.
Execute the commandline

Code: Select all

inxi -Fxz
exactly as it has been typed here.
Mark the complete text output which inxi will display in the terminal window.
Copy the marked text and paste it into your next reply.

Best regards,
Karl
Image
Linux Mint 18.1 64-bit Cinnamon Desktop, Total Commander 9.21a 64-bit
Ubuntu 18.04.1 32-bit Mate Desktop, Total Commander 9.21a 32-bit
Windows? - 1 window in every room

flackbait
Level 1
Level 1
Posts: 6
Joined: Sun Nov 11, 2018 7:24 pm

Re: Can't find wireless card on dell 8400 mint 19

Post by flackbait » Sun Nov 11, 2018 10:54 pm

Code: Select all

flackbait@flackbait-Dimension-8400:~$ inxi -Fxz
System:    Host: flackbait-Dimension-8400 Kernel: 4.15.0-38-generic i686
           bits: 32 gcc: 7.3.0
           Desktop: Cinnamon 3.8.9 (Gtk 3.22.30-1ubuntu1)
           Distro: Linux Mint 19 Tara
Machine:   Device: desktop System: Dell product: Dimension 8400 serial: N/A
           Mobo: Dell model: 0U7077 serial: N/A
           BIOS: Dell v: A09 date: 07/07/2006
CPU:       Single core Intel Pentium 4 (-UP-)
           arch: Netburst Prescott rev.4 cache: 1024 KB
           flags: (pae sse sse2 sse3) bmips: 6783 speed: 3391 MHz (max)
Graphics:  Card: NVIDIA NV41 [GeForce 6800] bus-ID: 01:00.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: nouveau (unloaded: modesetting,fbdev,vesa)
           Resolution: 1280x1024@60.02hz, 720x576@50.00hz
           OpenGL: renderer: NV41 version: 2.1 Mesa 18.0.5 Direct Render: Yes
Audio:     Card-1 Intel 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller
           driver: snd_intel8x0 ports: ec00 e8c0 bus-ID: 00:1e.2
           Card-2 Ensoniq ES1371/ES1373 / Creative Labs CT2518
           driver: snd_ens1371 port: dcc0 bus-ID: 04:02.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-38-generic
Network:   Card: Broadcom Limited NetXtreme BCM5751 Gigabit Ethernet PCIE
           driver: tg3 v: 3.137 bus-ID: 02:00.0
           IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 160.0GB (9.4% used)
           ID-1: /dev/sda model: ST3160023AS size: 160.0GB
Partition: ID-1: / size: 146G used: 14G (11%) fs: ext4 dev: /dev/sda1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 158 Uptime: 3 min Memory: 360.3/995.7MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56
flackbait@flackbait-Dimension-8400:~$

redlined
Level 4
Level 4
Posts: 365
Joined: Wed Jun 06, 2018 8:12 pm
Location: Mile High, Green State (Denver, CO:)

Re: Can't find wireless card on dell 8400 mint 19

Post by redlined » Sun Nov 11, 2018 11:49 pm

hi flackbait!

I see you are in most capable helping hands, Karlchen. I was curious however, as I see no mention of the wifi card you mentioned. How is it installed? or better, lets see what LM says. Please enter into terminal and paste the results of iwconfig in your reply. I think this will help troubleshoot the issue further. Thanks~
Moem kōan 42: Should tool manufacturers be required to fix their products so that you cannot use their saws to cut the tree branch that you're sitting on?

(The answer to the ultimate question of life, the universe and everything is... 42!!;)

Inundated
Level 1
Level 1
Posts: 44
Joined: Sat Sep 22, 2018 3:49 pm
Location: Akron, Ohio

Re: Can't find wireless card on dell 8400 mint 19

Post by Inundated » Mon Nov 12, 2018 12:38 am

I have the exact same computer.

I gave up on trying to get a new Netgear wireless USB stick working. I bought a TP-Link and it works flawlessly.

I see TP-Link has PCI cards, though I don't know if they'd work as well as the USB adapter does.
DESKTOP: Dell Dimension 8400 - Linux Mint 19 Xfce (currently out of service)
LAPTOP: Dell Latitude E6400 - Linux Mint 19 Cinnamon primary, Windows 10 dual boot (hooked to 20" Dell monitor)

flackbait
Level 1
Level 1
Posts: 6
Joined: Sun Nov 11, 2018 7:24 pm

Re: Can't find wireless card on dell 8400 mint 19

Post by flackbait » Mon Nov 12, 2018 1:22 pm

lackbait@flackbait-Dimension-8400:~$ iwconfig
enp2s0 no wireless extensions.

lo no wireless extensions.

flackbait@flackbait-Dimension-8400:~$

flackbait
Level 1
Level 1
Posts: 6
Joined: Sun Nov 11, 2018 7:24 pm

Re: Can't find wireless card on dell 8400 mint 19

Post by flackbait » Mon Nov 12, 2018 1:28 pm

I forgot to add that I am running the 32 bit version of mint19. I tried running with a mint 18 demo disk and I had the same problem. It looks like the Dell from Hell is the problem.

redlined
Level 4
Level 4
Posts: 365
Joined: Wed Jun 06, 2018 8:12 pm
Location: Mile High, Green State (Denver, CO:)

Re: Can't find wireless card on dell 8400 mint 19

Post by redlined » Mon Nov 12, 2018 2:34 pm

hi flackbait!
flackbait wrote:
Mon Nov 12, 2018 1:28 pm
It looks like the Dell from Hell is the problem.
I left that in quote, made me laugh- I've had those experiences :evil:

I did some more looking around, pulled up specs on both desktop computers you referenced (dimension 3000 and 8400) as well the wmp54gs v1 card (which since you state "card" I assumed PCI/PCMCIA card you manually insert into mobo). I do have some further thoughts about it and your past experience with it since I see on Linksys support pages that card was marked EOL (End of Life) as prior to 2012 this also means they no longer will even provide hardware support (max 7 years past EOL).

It is possible that the card will need additional drivers no longer included so system can recognize it and an old(er) kernel may help. I am finding a lot of old (and good) info for this particular card including issues marked [Solved] in this forum and ubuntu forums, from 2010-2012 so there is hope.

You mention it worked fine in your older Dell (3000) what OS were you on?

have you attempted to run LM 19 in a live session and see if it is recognized then? (USB or CD)

have you looked carefully at BIOS options and can see the card (ensuring it is enabled) anywhere in there?
flackbait wrote:
Sun Nov 11, 2018 7:36 pm
I have tried all the suggestions. I have a linksys-g 2.4 ghz wmp54gs ver 1 card. It worked in a Dell demension 3000. I can get on with a cable, but can't do wifi.
also, referring back to your initial post this thread I see your mention of being able to get on internet with a cable (but not wifi) and assume the ethernet port is not one on the wmp54gs card or is it?

Have you attempted to put the wmp54gs card into another card slot on motherboard? (if available, I'd try that to see if system recognizes it.

also I see terminal command lspci -nn may also help us confirm whether or not the card is recognized in system and give better specifics about it to help in finding compatible driver(s)/firmware. Please post the results of that command in next reply.
Moem kōan 42: Should tool manufacturers be required to fix their products so that you cannot use their saws to cut the tree branch that you're sitting on?

(The answer to the ultimate question of life, the universe and everything is... 42!!;)

flackbait
Level 1
Level 1
Posts: 6
Joined: Sun Nov 11, 2018 7:24 pm

Re: Can't find wireless card on dell 8400 mint 19

Post by flackbait » Mon Nov 12, 2018 6:51 pm

Dell 3000 is running on LM 18 32 bit . It could see the pci card.
I did try running the 8400 on CD LM 18 and 19 32 bit. The wireless pci card did not blink or show on the system tray.
Tried different slots. No joy.
Didn't see anything on the BIOS that related to wifi.

flackbait
Level 1
Level 1
Posts: 6
Joined: Sun Nov 11, 2018 7:24 pm

Re: Can't find wireless card on dell 8400 mint 19

Post by flackbait » Mon Nov 12, 2018 6:55 pm

The Ethernet bunny has the plug attached to the mother board.

redlined
Level 4
Level 4
Posts: 365
Joined: Wed Jun 06, 2018 8:12 pm
Location: Mile High, Green State (Denver, CO:)

Re: Can't find wireless card on dell 8400 mint 19

Post by redlined » Mon Nov 12, 2018 8:03 pm

hi flackbait!

Thank you for your responses. Since you've tried other card slots leads me to believe your newer computer has issue with that card and (as long as you know without doubt that the card is still good!) my own thoughts take me back to BIOS not just looking for anything wifi there but for any setting which may be disabling hardware at all, especially PCI/PMCIA slots. and if nothing presents perhaps an update to BIOS woudl be a worthy attempt (as it's over 10years old).. as well, searching for a new/used known compatible card you can use to get wifi to your pc as it is preferred, another option is USB wifi adapter also mentioned this thread. I'd also recommend disabling Secure Boot if you find that option enabled in BIOS, it messes with Linux by what I read in forums and is often a first mention advice

Please do continue to monitor this thread though as others might have ideas and advice to help get the wmp54gs v1 card working for you. Good luck!
Moem kōan 42: Should tool manufacturers be required to fix their products so that you cannot use their saws to cut the tree branch that you're sitting on?

(The answer to the ultimate question of life, the universe and everything is... 42!!;)

Post Reply

Return to “Wireless”