USB Adapter won't work

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
HarryX
Level 1
Level 1
Posts: 23
Joined: Fri Feb 10, 2017 5:06 pm

USB Adapter won't work

Post by HarryX » Wed Nov 14, 2018 12:49 pm

I have a USB adapter dual band, USB 2 , says drivers are rtl8812BU,rtl8822BU, problem is can't it install, it does say compatible with Linux but when plugged in shows nothing, any help with this would be grateful,now try make it easy not the best in the terminal.
inxi -Fxz
System: Host: harry Kernel: 4.15.0-39-generic x86_64 bits: 64 gcc: 7.3.0
Desktop: Cinnamon 3.8.9 (Gtk 3.22.30-1ubuntu1)
Distro: Linux Mint 19 Tara
Machine: Device: desktop System: Gigabyte product: N/A serial: N/A
Mobo: Gigabyte model: F2A58M-HD2 serial: N/A
BIOS: American Megatrends v: F1 date: 03/24/2014
CPU: Dual core AMD A6-7400K Radeon R5 6 Compute Cores 2C+4G (-MCP-)
arch: Steamroller rev.1 cache: 2048 KB

flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 13974
clock speeds: max: 3500 MHz 1: 1820 MHz 2: 1444 MHz
Graphics: Card-1: Advanced Micro Devices [AMD/ATI] Kaveri [Radeon R5 Graphics]
bus-ID: 00:01.0
Card-2: NVIDIA GK208 [GeForce GT 710B] bus-ID: 01:00.0
Display Server: x11 (X.Org 1.19.6 )
drivers: nvidia,ati,radeon (unloaded: modesetting,fbdev,vesa,nouveau)
Resolution: 1920x1080@60.00hz
OpenGL: renderer: GeForce GT 710/PCIe/SSE2
version: 4.6.0 NVIDIA 390.77 Direct Render: Yes
Audio: Card-1 Advanced Micro Devices [AMD] FCH Azalia Controller
driver: snd_hda_intel bus-ID: 00:14.2
Card-2 Advanced Micro Devices [AMD/ATI] Kaveri HDMI/DP Audio Controller
driver: snd_hda_intel bus-ID: 00:01.1
Card-3 NVIDIA GK208 HDMI/DP Audio Controller
driver: snd_hda_intel bus-ID: 01:00.1
Sound: Advanced Linux Sound Architecture v: k4.15.0-39-generic
Network: Card: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
driver: r8169 v: 2.3LK-NAPI port: d000 bus-ID: 02:00.0
IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives: HDD Total Size: 800.2GB (6.0% used)
ID-1: /dev/sda model: ST3500312CS size: 500.1GB
ID-2: /dev/sdb model: CT240BX200SSD1 size: 240.1GB
ID-3: /dev/sdc model: CHN_25SATA01M_06 size: 60.0GB
Partition: ID-1: / size: 220G used: 46G (22%) fs: ext4 dev: /dev/sdb1
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 4.0C mobo: N/A gpu: 0.0:44C
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 186 Uptime: 1:34 Memory: 2312.2/6904.3MB
Init: systemd runlevel: 5 Gcc sys: 7.3.0
Client: Shell (bash 4.4.191) inxi: 2.3.56
mike@harry:~$

JeremyB
Level 19
Level 19
Posts: 9471
Joined: Fri Feb 21, 2014 8:17 am

Re: USB Adapter won't work

Post by JeremyB » Wed Nov 14, 2018 2:46 pm

Post results for

Code: Select all

lsusb
With the wifi dongle plugged in

HarryX
Level 1
Level 1
Posts: 23
Joined: Fri Feb 10, 2017 5:06 pm

Re: USB Adapter won't work

Post by HarryX » Wed Nov 14, 2018 5:23 pm

lsusb
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 005: ID 0bda:c811 Realtek Semiconductor Corp.
Bus 002 Device 002: ID 04f9:0364 Brother Industries, Ltd
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 002: ID 248a:8367
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

JeremyB
Level 19
Level 19
Posts: 9471
Joined: Fri Feb 21, 2014 8:17 am

Re: USB Adapter won't work

Post by JeremyB » Wed Nov 14, 2018 6:04 pm

In terminal do

Code: Select all

sudo apt install git build-essential dkms
DRV_NAME=rtl8821CU
DRV_VERSION=5.2.5.3
sudo mkdir /usr/src/${DRV_NAME}-${DRV_VERSION}
git archive master | sudo tar -x -C /usr/src/${DRV_NAME}-${DRV_VERSION}
sudo dkms add -m ${DRV_NAME} -v ${DRV_VERSION}
sudo dkms build -m ${DRV_NAME} -v ${DRV_VERSION}
sudo dkms install -m ${DRV_NAME} -v ${DRV_VERSION}
Also check

Code: Select all

mokutil --sb-state
If it says Secure Boot is enabled, you will need to enter BIOS settings and disable Secure Boot, if it says mokutil not installed or EFI variables not enabled, just reboot

HarryX
Level 1
Level 1
Posts: 23
Joined: Fri Feb 10, 2017 5:06 pm

Re: USB Adapter won't work

Post by HarryX » Thu Nov 15, 2018 8:03 am

Thank you for the reply, however I'm getting to sudo mkdir /usr/src/${rtl8821CU}-${5.2.5.3} and then the output is bash: /usr/src/${rtl8821CU}-${5.2.5.3}: bad substitution, now this could be cause I'm a twit and not that brilliant in the terminal or some thing not going well.

HarryX
Level 1
Level 1
Posts: 23
Joined: Fri Feb 10, 2017 5:06 pm

Re: USB Adapter won't work

Post by HarryX » Thu Nov 15, 2018 8:05 am

Also in answer to the mokutil --sb-state the out put is
EFI variables are not supported on this system

Mopar512
Level 1
Level 1
Posts: 9
Joined: Mon Nov 05, 2018 1:40 am

Re: USB Adapter won't work

Post by Mopar512 » Thu Nov 15, 2018 1:25 pm

I had one of these that gave me a lot of difficulty getting it to work. It came with a linux driver on a cd but it was something I had to assemble from source code then install the driver. I was able to get it done using instructions from this link. https://sites.google.com/site/easylinux ... /reserve-7

Hope this helps.
Roger

User avatar
Flemur
Level 16
Level 16
Posts: 6290
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: USB Adapter won't work

Post by Flemur » Thu Nov 15, 2018 1:32 pm

HarryX wrote:
Thu Nov 15, 2018 8:03 am
sudo mkdir /usr/src/${rtl8821CU}-${5.2.5.3} and then the output is bash: /usr/src/${rtl8821CU}-${5.2.5.3}: bad substitution,
Copy/paste what JeremyB typed, don't do the string replacements yourself.
IOW, enter this:

Code: Select all

sudo mkdir /usr/src/${DRV_NAME}-${DRV_VERSION}
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less

HarryX
Level 1
Level 1
Posts: 23
Joined: Fri Feb 10, 2017 5:06 pm

Re: USB Adapter won't work

Post by HarryX » Sat Nov 17, 2018 11:24 am

Well first of all thank for all your help if nothing else I've learnt lots, I sent the WiFi USB adapter back and got a refund after doing a lot more research it appears that this adapter with these drivers can and in my case are a problem.

Post Reply

Return to “Wireless”