[Solved] Only 20Mhz channels on AR9565 wifi adapter

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
unxed
Level 1
Level 1
Posts: 3
Joined: Mon Nov 19, 2018 5:26 pm

[Solved] Only 20Mhz channels on AR9565 wifi adapter

Post by unxed » Mon Nov 19, 2018 5:28 pm

How to enable 40Mhz channels? My router supports it, is flashed with lastest openwrt and has 40Mhz enabled. Other clients work fine on 40Mhz. Kernel is 4.15.

Mint MATE 19 x64
Last edited by unxed on Thu Nov 22, 2018 2:26 pm, edited 1 time in total.

JeremyB
Level 19
Level 19
Posts: 9435
Joined: Fri Feb 21, 2014 8:17 am

Re: Only 20Mhz channels on AR9565 wifi adapter

Post by JeremyB » Mon Nov 19, 2018 5:47 pm

What country are you in and what is the result of

Code: Select all

iw reg get
I am not sure what else could cause an issue with 40 MHz channel width

unxed
Level 1
Level 1
Posts: 3
Joined: Mon Nov 19, 2018 5:26 pm

Re: Only 20Mhz channels on AR9565 wifi adapter

Post by unxed » Mon Nov 19, 2018 7:50 pm

JeremyB wrote:
Mon Nov 19, 2018 5:47 pm
What country are you in and what is the result of

Code: Select all

iw reg get
Russia,

Code: Select all

~ $ iw reg get
global
country RU: DFS-ETSI
	(2402 - 2482 @ 40), (N/A, 20), (N/A)
	(5170 - 5250 @ 80), (N/A, 20), (N/A), AUTO-BW
	(5250 - 5330 @ 80), (N/A, 20), (0 ms), DFS, AUTO-BW
	(5650 - 5730 @ 80), (N/A, 30), (0 ms), DFS
	(5735 - 5835 @ 80), (N/A, 30), (N/A)
	(57000 - 66000 @ 2160), (N/A, 40), (N/A)
,
thanks!

Btw, connection is still at 20Mhz :(

unxed
Level 1
Level 1
Posts: 3
Joined: Mon Nov 19, 2018 5:26 pm

Re: Only 20Mhz channels on AR9565 wifi adapter

Post by unxed » Thu Nov 22, 2018 2:26 pm

Sorry for that, has to enable "force 40mhz channels" in openwrt settings to make 40mhz work. Btw, this setting violates the standard and also does not bring any significant speed inprovement in my environment, so I disabled it back.

Post Reply

Return to “Wireless”