LinuxMint 19 Broadcom WiFi issue.

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Locked
signal
Level 1
Level 1
Posts: 4
Joined: Sat Dec 01, 2018 8:32 pm

LinuxMint 19 Broadcom WiFi issue.

Post by signal »

Hi linux nerds, last night I have installed linuxmint mate 19 and tried to cope with the majority of thread posted here to solve the wireless issue, anyway I can access internet using lan cable but wifi is what I need, I have the complete result of the code what Jeremy B has requested to someone in some other thread to similar issu.

PS: I don't see any wifi icon or AP/wifi options etc.


here is an overview:

Code: Select all

########## wireless info START ##########

Report from: 02 Dec 2018 00:29 GMT +0000

Booted last: 02 Dec 2018 00:00 GMT +0000

Script from: 22 Oct 2018 03:34 UTC +0000

##### release ###########################

Distributor ID:	LinuxMint
Description:	Linux Mint 19 Tara
Release:	19
Codename:	tara

##### kernel ############################

Linux 4.15.0-39-generic #42-Ubuntu SMP Tue Oct 23 15:43:58 UTC 2018 i686 i686 i686 GNU/Linux

Parameters: ro, quiet, splash, vt.handoff=1

##### desktop ###########################

MATE

##### lspci #############################

02:0e.0 Ethernet controller [0200]: Broadcom Limited BCM4401-B0 100Base-TX [14e4:170c] (rev 02)
	Subsystem: Hewlett-Packard Company NX7300 laptop [103c:30a2]
	Kernel driver in use: b44

10:00.0 Network controller [0280]: Broadcom Limited BCM4311 802.11b/g WLAN [14e4:4311] (rev 01)
	Subsystem: Hewlett-Packard Company BCM4311 802.11b/g Wireless LAN Controller [103c:1364]
	Kernel driver in use: b43-pci-bridge

##### lsusb #############################

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 03f0:171d Hewlett-Packard Bluetooth 2.0 Interface [Broadcom BCM2045]
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

##### PCMCIA card info ##################

PRODID_1=""
PRODID_2=""
PRODID_3=""
PRODID_4=""
MANFID=0000,0000
FUNCID=255

##### rfkill ############################

0: hp-wifi: Wireless LAN
	Soft blocked: no
	Hard blocked: no
1: hp-bluetooth: Bluetooth
	Soft blocked: no
	Hard blocked: no
2: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no

##### secure boot #######################

'mokutil' is not installed (package "mokutil").

##### lsmod #############################

ssb_hcd                16384  0
ssb                    57344  2 ssb_hcd,b44
hp_wmi                 16384  0
sparse_keymap          16384  1 hp_wmi
wl                   6213632  0
wmi_bmof               16384  0
cfg80211              532480  1 wl
wmi                    20480  2 wmi_bmof,hp_wmi

##### interfaces ########################

[/etc/network/interfaces]
auto lo
iface lo inet loopback

##### ifconfig ##########################

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback <MAC address> brd <MAC address>
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether <MAC 'eth0' [IF1]> brd <MAC address>
    inet 192.168.1.101/24 brd 192.168.1.255 scope global dynamic eth0
       valid_lft 82410sec preferred_lft 82410sec

##### iwconfig ##########################

lo        no wireless extensions.

eth0      no wireless extensions.

##### route #############################

default via 192.168.1.1 dev eth0 
default via 192.168.1.1 dev eth0 proto dhcp metric 100 
169.254.0.0/16 dev eth0 scope link metric 1000 
192.168.1.0/24 dev eth0 proto kernel scope link src 192.168.1.101 
192.168.1.0/24 dev eth0 proto kernel scope link src 192.168.1.101 metric 100 

##### resolv.conf #######################

[777 root '/etc/resolv.conf' -> '../run/systemd/resolve/stub-resolv.conf']

nameserver 127.0.0.53

##### network managers ##################

Installed:

	NetworkManager

Running:

root       636     1  0 Dec01 ?        00:00:00 /usr/sbin/NetworkManager --no-daemon

##### NetworkManager info ###############

GENERAL.DEVICE:                         eth0
GENERAL.TYPE:                           ethernet
GENERAL.NM-TYPE:                        NMDeviceEthernet
GENERAL.VENDOR:                         Broadcom Limited
GENERAL.PRODUCT:                        BCM4401-B0 100Base-TX (NX7300 laptop)
GENERAL.DRIVER:                         b44
GENERAL.DRIVER-VERSION:                 2.0
GENERAL.FIRMWARE-VERSION:               --
GENERAL.HWADDR:                         <MAC 'eth0' [IF1]>
GENERAL.MTU:                            1500
GENERAL.STATE:                          100 (connected)
GENERAL.REASON:                         0 (No reason given)
GENERAL.UDI:                            /sys/devices/pci0000:00/0000:00:1e.0/0000:02:0e.0/ssb1:0/net/eth0
GENERAL.IP-IFACE:                       eth0
GENERAL.IS-SOFTWARE:                    no
GENERAL.NM-MANAGED:                     yes
GENERAL.AUTOCONNECT:                    yes
GENERAL.FIRMWARE-MISSING:               no
GENERAL.NM-PLUGIN-MISSING:              no
GENERAL.PHYS-PORT-ID:                   --
GENERAL.CONNECTION:                     Wired connection 1
GENERAL.CON-UUID:                       51a9c7a9-6ded-3f4e-93f7-b8162c15123a
GENERAL.CON-PATH:                       /org/freedesktop/NetworkManager/ActiveConnection/1
GENERAL.METERED:                        no (guessed)
CAPABILITIES.CARRIER-DETECT:            yes
CAPABILITIES.SPEED:                     100 Mb/s
CAPABILITIES.IS-SOFTWARE:               no
CAPABILITIES.SRIOV:                     no
WIRED-PROPERTIES.CARRIER:               on
IP4.ADDRESS[1]:                         192.168.1.101/24
IP4.GATEWAY:                            192.168.1.1
IP4.ROUTE[1]:                           dst = 0.0.0.0/0, nh = 192.168.1.1, mt = 100
IP4.ROUTE[2]:                           dst = 192.168.1.0/24, nh = 0.0.0.0, mt = 0
IP4.ROUTE[3]:                           dst = 0.0.0.0/0, nh = 192.168.1.1, mt = 0
IP4.ROUTE[4]:                           dst = 192.168.1.0/24, nh = 0.0.0.0, mt = 100
IP4.ROUTE[5]:                           dst = 169.254.0.0/16, nh = 0.0.0.0, mt = 1000
IP4.DNS[1]:                             192.168.1.1
DHCP4.OPTION[1]:                        network_number = 192.168.1.0
DHCP4.OPTION[2]:                        requested_domain_search = 1
DHCP4.OPTION[3]:                        requested_broadcast_address = 1
DHCP4.OPTION[4]:                        requested_time_offset = 1
DHCP4.OPTION[5]:                        requested_rfc3442_classless_static_routes = 1
DHCP4.OPTION[6]:                        requested_domain_name = 1
DHCP4.OPTION[7]:                        requested_netbios_scope = 1
DHCP4.OPTION[8]:                        requested_wpad = 1
DHCP4.OPTION[9]:                        next_server = 0.0.0.0
DHCP4.OPTION[10]:                       expiry = 1543792975
DHCP4.OPTION[11]:                       dhcp_message_type = 5
DHCP4.OPTION[12]:                       requested_interface_mtu = 1
DHCP4.OPTION[13]:                       dhcp_lease_time = 86400
DHCP4.OPTION[14]:                       routers = 192.168.1.1
DHCP4.OPTION[15]:                       ip_address = 192.168.1.101
DHCP4.OPTION[16]:                       subnet_mask = 255.255.255.0
DHCP4.OPTION[17]:                       requested_static_routes = 1
DHCP4.OPTION[18]:                       requested_subnet_mask = 1
DHCP4.OPTION[19]:                       dhcp_renewal_time = 43200
DHCP4.OPTION[20]:                       broadcast_address = 192.168.1.255
DHCP4.OPTION[21]:                       domain_name_servers = 192.168.1.1 192.168.1.1
DHCP4.OPTION[22]:                       requested_ntp_servers = 1
DHCP4.OPTION[23]:                       requested_netbios_name_servers = 1
DHCP4.OPTION[24]:                       requested_ms_classless_static_routes = 1
DHCP4.OPTION[25]:                       requested_routers = 1
DHCP4.OPTION[26]:                       requested_domain_name_servers = 1
DHCP4.OPTION[27]:                       dhcp_rebinding_time = 75600
DHCP4.OPTION[28]:                       requested_host_name = 1
DHCP4.OPTION[29]:                       dhcp_server_identifier = 192.168.1.1
IP6.GATEWAY:                            --
IP6.ROUTE[1]:                           dst = ff00::/8, nh = ::, mt = 256, table=255
CONNECTIONS.AVAILABLE-CONNECTION-PATHS: /org/freedesktop/NetworkManager/Settings/{2}
CONNECTIONS.AVAILABLE-CONNECTIONS[1]:   51a9c7a9-6ded-3f4e-93f7-b8162c15123a | Wired connection 1

##### NetworkManager.state ##############

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true

##### NetworkManager config #############

[[/etc/NetworkManager/conf.d/default-wifi-powersave-on.conf]]
[connection]
wifi.powersave = 3

[[/etc/NetworkManager/NetworkManager.conf]]
[main]
plugins=ifupdown,keyfile
[ifupdown]
managed=false
[device]
wifi.scan-rand-mac-address=no

[[/usr/lib/NetworkManager/conf.d/10-dns-resolved.conf]]
[main]
dns=systemd-resolved

[[/usr/lib/NetworkManager/conf.d/10-globally-managed-devices.conf]]
[keyfile]
unmanaged-devices=*,except:type:wifi,except:type:wwan

[[/usr/lib/NetworkManager/conf.d/20-connectivity-ubuntu.conf]]
[connectivity]
uri=http://connectivity-check.ubuntu.com/

[[/usr/lib/NetworkManager/conf.d/no-mac-addr-change.conf]]
[device-mac-addr-change-wifi]
match-device=driver:rtl8723bs,driver:rtl8189es,driver:r8188eu,driver:8188eu,driver:eagle_sdio,driver:wl
wifi.scan-rand-mac-address=no
wifi.cloned-mac-address=preserve
ethernet.cloned-mac-address=preserve

##### NetworkManager profiles ###########

[[/etc/NetworkManager/system-connections/Wi-Fi connection 1]] (600 root)
[connection] id=Wi-Fi connection 1 | type=wifi | permissions=
[wifi] bssid=<MAC address> | mac-address=<MAC 'eth0' [IF1]> | mac-address-blacklist= | ssid=Ooredoo-B310-979C
[ipv4] method=auto
[ipv6] method=auto

##### Netplan config ####################

[/etc/netplan/1-network-manager-all.yaml]
network:
  version: 2
  renderer: NetworkManager

##### iw reg get ########################

Region: Europe/London (based on set time zone)

global
country 00: DFS-UNSET
	(2402 - 2472 @ 40), (N/A, 20), (N/A)
	(2457 - 2482 @ 20), (N/A, 20), (N/A), AUTO-BW, PASSIVE-SCAN
	(2474 - 2494 @ 20), (N/A, 20), (N/A), NO-OFDM, PASSIVE-SCAN
	(5170 - 5250 @ 80), (N/A, 20), (N/A), AUTO-BW, PASSIVE-SCAN
	(5250 - 5330 @ 80), (N/A, 20), (0 ms), DFS, AUTO-BW, PASSIVE-SCAN
	(5490 - 5730 @ 160), (N/A, 20), (0 ms), DFS, PASSIVE-SCAN
	(5735 - 5835 @ 80), (N/A, 20), (N/A), PASSIVE-SCAN
	(57240 - 63720 @ 2160), (N/A, 0), (N/A)

##### iwlist channels ###################

lo        no frequency information.

eth0      no frequency information.

##### iwlist scan #######################

lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

##### module infos ######################

[ssb_hcd]
filename:       /lib/modules/4.15.0-39-generic/kernel/drivers/usb/host/ssb-hcd.ko
license:        GPL
description:    Common USB driver for SSB Bus
author:         Hauke Mehrtens
srcversion:     D1CBD34E5A02BE2CD8EFC4E
depends:        ssb
retpoline:      Y
intree:         Y
name:           ssb_hcd
vermagic:       4.15.0-39-generic SMP mod_unload 686 
signat:         PKCS#7
signer:         
sig_key:        
sig_hashalgo:   md4

[ssb]
filename:       /lib/modules/4.15.0-39-generic/kernel/drivers/ssb/ssb.ko
license:        GPL
description:    Sonics Silicon Backplane driver
srcversion:     12D8BAB8F43573B88998E25
depends:        
retpoline:      Y
intree:         Y
name:           ssb
vermagic:       4.15.0-39-generic SMP mod_unload 686 
signat:         PKCS#7
signer:         
sig_key:        
sig_hashalgo:   md4

[wl]
filename:       /lib/modules/4.15.0-39-generic/updates/dkms/wl.ko
license:        MIXED/Proprietary
license:        MIXED/Proprietary
srcversion:     60D2D7E603B418654C8C9AA
depends:        cfg80211
retpoline:      Y
name:           wl
vermagic:       4.15.0-39-generic SMP mod_unload 686 
parm:           passivemode:int
parm:           wl_txq_thresh:int
parm:           oneonly:int
parm:           piomode:int
parm:           instance_base:int
parm:           nompc:int
parm:           intf_name:string

[cfg80211]
filename:       /lib/modules/4.15.0-39-generic/kernel/net/wireless/cfg80211.ko
description:    wireless configuration support
license:        GPL
author:         Johannes Berg
srcversion:     62FD05DCC5AEEA290640C3D
depends:        
retpoline:      Y
intree:         Y
name:           cfg80211
vermagic:       4.15.0-39-generic SMP mod_unload 686 
signat:         PKCS#7
signer:         
sig_key:        
sig_hashalgo:   md4
parm:           bss_entries_limit:limit to number of scan BSS entries (per wiphy, default 1000) (int)
parm:           ieee80211_regdom:IEEE 802.11 regulatory domain code (charp)
parm:           cfg80211_disable_40mhz_24ghz:Disable 40MHz support in the 2.4GHz band (bool)

##### module parameters #################

[cfg80211]
bss_entries_limit: 1000
cfg80211_disable_40mhz_24ghz: N
ieee80211_regdom: 00

##### /etc/modules ######################

##### modprobe options ##################

[/etc/modprobe.d/amd64-microcode-blacklist.conf]
blacklist microcode

[/etc/modprobe.d/blacklist-ath_pci.conf]
blacklist ath_pci

[/etc/modprobe.d/blacklist.conf]
blacklist evbug
blacklist usbmouse
blacklist usbkbd
blacklist eepro100
blacklist de4x5
blacklist eth1394
blacklist snd_intel8x0m
blacklist snd_aw2
blacklist prism54
blacklist bcm43xx
blacklist garmin_gps
blacklist asus_acpi
blacklist snd_pcsp
blacklist pcspkr
blacklist amd76x_edac

[/etc/modprobe.d/blacklist-rare-network.conf]
alias net-pf-3 off
alias net-pf-6 off
alias net-pf-9 off
alias net-pf-11 off
alias net-pf-12 off
alias net-pf-19 off
alias net-pf-21 off
alias net-pf-36 off

[/etc/modprobe.d/broadcom-sta-dkms.conf]
blacklist b43
blacklist b43legacy
blacklist b44
blacklist bcma
blacklist brcm80211
blacklist brcmsmac
blacklist ssb

[/etc/modprobe.d/intel-microcode-blacklist.conf]
blacklist microcode

[/etc/modprobe.d/iwlwifi.conf]
remove iwlwifi \
(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
&& /sbin/modprobe -r mac80211

##### rc.local ##########################

grep: /etc/rc.local: No such file or directory

##### pm-utils ##########################

##### udev rules ########################

##### dmesg #############################

[   21.995661] wl: loading out-of-tree module taints kernel.
[   21.995671] wl: module license 'MIXED/Proprietary' taints kernel.
[   22.005702] wl: module verification failed: signature and/or required key missing - tainting kernel
[   22.066555] wl driver 6.30.223.271 (r587334) failed with code 21
[   22.280138] ssb: Found chip with id 0x4311, rev 0x01 and package 0x00
[   22.280154] ssb: Core 0 found: ChipCommon (cc 0x800, rev 0x11, vendor 0x4243)
[   22.280162] ssb: Core 1 found: IEEE 802.11 (cc 0x812, rev 0x0A, vendor 0x4243)
[   22.280171] ssb: Core 2 found: USB 1.1 Host (cc 0x817, rev 0x03, vendor 0x4243)
[   22.280180] ssb: Core 3 found: PCI-E (cc 0x820, rev 0x01, vendor 0x4243)
[   22.372421] ssb: Sonics Silicon Backplane found on PCI device 0000:10:00.0
[   22.620076] ssb: Found chip with id 0x4401, rev 0x02 and package 0x00
[   22.620085] ssb: Core 0 found: Fast Ethernet (cc 0x806, rev 0x07, vendor 0x4243)
[   22.620092] ssb: Core 1 found: V90 (cc 0x807, rev 0x03, vendor 0x4243)
[   22.620099] ssb: Core 2 found: PCI (cc 0x804, rev 0x0A, vendor 0x4243)
[   22.684383] ssb: Sonics Silicon Backplane found on PCI device 0000:02:0e.0
[   22.718784] b44 ssb1:0 eth0: Broadcom 44xx/47xx 10/100 PCI ethernet driver <MAC 'eth0' [IF1]>
[   40.065312] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready (repeated 2 times)
[   43.804247] b44 ssb1:0 eth0: Link is up at 100 Mbps, full duplex
[   43.804255] b44 ssb1:0 eth0: Flow control is off for TX and off for RX
[   43.804384] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   54.307911] b44 ssb1:0 eth0: powering down PHY
[   54.321406] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   54.433542] b44 ssb1:0 eth0: powering down PHY
[   54.490287] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   57.820276] b44 ssb1:0 eth0: Link is up at 100 Mbps, full duplex
[   57.820283] b44 ssb1:0 eth0: Flow control is off for TX and off for RX
[   57.822143] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready

########## wireless info END ############

Ryan.
Last edited by JeremyB on Sun Dec 02, 2018 8:03 am, edited 1 time in total.
Reason: code tags
User avatar
Joe2Shoe
Level 5
Level 5
Posts: 542
Joined: Wed Oct 18, 2017 8:12 pm
Location: Ozone

Re: LinuxMint 19 Broadcom WiFi issue.

Post by Joe2Shoe »

In the Terminal:
lsusb
"Tolerance is the refuge of men without conviction."
"Common sense is not so common" - Voltaire
JeremyB
Level 20
Level 20
Posts: 11786
Joined: Fri Feb 21, 2014 8:17 am

Re: LinuxMint 19 Broadcom WiFi issue.

Post by JeremyB »

Code: Select all

sudo apt remove broadcom-sta-dkms bcmwl-kernel-source
sudo apt install firmware-b43-installer
Then reboot
signal
Level 1
Level 1
Posts: 4
Joined: Sat Dec 01, 2018 8:32 pm

Re: LinuxMint 19 Broadcom WiFi issue.

Post by signal »

Thanks for the response, but today something weird has happened, it doesnt even detect the cable connected (wired) anymore since the last reboot I did before sleeping last night, any help.

https://imgur.com/a/uVC5rS6

Ryan.
Last edited by signal on Sun Dec 02, 2018 11:50 am, edited 1 time in total.
JeremyB
Level 20
Level 20
Posts: 11786
Joined: Fri Feb 21, 2014 8:17 am

Re: LinuxMint 19 Broadcom WiFi issue.

Post by JeremyB »

Try

Code: Select all

sudo modprobe b44
signal
Level 1
Level 1
Posts: 4
Joined: Sat Dec 01, 2018 8:32 pm

Re: LinuxMint 19 Broadcom WiFi issue.

Post by signal »

JeremyB wrote:
Sun Dec 02, 2018 11:46 am
Try

Code: Select all

sudo modprobe b44
there was no response/result/messages after entering this command, tried reboot, no luck.

Ryan.
signal
Level 1
Level 1
Posts: 4
Joined: Sat Dec 01, 2018 8:32 pm

Re: LinuxMint 19 Broadcom WiFi issue.

Post by signal »

Sorry for the double post, after minutes the wired connection is back, thank you Jeremy, now shall I try the above mentioned codes to fix the wifi?


EDIT:
JeremyB wrote:
Sun Dec 02, 2018 8:02 am

Code: Select all

sudo apt remove broadcom-sta-dkms bcmwl-kernel-source
sudo apt install firmware-b43-installer
Then reboot
once again I lost wired connection after entering this command, but got the connection back with

Code: Select all

sudo modprobe b44


EDIT: I just realized that I'm losing wired connection every time I reboot.

Ryan.
JeremyB
Level 20
Level 20
Posts: 11786
Joined: Fri Feb 21, 2014 8:17 am

Re: LinuxMint 19 Broadcom WiFi issue.

Post by JeremyB »

Run the commands to fix wifi and it should fix your ethernet
Laugh2
Level 4
Level 4
Posts: 203
Joined: Fri Aug 16, 2013 4:01 am

Re: LinuxMint 19 Broadcom WiFi issue.

Post by Laugh2 »

JeremyB wrote:
Sun Dec 02, 2018 8:02 am

Code: Select all

sudo apt remove broadcom-sta-dkms bcmwl-kernel-source
sudo apt install firmware-b43-installer
Then reboot
Thank you, JeremyB. That worked for me immediately on use.

After a fresh install of LM 19.1 onto the laptop everything worked well except there was no wireless. I used Driver Manager to activate the proprietary Broadcom driver (also checked the hardware wireless switch was on) but wifi still didn't work. "lspci" showed that the internal wifi card is a Broadcom BCM4311. After doing as you suggested and a reboot all worked perfectly.

Hardware/Equipment
Linux Mint 19.1, 64bit, MATE
Dell Latitude D630 laptop with 4MB RAM
nVidia Quadro NVS 135M graphics (Driver: NVIDIA 340.107)
NigelMiles
Level 1
Level 1
Posts: 1
Joined: Wed Oct 28, 2020 1:39 am

Re: LinuxMint 19 Broadcom WiFi issue.

Post by NigelMiles »

I am completely new to LinuxMint, but this solved my WiFi problem on a Toshiba Satellite A10 32 bit which has a Broadcom WiFi 4300 series
Locked

Return to “Wireless”