[SOLVED] Bluetooth connection drops out after a few minutes

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 11
Joined: Sun Aug 30, 2015 9:59 pm

[SOLVED] Bluetooth connection drops out after a few minutes

Post by afilk » Tue Dec 04, 2018 5:02 pm

I have been having intermittent issues with my bluetooth. My devices pair just fine, and sometimes I will go full days without the connection dropping out. But at other points the bluetooth connection will just suddenly drop out, and if i restart bluetooth and/or turn off and on my headphones they will reconnect, but only for a few minutes before dropping out again. The issue generally goes away after restarting my computer, at least for a day or two.

Here is my hardware info. Please let me know if there is another output that I should include.

Code: Select all

System:    Host: amy-Inspiron-5537 Kernel: 4.4.0-116-generic i686 (32 bit gcc: 4.8.4)
           Desktop: Cinnamon 2.8.8 (Gtk 3.10.8~8+qiana)
           Distro: Linux Mint 17.3 Rosa
Machine:   System: Dell product: Inspiron 5537 v: A07
           Mobo: Dell model: 0WHKFR v: A00 Bios: Dell v: A07 date: 11/12/2013
CPU:       Dual core Intel Core i3-4010U (-HT-MCP-) cache: 3072 KB
           flags: (lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 6783
           clock speeds: max: 1700 MHz 1: 1700 MHz 2: 1700 MHz 3: 1700 MHz
           4: 1700 MHz
Graphics:  Card: Intel Haswell-ULT Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: X.Org 1.15.1 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.0hz, 1920x1080@60.0hz
           GLX Renderer: Mesa DRI Intel Haswell Mobile x86/MMX/SSE2
           GLX Version: 3.0 Mesa 10.1.3 Direct Rendering: Yes
Audio:     Card-1 Intel 8 Series HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Intel Haswell-ULT HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:03.0
           Sound: Advanced Linux Sound Architecture v: k4.4.0-116-generic
Network:   Card-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: 3000 bus-ID: 01:00.0
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
           Card-2: Intel Wireless 7260 driver: iwlwifi bus-ID: 02:00.0
           IF: wlan0 state: down mac: <filter>
Drives:    HDD Total Size: 500.1GB (84.2% used)
           ID-1: /dev/sda model: ST500LT012 size: 500.1GB
Partition: ID-1: / size: 46G used: 35G (80%) fs: ext4 dev: /dev/sda8
           ID-2: /HOME size: 150G used: 110G (78%) fs: ext4 dev: /dev/sda9
           ID-3: swap-1 size: 8.00GB used: 0.02GB (0%) fs: swap dev: /dev/sda10
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 49.0C mobo: N/A
           Fan Speeds (in rpm): cpu: 2600
Info:      Processes: 224 Uptime: 2 days Memory: 2177.4/5958.5MB
           Init: Upstart runlevel: 2 Gcc sys: 4.8.4
           Client: Shell (bash 4.3.111) inxi: 2.2.28 
Last edited by afilk on Fri Jan 18, 2019 1:12 pm, edited 1 time in total.

Level 1
Level 1
Posts: 11
Joined: Sun Aug 30, 2015 9:59 pm

Re: Bluetooth connection drops out after a few minutes

Post by afilk » Fri Jan 18, 2019 1:12 pm

This problem seems to be totally gone after updating from Mint 17.3 to 18.3. I had also tried installing blueman, but that didn't seem to be what solved my issue.

Level 1
Level 1
Posts: 1
Joined: Tue Aug 13, 2019 12:36 pm

Re: [SOLVED] Bluetooth connection drops out after a few minutes

Post by mobilelinux » Tue Aug 13, 2019 1:41 pm

In my case after I upgraded from 19.1 to 19.2, Bluetooth stopped working with the PXC 550 headphone.

After playing around with the different kernel versions, I settled on:

Linux 5.0.0-20-generic #21~18.04.1-Ubuntu

All the newer versions above this version did not work for me.

Code: Select all

System:    Host: myusbpc-passport Kernel: 5.0.0-20-generic x86_64 bits: 64 compiler: gcc v: 7.4.0 
           Desktop: Cinnamon 4.2.3 Distro: Linux Mint 19.2 Tina base: Ubuntu 18.04 bionic 
Machine:   Type: Desktop System: Dell product: XPS 8700 v: N/A serial: <root required> 
           Mobo: Dell model: 0KWVT8 v: A02 serial: <root required> BIOS: Dell v: A10 date: 12/08/2014 
CPU:       Topology: Quad Core model: Intel Core i7-4770 bits: 64 type: MT MCP arch: Haswell rev: 3 
           L2 cache: 8192 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 54271 
           Speed: 1596 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 1593 2: 1595 3: 1575 4: 1595 5: 1545 6: 1579 
           7: 1589 8: 1541 
Graphics:  Device-1: NVIDIA GK106 [GeForce GTX 645 OEM] driver: nvidia v: 390.116 bus ID: 01:00.0 
           Display: x11 server: X.Org 1.19.6 driver: nvidia unloaded: fbdev,modesetting,nouveau,vesa 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: GeForce GTX 645/PCIe/SSE2 v: 4.6.0 NVIDIA 390.116 direct render: Yes 
Audio:     Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: Dell driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 
           Device-2: NVIDIA GK106 HDMI Audio driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           Device-3: Audio-Technica type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 3-1.5:6 
           Sound Server: ALSA v: k5.0.0-20-generic 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell driver: r8169 v: kernel 
           port: d000 bus ID: 03:00.0 
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: f8:b1:56:d3:19:8a 
           Device-2: Qualcomm Atheros AR9485 Wireless Network Adapter vendor: Dell driver: ath9k v: kernel 
           port: d000 bus ID: 04:00.0 
           IF: wlp4s0 state: down mac: 54:35:30:cc:37:3f 
           Device-3: Atheros type: USB driver: btusb bus ID: 3-13:13 
           IF-ID-1: docker0 state: down mac: 02:42:22:94:40:b6 
Drives:    Local Storage: total: 10.01 TiB used: 2.67 TiB (26.7%) 
           ID-1: /dev/sda vendor: Seagate model: ST2000DM001-1CH164 size: 1.82 TiB 
           ID-2: /dev/sdb type: USB vendor: Seagate model: Expansion Desk size: 4.55 TiB 
           ID-3: /dev/sdc type: USB vendor: Western Digital model: WD My Passport 25E1 size: 1.82 TiB 
           ID-4: /dev/sdd type: USB vendor: Toshiba model: MQ01UBB200 size: 1.82 TiB 
Partition: ID-1: / size: 885.77 GiB used: 565.09 GiB (63.8%) fs: ext4 dev: /dev/sdc5 
           ID-2: swap-1 size: 30.57 GiB used: 2.8 MiB (0.0%) fs: swap dev: /dev/sdc3 
Sensors:   System Temperatures: cpu: 41.0 C mobo: N/A gpu: nvidia temp: 62 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 33% 
Info:      Processes: 340 Uptime: 13h 44m Memory: 15.61 GiB used: 7.33 GiB (47.0%) Init: systemd runlevel: 5 
           Compilers: gcc: 7.4.0 Shell: bash v: 4.4.20 inxi: 3.0.32 

Post Reply

Return to “Wireless”