Realtek R8822BE wireless (wifi) not working Mint 19 Tara

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
mwbrown
Level 1
Level 1
Posts: 1
Joined: Thu Jan 31, 2019 12:14 pm

Realtek R8822BE wireless (wifi) not working Mint 19 Tara

Post by mwbrown »

Lenovo Flex 14
Ryzen 7 2700U/RADEON Vega Graphics
Running Mint 19 Tara both off of live USB and local install as dual boot no wireless is recognized. MATE DE (just in case that matters at all)
Linux Kernel: 4.15.0-20-generic x86_64

inxi -i results as follows:
card: Realtek Device b8822 driver: r8822be IF: wlpls0 state: down mac: xx:xx:xx:xx WAN IP: None Detected! IF: wlps0 ip-v4: N/A ip-v6-link: N/A

rfkill results:
0 wlan ideapad_wlan Soft: unblocked Hard: blocked
1 bluetooth ideapad_bluetooth Soft: blocked Hard: blocked
2 bluetooth hci0 Soft: blocked Hard: unblocked
3 wlan phy0 Soft: unblocked Hard: unblocked

I'm pretty new to Linux, but I have Mint running fine on another Lenovo Ideapad Laptop with no issues, but of course, a different wireless adapter. I looked up a few videos on YouTube and did some searching but couldn't find a solution that worked. So far I've tried using Ndiswrapper to manually install the drivers for the card, rfkill unblock all (doesn't remove hard blocks).

I ran out of ideas so I'm posting this up here to see if there's anything specific that I can try or if others in the community have come across the same or similar issues. Any help is greatly appreciated. I love Mint and want to full make the switch from Windows. Hopefully I didn't just buy the wrong laptop for it (lesson learned if so).

Cheers all.

BretAB
Level 1
Level 1
Posts: 9
Joined: Tue Feb 05, 2019 1:56 pm

Re: Realtek R8822BE wireless (wifi) not working Mint 19 Tara

Post by BretAB »

Maybe my thread here can be helpful ? :
viewtopic.php?f=53&t=288127

JeremyB
Level 20
Level 20
Posts: 11475
Joined: Fri Feb 21, 2014 8:17 am

Re: Realtek R8822BE wireless (wifi) not working Mint 19 Tara

Post by JeremyB »

Actually run the commands in viewtopic.php?f=49&t=289493#p1604214
Make secure Boot is disabled in BIOS, leave the secure Boot keys alone, Reboot

Post Reply

Return to “Wireless”