Realtek RTL8812BU AC1200M Wireless NIC - Install for Mint 19.1 .

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
BretAB
Level 1
Level 1
Posts: 8
Joined: Tue Feb 05, 2019 1:56 pm

Realtek RTL8812BU AC1200M Wireless NIC - Install for Mint 19.1 .

Post by BretAB » Fri Feb 15, 2019 11:21 am

Hi,

I have one of the inexpensive AC1200M USB 3.0 NICs (aka Realtek RTL8812BU Wireless 802.11ac), as seen here:
https://www.ebay.com/itm/AC1200Mbps-USB ... 23a7f0375d > The NIC is plugged into a USB 2.0 port on my trusty old Dell 1501 Inspiron Laptop (upgraded to Samsung 840 SSD and AMD 2.3Ghz TL-66 x2). OS is Linux Mint 19.1 Tessa 64-bit, Kernel Linux 4.14.0-45-generic x86_64, MATE 1.20.1 .

I was able to get it to work relatively easily via cut and paste into Terminal of this code by chili555 that he posted at https://ubuntuforums.org/showthread.php?t=2394372 :
Code:

Code: Select all

sudo apt-get update 
sudo apt-get install build-essential git 
git clone https://github.com/cilynx/rtl88x2BU_WiFi_linux_v5.2.4.4_25643.20171212_COEX20171012-5044.git 
cd rtl88x2BU_WiFi_linux_v5.2.4.4_25643.20171212_COEX20171012-5044
VER=$(cat ./version) 
sudo rsync -rvhP ./ /usr/src/rtl88x2bu-${VER} 
sudo dkms add -m rtl88x2bu -v ${VER} 
sudo dkms build -m rtl88x2bu -v ${VER} 
sudo dkms install -m rtl88x2bu -v ${VER} 
sudo modprobe 88x2bu
After applying the code:
1) Reboot.
2) Open Control Center and the Network Connections.
3) Click the + sign, dropdown and select Wi-fi:
4) When the form opens, enter a descriptive Connection Name at the top.
5) On Wi-Fi tab add your SSID,
6) On Security tab select WPA2 Personal (or whatever security you're wireless router/gateway is using) and enter the wireless network's password.
7) Reboot

As a Linux n00b, that worked for me straight out of the box (after a reboot). Somewhere I also read that this code will need to be reapplied whenever the Kernel is updated: Not sure about that as it's above my paygrade :->

HTH . . .

Marcoose81
Level 1
Level 1
Posts: 1
Joined: Fri Jul 05, 2019 10:46 am

Re: Realtek RTL8812BU AC1200M Wireless NIC - Install for Mint 19.1 .

Post by Marcoose81 » Fri Jul 05, 2019 10:50 am

Oh you're an angel!
Worked for me. I have internet!!

:twisted:

Post Reply

Return to “Wireless”