Wireless speed slow since around 10 days

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
deepakdeshp
Level 15
Level 15
Posts: 5658
Joined: Sun Aug 09, 2015 10:00 am

Wireless speed slow since around 10 days

Post by deepakdeshp » Fri Mar 01, 2019 2:21 pm

hello,
As the title says my network speed is very slow.

Code: Select all

inxi -Fxz
System:
  Host: mint-18-uma Kernel: 4.19.13-041913-generic x86_64 bits: 64 
  compiler: gcc v: 8.2.0 Desktop: Cinnamon 4.0.9 
  Distro: Linux Mint 19.1 Tessa base: Ubuntu 18.04 bionic 
Machine:
  Type: Laptop System: Hewlett-Packard product: HP Notebook 
  v: Type1ProductConfigId serial: <filter> 
  Mobo: Hewlett-Packard model: 80CC v: 99.52 serial: <filter> UEFI: Insyde 
  v: F.25 date: 05/04/2018 
Battery:
  ID-1: BAT1 charge: 29.1 Wh condition: 30.8/30.8 Wh (100%) 
  model: 131-42-6E HS04041 status: Unknown 
CPU:
  Topology: Quad Core model: AMD A8-7410 APU with AMD Radeon R5 Graphics 
  bits: 64 type: MCP arch: Puma rev: 1 L2 cache: 2048 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 17568 
  Speed: 998 MHz min/max: 1000/2200 MHz Core speeds (MHz): 1: 998 2: 998 
  3: 998 4: 998 
Graphics:
  Device-1: AMD Mullins [Radeon R4/R5 Graphics] vendor: Hewlett-Packard 
  driver: radeon v: kernel bus ID: 00:01.0 
  Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 / R7 
  M520] 
  vendor: Hewlett-Packard driver: radeon v: kernel bus ID: 01:00.0 
  Display: x11 server: X.Org 1.19.6 driver: ati,radeon 
  unloaded: fbdev,modesetting,vesa resolution: 1366x768~60Hz 
  OpenGL: 
  renderer: AMD MULLINS (DRM 2.50.0 4.19.13-041913-generic LLVM 7.0.0) 
  v: 4.5 Mesa 18.2.2 direct render: Yes 
Audio:
  Device-1: AMD Kabini HDMI/DP Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 00:01.1 
  Device-2: AMD FCH Azalia vendor: Hewlett-Packard driver: snd_hda_intel 
  v: kernel bus ID: 00:14.2 
  Sound Server: ALSA v: k4.19.13-041913-generic 
Network:
  Device-1: Realtek RTL8723BE PCIe Wireless Network Adapter 
  vendor: Hewlett-Packard driver: rtl8723be v: kernel port: 3000 
  bus ID: 02:00.0 
  IF: wlo1 state: up mac: <filter> 
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: kernel port: 2000 bus ID: 03:00.0 
  IF: enp3s0 state: down mac: <filter> 
  IF-ID-1: virbr0 state: down mac: <filter> 
  IF-ID-2: virbr0-nic state: down mac: <filter> 
  IF-ID-3: vmnet1 state: unknown speed: N/A duplex: N/A mac: <filter> 
  IF-ID-4: vmnet8 state: unknown speed: N/A duplex: N/A mac: <filter> 
Drives:
  Local Storage: total: 465.76 GiB used: 220.46 GiB (47.3%) 
  ID-1: /dev/sda vendor: HGST (Hitachi) model: HTS545050A7E680 
  size: 465.76 GiB 
Partition:
  ID-1: / size: 145.55 GiB used: 132.19 GiB (90.8%) fs: ext4 dev: /dev/sda7 
  ID-2: swap-1 size: 4.98 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda8 
Sensors:
  System Temperatures: cpu: 45.1 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  GPU: device: radeon temp: 43 C device: radeon temp: 45 C 
Info:
  Processes: 291 Uptime: 34m Memory: 6.75 GiB used: 2.13 GiB (31.6%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.3.0 Shell: bash v: 4.4.19 
  inxi: 3.0.27 
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.2 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

User avatar
cool
Level 2
Level 2
Posts: 50
Joined: Sat May 28, 2011 12:44 am
Contact:

Re: Wireless speed slow since around 10 days

Post by cool » Fri Mar 01, 2019 5:12 pm

Just restarting the router helps? also check the Bit Rate, and Link Quality.

Code: Select all

iwconfig
For the very latest please visit: SpaceEdge

User avatar
Pjotr
Level 21
Level 21
Posts: 13223
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Wireless speed slow since around 10 days

Post by Pjotr » Fri Mar 01, 2019 5:34 pm

Couple of things:

1. You might try an antenna switch:

Code: Select all

sudo modprobe -r rtl8723be && sleep 5 && sudo modprobe rtl8723be ant_sel=2
If that is better:

Code: Select all

echo "options rtl8723be ant_sel=2" | sudo tee /etc/modprobe.d/rtl8723be.conf
2. Disable power management for your WiFi chipset:
https://easylinuxtipsproject.blogspot.c ... t.html#ID9
(item 9)

3. If that doesn't help, try a supported kernel instead of your current (UKUU?) kernel....

4. And for that supported kernel, you can try a driver switch:
https://easylinuxtipsproject.blogspot.c ... k.html#ID7
(item 7)
Tip: 10 things to do after installing Linux Mint 19.2 Tina
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

mediclaser
Level 4
Level 4
Posts: 362
Joined: Tue Mar 20, 2018 2:28 pm

Re: Wireless speed slow since around 10 days

Post by mediclaser » Fri Mar 01, 2019 11:40 pm

Do you have neighbors close by? One typical cause of Wifi slow down is having neighbors using the same frequency channel as your router. If you are on 2.4 Ghz, it's more prone to this type of interference compared to 5 Ghz.

I use Wifi Analyzer on my phone to check for neighboring routers which maybe using the same frequency channel as my mine.

Have you recently installed any household appliances which maybe on the same frequency as your wireless router?
If you're looking for a greener Linux pasture, you won't find any that is greener than Linux Mint. ;)

Post Reply

Return to “Wireless”