WiFi interface cannot switch to UP state

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
emitor
Level 1
Level 1
Posts: 25
Joined: Fri Jul 06, 2018 8:32 am

WiFi interface cannot switch to UP state

Post by emitor » Sat Mar 16, 2019 9:05 am

Hello World!

I am in trouble with WiFi adapter. I have laptop HP 350 with build-in RT3290 Wireless 802.11n 1T/1R PCIe. Laptop has Windows 10 installed. I am using Mint 19 running from USB to debug WiFi connect issue.

Problem description - same for Windows and Mint: WiFi networks are visible but after trying to connect it says just something like "Could not connect". WiFi was working correctly until Windows upgrade to Version 1709 (Fall Creators Update) or Version 1803 (April 2018 Update) I do not remember. It also may be some hardware issue but I still hope that it is not.

Mint's driver manager do not find any driver to update - see attached screenshot.

So I am trying to bring the interface UP via command line. But interface state is still DOWN. Any help welcome.

Thank you.

Code: Select all

root@mint:~# iw dev
phy#0
	Interface wlo1
		ifindex 3
		wdev 0x1
		addr 9c:d2:1e:43:84:69
		type managed
		txpower 20.00 dBm
root@mint:~# ip link set wlo1 down
root@mint:~# ip link show wlo1
3: wlo1: <BROADCAST,MULTICAST> mtu 1500 qdisc mq state DOWN mode DORMANT group default qlen 1000
    link/ether 9c:d2:1e:43:84:69 brd ff:ff:ff:ff:ff:ff
root@mint:~# ip link set wlo1 up
root@mint:~# ip link show wlo1
3: wlo1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DORMANT group default qlen 1000
    link/ether 9c:d2:1e:43:84:69 brd ff:ff:ff:ff:ff:ff
Maybe part of syslog may help

Code: Select all

Mar 16 13:45:33 mint NetworkManager[1243]: <info>  [1552743933.4475] manager: rfkill: WiFi hardware radio set enabled
Mar 16 13:45:33 mint systemd[1]: Starting Load/Save RF Kill Switch Status...
Mar 16 13:45:33 mint systemd[1]: Started Load/Save RF Kill Switch Status.
Mar 16 13:45:33 mint NetworkManager[1243]: <info>  [1552743933.5732] audit: op="radio-control" arg="wireless-enabled:1" pid=1795 uid=999 result="success"
Mar 16 13:45:33 mint NetworkManager[1243]: <info>  [1552743933.5742] manager: rfkill: WiFi now enabled by radio killswitch
Mar 16 13:45:33 mint kernel: [ 4098.758953] IPv6: ADDRCONF(NETDEV_UP): wlo1: link is not ready
Mar 16 13:45:33 mint wpa_supplicant[1179]: dbus: fill_dict_with_properties dbus_interface=fi.w1.wpa_supplicant1.Interface dbus_property=Stations getter failed
Mar 16 13:45:33 mint wpa_supplicant[1179]: dbus: wpa_dbus_get_object_properties: failed to get object properties: (none) none
Mar 16 13:45:33 mint wpa_supplicant[1179]: dbus: Failed to construct signal
Mar 16 13:45:33 mint wpa_supplicant[1179]: dbus: fill_dict_with_properties dbus_interface=fi.w1.wpa_supplicant1.Interface dbus_property=Stations getter failed
Mar 16 13:45:33 mint NetworkManager[1243]: <info>  [1552743933.6246] device (wlo1): supplicant interface state: starting -> ready
Mar 16 13:45:33 mint NetworkManager[1243]: <info>  [1552743933.6247] device (wlo1): state change: unavailable -> disconnected (reason 'supplicant-available', sys-iface-state: 'managed')
Mar 16 13:45:33 mint kernel: [ 4098.811963] IPv6: ADDRCONF(NETDEV_UP): wlo1: link is not ready
Mar 16 13:45:36 mint NetworkManager[1243]: <info>  [1552743936.9359] keyfile: add connection in-memory (d4174577-76bf-4593-b398-893c45d072b3,"Auto PLJ")
Mar 16 13:45:36 mint NetworkManager[1243]: <info>  [1552743936.9388] device (wlo1): Activation: starting connection 'Auto PLJ' (d4174577-76bf-4593-b398-893c45d072b3)
Mar 16 13:45:36 mint NetworkManager[1243]: <info>  [1552743936.9569] settings-connection[0x56477d96d520,d4174577-76bf-4593-b398-893c45d072b3]: write: successfully commited (keyfile: update /etc/NetworkManager/system-connections/Auto PLJ (d4174577-76bf-4593-b398-893c45d072b3,"Auto PLJ") and persist connection)
Mar 16 13:45:36 mint NetworkManager[1243]: <info>  [1552743936.9571] audit: op="connection-add-activate" uuid="d4174577-76bf-4593-b398-893c45d072b3" name="Auto PLJ" pid=1795 uid=999 result="success"
Mar 16 13:45:36 mint NetworkManager[1243]: <info>  [1552743936.9777] device (wlo1): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
Mar 16 13:45:36 mint NetworkManager[1243]: <info>  [1552743936.9788] manager: NetworkManager state is now CONNECTING
Mar 16 13:45:36 mint NetworkManager[1243]: <info>  [1552743936.9864] device (wlo1): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Mar 16 13:45:36 mint NetworkManager[1243]: <info>  [1552743936.9872] device (wlo1): Activation: (wifi) access point 'Auto PLJ' has security, but secrets are required.
Mar 16 13:45:36 mint NetworkManager[1243]: <info>  [1552743936.9873] device (wlo1): state change: config -> need-auth (reason 'none', sys-iface-state: 'managed')
Mar 16 13:45:37 mint dbus-daemon[1059]: [system] Activating via systemd: service name='org.freedesktop.hostname1' unit='dbus-org.freedesktop.hostname1.service' requested by ':1.49' (uid=999 pid=1816 comm="nm-applet " label="unconfined")
Mar 16 13:45:37 mint systemd[1]: Starting Hostname Service...
Mar 16 13:45:37 mint dbus-daemon[1059]: [system] Successfully activated service 'org.freedesktop.hostname1'
Mar 16 13:45:37 mint systemd[1]: Started Hostname Service.
Mar 16 13:45:51 mint NetworkManager[1243]: <info>  [1552743951.6127] settings-connection[0x56477d96d520,d4174577-76bf-4593-b398-893c45d072b3]: write: successfully commited (keyfile: update /etc/NetworkManager/system-connections/Auto PLJ (d4174577-76bf-4593-b398-893c45d072b3,"Auto PLJ"))
Mar 16 13:45:51 mint NetworkManager[1243]: <info>  [1552743951.6133] device (wlo1): state change: need-auth -> prepare (reason 'none', sys-iface-state: 'managed')
Mar 16 13:45:51 mint NetworkManager[1243]: <info>  [1552743951.6139] device (wlo1): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Mar 16 13:45:51 mint NetworkManager[1243]: <info>  [1552743951.6144] device (wlo1): Activation: (wifi) connection 'Auto PLJ' has security, and secrets exist.  No new secrets needed.
Mar 16 13:45:51 mint NetworkManager[1243]: <info>  [1552743951.6145] Config: added 'ssid' value 'PLJ'
Mar 16 13:45:51 mint NetworkManager[1243]: <info>  [1552743951.6145] Config: added 'scan_ssid' value '1'
Mar 16 13:45:51 mint NetworkManager[1243]: <info>  [1552743951.6145] Config: added 'bgscan' value 'simple:30:-80:86400'
Mar 16 13:45:51 mint NetworkManager[1243]: <info>  [1552743951.6146] Config: added 'key_mgmt' value 'WPA-PSK'
Mar 16 13:45:51 mint NetworkManager[1243]: <info>  [1552743951.6146] Config: added 'auth_alg' value 'OPEN'
Mar 16 13:45:51 mint NetworkManager[1243]: <info>  [1552743951.6146] Config: added 'psk' value '<hidden>'
Mar 16 13:45:51 mint NetworkManager[1243]: <info>  [1552743951.6479] device (wlo1): supplicant interface state: ready -> scanning
Mar 16 13:45:52 mint wpa_supplicant[1179]: wlo1: SME: Trying to authenticate with 00:4f:74:31:20:9e (SSID='PLJ' freq=2437 MHz)
Mar 16 13:45:52 mint kernel: [ 4117.820272] wlo1: authenticate with 00:4f:74:31:20:9e
Mar 16 13:45:52 mint kernel: [ 4117.820287] wlo1: No basic rates, using min rate instead
Mar 16 13:45:52 mint kernel: [ 4117.822453] wlo1: send auth to 00:4f:74:31:20:9e (try 1/3)
Mar 16 13:45:52 mint NetworkManager[1243]: <info>  [1552743952.6441] device (wlo1): supplicant interface state: scanning -> authenticating
Mar 16 13:45:52 mint kernel: [ 4117.861453] wlo1: send auth to 00:4f:74:31:20:9e (try 2/3)
Mar 16 13:45:52 mint kernel: [ 4117.899682] wlo1: send auth to 00:4f:74:31:20:9e (try 3/3)
Mar 16 13:45:52 mint kernel: [ 4117.950515] wlo1: authentication with 00:4f:74:31:20:9e timed out
Mar 16 13:45:52 mint NetworkManager[1243]: <info>  [1552743952.7847] device (wlo1): supplicant interface state: authenticating -> disconnected
Mar 16 13:45:52 mint NetworkManager[1243]: <info>  [1552743952.8851] device (wlo1): supplicant interface state: disconnected -> scanning
Mar 16 13:45:53 mint wpa_supplicant[1179]: wlo1: SME: Trying to authenticate with 00:4f:74:31:20:9e (SSID='PLJ' freq=2437 MHz)
Mar 16 13:45:53 mint kernel: [ 4119.060440] wlo1: authenticate with 00:4f:74:31:20:9e
Mar 16 13:45:53 mint kernel: [ 4119.060460] wlo1: No basic rates, using min rate instead
Mar 16 13:45:53 mint kernel: [ 4119.062352] wlo1: send auth to 00:4f:74:31:20:9e (try 1/3)
Mar 16 13:45:53 mint NetworkManager[1243]: <info>  [1552743953.8802] device (wlo1): supplicant interface state: scanning -> authenticating
Mar 16 13:45:53 mint kernel: [ 4119.086060] wlo1: send auth to 00:4f:74:31:20:9e (try 2/3)
Mar 16 13:45:53 mint kernel: [ 4119.138391] wlo1: send auth to 00:4f:74:31:20:9e (try 3/3)
Mar 16 13:45:53 mint kernel: [ 4119.175127] wlo1: authentication with 00:4f:74:31:20:9e timed out
Mar 16 13:45:54 mint NetworkManager[1243]: <info>  [1552743954.0124] device (wlo1): supplicant interface state: authenticating -> disconnected
Mar 16 13:45:54 mint NetworkManager[1243]: <info>  [1552743954.5132] device (wlo1): supplicant interface state: disconnected -> scanning
Mar 16 13:45:55 mint wpa_supplicant[1179]: wlo1: SME: Trying to authenticate with 00:4f:74:31:20:9e (SSID='PLJ' freq=2437 MHz)
Mar 16 13:45:55 mint kernel: [ 4120.692476] wlo1: authenticate with 00:4f:74:31:20:9e
Mar 16 13:45:55 mint kernel: [ 4120.692492] wlo1: No basic rates, using min rate instead
Mar 16 13:45:55 mint kernel: [ 4120.694340] wlo1: send auth to 00:4f:74:31:20:9e (try 1/3)
Mar 16 13:45:55 mint NetworkManager[1243]: <info>  [1552743955.5122] device (wlo1): supplicant interface state: scanning -> authenticating
Mar 16 13:45:55 mint kernel: [ 4120.733708] wlo1: send auth to 00:4f:74:31:20:9e (try 2/3)
Mar 16 13:45:55 mint kernel: [ 4120.773247] wlo1: send auth to 00:4f:74:31:20:9e (try 3/3)
Mar 16 13:45:55 mint kernel: [ 4120.804378] wlo1: authentication with 00:4f:74:31:20:9e timed out
Mar 16 13:45:55 mint NetworkManager[1243]: <info>  [1552743955.6406] device (wlo1): supplicant interface state: authenticating -> disconnected
Mar 16 13:45:56 mint NetworkManager[1243]: <info>  [1552743956.6419] device (wlo1): supplicant interface state: disconnected -> scanning
Mar 16 13:45:57 mint wpa_supplicant[1179]: wlo1: SME: Trying to authenticate with 00:4f:74:31:20:9e (SSID='PLJ' freq=2437 MHz)
Mar 16 13:45:57 mint kernel: [ 4122.816068] wlo1: authenticate with 00:4f:74:31:20:9e
Mar 16 13:45:57 mint kernel: [ 4122.816081] wlo1: No basic rates, using min rate instead
Mar 16 13:45:57 mint kernel: [ 4122.818353] wlo1: send auth to 00:4f:74:31:20:9e (try 1/3)
Mar 16 13:45:57 mint NetworkManager[1243]: <info>  [1552743957.6418] device (wlo1): supplicant interface state: scanning -> authenticating
Mar 16 13:45:57 mint kernel: [ 4122.855757] wlo1: send auth to 00:4f:74:31:20:9e (try 2/3)
Mar 16 13:45:57 mint kernel: [ 4122.887981] wlo1: send auth to 00:4f:74:31:20:9e (try 3/3)
Mar 16 13:45:57 mint kernel: [ 4122.926408] wlo1: authentication with 00:4f:74:31:20:9e timed out
Mar 16 13:45:57 mint wpa_supplicant[1179]: wlo1: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="PLJ" auth_failures=1 duration=10 reason=CONN_FAILED
Mar 16 13:45:57 mint NetworkManager[1243]: <info>  [1552743957.7605] device (wlo1): supplicant interface state: authenticating -> disconnected
Mar 16 13:46:02 mint NetworkManager[1243]: <info>  [1552743962.7629] device (wlo1): supplicant interface state: disconnected -> scanning
Mar 16 13:46:07 mint wpa_supplicant[1179]: wlo1: CTRL-EVENT-SSID-REENABLED id=0 ssid="PLJ"
Mar 16 13:46:07 mint wpa_supplicant[1179]: wlo1: SME: Trying to authenticate with 00:4f:74:31:20:9e (SSID='PLJ' freq=2437 MHz)
Mar 16 13:46:07 mint kernel: [ 4132.944382] wlo1: authenticate with 00:4f:74:31:20:9e
Mar 16 13:46:07 mint kernel: [ 4132.944395] wlo1: No basic rates, using min rate instead
Mar 16 13:46:07 mint kernel: [ 4132.946193] wlo1: send auth to 00:4f:74:31:20:9e (try 1/3)
Mar 16 13:46:07 mint NetworkManager[1243]: <info>  [1552743967.7640] device (wlo1): supplicant interface state: scanning -> authenticating
Mar 16 13:46:07 mint kernel: [ 4132.988802] wlo1: send auth to 00:4f:74:31:20:9e (try 2/3)
Mar 16 13:46:07 mint kernel: [ 4133.021044] wlo1: send auth to 00:4f:74:31:20:9e (try 3/3)
Mar 16 13:46:07 mint kernel: [ 4133.068595] wlo1: authentication with 00:4f:74:31:20:9e timed out
Mar 16 13:46:07 mint wpa_supplicant[1179]: wlo1: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="PLJ" auth_failures=2 duration=20 reason=CONN_FAILED
Mar 16 13:46:07 mint NetworkManager[1243]: <info>  [1552743967.9130] device (wlo1): supplicant interface state: authenticating -> disconnected
Mar 16 13:46:16 mint NetworkManager[1243]: <warn>  [1552743976.8027] device (wlo1): Activation: (wifi) association took too long, failing activation
Mar 16 13:46:16 mint NetworkManager[1243]: <info>  [1552743976.8028] device (wlo1): state change: config -> failed (reason 'ssid-not-found', sys-iface-state: 'managed')
Mar 16 13:46:16 mint NetworkManager[1243]: <info>  [1552743976.8034] manager: NetworkManager state is now DISCONNECTED
Mar 16 13:46:16 mint NetworkManager[1243]: <warn>  [1552743976.8052] device (wlo1): Activation: failed for connection 'Auto PLJ'
Mar 16 13:46:16 mint NetworkManager[1243]: <info>  [1552743976.8076] device (wlo1): state change: failed -> disconnected (reason 'none', sys-iface-state: 'managed')
Mar 16 13:46:16 mint kernel: [ 4141.994619] IPv6: ADDRCONF(NETDEV_UP): wlo1: link is not ready
Mar 16 13:46:17 mint NetworkManager[1243]: <info>  [1552743977.9129] device (wlo1): supplicant interface state: disconnected -> inactive
Mar 16 13:46:25 mint NetworkManager[1243]: <info>  [1552743985.8140] manager: rfkill: WiFi hardware radio set disabled
Mar 16 13:46:25 mint NetworkManager[1243]: <info>  [1552743985.8141] device (wlo1): state change: disconnected -> unavailable (reason 'none', sys-iface-state: 'managed')
Mar 16 13:46:25 mint wpa_supplicant[1179]: rfkill: WLAN soft blocked
Mar 16 13:46:25 mint systemd[1]: Starting Load/Save RF Kill Switch Status...
Mar 16 13:46:25 mint NetworkManager[1243]: <info>  [1552743985.8215] audit: op="radio-control" arg="wireless-enabled:0" pid=1795 uid=999 result="success"
Mar 16 13:46:25 mint NetworkManager[1243]: <info>  [1552743985.8220] manager: rfkill: WiFi now disabled by radio killswitch
Mar 16 13:46:25 mint systemd[1]: Started Load/Save RF Kill Switch Status.
Mar 16 13:46:25 mint wpa_supplicant[1179]: nl80211: deinit ifname=wlo1 disabled_11b_rates=0
I also tried to connect to open (no-password) wireless network:

Code: Select all

Mar 16 14:27:13 mint NetworkManager[1243]: <info>  [1552746433.6405] device (wlo1): Activation: starting connection 'Auto emitor-2g' (080465f1-1b6e-46fd-8111-d9c265739fbe)
Mar 16 14:27:13 mint NetworkManager[1243]: <info>  [1552746433.6408] audit: op="connection-activate" uuid="080465f1-1b6e-46fd-8111-d9c265739fbe" name="Auto emitor-2g" pid=6386 uid=999 result="success"
Mar 16 14:27:13 mint NetworkManager[1243]: <info>  [1552746433.6412] device (wlo1): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
Mar 16 14:27:13 mint NetworkManager[1243]: <info>  [1552746433.6416] manager: NetworkManager state is now CONNECTING
Mar 16 14:27:13 mint NetworkManager[1243]: <info>  [1552746433.6438] device (wlo1): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Mar 16 14:27:13 mint NetworkManager[1243]: <info>  [1552746433.6446] device (wlo1): Activation: (wifi) access point 'Auto emitor-2g' has security, but secrets are required.
Mar 16 14:27:13 mint NetworkManager[1243]: <info>  [1552746433.6448] device (wlo1): state change: config -> need-auth (reason 'none', sys-iface-state: 'managed')
Mar 16 14:27:13 mint NetworkManager[1243]: <info>  [1552746433.6544] device (wlo1): state change: need-auth -> prepare (reason 'none', sys-iface-state: 'managed')
Mar 16 14:27:13 mint NetworkManager[1243]: <info>  [1552746433.6550] device (wlo1): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Mar 16 14:27:13 mint NetworkManager[1243]: <info>  [1552746433.6553] device (wlo1): Activation: (wifi) connection 'Auto emitor-2g' has security, and secrets exist.  No new secrets needed.
Mar 16 14:27:13 mint NetworkManager[1243]: <info>  [1552746433.6554] Config: added 'ssid' value 'emitor-2g'
Mar 16 14:27:13 mint NetworkManager[1243]: <info>  [1552746433.6554] Config: added 'scan_ssid' value '1'
Mar 16 14:27:13 mint NetworkManager[1243]: <info>  [1552746433.6554] Config: added 'bgscan' value 'simple:30:-80:86400'
Mar 16 14:27:13 mint NetworkManager[1243]: <info>  [1552746433.6555] Config: added 'key_mgmt' value 'WPA-PSK'
Mar 16 14:27:13 mint NetworkManager[1243]: <info>  [1552746433.6555] Config: added 'auth_alg' value 'OPEN'
Mar 16 14:27:13 mint NetworkManager[1243]: <info>  [1552746433.6555] Config: added 'psk' value '<hidden>'
Mar 16 14:27:13 mint NetworkManager[1243]: <info>  [1552746433.6920] device (wlo1): supplicant interface state: ready -> scanning
Mar 16 14:27:38 mint NetworkManager[1243]: <warn>  [1552746458.8013] device (wlo1): Activation: (wifi) association took too long, failing activation
Mar 16 14:27:38 mint NetworkManager[1243]: <info>  [1552746458.8014] device (wlo1): state change: config -> failed (reason 'ssid-not-found', sys-iface-state: 'managed')
Mar 16 14:27:38 mint NetworkManager[1243]: <info>  [1552746458.8019] manager: NetworkManager state is now DISCONNECTED
Mar 16 14:27:38 mint NetworkManager[1243]: <warn>  [1552746458.8035] device (wlo1): Activation: failed for connection 'Auto emitor-2g'
Mar 16 14:27:38 mint NetworkManager[1243]: <info>  [1552746458.8046] device (wlo1): supplicant interface state: scanning -> disconnected
Mar 16 14:27:38 mint NetworkManager[1243]: <info>  [1552746458.8059] device (wlo1): state change: failed -> disconnected (reason 'none', sys-iface-state: 'managed')
Mar 16 14:27:38 mint kernel: [ 6623.985960] IPv6: ADDRCONF(NETDEV_UP): wlo1: link is not ready
Attachments
Screenshot from 2019-03-16 13-03-35.png
Screenshot from 2019-03-16 13-03-35.png (6.98 KiB) Viewed 1266 times
Last edited by emitor on Sat Mar 16, 2019 10:35 am, edited 1 time in total.

Olgatsu1Eiyuuki
Level 1
Level 1
Posts: 4
Joined: Sat Mar 16, 2019 10:02 am

Re: WiFi interface cannot switch to UP state

Post by Olgatsu1Eiyuuki » Sat Mar 16, 2019 10:44 am

Did you go to bios to turn on the network card manually?

1) BIOS by F10 immediately after powered on

2) Advance tab (system, advanced, boot and so)

3) Onboard PCIe or network card = Disabled, then Enable.

NOTE:even if onboard PCI or PCIe or network card is not under advance tab try other tabs as well!

Hope it helps

emitor
Level 1
Level 1
Posts: 25
Joined: Fri Jul 06, 2018 8:32 am

Re: WiFi interface cannot switch to UP state

Post by emitor » Sat Mar 16, 2019 11:15 am

Thank you for your reply. I think I could not see wireless networks with BIOS's disabled wifi network adapter
Attachments
Screenshot from 2019-03-16 16-14-30.png

Olgatsu1Eiyuuki
Level 1
Level 1
Posts: 4
Joined: Sat Mar 16, 2019 10:02 am

Re: WiFi interface cannot switch to UP state

Post by Olgatsu1Eiyuuki » Sat Mar 16, 2019 1:37 pm

A solution related to your topic back in 2015....

https://askubuntu.com/questions/686188/ ... -pcie-i-am

Well, a better investment is alfa networks Wifi adapter (AWUS036NHA). It is hard to carry around with you but that is the best bet if you have issues in both os. Plus alfa network has built-in adaptors as well as cd for drivers (for Windows and mac).

Hope I was a better help!

PS:I hate HP, they are not built properly. I have an SD card Slot that doesn't work in any OS!

emitor
Level 1
Level 1
Posts: 25
Joined: Fri Jul 06, 2018 8:32 am

Re: WiFi interface cannot switch to UP state

Post by emitor » Sat Mar 16, 2019 2:58 pm

Thank you for your reply.
Olgatsu1Eiyuuki wrote:
Sat Mar 16, 2019 1:37 pm
A solution related to your topic back in 2015....

https://askubuntu.com/questions/686188/ ... -pcie-i-am
In mentioned issue there is a solution: to install "firmware-ralink". I found it here:
http://ftp.br.debian.org/debian/pool/no ... -1_all.deb
But I can not install it, because of not satisfiable dependecy to firmware-misc-nonfree package.

What is the rfkill command for?

Code: Select all

root@mint:~# rfkill unblock all
root@mint:~# rfkill list
0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no

JeremyB
Level 20
Level 20
Posts: 11144
Joined: Fri Feb 21, 2014 8:17 am

Re: WiFi interface cannot switch to UP state

Post by JeremyB » Sat Mar 16, 2019 4:29 pm

What does iwconfig show? Any results for cat /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

Olgatsu1Eiyuuki
Level 1
Level 1
Posts: 4
Joined: Sat Mar 16, 2019 10:02 am

Re: WiFi interface cannot switch to UP state

Post by Olgatsu1Eiyuuki » Sat Mar 16, 2019 4:39 pm

rfkill index|type

e.g rfkill block wifi -> Turn OFF wifi
rfkill unblock wifi -> Turn ON wifi

just incase try with 'bluetooth' instead of 'wifi'

rfkill unblock bluetooth
or manually turn on bluetooth
then,
rfkill block bluetooth

Hope it was somewhat of help

PS: if possible try get a then network adaptor.... https://www.amazon.co.uk/Network-AWUS03 ... 483&sr=1-1

I am not sponsoring or something but it is really frustating with a wifi module that doen't work but as a last resort if you really want your built-in wifi module to work, maybe...just maybe try to open your laptop and unplug and replug the network adaptor

emitor
Level 1
Level 1
Posts: 25
Joined: Fri Jul 06, 2018 8:32 am

Re: WiFi interface cannot switch to UP state

Post by emitor » Sun Mar 17, 2019 5:20 am

JeremyB wrote:
Sat Mar 16, 2019 4:29 pm
What does iwconfig show? Any results for cat /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
Thank you for your reply.

Code: Select all

root@mint:~# iwconfig
lo        no wireless extensions.

wlo1      IEEE 802.11  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry short  long limit:2   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          
eno1      no wireless extensions.

Code: Select all

root@mint:~# cat /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
[connection]
wifi.powersave = 3
Last edited by emitor on Sun Mar 17, 2019 5:26 am, edited 1 time in total.

emitor
Level 1
Level 1
Posts: 25
Joined: Fri Jul 06, 2018 8:32 am

Re: WiFi interface cannot switch to UP state

Post by emitor » Sun Mar 17, 2019 5:26 am

Olgatsu1Eiyuuki wrote:
Sat Mar 16, 2019 4:39 pm
rfkill index|type

just incase try with 'bluetooth' instead of 'wifi'

rfkill unblock bluetooth
or manually turn on bluetooth
then,
rfkill block bluetooth
Thank you for your reply.

Code: Select all

root@mint:~# rfkill list
0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
root@mint:~# rfkill block wifi
root@mint:~# rfkill block bluetooth
root@mint:~# rfkill list
0: phy0: Wireless LAN
	Soft blocked: yes
	Hard blocked: no
root@mint:~# rfkill unblock wifi
root@mint:~# rfkill unblock bluetooth
root@mint:~# rfkill list
0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no

User avatar
Pjotr
Level 21
Level 21
Posts: 13876
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: WiFi interface cannot switch to UP state

Post by Pjotr » Sun Mar 17, 2019 5:44 am

root@mint? :shock:
Don't do that.
emitor wrote:
Sat Mar 16, 2019 9:05 am
Mint 19 running from USB
Anyway, we can best help you if you simply install Mint alongside Windows 10. Because then there are options such as the installation of another driver.
Tip: 10 things to do after installing Linux Mint 19.2 Tina
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

emitor
Level 1
Level 1
Posts: 25
Joined: Fri Jul 06, 2018 8:32 am

Re: WiFi interface cannot switch to UP state

Post by emitor » Sun Mar 17, 2019 9:13 am

Pjotr wrote:
Sun Mar 17, 2019 5:44 am
root@mint? :shock:
Don't do that.
Is it problem, to run any of these commands as root?

User avatar
Pjotr
Level 21
Level 21
Posts: 13876
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: WiFi interface cannot switch to UP state

Post by Pjotr » Sun Mar 17, 2019 10:54 am

emitor wrote:
Sun Mar 17, 2019 9:13 am
Pjotr wrote:
Sun Mar 17, 2019 5:44 am
root@mint? :shock:
Don't do that.
Is it problem, to run any of these commands as root?
Yes. Commands should only be executed as root when absolutely necessary. Otherwise there's the risk of collateral damage.
Tip: 10 things to do after installing Linux Mint 19.2 Tina
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

emitor
Level 1
Level 1
Posts: 25
Joined: Fri Jul 06, 2018 8:32 am

Re: WiFi interface cannot switch to UP state

Post by emitor » Tue Mar 19, 2019 3:40 am

Pjotr wrote:
Sun Mar 17, 2019 10:54 am
emitor wrote:
Sun Mar 17, 2019 9:13 am
Pjotr wrote:
Sun Mar 17, 2019 5:44 am
root@mint? :shock:
Don't do that.
Is it problem, to run any of these commands as root?
Yes. Commands should only be executed as root when absolutely necessary. Otherwise there's the risk of collateral damage.
What collateral damage can be made when Mint is running on USB stick?

User avatar
Pjotr
Level 21
Level 21
Posts: 13876
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: WiFi interface cannot switch to UP state

Post by Pjotr » Tue Mar 19, 2019 5:28 am

emitor wrote:
Tue Mar 19, 2019 3:40 am
Pjotr wrote:
Sun Mar 17, 2019 10:54 am
emitor wrote:
Sun Mar 17, 2019 9:13 am


Is it problem, to run any of these commands as root?
Yes. Commands should only be executed as root when absolutely necessary. Otherwise there's the risk of collateral damage.
What collateral damage can be made when Mint is running on USB stick?
Not much, granted, but it's a useless bad habit which it's best to unlearn before you start working with a hard drive install.
Tip: 10 things to do after installing Linux Mint 19.2 Tina
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

Jlvs2run
Level 3
Level 3
Posts: 143
Joined: Wed Sep 16, 2015 11:16 pm

Re: WiFi interface cannot switch to UP state

Post by Jlvs2run » Thu Mar 21, 2019 4:15 pm

Pjotr wrote:
Sun Mar 17, 2019 10:54 am
Commands should only be executed as root when absolutely necessary. Otherwise there's the risk of collateral damage.
I always sign in with sudo su and then password. Is it better to not do that?
LM 18.3 xfce / lenovo T520 / 8gb ram / 240gb ssd
LM 18.3 xfce / biostar a870u3 / amd athlon II x2 250 / 8gb ram / nvidia gt218 geforce 210 /

JeremyB
Level 20
Level 20
Posts: 11144
Joined: Fri Feb 21, 2014 8:17 am

Re: WiFi interface cannot switch to UP state

Post by JeremyB » Thu Mar 21, 2019 4:28 pm

Only use sudo when absolutely necessary

Post Reply

Return to “Wireless”