[SOLVED] Unable to connect to home WiFi in Linux Mint

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
Figroth
Level 1
Level 1
Posts: 6
Joined: Fri Mar 22, 2019 8:47 am

[SOLVED] Unable to connect to home WiFi in Linux Mint

Post by Figroth » Fri Mar 22, 2019 9:24 am

I know there are multiple topics with the very same subject, but I've not been able to solve this by reading through them, so I thought I'd try asking separately. For a while now, my laptop has been unable to connect to my Home WiFi when booted from Linux Mint. I can connect fine to Ethernet or other wireless networks and there's no problem when booted from Windows 10. If any of the more experienced Linux users around would help me figure this out, I would be very grateful.

Here is the output of a few commands that I've seen are relevant:

inxi -Fxz:

Code: Select all

System:    Host: Lenovo-ideapad-100-15IBD Kernel: 4.15.0-46-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: LENOVO (portable) product: 80QQ v: Lenovo ideapad 100-15IBD
           Mobo: LENOVO model: Nano 5B6 v: SDK0J40700 WIN
           Bios: LENOVO v: E0CN16WW date: 08/04/2015
CPU:       Dual core Intel Core i3-5005U (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 7981
           clock speeds: max: 1900 MHz 1: 869 MHz 2: 812 MHz 3: 906 MHz
           4: 917 MHz
Graphics:  Card-1: Intel HD Graphics 5500 bus-ID: 00:02.0
           Card-2: NVIDIA GK208BM [GeForce 920M] bus-ID: 04:00.0
           Display Server: X.Org 1.18.4 driver: nvidia
           Resolution: 1366x768@59.97hz
           GLX Renderer: GeForce 920M/PCIe/SSE2
           GLX Version: 4.5.0 NVIDIA 384.130 Direct Rendering: Yes
Audio:     Card-1 Intel Wildcat Point-LP High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Intel Broadwell-U Audio Controller
           driver: snd_hda_intel bus-ID: 00:03.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-46-generic
Network:   Card-1: Realtek RTL810xE PCI Express Fast Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: 5000 bus-ID: 02:00.0
           IF: enp2s0 state: down mac: <filter>
           Card-2: Realtek RTL8723BE PCIe Wireless Network Adapter
           driver: rtl8723be port: 4000 bus-ID: 03:00.0
           IF: wlp3s0 state: up mac: <filter>
Drives:    HDD Total Size: 500.1GB (2.8% used)
           ID-1: /dev/sda model: WDC_WD5000LPCX size: 500.1GB temp: 31C
Partition: ID-1: / size: 27G used: 9.4G (38%) fs: ext4 dev: /dev/sda8
           ID-2: swap-1 size: 4.21GB used: 0.00GB (0%) fs: swap dev: /dev/sda9
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 59.0C mobo: N/A gpu: 0.0:52C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 212 Uptime: 1:10 Memory: 1591.4/3859.4MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35
rfkill list all:

Code: Select all

0: ideapad_wlan: Wireless LAN
	Soft blocked: no
	Hard blocked: no
1: ideapad_bluetooth: Bluetooth
	Soft blocked: yes
	Hard blocked: no
2: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
3: hci0: Bluetooth
	Soft blocked: yes
	Hard blocked: no
iwconfig:

Code: Select all

lo        no wireless extensions.

wlp3s0    IEEE 802.11  ESSID:"wifiname"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: B8:A3:86:EC:19:FF   
          Bit Rate=7.2 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:on
          Link Quality=70/70  Signal level=-30 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:1   Missed beacon:0

enp2s0    no wireless extensions.
inxi -Nn:

Code: Select all

Network:   Card-1: Realtek RTL810xE PCI Express Fast Ethernet controller
           driver: r8169
           IF: enp2s0 state: down mac: 50:7b:9d:83:2c:86
           Card-2: Realtek RTL8723BE PCIe Wireless Network Adapter
           driver: rtl8723be
           IF: wlp3s0 state: up mac: 48:e2:44:a4:e0:41
Thanks in advance!
Last edited by Figroth on Sat Apr 06, 2019 4:39 pm, edited 1 time in total.

Figroth
Level 1
Level 1
Posts: 6
Joined: Fri Mar 22, 2019 8:47 am

Re: Unable to connect to home WiFi in Linux Mint

Post by Figroth » Sat Mar 30, 2019 8:50 am

If anyone could provide any insight, it would be really appreciated. If any more info is required on the situation, do ask.

User avatar
Pierre
Level 18
Level 18
Posts: 8902
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: Unable to connect to home WiFi in Linux Mint

Post by Pierre » Sat Mar 30, 2019 8:55 am

Open Terminal and run this:

Code: Select all

wget -N -t 5 -T 10 https://github.com/UbuntuForums/wireless-info/raw/master/wireless-info && chmod +x wireless-info && ./wireless-info

Code: Select all

cat wireless-info.txt | nc termbin.com 9999
Post URL from Terminal, back here, on your reply.
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

Figroth
Level 1
Level 1
Posts: 6
Joined: Fri Mar 22, 2019 8:47 am

Re: Unable to connect to home WiFi in Linux Mint

Post by Figroth » Sat Mar 30, 2019 10:31 am


User avatar
kelebek333
Level 3
Level 3
Posts: 127
Joined: Sat Jun 25, 2011 11:57 am
Location: Türkiye
Contact:

Re: Unable to connect to home WiFi in Linux Mint

Post by kelebek333 » Wed Apr 03, 2019 7:45 pm

Card-2: Realtek RTL8723BE PCIe Wireless Network Adapter
driver: rtl8723be port: 4000 bus-ID: 03:00.0
IF: wlp3s0 state: up mac: <filter>
You can try to create configuration file for rtl8723be driver module related antenna selection and power management with following command.

Code: Select all

echo "options rtl8723be swenc=1 ips=0 fwlps=0 ant_sel=2" | sudo tee /etc/modprobe.d/rtl8723be.conf

Figroth
Level 1
Level 1
Posts: 6
Joined: Fri Mar 22, 2019 8:47 am

Re: Unable to connect to home WiFi in Linux Mint

Post by Figroth » Fri Apr 05, 2019 12:21 pm

kelebek333 wrote:
Wed Apr 03, 2019 7:45 pm
Card-2: Realtek RTL8723BE PCIe Wireless Network Adapter
driver: rtl8723be port: 4000 bus-ID: 03:00.0
IF: wlp3s0 state: up mac: <filter>
You can try to create configuration file for rtl8723be driver module related antenna selection and power management with following command.

Code: Select all

echo "options rtl8723be swenc=1 ips=0 fwlps=0 ant_sel=2" | sudo tee /etc/modprobe.d/rtl8723be.conf
It doesn't seem to work.

qbit
Level 2
Level 2
Posts: 90
Joined: Thu Jan 10, 2019 12:14 pm

Re: Unable to connect to home WiFi in Linux Mint

Post by qbit » Fri Apr 05, 2019 1:57 pm

In your /de3j9 file which i've read from the server there is the line

CAPABILITIES.CARRIER-DETECT: no

This must should be a "yes", i guess, in my working wifi system it is Yes

So, compare the wifi frequency when you boot win10 , (hopefully that it be possible) with the frequency under mint.
Maybe it is a channel trouble with any automatic channel selection, country laws for wifi channels etc. etc

JeremyB
Level 20
Level 20
Posts: 10861
Joined: Fri Feb 21, 2014 8:17 am

Re: Unable to connect to home WiFi in Linux Mint

Post by JeremyB » Fri Apr 05, 2019 4:48 pm

I would do

Code: Select all

 sudo sed -i 's/3/2/' /etc/NetworkManager/conf.d/*
echo "options rtl8723be ips=N" | sudo tee /etc/modprobe.d/rtl8723be.conf
sudo iwconfig  wlp3s0 txpower 20
If you can make changes on the wifi router, disable TKIP encryption and move it to channel 11, and see if you can figure out why it is asking for the tx power to be limited to 20dbm

User avatar
kelebek333
Level 3
Level 3
Posts: 127
Joined: Sat Jun 25, 2011 11:57 am
Location: Türkiye
Contact:

Re: Unable to connect to home WiFi in Linux Mint

Post by kelebek333 » Sat Apr 06, 2019 3:30 am

Figroth wrote:
Fri Apr 05, 2019 12:21 pm
kelebek333 wrote:
Wed Apr 03, 2019 7:45 pm
Card-2: Realtek RTL8723BE PCIe Wireless Network Adapter
driver: rtl8723be port: 4000 bus-ID: 03:00.0
IF: wlp3s0 state: up mac: <filter>
You can try to create configuration file for rtl8723be driver module related antenna selection and power management with following command.

Code: Select all

echo "options rtl8723be swenc=1 ips=0 fwlps=0 ant_sel=2" | sudo tee /etc/modprobe.d/rtl8723be.conf
It doesn't seem to work.
Did you try to reboot after this configuration.

Figroth
Level 1
Level 1
Posts: 6
Joined: Fri Mar 22, 2019 8:47 am

Re: Unable to connect to home WiFi in Linux Mint

Post by Figroth » Sat Apr 06, 2019 6:30 am

kelebek333 wrote:
Sat Apr 06, 2019 3:30 am
Figroth wrote:
Fri Apr 05, 2019 12:21 pm
kelebek333 wrote:
Wed Apr 03, 2019 7:45 pm


You can try to create configuration file for rtl8723be driver module related antenna selection and power management with following command.

Code: Select all

echo "options rtl8723be swenc=1 ips=0 fwlps=0 ant_sel=2" | sudo tee /etc/modprobe.d/rtl8723be.conf
It doesn't seem to work.
Did you try to reboot after this configuration.
I did.

User avatar
kelebek333
Level 3
Level 3
Posts: 127
Joined: Sat Jun 25, 2011 11:57 am
Location: Türkiye
Contact:

Re: Unable to connect to home WiFi in Linux Mint

Post by kelebek333 » Sat Apr 06, 2019 9:00 am

You can try to install latest driver from rtlwifi-new github repo with following commands. You must disable secureboot before this.

1. Install requirements

Code: Select all

sudo apt-get install build-essential git dkms linux-headers-$(uname -r)
2. Download source and install rtlwifi-new driver with following commands

Code: Select all

git clone https://github.com/lwfinger/rtlwifi_new rtlwifi_new-dkms

Code: Select all

sudo dkms add ./rtlwifi_new-dkms

Code: Select all

sudo dkms build rtlwifi-new/0.6

Code: Select all

sudo dkms install rtlwifi-new/0.6
3. Reboot

If the issue is not solved in this way, you can also share the outputs of the following commands.

Code: Select all

apt install sysfsutils

Code: Select all

systool -vm rtl8723be

Code: Select all

modinfo rtl8723be

Code: Select all

dkms status

Code: Select all

iwconfig

Figroth
Level 1
Level 1
Posts: 6
Joined: Fri Mar 22, 2019 8:47 am

Re: Unable to connect to home WiFi in Linux Mint

Post by Figroth » Sat Apr 06, 2019 4:38 pm

@kelebek333
Yep. This worked for me. Thank you very much for the tip.

philrimer
Level 1
Level 1
Posts: 4
Joined: Sun Mar 12, 2017 9:07 am

Re: [SOLVED] Unable to connect to home WiFi in Linux Mint

Post by philrimer » Sun Apr 07, 2019 2:50 pm

Also wanted to thank kelebek333 for those steps. That also fixed my rtl8723be. That odd thing with mine was that it was working fine with kernel 4.15.0-20 once I added the ant_sel=2 option. Upgraded to the latest kernel and boom, no longer worked. Tried mucking with all the settings and nothing would work. reboot back on old kernel and worked fine. Just followed your steps to install the latest drives on 4.15.0-47 and now it is working.

Thank you.

JeremyB
Level 20
Level 20
Posts: 10861
Joined: Fri Feb 21, 2014 8:17 am

Re: [SOLVED] Unable to connect to home WiFi in Linux Mint

Post by JeremyB » Sun Apr 07, 2019 4:44 pm

The ant_sel=2 should only be needed on some HP laptops as they are known to only use 1 antenna wire on a couple Realtek wifi cards, the RTL8723BE and RTL8723DE

philrimer
Level 1
Level 1
Posts: 4
Joined: Sun Mar 12, 2017 9:07 am

Re: [SOLVED] Unable to connect to home WiFi in Linux Mint

Post by philrimer » Sun Apr 07, 2019 8:19 pm

I have 19.1 installed on an HP Pavilion all in one. Just did a fresh install of 19.1 and the only way to get the wifi adapter to work was with that setting. But that only worked with the -20 kernel.

JeremyB
Level 20
Level 20
Posts: 10861
Joined: Fri Feb 21, 2014 8:17 am

Re: [SOLVED] Unable to connect to home WiFi in Linux Mint

Post by JeremyB » Mon Apr 08, 2019 5:56 am

It should work up until 4.15.0-32 as that is when the bad commit was added

DanielDias6969
Level 1
Level 1
Posts: 7
Joined: Thu Apr 11, 2019 2:20 pm

Re: [Resolvido] não é possível conectar ao WiFi em casa no Linux Mint

Post by DanielDias6969 » Thu Apr 11, 2019 2:44 pm

Good afternoon. I have the same problem, I want to install Linux Mint 19.1 via USB pen and the Wifi does not work. I've tried using Ubunto, Fedora, Deebin, etc and I've never been able to connect to the internet :(
Someone can help me? I have Windows 10 and it works great, Linux does not work.

From what I saw in Windows 10 the network card is: Realtek RTL8723BE 802.11n PCI-E NIC.

I do not have internet cable at home. The internet in my house does not work, I can see the internet and when I try to call at the end it gives an error and does not connect at all. I've tried other wifi networks and it works, but my home network does not work.

Baldlygo
Level 3
Level 3
Posts: 101
Joined: Wed Feb 16, 2011 6:28 am
Location: Le Dorat, France
Contact:

Re: Unable to connect to home WiFi in Linux Mint

Post by Baldlygo » Sun Jun 30, 2019 7:23 am

kelebek333 wrote:
Sat Apr 06, 2019 9:00 am
You can try to install latest driver from rtlwifi-new github repo with following commands. You must disable secureboot before this.

1. Install requirements

Code: Select all

sudo apt-get install build-essential git dkms linux-headers-$(uname -r)
2. Download source and install rtlwifi-new driver with following commands

Code: Select all

git clone https://github.com/lwfinger/rtlwifi_new rtlwifi_new-dkms

Code: Select all

sudo dkms add ./rtlwifi_new-dkms

Code: Select all

sudo dkms build rtlwifi-new/0.6

Code: Select all

sudo dkms install rtlwifi-new/0.6
3. Reboot

If the issue is not solved in this way, you can also share the outputs of the following commands.

Code: Select all

apt install sysfsutils

Code: Select all

systool -vm rtl8723be

Code: Select all

modinfo rtl8723be

Code: Select all

dkms status

Code: Select all

iwconfig
May have given myself a big problem. I have just run these commands and forgot to take off secure boot. Taking off secure boot now prompts me for a password. If I enter the password could I lose my win10 wifi access which was working fine before?
Urgent help much appreciated.

If I choose ESC to not accept the pending change does this my change will be discarded?
Dell Inspiron R15 - Mint 17.3 Rosa

Post Reply

Return to “Wireless”