[SOLVED] HP 255 No wireless connection option

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Rob67
Level 1
Level 1
Posts: 20
Joined: Tue Mar 12, 2019 1:14 pm

[SOLVED] HP 255 No wireless connection option

Post by Rob67 »

Hi all.
I still have 2 issues finally getting Mint 19.1 installed and booting successfully(?) from the hard drive.
1. I have no option for a wireless internet connection (i can only use an Ethernet cable)
2. A message on the screen tells me I am in "software rendering mode". I presume this is not the norm.

There may be other issues of which I am as yet unaware.
After reading through threads and links I'm still unsure of how to proceed.

Please bear in mind that I am a total newbie and things may need to be explained very slowly...

Laptop Spec
HP 255 G7 Ryzen 3 8GB 256GB Laptop
AMD Ryzen 3 2200U
8GB DDR4 + 256GB SSD
15.6 Full HD Display
Radeon Vega 3 Graphics

Can anyone help? Thanks.
Last edited by Rob67 on Tue Apr 02, 2019 5:43 pm, edited 1 time in total.

deepakdeshp
Level 16
Level 16
Posts: 6627
Joined: Sun Aug 09, 2015 10:00 am

Re: No wireless connection option

Post by deepakdeshp »

Please post output of terminal command

Code: Select all

inxi -Fxz
in code tags which will help in knowing your configuration.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.3 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

Rob67
Level 1
Level 1
Posts: 20
Joined: Tue Mar 12, 2019 1:14 pm

Re: No wireless connection option

Post by Rob67 »

Hello Deepakdeshp
Sorry, I'm not sure what code tags are.
Last edited by Rob67 on Tue Apr 02, 2019 8:21 am, edited 1 time in total.

Rob67
Level 1
Level 1
Posts: 20
Joined: Tue Mar 12, 2019 1:14 pm

Re: No wireless connection option

Post by Rob67 »

Hah! Think I now know what code tags are....

Code: Select all

System:
  Host: rob-HP-255-G7-Notebook-PC Kernel: 4.15.0-46-generic x86_64 bits: 64 
  compiler: gcc v: 7.3.0 Desktop: Cinnamon 4.0.10 
  Distro: Linux Mint 19.1 Tessa base: Ubuntu 18.04 bionic 
Machine:
  Type: Laptop System: HP product: HP 255 G7 Notebook PC 
  v: Type1ProductConfigId serial: <filter> 
  Mobo: HP model: 84AE v: 86.21 serial: <filter> UEFI: Insyde v: F.16 
  date: 12/14/2018 
Battery:
  ID-1: BAT1 charge: 40.4 Wh condition: 39.4/41.9 Wh (94%) 
  model: Hewlett-Packard PABAS0241231 status: Unknown 
CPU:
  Topology: Dual Core model: AMD Ryzen 3 2200U with Radeon Vega Mobile Gfx 
  bits: 64 type: MT MCP arch: Zen L2 cache: 1024 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 19961 
  Speed: 1777 MHz min/max: 1600/2500 MHz Core speeds (MHz): 1: 1611 2: 1659 
  3: 2382 4: 2491 
Graphics:
  Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] 
  vendor: Hewlett-Packard driver: N/A bus ID: 04:00.0 
  Display: x11 server: X.Org 1.19.6 driver: ati,fbdev 
  unloaded: modesetting,radeon,vesa resolution: 1920x1080~77Hz 
  OpenGL: renderer: llvmpipe (LLVM 7.0 128 bits) v: 3.3 Mesa 18.2.8 
  direct render: Yes 
Audio:
  Device-1: AMD vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
  bus ID: 04:00.1 
  Device-2: AMD vendor: Hewlett-Packard driver: N/A bus ID: 04:00.5 
  Device-3: AMD vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
  bus ID: 04:00.6 
  Sound Server: ALSA v: k4.15.0-46-generic 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: 2.3LK-NAPI port: 3000 
  bus ID: 02:00.0 
  IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter 
  vendor: Hewlett-Packard driver: N/A port: 2000 bus ID: 03:00.0 
Drives:
  Local Storage: total: 238.47 GiB used: 17.67 GiB (7.4%) 
  ID-1: /dev/sda vendor: Samsung model: MZNLN256HAJQ-000H1 size: 238.47 GiB 
Partition:
  ID-1: / size: 233.24 GiB used: 17.66 GiB (7.6%) fs: ext4 dev: /dev/sda2 
Sensors:
  System Temperatures: cpu: 51.2 C mobo: 20.0 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 180 Uptime: 3h 29m Memory: 7.51 GiB used: 2.02 GiB (26.8%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.3.0 Shell: bash v: 4.4.19 
  inxi: 3.0.27 

User avatar
Lord Boltar
Level 5
Level 5
Posts: 688
Joined: Mon Jan 09, 2017 7:24 pm
Location: Sunny Florida

Re: No wireless connection option

Post by Lord Boltar »

You can download your radeon vega 3 graphics driver from here

https://www.amd.com/en/support/graphics ... rx-vega-64
IF your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members

The only way for evil to prosper is for good men to do nothing

Rob67
Level 1
Level 1
Posts: 20
Joined: Tue Mar 12, 2019 1:14 pm

Re: No wireless connection option

Post by Rob67 »

Thanks Lord Boltar.
I've downloaded Ubuntu x86 64-Bit from the link and extracted the files to a new folder I've created.

Following the installation documentation it states the following:

Extract the tar archive to a known location. In the following commands, replace YY.XX with the actual release number (e.g. 18.30) and NNNNNN six digit build number of the downloaded file:

$ cd ~/Downloads
$ tar -Jxvf amdgpu-pro-YY.XX-NNNNNN.tar.xz
$ cd ~/Downloads/amdgpu-pro-YY.XX-NNNNNN

I take this to mean that I open my Terminal and type in all the script as above as well as making the replacements?
I've taken a look at the rest of the guidance but it is way beyond me. I can't tell which info is relevant to me.

Showing my ignorance here, but why doesn't the Driver Manager find these files and install them?
I am trying to help myself but there is so much to learn.

JeremyB
Level 20
Level 20
Posts: 11403
Joined: Fri Feb 21, 2014 8:17 am

Re: No wireless connection option

Post by JeremyB »

In terminal

Code: Select all

sudo apt install git dkms build-essential
git clone https://github.com/tomaspinho/rtl8821ce.git
cd rtl8821ce
sudo ./dkms-install.sh
Reboot
Secure Boot will need to be disabled in BIOS

Rob67
Level 1
Level 1
Posts: 20
Joined: Tue Mar 12, 2019 1:14 pm

Re: No wireless connection option

Post by Rob67 »

Hi JeremyB. Thanks.

I copied and pasted into the terminal, and then rebooted.
I could see no immediate change so ran the Update Manager which installed some updates and then ran the Driver Manager but no result there. So I repasted the script into the Terminal again and got the following back which tells me that the first cut and paste worked.

Code: Select all

rob@rob-HP-255-G7-Notebook-PC:~$ sudo apt install git dkms build-essential
[sudo] password for rob:                                                      
Sorry, try again.
[sudo] password for rob:          
Reading package lists... Done
Building dependency tree       
Reading state information... Done
build-essential is already the newest version (12.4ubuntu1).
dkms is already the newest version (2.3-3ubuntu9.2).
git is already the newest version (1:2.17.1-1ubuntu0.4).
0 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade.
rob@rob-HP-255-G7-Notebook-PC:~$ 
I will try the Driver Manager again to see what happens.

Rob67
Level 1
Level 1
Posts: 20
Joined: Tue Mar 12, 2019 1:14 pm

Re: No wireless connection option

Post by Rob67 »

Driver Manager found nothing new.
Secure boot is definitely disabled.
Is there something I should be doing in the network settings? I noticed there is an option to use or set up a Network Proxy.

JeremyB
Level 20
Level 20
Posts: 11403
Joined: Fri Feb 21, 2014 8:17 am

Re: No wireless connection option

Post by JeremyB »

See the wireless script link in my signature and post results

Rob67
Level 1
Level 1
Posts: 20
Joined: Tue Mar 12, 2019 1:14 pm

Re: No wireless connection option

Post by Rob67 »

Hi JeremyB.
Below as requested.

Code: Select all

rob@rob-HP-255-G7-Notebook-PC:~$ wget -N -t 5 -T 10 https://github.com/UbuntuForums/wireless-info/raw/master/wireless-info && chmod +x wireless-info && ./wireless-info
--2019-04-02 18:51:44--  https://github.com/UbuntuForums/wireless-info/raw/master/wireless-info
Resolving github.com (github.com)... 140.82.118.3, 140.82.118.4
Connecting to github.com (github.com)|140.82.118.3|:443... connected.
HTTP request sent, awaiting response... 302 Found
Location: https://raw.githubusercontent.com/UbuntuForums/wireless-info/master/wireless-info [following]
--2019-04-02 18:51:44--  https://raw.githubusercontent.com/UbuntuForums/wireless-info/master/wireless-info
Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 151.101.16.133
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|151.101.16.133|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 17452 (17K) [text/plain]
Saving to: ‘wireless-info’

wireless-info       100%[===================>]  17.04K  --.-KB/s    in 0.03s   

Last-modified header missing -- time-stamps turned off.
2019-04-02 18:51:45 (653 KB/s) - ‘wireless-info’ saved [17452/17452]

[sudo] password for rob:          

Results saved in "/home/rob/wireless-info.txt".

rob@rob-HP-255-G7-Notebook-PC:~$ 

Rob67
Level 1
Level 1
Posts: 20
Joined: Tue Mar 12, 2019 1:14 pm

Re: No wireless connection option

Post by Rob67 »

JeremyB.
There was a second piece of code where the link led to.
Should I run that in the Terminal as well?

User avatar
Lord Boltar
Level 5
Level 5
Posts: 688
Joined: Mon Jan 09, 2017 7:24 pm
Location: Sunny Florida

Re: No wireless connection option

Post by Lord Boltar »

Save the file to downloads

To extract the file - right click and "Open with archive manager" in the same folder

you should now see a folder called amdgpu-pro-18.50-756341-ubuntu-18.04

open that folder you should see 2 install scripts amdgpu-pro-install and amdgpu-install

now open a terminal inside that folder and type in sudo bash ./amdgpu-pro-install

this should start the install process

Hope this helps
IF your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members

The only way for evil to prosper is for good men to do nothing

Rob67
Level 1
Level 1
Posts: 20
Joined: Tue Mar 12, 2019 1:14 pm

Re: No wireless connection option

Post by Rob67 »

Hi again Lord Boltar.
Thanks for taking the time to explain the steps.
I went through the steps but got this response:

Code: Select all

rob@rob-HP-255-G7-Notebook-PC:~$ sudo bash ./amdgpu-pro-install
[sudo] password for rob:          
bash: ./amdgpu-pro-install: No such file or directory
rob@rob-HP-255-G7-Notebook-PC:~$ 
I could see the two install scripts, among others, and therefore presumed that I was "inside" that folder, then opened the Terminal and typed in the code as presented.
I've tried a few times now. Could it be a simple syntax error on my part?

Rob67
Level 1
Level 1
Posts: 20
Joined: Tue Mar 12, 2019 1:14 pm

Re: No wireless connection option

Post by Rob67 »

I've just noticed that the amdgpu-pro-install document has no content but the amdgpu-install does.
Should I reference this script instead in the Terminal?

JeremyB
Level 20
Level 20
Posts: 11403
Joined: Fri Feb 21, 2014 8:17 am

Re: No wireless connection option

Post by JeremyB »

Did you run these lines of code

Code: Select all

git clone https://github.com/tomaspinho/rtl8821ce.git
cd rtl8821ce
sudo ./dkms-install.sh

Rob67
Level 1
Level 1
Posts: 20
Joined: Tue Mar 12, 2019 1:14 pm

Re: No wireless connection option

Post by Rob67 »

Hi again JeremyB.

I've just ran the script and this is what has come back.

Code: Select all

rob@rob-HP-255-G7-Notebook-PC:~$ git clone https://github.com/tomaspinho/rtl8821ce.git
Cloning into 'rtl8821ce'...
remote: Enumerating objects: 40, done.
remote: Counting objects: 100% (40/40), done.
remote: Compressing objects: 100% (25/25), done.
remote: Total 691 (delta 15), reused 40 (delta 15), pack-reused 651
Receiving objects: 100% (691/691), 3.35 MiB | 1.24 MiB/s, done.
Resolving deltas: 100% (244/244), done.
rob@rob-HP-255-G7-Notebook-PC:~$ cd rtl8821ce
rob@rob-HP-255-G7-Notebook-PC:~/rtl8821ce$ sudo ./dkms-install.sh
[sudo] password for rob:          
About to run dkms install steps...

Creating symlink /var/lib/dkms/rtl8821ce/v5.2.5_1.26055.20180108.1/source ->
                 /usr/src/rtl8821ce-v5.2.5_1.26055.20180108.1

DKMS: add completed.

Kernel preparation unnecessary for this kernel.  Skipping...

Building module:
cleaning build area...
'make' -j4 KVER=4.15.0-47-generic..................
Signing module:
 - /var/lib/dkms/rtl8821ce/v5.2.5_1.26055.20180108.1/4.15.0-47-generic/x86_64/module/8821ce.ko
Secure Boot not enabled on this system.
cleaning build area...

DKMS: build completed.

8821ce:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.15.0-47-generic/updates/dkms/

depmod...

DKMS: install completed.
Finished running dkms install steps.
rob@rob-HP-255-G7-Notebook-PC:~/rtl8821ce$ 
Should I now reboot?

JeremyB
Level 20
Level 20
Posts: 11403
Joined: Fri Feb 21, 2014 8:17 am

Re: No wireless connection option

Post by JeremyB »

Yes

Rob67
Level 1
Level 1
Posts: 20
Joined: Tue Mar 12, 2019 1:14 pm

[SOLVED] HP 255 No wireless connection option

Post by Rob67 »

BINGO!
Hat tip JeremyB and Lord Boltar

Wireless connection established. Finally free from the umbilical Ethernet cable. Able to roam the length and breadth of my office, laptop in hand.....
I was starting to lose faith in this after trawling through numerous threads and googling.

Thank you all who have offered help here.

I don't know if I have any more issues as yet apart from still being in "software rendering mode".
Is this a problem?

User avatar
Lord Boltar
Level 5
Level 5
Posts: 688
Joined: Mon Jan 09, 2017 7:24 pm
Location: Sunny Florida

Re: No wireless connection option

Post by Lord Boltar »

Rob67 wrote:
Tue Apr 02, 2019 4:19 pm
I've just noticed that the amdgpu-pro-install document has no content but the amdgpu-install does.
Should I reference this script instead in the Terminal?
simple answer is yes - you are correct if you see those 2 scripts you are inside that folder open now right click and select open terminal here the type in sudo bash ./amdgpu-install
IF your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members

The only way for evil to prosper is for good men to do nothing

Post Reply

Return to “Wireless”