Page 1 of 1

Wifi not working on lenovo legion

Posted: Sat Apr 20, 2019 6:53 am
by panqueinthebox
Hello everybody I installed Linux Mint 19.1 Cinnamon in my Lenovo legion Y530-15ICH and I can not connect to internet because it doesn't detect any internet connexion. How could I resolve this problem? I tried to install controllers from my bootable USB but it doesn't work, i got the message "failed to dowload repository information"

Thanks for you help

Re: Wifi not working on lenovo legion

Posted: Sat Apr 20, 2019 6:55 am
by karlchen
Hello, panqueinthebox.

To start with, please, give us a concise report on your hardware and on how Mint sees it. I.e. please, post a complete inxi -Fxz report.

Here is how to generate the report on post it:
  • Open a terminal window. Make it fullscreen to avoid unneeded linebreaks or chopped lines.
  • Execute the command

    Code: Select all

    inxi -Fxz
    exactly as it has been typed here.
  • Mark the complete text output which inxi -Fxz will display with your mouse.
  • Press the keyboard shortcut <Shift><Ctrl>C to copy the marked text into the clipboard.
  • Paste it into your next reply.
Best regards,
Karl

Re: Wifi not working on lenovo legion

Posted: Sat Apr 20, 2019 7:06 am
by panqueinthebox
Hi again and thanks for your help. This is what I got

Code: Select all

israelvergara@panqueinthebox:~$ inxi -Frz
System:    Host: panqueinthebox Kernel: 4.15.0-20-generic x86_64 bits: 64 Desktop: Cinnamon 4.0.8
           Distro: Linux Mint 19.1 Tessa
Machine:   Type: Laptop System: LENOVO product: 81FV v: Lenovo Legion Y530-15ICH serial: <filter>
           Mobo: LENOVO model: LNVNB161216 v: NO DPK serial: <filter> UEFI: LENOVO v: 8JCN48WW date: 11/02/2018
Battery:   ID-1: BAT0 charge: 50.9 Wh condition: 52.5/52.5 Wh (100%)
CPU:       Topology: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP L2 cache: 9216 KiB
           Speed: 800 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 800 2: 800 3: 801 4: 800 5: 800 6: 801 7: 801 8: 801
           9: 800 10: 801 11: 801 12: 800
Graphics:  Device-1: Intel driver: i915 v: kernel
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] driver: nouveau v: kernel
           Display: x11 server: X.Org 1.19.6 driver: modesetting,nouveau unloaded: fbdev,vesa resolution: 1920x1080~60Hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics (Coffeelake 3x8 GT2) v: 4.5 Mesa 18.0.5
Audio:     Device-1: Intel driver: snd_hda_intel
           Sound Server: ALSA v: k4.15.0-20-generic
Network:   Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter driver: ath10k_pci
           IF: wlp7s0 state: down mac: <filter>
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169
           IF: enp8s0 state: down mac: <filter>
Drives:    Local Storage: total: 931.51 GiB used: 26.85 GiB (2.9%)
           ID-1: /dev/sdb vendor: Seagate model: ST1000LM049-2GH172 size: 931.51 GiB
Partition: ID-1: / size: 915.40 GiB used: 13.42 GiB (1.5%) fs: ext4 dev: /dev/sdb2
           ID-2: swap-1 size: 2.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-0
Sensors:   System Temperatures: cpu: 56.0 C mobo: N/A gpu: nouveau temp: 41 C
           Fan Speeds (RPM): N/A
Repos:     No active apt repos in: /etc/apt/sources.list
           Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list
           1: deb http://packages.linuxmint.com tessa main upstream import backport #id:linuxmint_main
           2: deb http://archive.ubuntu.com/ubuntu bionic main restricted universe multiverse
           3: deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse
           4: deb http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
           5: deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
           6: deb http://archive.canonical.com/ubuntu/ bionic partner
Info:      Processes: 281 Uptime: 52m Memory: 7.67 GiB used: 1.45 GiB (18.9%) Shell: bash inxi: 3.0.27

Re: Wifi not working on lenovo legion

Posted: Sat Apr 20, 2019 7:14 am
by JeremyB
That model still has the rfkill bug, in terminal do

Code: Select all

sudo apt install git dkms build-essential
git clone https://github.com/jeremyb31/ideapad-laptop.git
sudo dkms add ./ideapad-laptop
sudo dkms install ideapad-laptop/1.0
Reboot and make sure Secure Boot in disabled in BIOS

Re: Wifi not working on lenovo legion

Posted: Sat Apr 20, 2019 1:46 pm
by panqueinthebox
Hi again, I tried your solution but I had this message -sorry but my computer was configured in spanish- :| :

Code: Select all

israelvergara@panqueinthebox:~$ sudo apt install git dkms build-essential
[sudo] password for israelvergara: *********************************************            
Sorry, try again.
[sudo] password for israelvergara:           
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
dkms ya está en su versión más reciente (2.3-3ubuntu9.2).
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios aún no se han creado o se
han sacado de «Incoming».
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
 build-essential : Depende: g++ (>= 4:7.2) pero no va a instalarse
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.

Re: Wifi not working on lenovo legion

Posted: Sat Apr 20, 2019 2:32 pm
by JeremyB
Do

Code: Select all

echo "blacklist ideapad-laptop" | sudo tee /etc/modprobe.d/ideapad-laptop.conf
reboot and do

Code: Select all

sudo apt update
sudo apt install git dkms build-essential
git clone https://github.com/jeremyb31/ideapad-laptop.git
sudo dkms add ./ideapad-laptop
sudo dkms install ideapad-laptop/1.0
sudo rm /etc/modprobe.d/ideapad-laptop.conf

Re: Wifi not working on lenovo legion

Posted: Sun Apr 21, 2019 10:48 am
by panqueinthebox
Nice, it works correctly now. Thank you so much!

Re: Wifi not working on lenovo legion

Posted: Sun Apr 21, 2019 1:29 pm
by JeremyB
Please edit the first post in the thread to add solved to the subject

Re: Wifi not working on lenovo legion

Posted: Sun Apr 21, 2019 1:57 pm
by jungle_boy
I am happy to know that the Lenovo Legion Y530 works with Linux mint, so I plan to buy this laptop.
@panqueinthebox, tell me, does keyboard lighting work fine on Linux Mint? Sorry for the topic out of the subject.

Re: Wifi not working on lenovo legion

Posted: Sun May 05, 2019 4:36 pm
by LFengineer
This solution worked perfectly for my Lenovo Miix 510. I did have to turn of secure boot in the BIOS.

Thanks for the knowledge base!

Re: Wifi not working on lenovo legion

Posted: Mon May 06, 2019 5:56 pm
by LFengineer
This fix did work to resolve the WIFI not working, until I restarted the computer. I verified that I did it correctly so I did try the solution again and it did work to regain WIFI functionality. But then when I restarted it was gone again. Is there a way to make this change permanent?

Re: Wifi not working on lenovo legion

Posted: Mon May 06, 2019 6:10 pm
by JeremyB
LFengineer wrote:
Mon May 06, 2019 5:56 pm
This fix did work to resolve the WIFI not working, until I restarted the computer. I verified that I did it correctly so I did try the solution again and it did work to regain WIFI functionality. But then when I restarted it was gone again. Is there a way to make this change permanent?
See the wireless script link in my signature and post results

Re: Wifi not working on lenovo legion

Posted: Tue May 07, 2019 11:54 am
by LFengineer

Re: Wifi not working on lenovo legion

Posted: Tue May 07, 2019 1:56 pm
by JeremyB
What about

Code: Select all

modinfo ideapad-laptop

Re: Wifi not working on lenovo legion

Posted: Tue May 07, 2019 8:13 pm
by LFengineer

Code: Select all

filename:       /lib/modules/4.15.0-48-generic/updates/ideapad-laptop.ko
version:        JB1
license:        GPL
description:    IdeaPad ACPI Extras
author:         David Woodhouse <dwmw2@infradead.org>
srcversion:     1508BC886B7D3706F36447B
alias:          acpi*:VPC2004:*
depends:        wmi,video,sparse-keymap
retpoline:      Y
name:           ideapad_laptop
vermagic:       4.15.0-48-generic SMP mod_unload 
signat:         PKCS#7
signer:         
sig_key:        
sig_hashalgo:   md4
parm:           no_bt_rfkill:No rfkill for bluetooth. (bool)
parm:           override_has_hw_rfkill_switch:Overrides the value of has_hw_rfkill_switch (int)

Re: Wifi not working on lenovo legion

Posted: Tue May 07, 2019 8:59 pm
by JeremyB
Try echo "options ideapad_laptop override_has_hw_rfkill_switch=0" | sudo tee /etc/modprobe.d/ideapad_laptop.conf and reboot

Re: Wifi not working on lenovo legion

Posted: Wed May 08, 2019 6:43 pm
by LFengineer
That did the trick and it stays after rebooting!

If I am looking at this correct, this set the rfkill switch to off at =0, correct? Sorry, I'm not much for programming.

Thank you for the assistance.

Re: Wifi not working on lenovo legion

Posted: Wed May 08, 2019 6:53 pm
by JeremyB
Yes, this was a custom patch from a person named ryuo on IRC as the kernel has a quirks list that only names so many models to ignore the rfkill info on some Lenovo laptops