Sony Vaio laptop PCG 61813m wi-fi connection failed

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
charlesparker9999
Level 1
Level 1
Posts: 3
Joined: Wed Jun 05, 2019 2:40 am

Sony Vaio laptop PCG 61813m wi-fi connection failed

Post by charlesparker9999 » Wed Jun 05, 2019 3:03 am

My wi-fi connection suddenly stopped working although my laptop works fine using an ethernet cable. I have done the following but without success:

(1) The wireless off/on switch is set to the on position.
(2) I can connect wirelessly okay using another laptop; so my router seems fine.
(3) I switched the router on and off.
(4) I tried using a Linux Mint 19 live disc.
(5) I have reinstalled the Linux Mint 19 operating system.
(6) I installed a replacement wireless card.
(7) I went into Driver Manager and did an update.
(8) I went into the terminal and did sudo apt-get update.

Nothing has worked, so far. The following information may help, perhaps:

Code: Select all

inxi -Fxz
System:    Host: charles-VPCCA2S0E Kernel: 4.15.0-51-generic x86_64
           bits: 64 gcc: 7.3.0
           Desktop: MATE 1.20.1 (Gtk 3.22.30-1ubuntu3)
           Distro: Linux Mint 19 Tara
Machine:   Device: laptop System: Sony product: VPCCA2S0E v: C609C4GE serial: N/A
           Mobo: Sony model: VAIO serial: N/A
           BIOS: American Megatrends v: R1100V2 date: 04/15/2011
Battery    BAT0: charge: 29.0 Wh 88.7% condition: 32.7/62.6 Wh (52%)
           model: Sony status: Charging
CPU:       Dual core Intel Core i3-2310M (-MT-MCP-) 
           arch: Sandy Bridge rev.7 cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 8380
           clock speeds: max: 2100 MHz 1: 865 MHz 2: 859 MHz 3: 886 MHz
           4: 865 MHz
Graphics:  Card: Intel 2nd Generation Core Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.00hz
           OpenGL: renderer: Mesa DRI Intel Sandybridge Mobile
           version: 3.3 Mesa 18.2.8 Direct Render: Yes
Audio:     Card Intel 6 Series/C200 Series Family High Def. Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-51-generic
Network:   Card-1: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express)
           driver: ath9k bus-ID: 01:00.0
           IF: wlp1s0 state: down mac: <filter>
           Card-2: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet
           driver: atl1c v: 1.0.1.1-NAPI port: a000 bus-ID: 04:00.0
           IF: enp4s0 state: down mac: <filter>
Drives:    HDD Total Size: 320.1GB (3.0% used)
           ID-1: /dev/sda model: TOSHIBA_MK3259GS size: 320.1GB
Partition: ID-1: / size: 293G used: 8.9G (4%) fs: ext4 dev: /dev/sda1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 52.0C mobo: 52.0C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 185 Uptime: 1 min Memory: 412.6/3854.0MB
           Init: systemd runlevel: 5 Gcc sys: 7.4.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56 
Any ideas, please? I should explain that my technical knowledge is basic. Hope someone can help.

Kind regards,

Richard

sleeper12
Level 5
Level 5
Posts: 900
Joined: Thu May 25, 2017 3:22 pm

Re: Sony Vaio laptop PCG 61813m wi-fi connection failed

Post by sleeper12 » Thu Jun 06, 2019 3:37 pm

No clue... but have you tried disconnecting the ethernet cable & rebooting?

charlesparker9999
Level 1
Level 1
Posts: 3
Joined: Wed Jun 05, 2019 2:40 am

Re: Sony Vaio laptop PCG 61813m wi-fi connection failed

Post by charlesparker9999 » Thu Jun 06, 2019 4:38 pm

I have but that didn't work; also Ii have tried using three different wi-fi dongles that I have but no success..

JeremyB
Level 20
Level 20
Posts: 10877
Joined: Fri Feb 21, 2014 8:17 am

Re: Sony Vaio laptop PCG 61813m wi-fi connection failed

Post by JeremyB » Thu Jun 06, 2019 4:43 pm

If the physical switch is broken, remove the internal wifi, then try USB wifi dongles

charlesparker9999
Level 1
Level 1
Posts: 3
Joined: Wed Jun 05, 2019 2:40 am

Re: Sony Vaio laptop PCG 61813m wi-fi connection failed

Post by charlesparker9999 » Fri Jun 07, 2019 3:26 pm

I did as you said: I removed the wi-fi card and, to my delight, was then able to connect to the Internet using a dongle. So, as you suggested the wi-fi switch must be defective - I don't really understand why there is one. Next, having established that the switch is at fault I soldered a wire across its terminals on the circuit board so that the connection is permanently made, re-installed the wi-fi card and all is now working perfectly without any need for a dongle. So, case closed - many thanks for your help; much appreciated.

Kind regards,

Richard

Post Reply

Return to “Wireless”