Wifi quit working, will not authenticate to WLAN

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
Pako
Level 1
Level 1
Posts: 3
Joined: Mon Jun 10, 2019 7:33 pm

Wifi quit working, will not authenticate to WLAN

Post by Pako » Mon Jun 10, 2019 7:46 pm

Greetings, new Linux Mint user here. So far I love it and have installed it on my machines that other OS's have made obsolete.

This laptop has been working great for about a month, then about a week ago, it just stopped authenticating when trying to connect to my wifi network. All other devices can connect without issue.

inxi -Fxz

Code: Select all

System:
  Host: april-Lenovo-IdeaPad-U310-Touch Kernel: 4.15.0-51-generic x86_64 
  bits: 64 compiler: gcc v: 7.3.0 Desktop: Cinnamon 4.0.10 
  Distro: Linux Mint 19.1 Tessa base: Ubuntu 18.04 bionic 
Machine:
  Type: Laptop System: LENOVO product: Lenovo IdeaPad U310 Touch 
  v: Lenovo IdeaPad U310 Touch serial: <filter> 
  Mobo: LENOVO model: Lenovo v: 31900003WIN8 STD MLT serial: <filter> 
  UEFI: LENOVO v: 65CN98WW date: 03/04/2013 
Battery:
  ID-1: BAT1 charge: 8.9 Wh condition: 33.6/41.6 Wh (81%) 
  model: SMP LNV-L11M3P01 status: Charging 
CPU:
  Topology: Dual Core model: Intel Core i5-3337U bits: 64 type: MT MCP 
  arch: Ivy Bridge rev: 9 L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 14366 
  Speed: 798 MHz min/max: 800/2700 MHz Core speeds (MHz): 1: 959 2: 848 
  3: 1140 4: 870 
Graphics:
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Lenovo 
  driver: i915 v: kernel bus ID: 00:02.0 
  Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile v: 4.2 Mesa 18.2.8 
  direct render: Yes 
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Sound Server: ALSA v: k4.15.0-51-generic 
Network:
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Lenovo 
  driver: r8169 v: 2.3LK-NAPI port: 2000 bus ID: 02:00.0 
  IF: enp2s0 state: down mac: <filter> 
  Device-2: Intel Centrino Wireless-N 2230 driver: iwlwifi v: kernel 
  port: 2000 bus ID: 03:00.0 
  IF: wlp3s0 state: down mac: <filter> 
Drives:
  Local Storage: total: 488.13 GiB used: 25.69 GiB (5.3%) 
  ID-1: /dev/sda vendor: Samsung model: MZMPA024HMCD-000L1 size: 22.37 GiB 
  ID-2: /dev/sdb vendor: Seagate model: ST500LT012-9WS142 size: 465.76 GiB 
Partition:
  ID-1: / size: 456.96 GiB used: 25.68 GiB (5.6%) fs: ext4 dev: /dev/sdb2 
Sensors:
  System Temperatures: cpu: 42.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 208 Uptime: 13m Memory: 7.65 GiB used: 825.0 MiB (10.5%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.19 
  inxi: 3.0.27 
Not sure if there was an update that caused the issue or what's going on.

Some things I checked:
  • No Soft or Hard blocks
  • Secure Boot disabled
  • WPA encryption and passphrase correct to wifi network
  • Latest updates installed

Any help would be greatly appreciated.

b1naryman
Level 1
Level 1
Posts: 8
Joined: Sat Oct 27, 2018 4:04 am

Re: Wifi quit working, will not authenticate to WLAN

Post by b1naryman » Mon Jun 10, 2019 11:41 pm

I'm having the same issue with my Lenovo Y530. It worked fine until a few days ago, then the connection was erratic, then yesterday it stopped working completely. I upgraded from 19.0 to 19.1 and no joy. Other posts mentioned installing the 4.18 kernel fixed it for them, but it had no effect on my system. Maybe the same fix will work for both of us.

Network: Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: N/A port: 5000 bus ID: 00:14.3
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169
v: 2.3LK-NAPI port: 3000 bus ID: 07:00.0
IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: <filter>

adam@AJB-Legion:~$ iwconfig
enp7s0 no wireless extensions.
lo no wireless extensions.

You'll see that it does not show up on the kill list:

adam@AJB-Legion:~$ rfkill list all
0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
adam@AJB-Legion:~$

It does not have a hardware switch, and it is enabled in the BIOS/UEFI. It's not loading the driver according the inxi output. I downloaded the driver from Intel's website, but I have not installed them successfully yet.

Pako
Level 1
Level 1
Posts: 3
Joined: Mon Jun 10, 2019 7:33 pm

Re: Wifi quit working, will not authenticate to WLAN

Post by Pako » Tue Jun 11, 2019 7:23 pm

Odd, I loaded the previous Kernels when wifi worked, but no dice. Even tried some of the 4.18 Kernels for fun, and still no luck. Sure could use some idea's on what I can trouble shoot.

Pako
Level 1
Level 1
Posts: 3
Joined: Mon Jun 10, 2019 7:33 pm

Re: Wifi quit working, will not authenticate to WLAN

Post by Pako » Fri Jun 14, 2019 9:10 pm

Further testing, I was able to connect to my cell phones Hot Spot just fine. Connected in seconds. I am really baffled. I verified that both my wifi and network adapter settings for this connection is using WPA 1 and 2 Personal with a 10 character password. I have verified the network's wireless connection with other wireless devices and they can connect without error. I have no blocked IP's or MAC address so I don't think it's a network issues. Any additional ideas would be so helpful.

[edited]
So I first created an open WLAN and connected immediately.
Then I created a hidden open WLAN, also connected immediately.
*So I created a WEP 40/128bit Key WLAN and was finally able to connection.
Then I created a WEP 128-bit WLAN and was not able to connect.

Seems this driver no longer supports WPA and WPA2 Personal network connections.

[edit 2]
This post actually helped: viewtopic.php?t=208557

Post Reply

Return to “Wireless”