[SOLVED] Wi-Fi unable to connect after updating nvidia proprietary driver (Linux mint 19 Cinnamon)

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Karrig
Level 1
Level 1
Posts: 18
Joined: Wed Jun 19, 2019 6:56 am

Re: Wi-Fi unable to connect after updating nvidia proprietary driver (Linux mint 19 Cinnamon)

Post by Karrig » Sun Jun 23, 2019 4:01 am

The only other kernel I have installed outside of 5.0.0-17 is 4.15.0-20

HAWR
Level 4
Level 4
Posts: 404
Joined: Thu Jun 06, 2019 1:15 pm

Re: Wi-Fi unable to connect after updating nvidia proprietary driver (Linux mint 19 Cinnamon)

Post by HAWR » Sun Jun 23, 2019 5:16 am

I think, we will then install the actual 4.15.0-52 kernel first. For that, you go back to the update-manager > view > linux kernel and then click on 4.15.0-52, which open/drop down a dialogue, where you can click on install and confirm with your password. When it is installed, reboot your system.

In the grub-menu you choose advanced option with the arrow keys, press Enter. There go to the line with 4.15.0-52 generic at the end and press Enter again. Then the system boots with that kernel, just as you already know it. On the following website you see pictures of the grub-menu and the advanced options (simply replace Ubuntu with Linux to understand).

https://askubuntu.com/questions/1014634 ... ns-in-grub

When you are back to Cinnamon, you go to the linux kernel in the update manager, choose the 5.0.0-17 kernel and remove it. We do this to prevent the system from rebooting with this kernel next time (automatically the system boots always with the "highest" kernel installed).

If that is done, you can apply the codes one by one JeremyB wrote down (you already know how to proceed with password and enter). I think it's easier to copy each code and paste it into the terminal. Of course, if there appear error messages, report them here.

Karrig
Level 1
Level 1
Posts: 18
Joined: Wed Jun 19, 2019 6:56 am

Re: Wi-Fi unable to connect after updating nvidia proprietary driver (Linux mint 19 Cinnamon)

Post by Karrig » Sun Jun 23, 2019 8:59 am

Thanks again for the help both of you.

I managed to install the 4.15.0-52 kernels without any issues except wi-fi not being able to connect again. Used phone as usb adapter to be able to follow the steps JeremyB posted. However on the second step this happened:

Code: Select all

git clone https://github.com/Mange/rtl8192eu-linux-driver.git
fatal: destination path 'rtl8192eu-linux-driver' already exists and is not an empty directory.
I tried a while back to do a solution that involved updating the drivers through the terminal and I presume this is because of it? Should I try to skip this step, delete the folder there and run it again?

JeremyB
Level 20
Level 20
Posts: 10937
Joined: Fri Feb 21, 2014 8:17 am

Re: Wi-Fi unable to connect after updating nvidia proprietary driver (Linux mint 19 Cinnamon)

Post by JeremyB » Sun Jun 23, 2019 9:03 am

Delete the folder and try again or just cd Desktop and run all the commands

Karrig
Level 1
Level 1
Posts: 18
Joined: Wed Jun 19, 2019 6:56 am

Re: Wi-Fi unable to connect after updating nvidia proprietary driver (Linux mint 19 Cinnamon)

Post by Karrig » Sun Jun 23, 2019 9:13 am

I deleted the folder and cloned it again, then on step three it gave me this error:

Code: Select all

Error! DKMS tree already contains: rtl8192eu-1.0
You cannot add the same module/version combo more than once.

JeremyB
Level 20
Level 20
Posts: 10937
Joined: Fri Feb 21, 2014 8:17 am

Re: Wi-Fi unable to connect after updating nvidia proprietary driver (Linux mint 19 Cinnamon)

Post by JeremyB » Sun Jun 23, 2019 9:20 am

post results for dkms status

Karrig
Level 1
Level 1
Posts: 18
Joined: Wed Jun 19, 2019 6:56 am

Re: Wi-Fi unable to connect after updating nvidia proprietary driver (Linux mint 19 Cinnamon)

Post by Karrig » Sun Jun 23, 2019 9:22 am

Code: Select all

nvidia, 390.116, 4.15.0-20-generic, x86_64: installed
nvidia, 390.116, 4.15.0-52-generic, x86_64: installed
rtl8192eu, 1.0, 4.15.0-20-generic, x86_64: installed
rtl8192eu, 1.0, 4.15.0-52-generic, x86_64: installed

JeremyB
Level 20
Level 20
Posts: 10937
Joined: Fri Feb 21, 2014 8:17 am

Re: Wi-Fi unable to connect after updating nvidia proprietary driver (Linux mint 19 Cinnamon)

Post by JeremyB » Sun Jun 23, 2019 9:27 am

Post results for

Code: Select all

lsmod | grep cfg; modinfo 8192eu

Karrig
Level 1
Level 1
Posts: 18
Joined: Wed Jun 19, 2019 6:56 am

Re: Wi-Fi unable to connect after updating nvidia proprietary driver (Linux mint 19 Cinnamon)

Post by Karrig » Sun Jun 23, 2019 9:29 am

Code: Select all

cfg80211              622592  2 8192eu,mac80211
filename:       /lib/modules/4.15.0-52-generic/kernel/drivers/net/wireless/8192eu.ko
version:        v4.4.1_17696.20160509_BTCOEX20160412-0042
author:         Realtek Semiconductor Corp.
description:    Realtek Wireless Lan Driver
license:        GPL
srcversion:     3F5E5AAE120B5EE98AEBD7A
alias:          usb:v2001p3319d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v2019pAB33d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v2357p0126d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v2357p0109d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v2357p0108d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v2357p0107d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0BDAp818Cd*dc*dsc*dp*icFFiscFFipFFin*
alias:          usb:v0BDAp818Bd*dc*dsc*dp*icFFiscFFipFFin*
depends:        cfg80211
retpoline:      Y
name:           8192eu
vermagic:       4.15.0-52-generic SMP mod_unload 
parm:           rtw_ips_mode:The default IPS mode (int)
parm:           rtw_usb_rxagg_mode:int
parm:           rtw_country_code:The default country code (in alpha2) (charp)
parm:           rtw_channel_plan:The default chplan ID when rtw_alpha2 is not specified or valid (int)
parm:           rtw_excl_chs:exclusive channel array (array of uint)
parm:           rtw_force_igi_lb:force IGI low-bound, 0:no specified (int)
parm:           rtw_qos_opt_enable:int
parm:           ifname:The default name to allocate for first interface (charp)
parm:           if2name:The default name to allocate for second interface (charp)
parm:           rtw_pwrtrim_enable:int
parm:           rtw_initmac:charp
parm:           rtw_special_rf_path:int
parm:           rtw_chip_version:int
parm:           rtw_rfintfs:int
parm:           rtw_lbkmode:int
parm:           rtw_network_mode:int
parm:           rtw_channel:int
parm:           rtw_mp_mode:int
parm:           rtw_wmm_enable:int
parm:           rtw_vrtl_carrier_sense:int
parm:           rtw_vcs_type:int
parm:           rtw_busy_thresh:int
parm:           rtw_ht_enable:int
parm:           rtw_bw_mode:int
parm:           rtw_ampdu_enable:int
parm:           rtw_rx_stbc:int
parm:           rtw_ampdu_amsdu:int
parm:           rtw_lowrate_two_xmit:int
parm:           rtw_rf_config:int
parm:           rtw_power_mgnt:int
parm:           rtw_smart_ps:int
parm:           rtw_low_power:int
parm:           rtw_wifi_spec:int
parm:           rtw_full_ch_in_p2p_handshake:int
parm:           rtw_antdiv_cfg:int
parm:           rtw_antdiv_type:int
parm:           rtw_switch_usb_mode:int
parm:           rtw_enusbss:int
parm:           rtw_hwpdn_mode:int
parm:           rtw_hwpwrp_detect:int
parm:           rtw_hw_wps_pbc:int
parm:           rtw_max_roaming_times:The max roaming times to try (uint)
parm:           rtw_mc2u_disable:int
parm:           rtw_80211d:Enable 802.11d mechanism (int)
parm:           rtw_notch_filter:0:Disable, 1:Enable, 2:Enable only for P2P (uint)
parm:           rtw_hiq_filter:0:allow all, 1:allow special, 2:deny all (uint)
parm:           rtw_adaptivity_en:0:disable, 1:enable (uint)
parm:           rtw_adaptivity_mode:0:normal, 1:carrier sense (uint)
parm:           rtw_adaptivity_dml:0:disable, 1:enable (uint)
parm:           rtw_adaptivity_dc_backoff:DC backoff for Adaptivity (uint)
parm:           rtw_adaptivity_th_l2h_ini:TH_L2H_ini for Adaptivity (int)
parm:           rtw_adaptivity_th_edcca_hl_diff:TH_EDCCA_HL_diff for Adaptivity (int)
parm:           rtw_amplifier_type_2g:BIT3:2G ext-PA, BIT4:2G ext-LNA (uint)
parm:           rtw_amplifier_type_5g:BIT6:5G ext-PA, BIT7:5G ext-LNA (uint)
parm:           rtw_RFE_type:default init value:64 (uint)
parm:           rtw_GLNA_type:default init value:0 (uint)
parm:           rtw_TxBBSwing_2G:default init value:0xFF (uint)
parm:           rtw_TxBBSwing_5G:default init value:0xFF (uint)
parm:           rtw_OffEfuseMask:default open Efuse Mask value:0 (uint)
parm:           rtw_FileMaskEfuse:default drv Mask Efuse value:0 (uint)
parm:           rtw_rxgain_offset_2g:default RF Gain 2G Offset value:0 (uint)
parm:           rtw_rxgain_offset_5gl:default RF Gain 5GL Offset value:0 (uint)
parm:           rtw_rxgain_offset_5gh:uint
parm:           rtw_rxgain_offset_5gm:default RF Gain 5GM Offset value:0 (uint)
parm:           rtw_pll_ref_clk_sel:force pll_ref_clk_sel, 0xF:use autoload value (uint)
parm:           rtw_tx_pwr_lmt_enable:0:Disable, 1:Enable, 2: Depend on efuse (int)
parm:           rtw_tx_pwr_by_rate:0:Disable, 1:Enable, 2: Depend on efuse (int)
parm:           rtw_target_tx_pwr_2g_a:2.4G target tx power (unit:dBm) of RF path A for each rate section, should match the real calibrate power, -1: undefined (array of int)
parm:           rtw_target_tx_pwr_2g_b:2.4G target tx power (unit:dBm) of RF path B for each rate section, should match the real calibrate power, -1: undefined (array of int)
parm:           rtw_target_tx_pwr_2g_c:2.4G target tx power (unit:dBm) of RF path C for each rate section, should match the real calibrate power, -1: undefined (array of int)
parm:           rtw_target_tx_pwr_2g_d:2.4G target tx power (unit:dBm) of RF path D for each rate section, should match the real calibrate power, -1: undefined (array of int)
parm:           rtw_phy_file_path:The path of phy parameter (charp)
parm:           rtw_load_phy_file:PHY File Bit Map (int)
parm:           rtw_decrypt_phy_file:Enable Decrypt PHY File (int)

JeremyB
Level 20
Level 20
Posts: 10937
Joined: Fri Feb 21, 2014 8:17 am

Re: Wi-Fi unable to connect after updating nvidia proprietary driver (Linux mint 19 Cinnamon)

Post by JeremyB » Sun Jun 23, 2019 9:32 am

That looks ok,

Code: Select all

dmesg | grep 8192eu

Karrig
Level 1
Level 1
Posts: 18
Joined: Wed Jun 19, 2019 6:56 am

Re: Wi-Fi unable to connect after updating nvidia proprietary driver (Linux mint 19 Cinnamon)

Post by Karrig » Sun Jun 23, 2019 9:34 am

Code: Select all

[    6.788010] usb 1-1: rtl8192eu_parse_efuse: dumping efuse (0x200 bytes):
[    6.788112] usb 1-1: rtl8xxxu: Loading firmware rtlwifi/rtl8192eu_nic.bin
[    8.211471] RTL871X: rtl8192eu v4.4.1_17696.20160509_BTCOEX20160412-0042
[    8.211473] RTL871X: rtl8192eu BT-Coex version = BTCOEX20160412-0042
[    8.211510] usbcore: registered new interface driver rtl8192eu

JeremyB
Level 20
Level 20
Posts: 10937
Joined: Fri Feb 21, 2014 8:17 am

Re: Wi-Fi unable to connect after updating nvidia proprietary driver (Linux mint 19 Cinnamon)

Post by JeremyB » Sun Jun 23, 2019 11:20 am

Karrig wrote:
Sun Jun 23, 2019 9:34 am

Code: Select all

[    6.788010] usb 1-1: rtl8192eu_parse_efuse: dumping efuse (0x200 bytes):
[    6.788112] usb 1-1: rtl8xxxu: Loading firmware rtlwifi/rtl8192eu_nic.bin
[    8.211471] RTL871X: rtl8192eu v4.4.1_17696.20160509_BTCOEX20160412-0042
[    8.211473] RTL871X: rtl8192eu BT-Coex version = BTCOEX20160412-0042
[    8.211510] usbcore: registered new interface driver rtl8192eu
It looks like you have done

Code: Select all

echo "blacklist rtl8xxxu" | sudo tee /etc/modprobe.d/rtl8xxxu.conf
Reboot

Karrig
Level 1
Level 1
Posts: 18
Joined: Wed Jun 19, 2019 6:56 am

Re: Wi-Fi unable to connect after updating nvidia proprietary driver (Linux mint 19 Cinnamon)

Post by Karrig » Mon Jun 24, 2019 5:55 am

Rebooted, wi-fi works once more, tho the strength issue is still there.

Should I edit the post as solved?

JeremyB
Level 20
Level 20
Posts: 10937
Joined: Fri Feb 21, 2014 8:17 am

Re: Wi-Fi unable to connect after updating nvidia proprietary driver (Linux mint 19 Cinnamon)

Post by JeremyB » Mon Jun 24, 2019 6:17 am

Signal strength might improve if wifi power management is disabled

Code: Select all

echo "options 8192eu rtw_power_mgnt=0 rtw_enusbss=0" | sudo tee /etc/modprobe.d/8192eu.conf
sudo sed -i 's/wifi.powersave = 3/wifi.powersave = 2/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
Reboot

Karrig
Level 1
Level 1
Posts: 18
Joined: Wed Jun 19, 2019 6:56 am

Re: Wi-Fi unable to connect after updating nvidia proprietary driver (Linux mint 19 Cinnamon)

Post by Karrig » Mon Jun 24, 2019 6:29 am

Did that, wi-fi unable to connect again.

JeremyB
Level 20
Level 20
Posts: 10937
Joined: Fri Feb 21, 2014 8:17 am

Re: Wi-Fi unable to connect after updating nvidia proprietary driver (Linux mint 19 Cinnamon)

Post by JeremyB » Mon Jun 24, 2019 6:33 am

This will undo that change

Code: Select all

sudo rm /etc/modprobe.d/8192eu.conf
sudo sed -i 's/wifi.powersave = 2/wifi.powersave = 3/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

Karrig
Level 1
Level 1
Posts: 18
Joined: Wed Jun 19, 2019 6:56 am

Re: Wi-Fi unable to connect after updating nvidia proprietary driver (Linux mint 19 Cinnamon)

Post by Karrig » Mon Jun 24, 2019 6:40 am

Still unable to connect

JeremyB
Level 20
Level 20
Posts: 10937
Joined: Fri Feb 21, 2014 8:17 am

Re: Wi-Fi unable to connect after updating nvidia proprietary driver (Linux mint 19 Cinnamon)

Post by JeremyB » Mon Jun 24, 2019 6:45 am

Run the 2 commands at https://gist.github.com/jeremyb31/a2bee ... bc31bf9480 in terminal and paste the termbin link


JeremyB
Level 20
Level 20
Posts: 10937
Joined: Fri Feb 21, 2014 8:17 am

Re: Wi-Fi unable to connect after updating nvidia proprietary driver (Linux mint 19 Cinnamon)

Post by JeremyB » Mon Jun 24, 2019 7:34 am

Code: Select all

echo "blacklist rtl8xxxu" | sudo tee /etc/modprobe.d/rtl8xxxu.conf
I don't know why that is missing

Post Reply

Return to “Wireless”