Wifi dies Linux Mint 19.1 Mate Lenovo T420

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
MosheLikesBagels7
Level 1
Level 1
Posts: 10
Joined: Thu Mar 03, 2016 12:05 pm

Wifi dies Linux Mint 19.1 Mate Lenovo T420

Post by MosheLikesBagels7 » Mon Jul 15, 2019 3:51 pm

I am wondering whether there's an alternative to disabling the Bluetooth for the wifi to work properly?

Code: Select all

moshe@moshe-ThinkPad-T420:~$ inxi -Fxz
System:
  Host: moshe-ThinkPad-T420 Kernel: 5.0.0-20-generic x86_64 bits: 64 
  compiler: gcc v: 7.4.0 Desktop: MATE 1.20.1 Distro: Linux Mint 19.1 Tessa 
  base: Ubuntu 18.04 bionic 
Machine:
  Type: Laptop System: LENOVO product: 4236DJ7 v: ThinkPad T420 
  serial: <filter> 
  Mobo: LENOVO model: 4236DJ7 serial: <filter> UEFI [Legacy]: LENOVO 
  v: 83ET76WW (1.46 ) date: 07/05/2013 
Battery:
  ID-1: BAT0 charge: 40.8 Wh condition: 42.7/47.5 Wh (90%) 
  model: LGC 42T4911 status: Unknown 
CPU:
  Topology: Dual Core model: Intel Core i5-2520M bits: 64 type: MT MCP 
  arch: Sandy Bridge rev: 7 L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19934 
  Speed: 797 MHz min/max: 800/3200 MHz Core speeds (MHz): 1: 850 2: 798 
  3: 807 4: 798 
Graphics:
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics 
  vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 
  Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel Sandybridge Mobile v: 3.3 Mesa 19.0.2 
  direct render: Yes 
Audio:
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio 
  vendor: Lenovo driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Sound Server: ALSA v: k5.0.0-20-generic 
Network:
  Device-1: Intel 82579LM Gigabit Network vendor: Lenovo ThinkPad T520 
  driver: e1000e v: 3.2.6-k port: 5080 bus ID: 00:19.0 
  IF: enp0s25 state: down mac: <filter> 
  Device-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi 
  v: kernel port: efa0 bus ID: 03:00.0 
  IF: wlp3s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 465.76 GiB used: 244.56 GiB (52.5%) 
  ID-1: /dev/sda vendor: HGST (Hitachi) model: HTS545050A7E680 
  size: 465.76 GiB 
Partition:
  ID-1: / size: 72.83 GiB used: 66.48 GiB (91.3%) fs: ext4 dev: /dev/sda5 
  ID-2: swap-1 size: 6.38 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda6 
Sensors:
  System Temperatures: cpu: 47.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 3221 
Info:
  Processes: 228 Uptime: 14m Memory: 3.63 GiB used: 1.41 GiB (38.7%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.20 
  inxi: 3.0.27

Code: Select all

moshe@moshe-ThinkPad-T420:~$ lspci -nnk | grep -iA3 net
00:19.0 Ethernet controller [0200]: Intel Corporation 82579LM Gigabit Network Connection (Lewisville) [8086:1502] (rev 04)
	Subsystem: Lenovo ThinkPad T520 [17aa:21ce]
	Kernel driver in use: e1000e
	Kernel modules: e1000e
--
03:00.0 Network controller [0280]: Intel Corporation Centrino Advanced-N 6205 [Taylor Peak] [8086:0085] (rev 34)
	Subsystem: Intel Corporation Centrino Advanced-N 6205 (802.11a/b/g/n) [8086:1311]
	Kernel driver in use: iwlwifi
	Kernel modules: iwlwifi
moshe@moshe-ThinkPad-T420:~$

User avatar
kelebek333
Level 3
Level 3
Posts: 127
Joined: Sat Jun 25, 2011 11:57 am
Location: Türkiye
Contact:

Re: Wifi dies Linux Mint 19.1 Mate Lenovo T420

Post by kelebek333 » Thu Sep 05, 2019 8:00 am

You can try to enable 11n_disable=2 parameter with following command. Same problem solved by same parameter on Linux Mint Turkey forum for Lenovo X220 device.

Code: Select all

echo "options iwlwifi 11n_disable=2" | sudo tee /etc/modprobe.d/iwlwifi.conf

Post Reply

Return to “Wireless”