Cloudflare DNS doesn't work

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
fw190
Level 2
Level 2
Posts: 62
Joined: Sun Dec 21, 2014 10:03 am

Cloudflare DNS doesn't work

Post by fw190 » Tue Jul 16, 2019 3:50 pm

Hi!

I have followed the online guides to set up Cloudflare DNS on my laptop but while checking the Cloudlfare page https://1.1.1.1/help I still get my original DNS which means it doesn't work.

On my router I have also set it up as in the guides but it doesn't help.

I could only set it up in Firefox in its about:config settings but Chromium although everything should be set up both in Cinnamon and on the DD-WRT router still shows my original ISP DNS.

I have to do something wrong. Any hints what?
Attachments
Screenshot from 2019-07-16 21-49-16.png
Screenshot from 2019-07-16 21-49-01.png
Screenshot from 2019-07-16 21-47-08.png

User avatar
majpooper
Level 5
Level 5
Posts: 915
Joined: Thu May 09, 2013 1:56 pm
Location: North Carolina, USA

Re: Cloudflare DNS doesn't work

Post by majpooper » Tue Jul 16, 2019 6:25 pm

use the nslookup command from the terminal - it should show the IP of the DNS resolver you are using.

Code: Select all

nslookup www.google.com

DAMIEN1307
Level 7
Level 7
Posts: 1953
Joined: Tue Feb 21, 2017 8:13 pm
Location: Alamogordo, New Mexico, USA

Re: Cloudflare DNS doesn't work

Post by DAMIEN1307 » Tue Jul 16, 2019 10:51 pm

On your first screen shot, upper right hand corner where it says "Automatic (DHCP)", you need to click that setting and change it to "Automatic (DHCP) Addressess Only" , click "apply", and then REBOOT to apply changes...see if that doesnt fix the issue...DAMIEN

The 1.1.1.1 help on my system shows this when configured correctly: (i have also disabled the IPV6 capability on my systems):
Connectivity to Resolver IP Addresses
1.1.1.1 Yes
1.0.0.1 Yes
2606:4700:4700::1111 No
2606:4700:4700::1001 No

The terminal command from majpooper on my system will show this with this configuration:

Code: Select all

damien@damien ~ $ nslookup www.google.com
Server:		127.0.0.53
Address:	127.0.0.53#53

Non-authoritative answer:
Name:	www.google.com
Address: 172.217.4.132
Name:	www.google.com
Address: 2607:f8b0:4007:80e::2004

The terminal command i would use instead is not the "google" one but this one showing "cloudflare" in the code instead"

Code: Select all

nslookup www.cloudflare.com
It will looksomething like this:

Code: Select all

damien@damien ~ $ nslookup www.cloudflare.com
Server:		127.0.0.53
Address:	127.0.0.53#53

Non-authoritative answer:
Name:	www.cloudflare.com
Address: 104.17.210.9
Name:	www.cloudflare.com
Address: 104.17.209.9
Name:	www.cloudflare.com
Address: 2606:4700::6811:d109
Name:	www.cloudflare.com
Address: 2606:4700::6811:d209
Last edited by DAMIEN1307 on Wed Jul 17, 2019 12:00 am, edited 3 times in total.
ORDO AB CHAO

User avatar
phd21
Level 19
Level 19
Posts: 9182
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Cloudflare DNS doesn't work

Post by phd21 » Tue Jul 16, 2019 11:34 pm

Hi fw190,

I just read your post and the good replies to it. Here are my thoughts on this as well.

A couple of other Linux console terminal commands to check DNS server information

Code: Select all

nmcli dev show | grep DNS
or

Code: Select all

systemd-resolve --status
phd21 wrote:I would highly recommend setting up "DNS over TLS" on all computer desktops for even more security.

How to Protect Your DNS Privacy on Ubuntu 18.04 with DNS over TLS
https://www.linuxbabe.com/ubuntu/ubuntu ... s-over-tls

OpenDNS has great tutorials on changing your ISP's default DNS servers to those from any DNS provider like Cloudflare or OpenDNS.

* If you use IPv4 and IPv6 (most up to date ISP's do) then you will have to add Cloudflare DNS to both those tabs configurations and reboot your computer before testing. And has been stated before, some people may also have to select "use IPv4 only" on the IPv4 tab if they are still having issues or disable IPv6 completely (see links at bottom).

CloudFlare's DNS Servers
For IPv4: 1.1.1.1
For IPv4: 1.0.0.1

For IPv6: 2606:4700:4700::1111
For IPv6: 2606:4700:4700::1001


Setup Guide | OpenDNS
- Click computer workstation and laptops then Linux Mint
- Click Routers for their setup instructions
https://www.opendns.com/setupguide/

Linux Mint/Cinnamon – OpenDNS
https://support.opendns.com/hc/en-us/ar ... t-Cinnamon

Router Configuration (best for home use) – OpenDNS
https://support.opendns.com/hc/en-us/se ... 1#articles
=============================================================================
DD-WRT Forum :: View topic - How to set up Cloudflare DNS 1.1.1.1 correctly in DD-WRT?
https://forum.dd-wrt.com/phpBB2/viewtop ... 38a82f3d96

How to set up Smart DNS on DD-WRT Router | SmartyDNS
https://www.smartydns.com/support/smart ... rt-router/

DD-WRT Forum :: View topic - DNS settings not set accordingly.
https://forum.dd-wrt.com/phpBB2/viewtop ... 40ef7fbf75
=============================================================================
How to disable IPv6 address on Ubuntu 18.04 Bionic Beaver Linux - LinuxConfig.org
https://linuxconfig.org/how-to-disable- ... aver-linux

How to Disable IPv6 on Ubuntu Linux
https://itsfoss.com/disable-ipv6-ubuntu-linux/

Hope this helps ...
Phd21: Mint KDE 18.3 & 19, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

User avatar
trytip
Level 11
Level 11
Posts: 3582
Joined: Tue Jul 05, 2016 1:20 pm

Re: Cloudflare DNS doesn't work

Post by trytip » Wed Jul 17, 2019 9:49 am

https://dnsleaktest.com/ and do an extended test, which DNS do you have?
Image

fw190
Level 2
Level 2
Posts: 62
Joined: Sun Dec 21, 2014 10:03 am

Re: Cloudflare DNS doesn't work

Post by fw190 » Wed Jul 17, 2019 11:54 am

Hi!

Thank you for all of your replies.

In Cinnamon there is no option like: "Automatic (DHCP) Addressess Only" there are only:
Automatic (DHCP)
Manual
LInk-Local only

I have tried the last one and after reboot there was no internet.

Code: Select all

fw190@wurger:~$ nmcli dev show | grep DNS
IP4.DNS[1]:                             1.1.1.1
IP4.DNS[2]:                             1.0.0.1
IP6.DNS[1]:                             2606:4700:4700::1111
IP6.DNS[2]:                             2606:4700:4700::1001
fw190@wurger:~$
So everything looks like it should work but when I go to dnsleaktest.com with Chromium is shows the real DNS. The same goes for the gnome browser.

I have tried to clear DNS cache in Chromium like posted here: https://superuser.com/questions/203674/ ... gle-chrome

But still it leaks.

I have the routers set up. Shouldn't it stop the whole thing and force the Cloudflare DNS?

User avatar
phd21
Level 19
Level 19
Posts: 9182
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Cloudflare DNS doesn't work

Post by phd21 » Wed Jul 17, 2019 12:48 pm

Hi fw190

You are welcome from all of us that replied...

Your results from the console terminal command look good and correct.

Have you tried other browsers than Chromium? (FYI: "Vivaldi" is a Chromium-based browser with many more features including settings sync)

If your router's software (firmware) has a setting for DNS to force clients then enable that (check or turn it on) to make anything that connects to the router using its DNS settings.

I still recommend using the instructions from the link in my reply to setup DNS over TLS on computers, etc.. which will require you to install "stubby", add the Cloudflare option to stubby's configuration file, and change the computer's Network Manager ISP connection DNS entry to just "127.0.0.1", restart your computer.

How to Flush DNS Cache on Ubuntu 18.04 LTS (Linux Mint 19.x)
https://vitux.com/how-to-flush-dns-cache-on-ubuntu/

Flush DNS Cache on Ubuntu – Linux Hint
https://linuxhint.com/flush_dns_cache_ubuntu/

Test link - Cloudflare ESNI Checker
https://www.cloudflare.com/ssl/encrypted-sni/

Hope this helps ...
.
Example of my router's custom DNS (OpenWrt 18.06.1 )
Example of my router's custom DNS (OpenWrt 18.06.1 )
.
KDE Neon custom DNS over TLS ipv4 tab.jpg
KDE Neon custom DNS over TLS ipv4 tab.jpg
.
KDE Neon custom DNS over TLS ipv6 tab.jpg
KDE Neon custom DNS over TLS ipv6 tab.jpg
Phd21: Mint KDE 18.3 & 19, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

fw190
Level 2
Level 2
Posts: 62
Joined: Sun Dec 21, 2014 10:03 am

Re: Cloudflare DNS doesn't work

Post by fw190 » Wed Jul 17, 2019 2:42 pm

I have followed the stubby tutorial and added the cloudflare dns and it seems to work ok now. The question is why it didn't work previously?

With stubby set up the internet connection I connect to doesn't matter and I will always use Cloudflare, right?

Pippin
Level 4
Level 4
Posts: 273
Joined: Wed Dec 13, 2017 11:14 am
Location: NL/DE/TH

Re: Cloudflare DNS doesn't work

Post by Pippin » Wed Jul 17, 2019 2:48 pm

With stubby set up the internet connection I connect to doesn't matter
Captive portals, DPI, DNS redirection can be problematic, meaning, possibly unable to connect to some of those networks.
Everything is electric.

User avatar
phd21
Level 19
Level 19
Posts: 9182
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Cloudflare DNS doesn't work

Post by phd21 » Wed Jul 17, 2019 2:51 pm

Hi fw190,

You are welcome...

Yes, it will use Cloudflare unless it is not available then it will use one of the other secure DNS options. I have had no problems with Cloudflare so far and I really like having extra security and encrypted DNS.

I do not know why it did not work for you before, perhaps you did not have "resolvconf" or "openresolv" packages installed before or it could be something else.
Phd21: Mint KDE 18.3 & 19, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

User avatar
trytip
Level 11
Level 11
Posts: 3582
Joined: Tue Jul 05, 2016 1:20 pm

Re: Cloudflare DNS doesn't work

Post by trytip » Thu Jul 18, 2019 9:26 am

In Cinnamon there is no option like: "Automatic (DHCP) Addressess Only"
i think the issue may be in the cinnamon settings

you would choose Automatic (DHCP) Addressess Only by click the network tray icon > network connections > doubleclici you connection > IPV4 > and then have the option of using the ONLY under method
Image

Post Reply

Return to “Wireless”