Wifi Unable to Connect on Dell Optiplex 755

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
anikun2k12
Level 1
Level 1
Posts: 3
Joined: Mon Jul 22, 2019 11:24 am

Wifi Unable to Connect on Dell Optiplex 755

Post by anikun2k12 » Mon Jul 22, 2019 11:46 am

Im using Mint 19.1 32-bit on a Dell Optiplex 755 and whenever i try to connect to wifi via the network manager it throws a "activation of network connection failed", when trying iwconfig it tends to throw either a "Error for wireless request "Set ESSID" (8B1A) : SET failed on device ; Operation not permitted" and "Error for wireless request "Set Encode" (8B2A) : invalid argument [my network password]"

Code: Select all

System:    Host: anikun-OptiPlex-755 Kernel: 4.15.0-20-generic i686 bits: 32 compiler: gcc v: 7.3.0 Desktop: Cinnamon 4.0.8 
           Distro: Linux Mint 19.1 Tessa base: Ubuntu 18.04 bionic 
Machine:   Type: Desktop System: Dell product: OptiPlex 755 v: N/A serial: <filter> 
           Mobo: Dell model: 0PU052 serial: <filter> BIOS: Dell v: A04 date: 11/05/2007 
CPU:       Topology: Dual Core model: Intel Core2 Duo E4400 bits: 64 type: MCP arch: Core Merom rev: D L2 cache: 2048 KiB 
           flags: lm nx pae sse sse2 sse3 ssse3 bogomips: 7980 
           Speed: 1196 MHz min/max: 1200/2000 MHz Core speeds (MHz): 1: 1198 2: 1197 
Graphics:  Device-1: NVIDIA GF108 [GeForce GT 620] vendor: eVga.com. driver: nouveau v: kernel bus ID: 01:00.0 
           Display: x11 server: X.Org 1.19.6 driver: nouveau unloaded: fbdev,modesetting,vesa resolution: 1600x900~60Hz 
           OpenGL: renderer: NVC1 v: 4.3 Mesa 18.0.5 direct render: Yes 
Audio:     Device-1: Intel 82801I HD Audio vendor: Dell Optiplex 755 driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           Device-2: NVIDIA GF108 High Definition Audio vendor: eVga.com. driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           Sound Server: ALSA v: k4.15.0-20-generic 
Network:   Device-1: Intel 82566DM-2 Gigabit Network vendor: Dell OptiPlex 755 driver: e1000e v: 3.2.6-k port: ecc0 
           bus ID: 00:19.0 
           IF: enp0s25 state: down mac: <filter> 
           Device-2: Qualcomm Atheros AR5416 Wireless Network Adapter [AR5008 802.11bgn] driver: ath9k v: kernel port: dc80 
           bus ID: 03:00.0 
           IF: wlp3s0 state: down mac: <filter> 
Drives:    Local Storage: total: 149.01 GiB used: 7.31 GiB (4.9%) 
           ID-1: /dev/sda vendor: Hitachi model: HDS721616PLA380 size: 149.01 GiB 
Partition: ID-1: / size: 41.37 GiB used: 7.31 GiB (17.7%) fs: ext4 dev: /dev/sda5 
Sensors:   System Temperatures: cpu: 52.0 C mobo: N/A gpu: nouveau temp: 83 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 172 Uptime: 50m Memory: 4.81 GiB used: 585.3 MiB (11.9%) Init: systemd runlevel: 5 Compilers: gcc: 7.3.0 
           Shell: bash v: 4.4.19 inxi: 3.0.27 

anikun2k12
Level 1
Level 1
Posts: 3
Joined: Mon Jul 22, 2019 11:24 am

Re: Wifi Unable to Connect on Dell Optiplex 755

Post by anikun2k12 » Mon Jul 22, 2019 2:02 pm

Nevermind i found out what the problem was, i needed to update my bios

anikun2k12
Level 1
Level 1
Posts: 3
Joined: Mon Jul 22, 2019 11:24 am

Re: Wifi Unable to Connect on Dell Optiplex 755

Post by anikun2k12 » Mon Jul 22, 2019 9:45 pm

Nevermind that nevermind, after a restart its broke again with the same issue as above, but i have noticed something, all networks shown in network manager come up as 100% vs when it was briefly working early no network was at 100%

Post Reply

Return to “Wireless”