<SOLVED> Wifi broke after while

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 2
Joined: Mon Jul 22, 2019 3:24 pm

<SOLVED> Wifi broke after while

Post by Hopeles » Mon Jul 22, 2019 4:17 pm

I have old Fujitsu AMILO L1310G with Ralink RT2500 Wireless 802.11bg wlan-card. I had some problems with mint 16 (Xfce) first, but then wifi worked fine until I updated laptop to mint 18. Now wlan start up ok, but after minute or two it lose whole wifi. After I set wifi off and back on from network-manager wifi connect and work again minute or two. How I set it up to do it all by it self?

Code: Select all

~ $ inxi -Fxz
System:    Host: xxxxxx Kernel: 4.4.0-154-generic i686 (32 bit gcc: 5.4.0)
           Desktop: Xfce 4.12.3 (Gtk 2.24.28) Distro: Linux Mint 18 Sarah
Machine:   System: FUJITSU SIEMENS (portable) product: AMILO L Series
           Mobo: FUJITSU SIEMENS model: AMILO L1310 v: 0.3C
           Bios: FUJITSU SIEMENS v: 1.0A-8042-8A20 date: 07/12/05
CPU:       Single core Intel Celeron M (-UP-) cache: 1024 KB
           flags: (nx pae sse sse2) bmips: 3219 speed: 1609 MHz (max)
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RC410M [Mobility Radeon Xpress 200M]
           bus-ID: 01:05.0
           Display Server: X.Org 1.18.4 drivers: ati,radeon (unloaded: fbdev,vesa)
           Resolution: 1280x800@60.19hz
           GLX Renderer: ATI RC410
           GLX Version: 2.1 Mesa 18.0.5 Direct Rendering: Yes
Audio:     Card Advanced Micro Devices [AMD/ATI] IXP SB400 AC'97 Audio Controller
           driver: snd_atiixp bus-ID: 00:14.5
           Sound: Advanced Linux Sound Architecture v: k4.4.0-154-generic
Network:   Card-1: Ralink RT2500 Wireless 802.11bg
           driver: rt2500pci v: 2.3.0 bus-ID: 02:01.0
           IF: wlan0 state: up mac: <filter>
           Card-2: Broadcom and subsidiaries BCM4401-B0 100Base-TX
           driver: b44 v: 2.0 bus-ID: 02:0d.0
           IF: eth0 state: down mac: <filter>
Drives:    HDD Total Size: 80.0GB (14.0% used)
           ID-1: /dev/sda model: ST9808210A size: 80.0GB temp: 39C
Partition: ID-1: / size: 25G used: 9.8G (42%) fs: ext4 dev: /dev/sda6
           ID-2: swap-1 size: 0.81GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 67.8C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 190 Uptime: 1:12 Memory: 497.9/1121.5MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35
Last edited by Hopeles on Thu Aug 01, 2019 8:04 am, edited 2 times in total.

Level 20
Level 20
Posts: 11138
Joined: Fri Feb 21, 2014 8:17 am

Re: Wifi broke after while

Post by JeremyB » Mon Jul 22, 2019 4:58 pm

Disable wifi power management with the following command and reboot

Code: Select all

sudo sed -i 's/3/2/' /etc/NetworkManager/conf.d/*

Level 1
Level 1
Posts: 2
Joined: Mon Jul 22, 2019 3:24 pm

Re: <SOLVED> Wifi broke after while

Post by Hopeles » Thu Aug 01, 2019 8:06 am

Thanks for quick answer! It took me a while to test it, because of summerholiday trip. That code seems to do the trick. :)

Post Reply

Return to “Wireless”