Own WiFi-SSID invisible

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
WimpReaper
Level 1
Level 1
Posts: 3
Joined: Sun Jul 28, 2019 7:28 am

Own WiFi-SSID invisible

Post by WimpReaper » Sun Jul 28, 2019 8:03 am

Hi everyone,

I decided to try something new and installed Linux Mint MATE 19.1 64bit on my old laptop "Fujitsu Siemens Amilo Xa 1526". Then had a few problems getting the "Fujitsu Siemens s miniCard D2301 802.11bg Wireless Module [SiS163U]" to work. With ndiswrapper and a modified 64bit-driver the device finally works and shows me some of the access points in the surroundings. My own network yet remains invisible.

The router is a FRITZ!Box 7530 OC. Seeing and connecting to the network via mobile or iPad works. Connecting the laptop via ethernet works, too.

Changing the WLAN-standard for 2,4GHz to 802.11n+b+g or changing the SSID didn't help.


Maybe some of you has any idea or a good solution.
If you need more information, you need to explain what I have to do. As mentioned: I'm a bloody noob to linux...

HAWR
Level 4
Level 4
Posts: 292
Joined: Thu Jun 06, 2019 1:15 pm

Re: Own WiFi-SSID invisible

Post by HAWR » Mon Jul 29, 2019 2:56 pm

Hello WimpReaper,

we can have a try in the terminal (I hope you know it a little bit). Run the following command:

Code: Select all

nmcli radio
and see, if you get an output with “enabled enabled enabled enabled”

If yes, run the following commands:

Code: Select all

nmcli device wifi rescan

Code: Select all

nmcli device wifi list
The last one should show you a list of accessable wireless networks. Maybe you see your own recognizing its SSID. If yes or not, then run:

Code: Select all

nmcli device wifi connect SSID
(for SSID take the name of your own network)

Maybe it works. IIf not, we must look further.

WimpReaper
Level 1
Level 1
Posts: 3
Joined: Sun Jul 28, 2019 7:28 am

Re: Own WiFi-SSID invisible

Post by WimpReaper » Mon Jul 29, 2019 6:48 pm

Hi HAWR,

the "nmcli radio" command returns the four "enabled" outputs (I'm using the german language-setting):

Code: Select all

@LinuxMint:~$ nmcli radio
WIFI-HW    WIFI       WWAN-HW    WWAN
aktiviert  aktiviert  aktiviert  aktiviert

Entering "nmcli device wifi rescan" is executed without any prompt, so I think it's okay.


"nmcli device wifi list" returns a list of networks, again without my own. Looks like this (I hope it's okay to post network-names and some details since you don't know where I am :wink: ):

Code: Select all

@LinuxMint:~$ nmcli device wifi list
IN-USE  SSID                 MODE   CHAN  RATE        SIGNAL  BARS  SECURITY    
        WLAN-2MU5Z6          Infra  1     130 Mbit/s  67      ▂▄▆_  WPA2        
        Telekom_FON          Infra  1     130 Mbit/s  67      ▂▄▆_  --          
        UPCBE38653           Infra  11    130 Mbit/s  57      ▂▄▆_  WPA1 WPA2   
        Unitymedia WifiSpot  Infra  11    130 Mbit/s  54      ▂▄__  WPA2 802.1X 
        TeleData DSL 68346   Infra  8     54 Mbit/s   39      ▂▄__  WPA1 WPA2   
        Mi Casa Su Casa      Infra  4     270 Mbit/s  35      ▂▄__  WPA2        
        ISIK-Y2              Infra  13    195 Mbit/s  35      ▂▄__  WPA2        
        HomeSweetHome        Infra  11    130 Mbit/s  30      ▂___  WPA2        
        Unitymedia WifiSpot  Infra  11    130 Mbit/s  25      ▂___  WPA2 802.1X 
        HomeSweetHome        Infra  11    130 Mbit/s  25      ▂___  WPA1 WPA2 

Using your last code returns an error, so I don't know if I entered the SSID wrong (with/without quotation marks etc.) or if it's because the SSID is not recognized by Linux/wireless device:

Code: Select all

@LinuxMint:~$ nmcli device wifi connect FRITZ!Box 7530 OC
bash: !Box: event not found

One more info: I managed to open a "personal hotspot" via mobile phone and it was detected by Linux. So I connected with it, but after a few moments the whole system freezed and all I could do was kind of a "cold-shut-down" with the power button.
Same problem occured when I, just for fun, connected to the "Telekom_FON"-network, which is unsecured.

I already read that some other people have/had the same problem with this kind of network device... but I couldn't find a good solution... (besides buying a new network card/stick)...


If you need anything else feel free to ask. And thank you for your approach to solve the problem!

HAWR
Level 4
Level 4
Posts: 292
Joined: Thu Jun 06, 2019 1:15 pm

Re: Own WiFi-SSID invisible

Post by HAWR » Tue Jul 30, 2019 11:48 am

Hello WimpReaper,

when your router's name is your SSID, then there could be problems with the exclamation mark and the spaces in it. So it would be better to give it a "normal" expression without punctuation mark and spaces (for example WimpReaper :D ). But you can try it first with the following before changing the SSID in your router configuration:

Code: Select all

nmcli device wifi connect FRITZ!Box\ \7530\ \OC 
The backslashes tells the system, that there are spaces. If that and a changed SSID won't run, than please show the results of the following commands:

general system hardware overview

Code: Select all

inxi -Fxz
wifi related view

Code: Select all

iwconfig
possible soft or hard blocks

Code: Select all

rfkill list all
overview of PCI devices (if you have a wireless related PCI device)

Code: Select all

lspci
overview of USB devices (if you have a wireless related USB device)

Code: Select all

lsusb
Have you enabled the firewall, which is installed by default but disabled?

WimpReaper
Level 1
Level 1
Posts: 3
Joined: Sun Jul 28, 2019 7:28 am

Re: Own WiFi-SSID invisible

Post by WimpReaper » Thu Aug 01, 2019 4:38 pm

Hi HAWR,

since the last time I answered your post a friend gave me his old FRITZ! WLAN USB Stick.

With ndiswrapper and the right driver the device works without problems. So I think there's no need to put any more effort in getting the Fujitsu Siemens device to run.

BTW: do you recommend enabling the firewall?

Thanks for your help,

-WimpReaper

HAWR
Level 4
Level 4
Posts: 292
Joined: Thu Jun 06, 2019 1:15 pm

Re: Own WiFi-SSID invisible

Post by HAWR » Sat Aug 03, 2019 4:59 am

Hello WimpReaper,

Yes, Fritz & Fritz must get along well. :)

I don't use the firewall on my desktop and only enabled it for a while. Since I had the impression that the corresponding ufw.service had extended the system startup, I disabled it again. It makes no difference to me, but I'm also connected within a network where the main router itself also has a firewall. It is especially recommended on mobile devices that are more often logged into other and/or public networks.

Post Reply

Return to “Wireless”