Wireless not working Linux Mint 19.1 Cinnamon

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
FragMuffin
Level 1
Level 1
Posts: 19
Joined: Wed Jul 31, 2019 7:57 am

Wireless not working Linux Mint 19.1 Cinnamon

Post by FragMuffin » Wed Jul 31, 2019 8:18 am

Im very new to Linux and I cant seem to get wireless networking to work, A wired cable works. I had WIndows 10 on and decided to do a clean install and the computer cant seem to recognize i have a network card

User avatar
Pierre
Level 18
Level 18
Posts: 8916
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: Wireless not working Linux Mint 19.1 Cinnamon

Post by Pierre » Wed Jul 31, 2019 9:15 am

Open Terminal and run these:

Code: Select all

wget -N -t 5 -T 10 https://github.com/UbuntuForums/wireless-info/raw/master/wireless-info && chmod +x wireless-info && ./wireless-info

Code: Select all

cat wireless-info.txt | nc termbin.com 9999
Post URL from Terminal

can you also post back, here, the result of inxi -Fxz
- all back here, on your reply.
8)
NB: you will need to have your Ethernet cable, also connected.
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

FragMuffin
Level 1
Level 1
Posts: 19
Joined: Wed Jul 31, 2019 7:57 am

Re: Wireless not working Linux Mint 19.1 Cinnamon

Post by FragMuffin » Wed Jul 31, 2019 9:55 am

Code: Select all

  Host: christopherstone-HP-Laptop-15-bw0xx Kernel: 4.15.0-20-generic x86_64 
  bits: 64 compiler: gcc v: 7.3.0 Desktop: Cinnamon 4.0.8 
  Distro: Linux Mint 19.1 Tessa base: Ubuntu 18.04 bionic 
Machine:
  Type: Laptop System: HP product: HP Laptop 15-bw0xx 
  v: Type1ProductConfigId serial: <filter> 
  Mobo: HP model: 8332 v: 28.33 serial: <filter> UEFI [Legacy]: Insyde 
  v: F.31 date: 07/25/2018 
Battery:
  ID-1: BAT1 charge: 40.3 Wh condition: 40.3/41.6 Wh (97%) 
  model: Hewlett-Packard PABAS0241231 status: Full 
CPU:
  Topology: Quad Core model: AMD A10-9620P RADEON R5 10 COMPUTE CORES 4C+6G 
  bits: 64 type: MCP arch: Excavator rev: 1 L2 cache: 1024 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 19961 
  Speed: 1292 MHz min/max: 1300/2500 MHz Core speeds (MHz): 1: 1297 2: 1296 
  3: 1292 4: 1327 
Graphics:
  Device-1: AMD Wani [Radeon R5/R6/R7 Graphics] 
  vendor: Hewlett-Packard Carrizo driver: amdgpu v: kernel bus ID: 00:01.0 
  Display: x11 server: X.Org 1.19.6 driver: amdgpu,ati 
  unloaded: fbdev,modesetting,radeon,vesa resolution: 1920x1080~60Hz 
  OpenGL: renderer: AMD CARRIZO (DRM 3.23.0 4.15.0-20-generic LLVM 8.0.0) 
  v: 4.5 Mesa 19.0.2 direct render: Yes 
Audio:
  Device-1: AMD Kabini HDMI/DP Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 00:01.1 
  Device-2: AMD Family 15h Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 00:09.2 
  Sound Server: ALSA v: k4.15.0-20-generic 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: 2.3LK-NAPI port: 3000 
  bus ID: 01:00.0 
  IF: enp1s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Device-2: Realtek vendor: Hewlett-Packard driver: N/A port: 2000 
  bus ID: 02:00.0 
Drives:
  Local Storage: total: 931.51 GiB used: 8.16 GiB (0.9%) 
  ID-1: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB 
  temp: 32 C 
Partition:
  ID-1: / size: 904.42 GiB used: 8.16 GiB (0.9%) fs: ext4 dev: /dev/dm-0 
  ID-2: swap-1 size: 11.46 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-1 
Sensors:
  System Temperatures: cpu: 50.0 C mobo: 20.0 C gpu: amdgpu temp: 48 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 210 Uptime: 2h 08m Memory: 11.20 GiB used: 1.22 GiB (10.9%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.19 
  inxi: 3.0.27 
Im not sure what URL you're talking about

User avatar
Pierre
Level 18
Level 18
Posts: 8916
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: Wireless not working Linux Mint 19.1 Cinnamon

Post by Pierre » Wed Jul 31, 2019 10:06 am

the result is saved in - - "/home/user/wireless-info.txt".
- - where 'user' is your LinuxMint User Name.
- find that file & copy it back here.
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

FragMuffin
Level 1
Level 1
Posts: 19
Joined: Wed Jul 31, 2019 7:57 am

Re: Wireless not working Linux Mint 19.1 Cinnamon

Post by FragMuffin » Wed Jul 31, 2019 10:17 am

Code: Select all

########## wireless info START ##########

Report from: 31 Jul 2019 15:51 SAST +0200

Booted last: 31 Jul 2019 00:00 SAST +0200

Script from: 22 Oct 2018 03:34 UTC +0000

##### release ###########################

Distributor ID:	LinuxMint
Description:	Linux Mint 19.1 Tessa
Release:	19.1
Codename:	tessa

##### kernel ############################

Linux 4.15.0-20-generic #21-Ubuntu SMP Tue Apr 24 06:16:15 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Parameters: ro, quiet, splash, vt.handoff=1

##### desktop ###########################

Cinnamon

##### lspci #############################

01:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)
	Subsystem: Hewlett-Packard Company RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [103c:8332]
	Kernel driver in use: r8169

02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. Device [10ec:d723]
	Subsystem: Hewlett-Packard Company Device [103c:8319]
	Kernel modules: wl

##### lsusb #############################

Bus 001 Device 004: ID 0bda:b009 Realtek Semiconductor Corp. 
Bus 001 Device 003: ID 045e:0745 Microsoft Corp. Nano Transceiver v1.0 for Bluetooth
Bus 001 Device 002: ID 0438:7900 Advanced Micro Devices, Inc. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 002: ID 0408:5180 Quanta Computer, Inc. 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

##### PCMCIA card info ##################

##### rfkill ############################

0: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no

##### secure boot #######################

'mokutil' is not installed (package "mokutil").

##### lsmod #############################

wl                   6447104  0
cfg80211              622592  1 wl
hp_wmi                 16384  0
sparse_keymap          16384  1 hp_wmi
wmi_bmof               16384  0
wmi                    24576  2 wmi_bmof,hp_wmi

##### interfaces ########################

[/etc/network/interfaces]
auto lo
iface lo inet loopback

##### ifconfig ##########################

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback <MAC address> brd <MAC address>
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp1s0: <BROADCAST,MULTICAST,DYNAMIC,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether <MAC 'enp1s0' [IF1]> brd <MAC address>
    inet 192.168.0.3/24 brd 192.168.0.255 scope global dynamic enp1s0
       valid_lft 86362sec preferred_lft 86362sec

##### iwconfig ##########################

lo        no wireless extensions.

enp1s0    no wireless extensions.

##### route #############################

default via 192.168.0.1 dev enp1s0 
default via 192.168.0.1 dev enp1s0 proto dhcp metric 100 
1.0.0.1 via 192.168.0.1 dev enp1s0 
1.1.1.1 via 192.168.0.1 dev enp1s0 
169.254.0.0/16 dev enp1s0 scope link metric 1000 
192.168.0.0/24 dev enp1s0 proto kernel scope link src 192.168.0.3 
192.168.0.0/24 dev enp1s0 proto kernel scope link src 192.168.0.3 metric 100 
192.168.0.1 dev enp1s0 scope link 
192.168.88.1 via 192.168.0.1 dev enp1s0 

##### resolv.conf #######################

[777 root '/etc/resolv.conf' -> '/run/connman/resolv.conf']
nameserver ::1
nameserver 127.0.0.1

##### network managers ##################

Installed:

	NetworkManager
	ConnMan

Running:

root       799     1  0 13:46 ?        00:00:01 /usr/sbin/connmand -n
root       810     1  0 13:46 ?        00:00:01 /usr/sbin/NetworkManager --no-daemon

##### NetworkManager info ###############

GENERAL.DEVICE:                         enp1s0
GENERAL.TYPE:                           ethernet
GENERAL.NM-TYPE:                        NMDeviceEthernet
GENERAL.VENDOR:                         Realtek Semiconductor Co., Ltd.
GENERAL.PRODUCT:                        RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
GENERAL.DRIVER:                         r8169
GENERAL.DRIVER-VERSION:                 2.3LK-NAPI
GENERAL.FIRMWARE-VERSION:               rtl8168h-2_0.0.2 02/26/15
GENERAL.HWADDR:                         <MAC 'enp1s0' [IF1]>
GENERAL.MTU:                            1500
GENERAL.STATE:                          100 (connected)
GENERAL.REASON:                         0 (No reason given)
GENERAL.UDI:                            /sys/devices/pci0000:00/0000:00:02.2/0000:01:00.0/net/enp1s0
GENERAL.IP-IFACE:                       enp1s0
GENERAL.IS-SOFTWARE:                    no
GENERAL.NM-MANAGED:                     yes
GENERAL.AUTOCONNECT:                    yes
GENERAL.FIRMWARE-MISSING:               no
GENERAL.NM-PLUGIN-MISSING:              no
GENERAL.PHYS-PORT-ID:                   --
GENERAL.CONNECTION:                     Wired connection 1
GENERAL.CON-UUID:                       75a69237-b41e-36f1-b0b5-0c09842af58d
GENERAL.CON-PATH:                       /org/freedesktop/NetworkManager/ActiveConnection/11
GENERAL.METERED:                        no (guessed)
CAPABILITIES.CARRIER-DETECT:            yes
CAPABILITIES.SPEED:                     100 Mb/s
CAPABILITIES.IS-SOFTWARE:               no
CAPABILITIES.SRIOV:                     no
WIRED-PROPERTIES.CARRIER:               on
IP4.ADDRESS[1]:                         192.168.0.3/24
IP4.GATEWAY:                            192.168.0.1
IP4.ROUTE[1]:                           dst = 0.0.0.0/0, nh = 192.168.0.1, mt = 100
IP4.ROUTE[2]:                           dst = 192.168.0.0/24, nh = 0.0.0.0, mt = 0
IP4.ROUTE[3]:                           dst = 192.168.0.1/32, nh = 0.0.0.0, mt = 0
IP4.ROUTE[4]:                           dst = 192.168.88.1/32, nh = 192.168.0.1, mt = 0
IP4.ROUTE[5]:                           dst = 1.1.1.1/32, nh = 192.168.0.1, mt = 0
IP4.ROUTE[6]:                           dst = 1.0.0.1/32, nh = 192.168.0.1, mt = 0
IP4.ROUTE[7]:                           dst = 0.0.0.0/0, nh = 192.168.0.1, mt = 0
IP4.ROUTE[8]:                           dst = 192.168.0.0/24, nh = 0.0.0.0, mt = 100
IP4.ROUTE[9]:                           dst = 169.254.0.0/16, nh = 0.0.0.0, mt = 1000
IP4.DNS[1]:                             192.168.88.1
IP4.DNS[2]:                             1.1.1.1
IP4.DNS[3]:                             1.0.0.1
DHCP4.OPTION[1]:                        network_number = 192.168.0.0
DHCP4.OPTION[2]:                        requested_domain_search = 1
DHCP4.OPTION[3]:                        requested_time_offset = 1
DHCP4.OPTION[4]:                        requested_domain_name = 1
DHCP4.OPTION[5]:                        requested_rfc3442_classless_static_routes = 1
DHCP4.OPTION[6]:                        requested_broadcast_address = 1
DHCP4.OPTION[7]:                        requested_netbios_scope = 1
DHCP4.OPTION[8]:                        expiry = 1564667433
DHCP4.OPTION[9]:                        next_server = 0.0.0.0
DHCP4.OPTION[10]:                       broadcast_address = 192.168.0.255
DHCP4.OPTION[11]:                       dhcp_message_type = 5
DHCP4.OPTION[12]:                       requested_interface_mtu = 1
DHCP4.OPTION[13]:                       routers = 192.168.0.1
DHCP4.OPTION[14]:                       ip_address = 192.168.0.3
DHCP4.OPTION[15]:                       requested_subnet_mask = 1
DHCP4.OPTION[16]:                       requested_domain_name_servers = 1
DHCP4.OPTION[17]:                       subnet_mask = 255.255.255.0
DHCP4.OPTION[18]:                       requested_static_routes = 1
DHCP4.OPTION[19]:                       requested_wpad = 1
DHCP4.OPTION[20]:                       requested_ntp_servers = 1
DHCP4.OPTION[21]:                       domain_name_servers = 192.168.88.1 1.1.1.1 1.0.0.1
DHCP4.OPTION[22]:                       requested_netbios_name_servers = 1
DHCP4.OPTION[23]:                       requested_routers = 1
DHCP4.OPTION[24]:                       requested_ms_classless_static_routes = 1
DHCP4.OPTION[25]:                       dhcp_lease_time = 86400
DHCP4.OPTION[26]:                       requested_host_name = 1
DHCP4.OPTION[27]:                       dhcp_server_identifier = 192.168.0.1
IP6.ADDRESS[1]:                         fe80::2a70:48b9:6102:240f/64
IP6.GATEWAY:                            --
IP6.ROUTE[1]:                           dst = ff00::/8, nh = ::, mt = 256, table=255
CONNECTIONS.AVAILABLE-CONNECTION-PATHS: /org/freedesktop/NetworkManager/Settings/{2}
CONNECTIONS.AVAILABLE-CONNECTIONS[1]:   75a69237-b41e-36f1-b0b5-0c09842af58d | Wired connection 1

##### NetworkManager.state ##############

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true

##### NetworkManager config #############

[[/etc/NetworkManager/conf.d/default-wifi-powersave-on.conf]]
[connection]
wifi.powersave = 3

[[/etc/NetworkManager/NetworkManager.conf]]
[main]
plugins=ifupdown,keyfile
[ifupdown]
managed=false
[device]
wifi.scan-rand-mac-address=no

[[/usr/lib/NetworkManager/conf.d/10-dns-resolved.conf]]
[main]
dns=systemd-resolved

[[/usr/lib/NetworkManager/conf.d/10-globally-managed-devices.conf]]
[keyfile]
unmanaged-devices=*,except:type:wifi,except:type:wwan

[[/usr/lib/NetworkManager/conf.d/20-connectivity-ubuntu.conf]]
[connectivity]
uri=http://connectivity-check.ubuntu.com/

[[/usr/lib/NetworkManager/conf.d/no-mac-addr-change.conf]]
[device-mac-addr-change-wifi]
match-device=driver:rtl8723bs,driver:rtl8189es,driver:r8188eu,driver:8188eu,driver:eagle_sdio,driver:wl
wifi.scan-rand-mac-address=no
wifi.cloned-mac-address=preserve
ethernet.cloned-mac-address=preserve

##### NetworkManager profiles ###########

[[/etc/NetworkManager/system-connections/Wi-Fi connection 1]] (600 root)
[connection] id=Wi-Fi connection 1 | type=wifi | permissions=
[wifi] mac-address-blacklist= | ssid=PeterKate
[ipv4] method=auto
[ipv6] method=auto

##### Netplan config ####################

[/etc/netplan/1-network-manager-all.yaml]
network:
  version: 2
  renderer: NetworkManager

##### iw reg get ########################

Region: Africa/Johannesburg (based on set time zone)

global
country 00: DFS-UNSET
	(2402 - 2472 @ 40), (N/A, 20), (N/A)
	(2457 - 2482 @ 20), (N/A, 20), (N/A), AUTO-BW, PASSIVE-SCAN
	(2474 - 2494 @ 20), (N/A, 20), (N/A), NO-OFDM, PASSIVE-SCAN
	(5170 - 5250 @ 80), (N/A, 20), (N/A), AUTO-BW, PASSIVE-SCAN
	(5250 - 5330 @ 80), (N/A, 20), (0 ms), DFS, AUTO-BW, PASSIVE-SCAN
	(5490 - 5730 @ 160), (N/A, 20), (0 ms), DFS, PASSIVE-SCAN
	(5735 - 5835 @ 80), (N/A, 20), (N/A), PASSIVE-SCAN
	(57240 - 63720 @ 2160), (N/A, 0), (N/A)

##### iwlist channels ###################

lo        no frequency information.

enp1s0    no frequency information.

##### iwlist scan #######################

lo        Interface doesn't support scanning.

enp1s0    Interface doesn't support scanning.

##### module infos ######################

[wl]
filename:       /lib/modules/4.15.0-20-generic/updates/wl.ko
license:        MIXED/Proprietary
srcversion:     00D38A27B7E3C7B97C238FC
depends:        cfg80211
retpoline:      Y
name:           wl
vermagic:       4.15.0-20-generic SMP mod_unload 
parm:           passivemode:int
parm:           wl_txq_thresh:int
parm:           oneonly:int
parm:           piomode:int
parm:           instance_base:int
parm:           nompc:int
parm:           intf_name:string

[cfg80211]
filename:       /lib/modules/4.15.0-20-generic/kernel/net/wireless/cfg80211.ko
description:    wireless configuration support
license:        GPL
author:         Johannes Berg
srcversion:     D5B0789D4C423C81CCFB437
depends:        
retpoline:      Y
intree:         Y
name:           cfg80211
vermagic:       4.15.0-20-generic SMP mod_unload 
signat:         PKCS#7
signer:         
sig_key:        
sig_hashalgo:   md4
parm:           bss_entries_limit:limit to number of scan BSS entries (per wiphy, default 1000) (int)
parm:           ieee80211_regdom:IEEE 802.11 regulatory domain code (charp)
parm:           cfg80211_disable_40mhz_24ghz:Disable 40MHz support in the 2.4GHz band (bool)

##### module parameters #################

[cfg80211]
bss_entries_limit: 1000
cfg80211_disable_40mhz_24ghz: N
ieee80211_regdom: 00

##### /etc/modules ######################

##### modprobe options ##################

[/etc/modprobe.d/amd64-microcode-blacklist.conf]
blacklist microcode

[/etc/modprobe.d/blacklist-ath_pci.conf]
blacklist ath_pci

[/etc/modprobe.d/blacklist-bcm43.conf]
blacklist b43
blacklist b43legacy
blacklist ssb
blacklist bcm43xx
blacklist brcm80211
blacklist brcmfmac
blacklist brcmsmac
blacklist bcma

[/etc/modprobe.d/blacklist.conf]
blacklist evbug
blacklist usbmouse
blacklist usbkbd
blacklist eepro100
blacklist de4x5
blacklist eth1394
blacklist snd_intel8x0m
blacklist snd_aw2
blacklist prism54
blacklist bcm43xx
blacklist garmin_gps
blacklist asus_acpi
blacklist snd_pcsp
blacklist pcspkr
blacklist amd76x_edac

[/etc/modprobe.d/blacklist-rare-network.conf]
alias net-pf-3 off
alias net-pf-6 off
alias net-pf-9 off
alias net-pf-11 off
alias net-pf-12 off
alias net-pf-19 off
alias net-pf-21 off
alias net-pf-36 off

[/etc/modprobe.d/intel-microcode-blacklist.conf]
blacklist microcode

[/etc/modprobe.d/iwlwifi.conf]
remove iwlwifi \
(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
&& /sbin/modprobe -r mac80211

##### rc.local ##########################

grep: /etc/rc.local: No such file or directory

##### pm-utils ##########################

##### udev rules ########################

##### dmesg #############################

[ 1216.761674] IPv6: ADDRCONF(NETDEV_CHANGE): enp1s0: link becomes ready
[ 1216.815742] r8169 0000:01:00.0 enp1s0: link down (repeated 2 times)
[ 1216.815915] IPv6: ADDRCONF(NETDEV_UP): enp1s0: link is not ready (repeated 3 times)
[ 1218.398402] r8169 0000:01:00.0 enp1s0: link up
[ 1218.398427] IPv6: ADDRCONF(NETDEV_CHANGE): enp1s0: link becomes ready
[ 1301.164886] r8169 0000:01:00.0 enp1s0: link down
[ 1301.231761] IPv6: ADDRCONF(NETDEV_UP): enp1s0: link is not ready
[ 1307.244134] r8169 0000:01:00.0 enp1s0: link down
[ 1307.244284] IPv6: ADDRCONF(NETDEV_UP): enp1s0: link is not ready
[ 1308.810789] r8169 0000:01:00.0 enp1s0: link up
[ 1308.810812] IPv6: ADDRCONF(NETDEV_CHANGE): enp1s0: link becomes ready
[ 1308.868113] r8169 0000:01:00.0 enp1s0: link down (repeated 2 times)
[ 1308.868328] IPv6: ADDRCONF(NETDEV_UP): enp1s0: link is not ready (repeated 3 times)
[ 1310.453680] r8169 0000:01:00.0 enp1s0: link up
[ 1310.453701] IPv6: ADDRCONF(NETDEV_CHANGE): enp1s0: link becomes ready
[ 1852.112210] r8169 0000:01:00.0 enp1s0: link down
[ 1852.222303] IPv6: ADDRCONF(NETDEV_UP): enp1s0: link is not ready
[ 1858.194109] r8169 0000:01:00.0 enp1s0: link down
[ 1858.194314] IPv6: ADDRCONF(NETDEV_UP): enp1s0: link is not ready
[ 1866.241149] r8169 0000:01:00.0 enp1s0: link up
[ 1866.241169] IPv6: ADDRCONF(NETDEV_CHANGE): enp1s0: link becomes ready
[ 1866.294133] r8169 0000:01:00.0 enp1s0: link down (repeated 2 times)
[ 1866.294316] IPv6: ADDRCONF(NETDEV_UP): enp1s0: link is not ready (repeated 3 times)
[ 1867.895735] r8169 0000:01:00.0 enp1s0: link up
[ 1867.895760] IPv6: ADDRCONF(NETDEV_CHANGE): enp1s0: link becomes ready
[ 6013.179181] r8169 0000:01:00.0 enp1s0: link down
[ 6013.248597] IPv6: ADDRCONF(NETDEV_UP): enp1s0: link is not ready
[ 6019.245740] r8169 0000:01:00.0 enp1s0: link down
[ 6019.245897] IPv6: ADDRCONF(NETDEV_UP): enp1s0: link is not ready
[ 6086.366945] r8169 0000:01:00.0 enp1s0: link up
[ 6086.366968] IPv6: ADDRCONF(NETDEV_CHANGE): enp1s0: link becomes ready
[ 6086.408756] r8169 0000:01:00.0 enp1s0: link down (repeated 2 times)
[ 6086.408873] IPv6: ADDRCONF(NETDEV_UP): enp1s0: link is not ready (repeated 3 times)
[ 6088.027826] r8169 0000:01:00.0 enp1s0: link up
[ 6088.027851] IPv6: ADDRCONF(NETDEV_CHANGE): enp1s0: link becomes ready
[ 6616.663298] r8169 0000:01:00.0 enp1s0: link up (repeated 5 times)
[ 7059.159693] r8169 0000:01:00.0 enp1s0: link down
[ 7059.229748] IPv6: ADDRCONF(NETDEV_UP): enp1s0: link is not ready
[ 7065.237881] r8169 0000:01:00.0 enp1s0: link down
[ 7065.238078] IPv6: ADDRCONF(NETDEV_UP): enp1s0: link is not ready
[ 7071.596815] r8169 0000:01:00.0 enp1s0: link up
[ 7071.596833] IPv6: ADDRCONF(NETDEV_CHANGE): enp1s0: link becomes ready
[ 7071.645696] r8169 0000:01:00.0 enp1s0: link down
[ 7071.645882] IPv6: ADDRCONF(NETDEV_UP): enp1s0: link is not ready
[ 7071.647564] r8169 0000:01:00.0 enp1s0: link down
[ 7071.655760] IPv6: ADDRCONF(NETDEV_UP): enp1s0: link is not ready (repeated 2 times)
[ 7073.338592] r8169 0000:01:00.0 enp1s0: link up
[ 7073.338618] IPv6: ADDRCONF(NETDEV_CHANGE): enp1s0: link becomes ready
[ 7103.813130] r8169 0000:01:00.0 enp1s0: link up (repeated 3 times)
[ 7280.192387] r8169 0000:01:00.0 enp1s0: link down
[ 7280.264023] IPv6: ADDRCONF(NETDEV_UP): enp1s0: link is not ready
[ 7286.264965] r8169 0000:01:00.0 enp1s0: link down
[ 7286.265090] IPv6: ADDRCONF(NETDEV_UP): enp1s0: link is not ready
[ 7292.225238] r8169 0000:01:00.0 enp1s0: link up
[ 7292.225262] IPv6: ADDRCONF(NETDEV_CHANGE): enp1s0: link becomes ready
[ 7292.268976] r8169 0000:01:00.0 enp1s0: link down (repeated 2 times)
[ 7292.269102] IPv6: ADDRCONF(NETDEV_UP): enp1s0: link is not ready (repeated 3 times)
[ 7293.898533] r8169 0000:01:00.0 enp1s0: link up
[ 7293.898552] IPv6: ADDRCONF(NETDEV_CHANGE): enp1s0: link becomes ready
[ 7446.211494] r8169 0000:01:00.0 enp1s0: link down
[ 7446.285248] IPv6: ADDRCONF(NETDEV_UP): enp1s0: link is not ready
[ 7452.273440] r8169 0000:01:00.0 enp1s0: link down
[ 7452.273581] IPv6: ADDRCONF(NETDEV_UP): enp1s0: link is not ready
[ 7473.531591] r8169 0000:01:00.0 enp1s0: link up
[ 7473.531616] IPv6: ADDRCONF(NETDEV_CHANGE): enp1s0: link becomes ready
[ 7473.576966] r8169 0000:01:00.0 enp1s0: link down (repeated 2 times)
[ 7473.577087] IPv6: ADDRCONF(NETDEV_UP): enp1s0: link is not ready (repeated 3 times)
[ 7475.207134] r8169 0000:01:00.0 enp1s0: link up
[ 7475.207158] IPv6: ADDRCONF(NETDEV_CHANGE): enp1s0: link becomes ready

########## wireless info END ############
Also the wired connection comes and gos

HAWR
Level 4
Level 4
Posts: 284
Joined: Thu Jun 06, 2019 1:15 pm

Re: Wireless not working Linux Mint 19.1 Cinnamon

Post by HAWR » Wed Jul 31, 2019 11:48 am

Hello FragMuffin,

first you should have a look in the BIOS to disable Secure Boot. You can get the status in the terminal with:

Code: Select all

mokutil --sb-state
Because "mokutil" is not installed, you can install it with the command:

Code: Select all

sudo apt install mokutil
If that brings no positive result, have a look at this site, because there can be a known issue with the antennas:

https://easylinuxtipsproject.blogspot.c ... k.html#ID2

Your wireless adapter with the ID 10ec:d723 needs the driver RTL8723de, which should be on your system. Furthermore I would recommend you to install the latest kernel of the 4.15 series via the update manager. In the manager's help you find a short description of kernel updates.

FragMuffin
Level 1
Level 1
Posts: 19
Joined: Wed Jul 31, 2019 7:57 am

Re: Wireless not working Linux Mint 19.1 Cinnamon

Post by FragMuffin » Wed Jul 31, 2019 12:00 pm

Results of doing the above

Code: Select all

christopherstone@christopherstone-HP-Laptop-15-bw0xx:~$ mokutil --sb-state
EFI variables are not supported on this system
christopherstone@christopherstone-HP-Laptop-15-bw0xx:~$ sudo modprobe -r rtl8723be
[sudo] password for christopherstone:  
christopherstone@christopherstone-HP-Laptop-15-bw0xx:~$ sudo modprobe rtl8723de ant_sel=2
modprobe: FATAL: Module rtl8723de not found in directory /lib/modules/4.15.0-55-generic
christopherstone@christopherstone-HP-Laptop-15-bw0xx:~$ 

HAWR
Level 4
Level 4
Posts: 284
Joined: Thu Jun 06, 2019 1:15 pm

Re: Wireless not working Linux Mint 19.1 Cinnamon

Post by HAWR » Wed Jul 31, 2019 12:22 pm

Be aware of that the tips on the website are for RTL8723BE and RTL8723DE. The commands uses BE but you have to take DE instead.
Note: the how-to below, is written for an RTL8723BE chipset. If you have an RTL8723DE chipset, then replace all instances of rtl8723be by rtl8723de.

FragMuffin
Level 1
Level 1
Posts: 19
Joined: Wed Jul 31, 2019 7:57 am

Re: Wireless not working Linux Mint 19.1 Cinnamon

Post by FragMuffin » Wed Jul 31, 2019 12:27 pm

It says:
modprobe: FATAL: Module rtl8723de not found

HAWR
Level 4
Level 4
Posts: 284
Joined: Thu Jun 06, 2019 1:15 pm

Re: Wireless not working Linux Mint 19.1 Cinnamon

Post by HAWR » Wed Jul 31, 2019 12:45 pm

Hello FragMuffin,

a little mistake of mine: for your Realtek adapter you need the rtlwifi_new driver. A how-to is described on that website, too:

https://easylinuxtipsproject.blogspot.c ... k.html#ID8

Be aware of the Note at the end related to later kernel updates!

FragMuffin
Level 1
Level 1
Posts: 19
Joined: Wed Jul 31, 2019 7:57 am

Re: Wireless not working Linux Mint 19.1 Cinnamon

Post by FragMuffin » Wed Jul 31, 2019 1:27 pm

It connects to the wifi network but no internet

HAWR
Level 4
Level 4
Posts: 284
Joined: Thu Jun 06, 2019 1:15 pm

Re: Wireless not working Linux Mint 19.1 Cinnamon

Post by HAWR » Wed Jul 31, 2019 2:06 pm

Hello FragMuffin,

that's a good sign. Now we have to find the reason, why there is no internet. Please show now the results of the following commands, because now your wifi works:

for possible blocks:

Code: Select all

rfkill list all
right detection:

Code: Select all

iwconfig
right detection:

Code: Select all

inxi -nxz
test for internet connection:

Code: Select all

ping google.com -c3
right working:

Code: Select all

nmcli radio
wireless network list

Code: Select all

nmcli device wifi list
The last command should show your network. You can post only this result. For get all informations enlarge the terminal window.

FragMuffin
Level 1
Level 1
Posts: 19
Joined: Wed Jul 31, 2019 7:57 am

Re: Wireless not working Linux Mint 19.1 Cinnamon

Post by FragMuffin » Wed Jul 31, 2019 2:18 pm

Code: Select all

rfkill list all: 
0: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
1: phy0: Wireless LAN
	Soft blocked: yes
	Hard blocked: no

right detection:
lo        no wireless extensions.

enp1s0    no wireless extensions.

wlp2s0    IEEE 802.11  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=off   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:on
          

Code: Select all

right detection:
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: 2.3LK-NAPI port: 3000 
  bus ID: 01:00.0 
  IF: enp1s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Device-2: Realtek vendor: Hewlett-Packard driver: rtl8723de v: kernel 
  port: 2000 bus ID: 02:00.0 
  IF: wlp2s0 state: down mac: <filter> 

test for internet connection:
ping google.com -c3

right working: 
nmcli radio

Code: Select all

wireless network list:
IN-USE  SSID              MODE   CHAN  RATE        SIGNAL  BARS  SECURITY  
        PeterKate1        Infra  11    270 Mbit/s  100     ▂▄▆█  WPA1      
        HUAWEI-B315-4255  Infra  10    130 Mbit/s  79      ▂▄▆_  WPA2      
        STUPEN            Infra  5     405 Mbit/s  37      ▂▄__  WPA1 WPA2

HAWR
Level 4
Level 4
Posts: 284
Joined: Thu Jun 06, 2019 1:15 pm

Re: Wireless not working Linux Mint 19.1 Cinnamon

Post by HAWR » Wed Jul 31, 2019 2:31 pm

There is a soft block, so we try to solve it with the following command:

Code: Select all

rfkill unblock all
Then test it again with:

Code: Select all

rfkill list all
If it is solved, try again the ping-command and the nmcli radio command.


Which one of the three networks is yours?

FragMuffin
Level 1
Level 1
Posts: 19
Joined: Wed Jul 31, 2019 7:57 am

Re: Wireless not working Linux Mint 19.1 Cinnamon

Post by FragMuffin » Wed Jul 31, 2019 2:34 pm

Which one of the three networks is yours?
PeterKate

HAWR
Level 4
Level 4
Posts: 284
Joined: Thu Jun 06, 2019 1:15 pm

Re: Wireless not working Linux Mint 19.1 Cinnamon

Post by HAWR » Wed Jul 31, 2019 2:43 pm

What is the result of the unblock command?

For your internet security I recommend to set it in the router configuration to WPA2 (AES) if possible.

FragMuffin
Level 1
Level 1
Posts: 19
Joined: Wed Jul 31, 2019 7:57 am

Re: Wireless not working Linux Mint 19.1 Cinnamon

Post by FragMuffin » Wed Jul 31, 2019 2:44 pm

0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

HAWR
Level 4
Level 4
Posts: 284
Joined: Thu Jun 06, 2019 1:15 pm

Re: Wireless not working Linux Mint 19.1 Cinnamon

Post by HAWR » Wed Jul 31, 2019 2:46 pm

Then it should work now and the other two commands should show an output.

FragMuffin
Level 1
Level 1
Posts: 19
Joined: Wed Jul 31, 2019 7:57 am

Re: Wireless not working Linux Mint 19.1 Cinnamon

Post by FragMuffin » Wed Jul 31, 2019 2:51 pm

It says network unreachable

HAWR
Level 4
Level 4
Posts: 284
Joined: Thu Jun 06, 2019 1:15 pm

Re: Wireless not working Linux Mint 19.1 Cinnamon

Post by HAWR » Wed Jul 31, 2019 3:11 pm

Please run in the terminal the following command:

Code: Select all

nmcli device wifi connect PeterKate1
Have you made manual changes in your network settings?

Post Reply

Return to “Wireless”