Wireless not working on Dell XPS 15-7590, with Mint 19.1 Tessa

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
fiftyfour
Level 1
Level 1
Posts: 6
Joined: Thu Aug 01, 2019 2:42 pm

Wireless not working on Dell XPS 15-7590, with Mint 19.1 Tessa

Post by fiftyfour » Thu Aug 01, 2019 3:22 pm

I have installed this version of Linux Mint, and though a wired Ethernet cable works I cannot seem to get any wifi connections or even wifi scanning up and running.

I have gone through all available updates and upgrades that I have been able to find thus far. Any help appreciated

Output of inxi -Fxs is

Code: Select all

System:
  Host: localhost-XPS-15-7590 Kernel: 4.15.0-55-generic x86_64 bits: 64 
  compiler: gcc v: 7.4.0 Desktop: Cinnamon 4.0.10 
  Distro: Linux Mint 19.1 Tessa base: Ubuntu 18.04 bionic 
Machine:
  Type: Laptop System: Dell product: XPS 15 7590 v: N/A serial: <filter> 
  Mobo: Dell model: 0T8KGX v: A00 serial: <filter> UEFI: Dell v: 1.1.1 
  date: 05/31/2019 
Battery:
  ID-1: BAT0 charge: 84.0 Wh condition: 87.4/97.0 Wh (90%) 
  model: SMP DELL GPM0365 status: Charging 
CPU:
  Topology: 8-Core model: Intel Core i9-9980HK bits: 64 type: MT MCP 
  arch: Kaby Lake rev: D L2 cache: 16.0 MiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 76800 
  Speed: 800 MHz min/max: 800/5000 MHz Core speeds (MHz): 1: 890 2: 833 
  3: 841 4: 821 5: 840 6: 838 7: 843 8: 839 9: 899 10: 848 11: 813 12: 898 
  13: 807 14: 827 15: 892 16: 837 
Graphics:
  Device-1: Intel vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 
  Device-2: NVIDIA vendor: Dell driver: N/A bus ID: 01:00.0 
  Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa 
  resolution: 3840x2160~60Hz 
  OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2) 
  v: 4.5 Mesa 19.0.2 direct render: Yes 
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel 
  v: kernel bus ID: 00:1f.3 
  Sound Server: ALSA v: k4.15.0-55-generic 
Network:
  Device-1: Intel vendor: Bigfoot Networks driver: N/A port: 3000 
  bus ID: 3b:00.0 
  Device-2: Realtek type: USB driver: r8152 bus ID: 4-1.2:3 
  IF: enx8c04ba740c85 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 1.86 TiB used: 7.05 GiB (0.4%) 
  ID-1: /dev/nvme0n1 vendor: Toshiba model: KXG50PNV2T04 NVMe 2048GB 
  size: 1.86 TiB 
Partition:
  ID-1: / size: 1.76 TiB used: 7.04 GiB (0.4%) fs: ext4 dev: /dev/dm-0 
  ID-2: swap-1 size: 31.64 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-1 
Sensors:
  System Temperatures: cpu: 51.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 306 Uptime: 33m Memory: 31.06 GiB used: 1.49 GiB (4.8%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.20 
  inxi: 3.0.27

sleeper12
Level 5
Level 5
Posts: 900
Joined: Thu May 25, 2017 3:22 pm

Re: Wireless not working on Dell XPS 15-7590, with Mint 19.1 Tessa

Post by sleeper12 » Thu Aug 01, 2019 10:21 pm

Does Fn & PrtScr keys turn wifi on?

fiftyfour
Level 1
Level 1
Posts: 6
Joined: Thu Aug 01, 2019 2:42 pm

Re: Wireless not working on Dell XPS 15-7590, with Mint 19.1 Tessa

Post by fiftyfour » Fri Aug 02, 2019 9:49 am

Fn & PrtScr turns Bluetooth on and off, but i cannot see any effect on the WiFi

sleeper12
Level 5
Level 5
Posts: 900
Joined: Thu May 25, 2017 3:22 pm

Re: Wireless not working on Dell XPS 15-7590, with Mint 19.1 Tessa

Post by sleeper12 » Fri Aug 02, 2019 11:27 am

What does this command show:

Code: Select all

 rfkill list all 

fiftyfour
Level 1
Level 1
Posts: 6
Joined: Thu Aug 01, 2019 2:42 pm

Re: Wireless not working on Dell XPS 15-7590, with Mint 19.1 Tessa

Post by fiftyfour » Fri Aug 02, 2019 11:59 am

Code: Select all

localhost@localhost-XPS-15-7590:~$ rfkill list all
0: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no

sleeper12
Level 5
Level 5
Posts: 900
Joined: Thu May 25, 2017 3:22 pm

Re: Wireless not working on Dell XPS 15-7590, with Mint 19.1 Tessa

Post by sleeper12 » Fri Aug 02, 2019 12:05 pm

Turn off secure boot in Bios if it's on.

If that doesn't help, see if there is a wifi switch on front or side or maybe a different Fn/F key to turn it on?

Still nothing, maybe something here:
https://easylinuxtipsproject.blogspot.c ... blems.html

fiftyfour
Level 1
Level 1
Posts: 6
Joined: Thu Aug 01, 2019 2:42 pm

Re: Wireless not working on Dell XPS 15-7590, with Mint 19.1 Tessa

Post by fiftyfour » Fri Aug 02, 2019 12:42 pm

SecureBoot is off,

Code: Select all

localhost@localhost-XPS-15-7590:~$ mokutil --sb-state
SecureBoot disabled
There is one button on the side, but as far as I can tell from use and research it only serves to light up any number of 5 consecutive lights as a power level indicator

sleeper12
Level 5
Level 5
Posts: 900
Joined: Thu May 25, 2017 3:22 pm

Re: Wireless not working on Dell XPS 15-7590, with Mint 19.1 Tessa

Post by sleeper12 » Fri Aug 02, 2019 2:43 pm

Unless someone has more, you might just pick up a usb wifi adapter for that machine.

carum carvi
Level 5
Level 5
Posts: 961
Joined: Sun Apr 16, 2017 11:44 pm

Re: Wireless not working on Dell XPS 15-7590, with Mint 19.1 Tessa

Post by carum carvi » Fri Aug 02, 2019 2:54 pm

sleeper12 wrote:
Fri Aug 02, 2019 2:43 pm
Unless someone has more, you might just pick up a usb wifi adapter for that machine.
Great tip.

Panda. Panda Panda. :D

Simply buy a Panda Wireless Usb Adapter. Costs no more than 30 dollars, at most. And many forummembers have got their Wifi problems solved instantly. Just search this forum post''s for the name " Panda" and " wifi" and you will find an easy solution to your hardware wifi problems, for which Linux is unfortunately known for...

User avatar
thx-1138
Level 7
Level 7
Posts: 1843
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: Wireless not working on Dell XPS 15-7590, with Mint 19.1 Tessa

Post by thx-1138 » Fri Aug 02, 2019 3:54 pm

...your laptop is super-extra cutting edge / brand new.
https://wiki.archlinux.org/index.php/De ... _Bluetooth
Even the early revisions of 5.2.x has issues with it.

JeremyB
Level 20
Level 20
Posts: 10877
Joined: Fri Feb 21, 2014 8:17 am

Re: Wireless not working on Dell XPS 15-7590, with Mint 19.1 Tessa

Post by JeremyB » Fri Aug 02, 2019 4:43 pm

Post results for

Code: Select all

lspci -nnk | grep -iA3 net
I suspect you have a very new Intel wifi device

fiftyfour
Level 1
Level 1
Posts: 6
Joined: Thu Aug 01, 2019 2:42 pm

Re: Wireless not working on Dell XPS 15-7590, with Mint 19.1 Tessa

Post by fiftyfour » Mon Aug 05, 2019 10:41 am

Thanks everyone for the advice, am looking into the links to sites for newer devices, as well as possibly buying a panda wireless adapter

Output of lspci -nnk | grep -iA3 net is:

Code: Select all

localhost@localhost-XPS-15-7590:~$ lspci -nnk | grep -iA3 net
3b:00.0 Network controller [0280]: Intel Corporation Device [8086:2723] (rev 1a)
	Subsystem: Bigfoot Networks, Inc. Device [1a56:1654]
	Kernel modules: wl
3c:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS525A PCI Express Card Reader [10ec:525a] (rev 01)
	Subsystem: Dell RTS525A PCI Express Card Reader [1028:0905]


jglen490
Level 5
Level 5
Posts: 625
Joined: Sat Jul 15, 2017 9:57 pm

Re: Wireless not working on Dell XPS 15-7590, with Mint 19.1 Tessa

Post by jglen490 » Mon Aug 05, 2019 9:16 pm

It appears from your inxi output that there is a driver associated with the wifi chip.

What does

Code: Select all

iwconfig
show?
I feel more like I do than I did when I got here.
Toshiba A135-S2386, Intel T2080, ATI Radeon® Xpress 200M Chipset, 2GB RAM, 500GB

JorgenMint
Level 1
Level 1
Posts: 2
Joined: Sat May 24, 2014 1:58 am

Re: Wireless not working on Dell XPS 15-7590, with Mint 19.1 Tessa

Post by JorgenMint » Wed Aug 21, 2019 2:57 am

I used the instructions from the official site (and drivers from the backport):
https://support.killernetworking.com/kn ... ntu-16-04/

worked great on my XPS 7590

Code: Select all

sudo apt-get install git
sudo apt-get install build-essential
git clone https://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/backport-iwlwifi.git
cd backport-iwlwifi
make defconfig-iwlwifi-public
make -j4
sudo make install
Btw. to run the first commands you have to use a USB-LAN adapter or USB-WiFi adapter...

Post Reply

Return to “Wireless”