[solved] WiFi Adapter Driver - Old Problems Arise Once More

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
User avatar
Level 1
Level 1
Posts: 9
Joined: Sun Feb 03, 2019 6:39 pm

[solved] WiFi Adapter Driver - Old Problems Arise Once More

Post by Zoltan955342 » Sun Aug 04, 2019 6:32 pm

Turns out my problem was a simple spelling error. I was typing "rt18821ce" when I needed to be typing "rtl8821ce". Sorry for the wasted post and stupid mistake. Don't forget to check your spelling, guys. I'm feeling pretty dumb right now. :?

So I ended up trying out a few different distros on my laptop and then eventually ended up taking a long break from playing with Linux. I'm now back to Linux Mint, this time probably for good because it was my favorite, but I'm having a problem with my wifi again. The issue is a missing driver for my laptop's internal wifi adapter. I went back to this thread where I previously found the solution to my problem. The problem now is that when I run the git clone command posted by JeremyB, the repository to which it refers is returned as not found.

I need a new solution to my wifi driver issue. Can someone please give me a hand?

Edit: Here is my system info after running

Code: Select all

inxi -Fxz

Code: Select all

  Host: zoltan-HP-Laptop-15-db0xxx Kernel: 4.15.0-54-generic x86_64 bits: 64 
  compiler: gcc v: 7.4.0 Desktop: Cinnamon 4.2.3 Distro: Linux Mint 19.2 Tina 
  base: Ubuntu 18.04 bionic 
  Type: Laptop System: HP product: HP Laptop 15-db0xxx v: Type1ProductConfigId 
  serial: <filter> 
  Mobo: HP model: 84AE v: 86.20 serial: <filter> UEFI: Insyde v: F.10 
  date: 05/31/2018 
  ID-1: BAT1 charge: 11.4 Wh condition: 40.2/42.1 Wh (95%) 
  model: Hewlett-Packard PABAS0241231 status: Discharging 
  Topology: Dual Core model: AMD Ryzen 3 2200U with Radeon Vega Mobile Gfx 
  bits: 64 type: MT MCP arch: Zen L2 cache: 1024 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 19963 
  Speed: 1368 MHz min/max: 1600/2500 MHz Core speeds (MHz): 1: 1368 2: 1369 
  3: 1387 4: 1412 
  Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] 
  vendor: Hewlett-Packard driver: amdgpu v: kernel bus ID: 04:00.0 
  Display: x11 server: X.Org 1.19.6 driver: amdgpu,ati 
  unloaded: fbdev,modesetting,radeon,vesa resolution: 1366x768~60Hz 
  OpenGL: renderer: AMD RAVEN (DRM 3.23.0 4.15.0-54-generic LLVM 8.0.0) 
  v: 4.5 Mesa 19.0.2 direct render: Yes 
  Device-1: AMD vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
  bus ID: 04:00.1 
  Device-2: AMD vendor: Hewlett-Packard driver: N/A bus ID: 04:00.5 
  Device-3: AMD vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
  bus ID: 04:00.6 
  Sound Server: ALSA v: k4.15.0-54-generic 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: 2.3LK-NAPI port: 3000 
  bus ID: 02:00.0 
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter 
  vendor: Hewlett-Packard driver: N/A port: 2000 bus ID: 03:00.0 
  Local Storage: total: 931.51 GiB used: 7.88 GiB (0.8%) 
  ID-1: /dev/sda vendor: HGST (Hitachi) model: HTS541010B7E610 size: 931.51 GiB 
  ID-1: / size: 915.40 GiB used: 7.87 GiB (0.9%) fs: ext4 dev: /dev/sda2 
  System Temperatures: cpu: 43.9 C mobo: 20.0 C gpu: amdgpu temp: 0 C 
  Fan Speeds (RPM): N/A 
  Processes: 194 Uptime: 2h 12m Memory: 3.58 GiB used: 857.4 MiB (23.4%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.20 
  inxi: 3.0.32 

User avatar
Level 20
Level 20
Posts: 11234
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: [solved] WiFi Adapter Driver - Old Problems Arise Once More

Post by karlchen » Thu Aug 08, 2019 11:05 am

Great that you found out yourself. Also great that you linked to the relevant thread. Other users, affected by a similar problem, will appreciate. :)
Linux Mint 19.2 32-bit xfce Desktop, Total Commander 9.22a 32-bit
Linux Mint 18.1 64-bit Cinnamon Desktop, Total Commander 9.22a 64-bit
Windows? - 1 window in every room

Post Reply

Return to “Wireless”