EP-AC1605(Mediatek 7612)+ Linux mint 19.10 64bit driver installation...

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
kostaspd
Level 1
Level 1
Posts: 5
Joined: Sun Jul 21, 2019 4:52 pm

EP-AC1605(Mediatek 7612)+ Linux mint 19.10 64bit driver installation...

Post by kostaspd » Fri Aug 09, 2019 12:08 pm

Hello...

I just have done a fresh install of Linux mint 19.10 64bit on an Asus p5k pc and i updated the whole system...

I bought a usb wifi adapter EP-AC1605(Mediatek 7612) wlac-1200 Dual Antenna and i need to guide me so as to install
the appropriate driver, because it doesn't work out of the box (plug & play)...

I appreciate any help...

Thanks a lot!!!

HAWR
Level 4
Level 4
Posts: 298
Joined: Thu Jun 06, 2019 1:15 pm

Re: EP-AC1605(Mediatek 7612)+ Linux mint 19.10 64bit driver installation...

Post by HAWR » Sat Aug 10, 2019 5:40 am

Hello kostaspd,

for your USB-wifi-adapter there are rarely informations to get it working with Linux, so it is not the best choice. First we need the exact information about the chipset, which you get by the following terminal command (of course the adapter must be plugged in):

Code: Select all

lsusb
Post the output here. Information about the hardware you are using is also important:

Code: Select all

inxi _Fxz
I've found these two websites which could be suitable, but that depends on the upper information from you:

https://roddines.blogspot.com/2016/11/i ... buntu.html

https://askubuntu.com/questions/1119004 ... em/1119028

kostaspd
Level 1
Level 1
Posts: 5
Joined: Sun Jul 21, 2019 4:52 pm

Re: EP-AC1605(Mediatek 7612)+ Linux mint 19.10 64bit driver installation...

Post by kostaspd » Sat Aug 10, 2019 5:52 am

Code: Select all

~$ lsusb
Bus 002 Device 003: ID 0bda:0111 Realtek Semiconductor Corp. RTS5111 Card Reader Controller
Bus 002 Device 007: ID 2717:ff88  
Bus 002 Device 004: ID 0781:5591 SanDisk Corp. 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 0e8d:7612 MediaTek Inc. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 002: ID 1bcf:0005 Sunplus Innovation Technology Inc. Optical Mouse
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 04d9:1702 Holtek Semiconductor, Inc. Keyboard LKS02
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Code: Select all

~$ inxi -Fxz
System:
  Host: kostaspd-P5K Kernel: 4.15.0-20-generic x86_64 bits: 64 compiler: gcc 
  v: 7.3.0 Desktop: Cinnamon 4.0.10 Distro: Linux Mint 19.1 Tessa 
  base: Ubuntu 18.04 bionic 
Machine:
  Type: Desktop Mobo: ASUSTeK model: P5K v: Rev 1.xx serial: <filter> 
  BIOS: American Megatrends v: 0603 date: 07/03/2007 
CPU:
  Topology: Quad Core model: Intel Core2 Quad Q6600 bits: 64 type: MCP 
  arch: Core Merom rev: B L2 cache: 4096 KiB 
  flags: lm nx pae sse sse2 sse3 ssse3 vmx bogomips: 19244 
  Speed: 1604 MHz min/max: 1596/2394 MHz Core speeds (MHz): 1: 1604 2: 1604 
  3: 1604 4: 1604 
Graphics:
  Device-1: NVIDIA G84 [GeForce 8600 GT] vendor: ASUSTeK driver: nouveau 
  v: kernel bus ID: 01:00.0 
  Display: x11 server: X.Org 1.19.6 driver: nouveau 
  unloaded: fbdev,modesetting,vesa resolution: 1680x1050~60Hz 
  OpenGL: renderer: NV84 v: 3.3 Mesa 19.0.2 direct render: Yes 
Audio:
  Device-1: Intel 82801I HD Audio vendor: ASUSTeK P5K PRO : 82801IR 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Sound Server: ALSA v: k4.15.0-20-generic 
Network:
  Device-1: Qualcomm Atheros Attansic L1 Gigabit Ethernet 
  vendor: ASUSTeK P5KPL-VM driver: atl1 v: 2.1.3 port: cc00 bus ID: 02:00.0 
  IF: enp2s0 state: down mac: <filter> 
  IF-ID-1: enp0s29f7u4 state: unknown speed: N/A duplex: N/A mac: <filter> 
Drives:
  Local Storage: total: 960.16 GiB used: 27.68 GiB (2.9%) 
  ID-1: /dev/sda vendor: Seagate model: ST3500630AS size: 465.76 GiB 
  ID-2: /dev/sdb vendor: Seagate model: ST3500630AS size: 465.76 GiB 
  ID-3: /dev/sde type: USB vendor: SanDisk model: Ultra USB 3.0 
  size: 28.64 GiB 
Partition:
  ID-1: / size: 186.92 GiB used: 7.23 GiB (3.9%) fs: ext4 dev: /dev/sda1 
  ID-2: /home size: 259.44 GiB used: 473.9 MiB (0.2%) fs: ext4 
  dev: /dev/sda3 
  ID-3: swap-1 size: 10.24 GiB used: 534.6 MiB (5.1%) fs: swap 
  dev: /dev/sda2 
Sensors:
  System Temperatures: cpu: 51.0 C mobo: N/A gpu: nouveau temp: 82 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 224 Uptime: 8h 29m Memory: 1.95 GiB used: 1.26 GiB (64.6%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.20 
  inxi: 3.0.27 

Thanks for the help...

HAWR
Level 4
Level 4
Posts: 298
Joined: Thu Jun 06, 2019 1:15 pm

Re: EP-AC1605(Mediatek 7612)+ Linux mint 19.10 64bit driver installation...

Post by HAWR » Sat Aug 10, 2019 6:28 am

Hello kostaspd,

thank you for the information. You have an older desktop PC with only BIOS, so things like secure boot are not important to note. Both Mediatek and EDUP offer a linux driver for your Device and if I'm right, the second link I've posted above can help you in an easier way, though the user there had no access with it, but his device had another ID.

https://askubuntu.com/questions/1119004 ... em/1119028

The answer shows you the install instruction and needed commands. You need an internet connection, but I think you use the ethernet connection. If I'm not completely wrong, the author of the answer there is also JeremyB, who supports here in the forum. So I think he'll see that post, too.

Good luck!

kostaspd
Level 1
Level 1
Posts: 5
Joined: Sun Jul 21, 2019 4:52 pm

Re: EP-AC1605(Mediatek 7612)+ Linux mint 19.10 64bit driver installation...

Post by kostaspd » Sat Aug 10, 2019 6:33 am

Thanks for your reply...

I use tethering for internet connection temporarily...

I'll be waiting for JeremyB to help me too...


I followed the instructions here https://askubuntu.com/questions/1119004 ... em/1119028 but nothing happened after reboot!
No mistakes happened during installation...

What should i do now..?

Thanks...

Post Reply

Return to “Wireless”