Wifi not working.

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
User avatar
Spearmint2
Level 16
Level 16
Posts: 6880
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: Wifi not working.

Post by Spearmint2 » Fri Aug 16, 2019 2:41 pm

Pjotr wrote:
Fri Aug 16, 2019 1:43 pm
Still soft blocked.... strange.

Try this: disable Bluetooth and reboot.
I remember recently reading about bluetooth interfering with wifi on Mint, if I can find and post it. Hmm, maybe linuxtips site?

update: Aha, found it.

https://easylinuxtipsproject.blogspot.c ... .html#ID14
Wireless internet is sometimes being blocked by Bluetooth
14. On some laptops, wireless internet (wifi or 3G) is being blocked by Bluetooth. In that case, the solution is simple: temporarily disable Bluetooth, by clicking on the bluetooth icon in the upper panel. Then reboot your laptop. Bluetooth should remain disabled and you should be able to make wifi or 3G connection.

If Bluetooth should be enabled again after reboot, disable it more thoroughly by disabling it in the BIOS of your laptop.
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

User avatar
Spearmint2
Level 16
Level 16
Posts: 6880
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: Wifi not working.

Post by Spearmint2 » Fri Aug 16, 2019 2:47 pm

Bee999 wrote:
Fri Aug 16, 2019 2:37 pm
installed new kernel, still nothing :(
Did you reboot after install? Do you need bluetooth?

Does 19.2 use blueberry or bluez? Check this way.

Code: Select all

aptitude show blueberry
or perhaps

Code: Select all

 lsmod |grep blue
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

User avatar
Spearmint2
Level 16
Level 16
Posts: 6880
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: Wifi not working.

Post by Spearmint2 » Fri Aug 16, 2019 3:55 pm

Bee999 wrote:
Fri Aug 16, 2019 1:21 pm
i thought it worked but it didn't. what happens is: wireless network turns on and shows a list of networks available(sometimes) and it suddenly stops after about one minute. wireless is on, but there are no networks available.
this problem exists even when i unplug my ethernet cable and reboot.
Maybe your internal wifi has a hardware problem. Do you have a linux capable USB device (like a Panda) which you can try out on the system?
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

User avatar
kc1di
Level 14
Level 14
Posts: 5478
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Wifi not working.

Post by kc1di » Fri Aug 16, 2019 7:12 pm

If you have secure boot engaged shut it off see if that will work.
Easy tips : https://easylinuxtipsproject.blogspot.com/ Pjotr's Great Linux projects page.
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

sleeper12
Level 6
Level 6
Posts: 1284
Joined: Thu May 25, 2017 3:22 pm

Re: Wifi not working.

Post by sleeper12 » Fri Aug 16, 2019 9:48 pm

If all else fails, try:

Code: Select all

 sudo ifconfig wlo1 up 

Bee999
Level 1
Level 1
Posts: 13
Joined: Thu Aug 15, 2019 1:11 pm

Re: Wifi not working.

Post by Bee999 » Sat Aug 17, 2019 12:01 am

Spearmint2 wrote:
Fri Aug 16, 2019 2:41 pm
Pjotr wrote:
Fri Aug 16, 2019 1:43 pm
Still soft blocked.... strange.

Try this: disable Bluetooth and reboot.
I remember recently reading about bluetooth interfering with wifi on Mint, if I can find and post it. Hmm, maybe linuxtips site?

update: Aha, found it.

https://easylinuxtipsproject.blogspot.c ... .html#ID14
Wireless internet is sometimes being blocked by Bluetooth
14. On some laptops, wireless internet (wifi or 3G) is being blocked by Bluetooth. In that case, the solution is simple: temporarily disable Bluetooth, by clicking on the bluetooth icon in the upper panel. Then reboot your laptop. Bluetooth should remain disabled and you should be able to make wifi or 3G connection.

If Bluetooth should be enabled again after reboot, disable it more thoroughly by disabling it in the BIOS of your laptop.
it seemed like bluetooth was causing the problem, but on the second time wireless could not scan any networks even when Bluetooth was turned off.
i dont know how to turn it off in BIOS. There are no bluetooth options.

Bee999
Level 1
Level 1
Posts: 13
Joined: Thu Aug 15, 2019 1:11 pm

Re: Wifi not working.

Post by Bee999 » Sat Aug 17, 2019 12:08 am

Spearmint2 wrote:
Fri Aug 16, 2019 3:55 pm
Bee999 wrote:
Fri Aug 16, 2019 1:21 pm
i thought it worked but it didn't. what happens is: wireless network turns on and shows a list of networks available(sometimes) and it suddenly stops after about one minute. wireless is on, but there are no networks available.
this problem exists even when i unplug my ethernet cable and reboot.
Maybe your internal wifi has a hardware problem. Do you have a linux capable USB device (like a Panda) which you can try out on the system?
No, i dont have one.
it was working file before.
cant i check my hardware some other way?

Bee999
Level 1
Level 1
Posts: 13
Joined: Thu Aug 15, 2019 1:11 pm

Re: Wifi not working.

Post by Bee999 » Sat Aug 17, 2019 12:13 am

Spearmint2 wrote:
Fri Aug 16, 2019 2:47 pm
Bee999 wrote:
Fri Aug 16, 2019 2:37 pm
installed new kernel, still nothing :(
Did you reboot after install? Do you need bluetooth?

Does 19.2 use blueberry or bluez? Check this way.

Code: Select all

aptitude show blueberry
or perhaps

Code: Select all

 lsmod |grep blue
aptitude show blueberry:

Code: Select all

Package: blueberry                       
Version: 1.2.9
State: installed
Automatically installed: no
Priority: optional
Section: admin
Maintainer: Clement Lefebvre <root@linuxmint.com>
Architecture: all
Uncompressed Size: 2,118 k
Depends: python (>= 2.4), python (< 3), gnome-bluetooth,
         gir1.2-gnomebluetooth-1.0, rfkill, wmctrl, python-setproctitle,
         bluez-obexd, bluez-tools, python-dbus, gir1.2-notify-0.7, python-gi
Breaks: cinnamon-bluetooth
Replaces: cinnamon-bluetooth
Description: A configuration tool for Bluetooth
 Configure Bluetooth devices.
lsmod |grep blue:

Code: Select all

bluetooth             557056  44 btrtl,btintel,btbcm,bnep,ath3k,btusb,rfcomm
ecdh_generic           28672  1 bluetooth
 
No, i dont need bluetooth if removing this will fix the issue.

User avatar
Spearmint2
Level 16
Level 16
Posts: 6880
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: Wifi not working.

Post by Spearmint2 » Sat Aug 17, 2019 2:15 am

Can you enter Control Panel, find the Bluetooth icon there and turn the bluetooth off? Since it's a laptop, does it have a manual off switch on it? I think that's how I got rid of bluetooth on my system. I ran a search and it's not there in kernel at all. I may have used Package Manager, did a search on "blue" and then uninstalled it that way.

Code: Select all

 ~ $ lsmod |grep bl
ip6table_filter        16384  1
ip6_tables             20480  53 ip6table_filter
iptable_filter         16384  1
ip_tables              20480  11 iptable_filter
x_tables               24576  13 ip6table_filter,xt_hl,ip_tables,xt_tcpudp,xt_limit,xt_conntrack,xt_LOG,iptable_filter,ip6t_rt,ipt_REJECT,ip6_tables,xt_addrtype,ip6t_REJECT
sysimgblt              16384  1 drm_kms_helper
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

Post Reply

Return to “Wireless”