[SOLVED] WiFi not working, hard blocked (RTL8821CE)

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
Prosperous Fart
Level 1
Level 1
Posts: 4
Joined: Sat Aug 17, 2019 4:13 pm

[SOLVED] WiFi not working, hard blocked (RTL8821CE)

Post by Prosperous Fart » Sat Aug 17, 2019 5:50 pm

Hello, I just decided to switch to linux from windows. So far I am loving the features and speed of the OS, but I cannot get my WiFi to work (smartphone usb tethering works).
I have read several threads and tried multiple solutions and so far I have gotten the WiFi switch and screen to show up (it was non-existent before) but I can't seem to get any connections to show up. I think it may be because the card is hard blocked and I whatever method I try won't unblock it.

Any suggestion on what I could do to make this work?

Code: Select all

~$ rfkill list
0: ideapad_wlan: Wireless LAN
	Soft blocked: no
	Hard blocked: yes
1: ideapad_bluetooth: Bluetooth
	Soft blocked: no
	Hard blocked: yes
2: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
3: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no

Code: Select all

~$ inxi -Fxz
System:
  Host: david-Lenovo-ideapad-S130-14IGM Kernel: 5.0.0-25-generic x86_64 
  bits: 64 compiler: gcc v: 7.4.0 Desktop: Cinnamon 4.0.10 
  Distro: Linux Mint 19.1 Tessa base: Ubuntu 18.04 bionic 
Machine:
  Type: Laptop System: LENOVO product: 81J2 v: Lenovo ideapad S130-14IGM 
  serial: <filter> 
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40700WIN serial: <filter> 
  UEFI [Legacy]: LENOVO v: 9HCN25WW X64 date: 05/29/2019 
Battery:
  ID-1: BAT1 charge: 29.5 Wh condition: 29.5/32.2 Wh (92%) 
  model: LENOVO BASE-BAT status: Discharging 
CPU:
  Topology: Quad Core model: Intel Pentium Silver N5000 bits: 64 type: MCP 
  arch: Goldmont Plus rev: 1 L2 cache: 4096 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 8755 
  Speed: 796 MHz min/max: 800/2700 MHz Core speeds (MHz): 1: 796 2: 796 
  3: 796 4: 796 
Graphics:
  Device-1: Intel vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 
  Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa DRI Intel UHD Graphics 605 (Geminilake) 
  v: 4.5 Mesa 18.0.5 direct render: Yes 
Audio:
  Device-1: Intel vendor: Lenovo driver: snd_hda_intel v: kernel 
  bus ID: 00:0e.0 
  Sound Server: ALSA v: k5.0.0-25-generic 
Network:
  Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter 
  vendor: Lenovo driver: rtl8821ce v: N/A port: 1000 bus ID: 03:00.0 
  IF: wlp3s0 state: down mac: <filter> 
  IF-ID-1: enp0s21f0u5 state: unknown speed: N/A duplex: N/A mac: <filter> 
Drives:
  Local Storage: total: 119.24 GiB used: 11.74 GiB (9.8%) 
  ID-1: /dev/nvme0n1 model: HFM128GDHTNG-8310A size: 119.24 GiB 
Partition:
  ID-1: / size: 116.87 GiB used: 11.74 GiB (10.0%) fs: ext4 
  dev: /dev/nvme0n1p1 
Sensors:
  System Temperatures: cpu: 52.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 201 Uptime: 14m Memory: 3.60 GiB used: 1.14 GiB (31.7%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.20 
  inxi: 3.0.27 

Code: Select all

iwconfig
wlp3s0    unassociated  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency=2.412 GHz  Access Point: Not-Associated   
          Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=0/100  Signal level=0 dBm  Noise level=0 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

lo        no wireless extensions.

enp0s21f0u5  no wireless extensions.

Code: Select all

:~$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 04f2:b5fa Chicony Electronics Co., Ltd 
Bus 001 Device 003: ID 0bda:c024 Realtek Semiconductor Corp. 
Bus 001 Device 002: ID 18d1:4ee3 Google Inc. Nexus 4 (tether)
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Code: Select all

lspci
00:00.0 Host bridge: Intel Corporation Device 31f0 (rev 03)
00:00.1 Signal processing controller: Intel Corporation Device 318c (rev 03)
00:00.3 System peripheral: Intel Corporation Device 3190 (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Device 3184 (rev 03)
00:0e.0 Audio device: Intel Corporation Device 3198 (rev 03)
00:0f.0 Communication controller: Intel Corporation Device 319a (rev 03)
00:12.0 SATA controller: Intel Corporation Device 31e3 (rev 03)
00:13.0 PCI bridge: Intel Corporation Device 31d8 (rev f3)
00:14.0 PCI bridge: Intel Corporation Device 31d6 (rev f3)
00:14.1 PCI bridge: Intel Corporation Device 31d7 (rev f3)
00:15.0 USB controller: Intel Corporation Device 31a8 (rev 03)
00:17.0 Signal processing controller: Intel Corporation Device 31b4 (rev 03)
00:1c.0 SD Host controller: Intel Corporation Device 31cc (rev 03)
00:1f.0 ISA bridge: Intel Corporation Device 31e8 (rev 03)
00:1f.1 SMBus: Intel Corporation Device 31d4 (rev 03)
01:00.0 Non-Volatile memory controller: SK hynix Device 1327
02:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5229 PCI Express Card Reader (rev 01)
03:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter
What I've tried so far:
sudo apt-get install git dkms build-essential

git clone https://github.com/tomaspinho/rtl8821ce.git

cd rtl8821ce

sudo ./dkms-install.sh
The above commands got the WiFi switch and screen to show up.
Updated from kernel 4.15.0-20-generic to 5.0.0-25-generic and rebooted
Attachments
Screenshot from 2019-08-17 23-20-02.png
Screenshot from 2019-08-17 23-18-52.png
Last edited by Prosperous Fart on Sat Aug 17, 2019 7:18 pm, edited 1 time in total.

JeremyB
Level 20
Level 20
Posts: 10877
Joined: Fri Feb 21, 2014 8:17 am

Re: WiFi not working, hard blocked (RTL8821CE)

Post by JeremyB » Sat Aug 17, 2019 6:09 pm

Quick fix is

Code: Select all

echo "blacklist ideapad_laptop" | sudo tee /etc/modprobe.d/ideapad-laptop.conf
Reboot

Prosperous Fart
Level 1
Level 1
Posts: 4
Joined: Sat Aug 17, 2019 4:13 pm

Re: WiFi not working, hard blocked (RTL8821CE)

Post by Prosperous Fart » Sat Aug 17, 2019 6:52 pm

Ran the commands but got no results.
"rfkill list" still shows that wlan is hard blocked.

Any other suggestions?

JeremyB
Level 20
Level 20
Posts: 10877
Joined: Fri Feb 21, 2014 8:17 am

Re: WiFi not working, hard blocked (RTL8821CE)

Post by JeremyB » Sat Aug 17, 2019 6:59 pm

Post results from terminal for

Code: Select all

 lsmod | grep ideapad; rfkill list

Prosperous Fart
Level 1
Level 1
Posts: 4
Joined: Sat Aug 17, 2019 4:13 pm

Re: WiFi not working, hard blocked (RTL8821CE)

Post by Prosperous Fart » Sat Aug 17, 2019 7:04 pm

Code: Select all

~$  lsmod | grep ideapad; rfkill list
ideapad_laptop         36864  0
sparse_keymap          16384  1 ideapad_laptop
wmi                    28672  1 ideapad_laptop
video                  49152  2 ideapad_laptop,i915
0: ideapad_wlan: Wireless LAN
	Soft blocked: no
	Hard blocked: yes
1: ideapad_bluetooth: Bluetooth
	Soft blocked: no
	Hard blocked: yes
2: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
3: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no

JeremyB
Level 20
Level 20
Posts: 10877
Joined: Fri Feb 21, 2014 8:17 am

Re: WiFi not working, hard blocked (RTL8821CE)

Post by JeremyB » Sat Aug 17, 2019 7:06 pm

What about

Code: Select all

cat /etc/modprobe.d/ideapad-laptop.conf

Prosperous Fart
Level 1
Level 1
Posts: 4
Joined: Sat Aug 17, 2019 4:13 pm

Re: WiFi not working, hard blocked (RTL8821CE)

Post by Prosperous Fart » Sat Aug 17, 2019 7:12 pm

It works! :D

Thank you for solving this, now I can fully enjoy my linux experience :)

Post Reply

Return to “Wireless”