[solved] Realtek RTL8821CE wifi not working on Lenovo ideapad 130-15IKB

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
veronica
Level 1
Level 1
Posts: 11
Joined: Wed Aug 21, 2019 11:22 am

[solved] Realtek RTL8821CE wifi not working on Lenovo ideapad 130-15IKB

Post by veronica » Wed Aug 21, 2019 12:11 pm

Code: Select all

System:
  Host: veronica Kernel: 5.0.0-25-generic x86_64 bits: 64 compiler: gcc 
  v: 7.4.0 Desktop: Cinnamon 4.2.3 Distro: Linux Mint 19.2 Tina 
  base: Ubuntu 18.04 bionic 
Machine:
  Type: Laptop System: LENOVO product: 81H7 v: Lenovo ideapad 130-15IKB 
  serial: <filter> 
  Mobo: LENOVO model: LNVNB161216 v: No DPK serial: <filter> UEFI: LENOVO 
  v: 8QCN19WW(V1.07) date: 05/15/2019 
Battery:
  ID-1: BAT1 charge: 30.8 Wh condition: 31.4/30.6 Wh (103%) 
  model: 0x43 0x50 0x54 0x2D 0x43 0x4F 0x PABAS0241231 status: Unknown 
CPU:
  Topology: Dual Core model: Intel Core i3-6006U bits: 64 type: MT MCP 
  arch: Skylake rev: 3 L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 15936 
  Speed: 2000 MHz min/max: 400/2000 MHz Core speeds (MHz): 1: 2000 2: 2000 
  3: 2000 4: 2000 
Graphics:
  Device-1: Intel HD Graphics 520 vendor: Lenovo driver: i915 v: kernel 
  bus ID: 00:02.0 
  Device-2: NVIDIA GM108M [GeForce MX110] vendor: Lenovo driver: nvidia 
  v: 430.26 bus ID: 01:00.0 
  Display: x11 server: X.Org 1.19.6 driver: modesetting,nvidia 
  unloaded: fbdev,nouveau,vesa resolution: 1360x768~60Hz 
  OpenGL: renderer: GeForce MX110/PCIe/SSE2 v: 4.6.0 NVIDIA 430.26 
  direct render: Yes 
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
  Sound Server: ALSA v: k5.0.0-25-generic 
Network:
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Lenovo 
  driver: r8169 v: kernel port: 4000 bus ID: 02:00.0 
  IF: enp2s0 state: down mac: <filter> 
  Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter 
  vendor: Lenovo driver: N/A port: 3000 bus ID: 03:00.0 
  IF-ID-1: bnep0 state: unknown speed: N/A duplex: N/A mac: <filter> 
Drives:
  Local Storage: total: 931.51 GiB used: 11.37 GiB (1.2%) 
  ID-1: /dev/sda vendor: Western Digital model: WD10SPZX-24Z10 
  size: 931.51 GiB 
Partition:
  ID-1: / size: 145.75 GiB used: 11.34 GiB (7.8%) fs: ext4 dev: /dev/sda7 
Sensors:
  System Temperatures: cpu: 52.0 C mobo: N/A gpu: nvidia temp: 54 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 195 Uptime: 27m Memory: 3.72 GiB used: 1.16 GiB (31.3%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.20 
  inxi: 3.0.32
Last edited by veronica on Fri Aug 23, 2019 2:18 am, edited 1 time in total.

HAWR
Level 4
Level 4
Posts: 288
Joined: Thu Jun 06, 2019 1:15 pm

Re: Realtek RTL8821CE wifi not working on Lenovo ideapad 130-15IKB

Post by HAWR » Wed Aug 21, 2019 2:46 pm

Hello veronica,

you need to install a driver for your Realtek adapter. On the following website you find a good how-to:

https://easylinuxtipsproject.blogspot.c ... .html#ID10

veronica
Level 1
Level 1
Posts: 11
Joined: Wed Aug 21, 2019 11:22 am

Re: Realtek RTL8821CE wifi not working on Lenovo ideapad 130-15IKB

Post by veronica » Thu Aug 22, 2019 1:57 pm

wow it works thanks a lot for helping me out

User avatar
phd21
Level 19
Level 19
Posts: 9178
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Realtek RTL8821CE wifi not working on Lenovo ideapad 130-15IKB

Post by phd21 » Thu Aug 22, 2019 2:08 pm

Hi veronica,

Welcome to the wonderful world of Linux Mint and its excellent forum!
Phd21: Mint KDE 18.3 & 19, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

deepakdeshp
Level 15
Level 15
Posts: 5658
Joined: Sun Aug 09, 2015 10:00 am

Re: Realtek RTL8821CE wifi not working on Lenovo ideapad 130-15IKB

Post by deepakdeshp » Thu Aug 22, 2019 2:59 pm

Welcome to the forums.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.2 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

Post Reply

Return to “Wireless”