Mint 19 not connecting to Wifi

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
yazanalsoradi76
Level 1
Level 1
Posts: 5
Joined: Thu Aug 22, 2019 7:33 pm

Mint 19 not connecting to Wifi

Post by yazanalsoradi76 » Thu Aug 22, 2019 7:42 pm

I have linux mint 19 dualboot with windows 10
But there's a problem when I try to connect to the wifi, after entering the correct password it keeps connecting but doesn't connect

User avatar
kc1di
Level 14
Level 14
Posts: 5254
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Mint 19 not connecting to Wifi

Post by kc1di » Fri Aug 23, 2019 7:09 am

Please go to a terminal and enter this code and post the output back here. This will give those trying to help you an Idea of what your working with.

Code: Select all

inxi -Fxz
Easy tips : https://easylinuxtipsproject.blogspot.com/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

yazanalsoradi76
Level 1
Level 1
Posts: 5
Joined: Thu Aug 22, 2019 7:33 pm

Re: Mint 19 not connecting to Wifi

Post by yazanalsoradi76 » Fri Aug 23, 2019 10:59 am

yazan@msi:-$ inxi -Fxz System: Host: msi Kernel: 4.15.0-20-generic x86 64 bits: 64 compiler: gcc v: 7.3.0
Desktop: Cinnamon 4.0.10 Distro: Linux Mint 19.1 Tessa
base: Ubuntu Machine: 18.04 bionic
Type: Laptop
serial: <filter Mobo: Micro-Star model: MS-16R3 v: REV:1.0 serial: <filter UEFI: American Megatrends v: E16R3IMS.303 date: 03/08/2019 Battery: ID-1: BATI charge: 21.2 Wh condition: 50.2/51.3 Wh (98%) model: MSI Corp. MS-16R3 status: Discharging System: Micro-Star product: GF63 Thin 8RCS v: REV:1.0 Topology: 6-Core model: Intel Core 17-8750H bits: 64 type: HT MCP arch: Kaby Lake rev: A L2 cache: 9216 KiB flags: tm nx pae sse sse2 sse3 sse4 1 sse4 2 sse3 Speed: 800 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 800 2: 800 3 801 4: 800 5:800 6: 801 7: 801 8: 800 9: 801 10: 802 11: 800 12: 800 Graphics: Device-1: Intel vendor: bus ID: 08:02.0 Device-2: NVIDIA vendor: Micro-Star MSI driver: N/A bus ID: 01:00.0 Display: x11 server: X.0rg 1.19.6 driver: modesetting unloaded: fbdev.vesa resolution: 1920x1086-60H2 OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake Vi 4.5 Mesa 19.0.8 direct render: Yes vmx bogomips: 52992 Micro-Star MSI driver: 1915 v: kernel 3x8 GT2) OTpny Device-1: Intel vendor: Micro-Star MSI driver: snd hda intel v: kernel bus ID: 00:1f.3 Sound Server: ALSA v: k4.15.0-20-generic Network: Device-1: Intel driver: iwlwifi v: kernel port: 6000 bus ID: 00:14.3 IF: wlol state: up mac: <filter Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI driver: r8169 V: 2.3LK-NAPI port: 3000 bus ID: 03:00.0 IF: enp3se state: down mac: <filter Drives: Local Storage: ID-1: /dev/nvmeenl vendor: Kingston model: RBUSNS8154P3128GJ size: 119.24 GiB total: 1.03 TiB used: 11.86 GiB (1.1%) ID-2: /dev/sda vendor: Western Digital model: WD10SPZX-17Z10T size: 931.51 GiB Partition: ID-1: size: 50.17 GiB used: 11.41 GiB (22.7%) fs: ext4 dev: /dev/sda4 ID-2: /boot size: 453.9 MiB used: 78.0 MiB (17.2 %) fs: ext4 dev: /dev/sda3 ID-3: /home size: 51.73 GiB used: 349.5 Mi8 (0.7% ) fs: ext4 dev: /dev/sda5 Sensors: System Temperatures: cpu: 54.0 C mobo: N/A Fan Speeds (RPM): N/A Info: u Processes: 303 Uptime: 2m Memory: 7.64 GiB used: 634.1 MiB (8.1%) Init: systemd runlevel: 5 Compilers: gcc: 7.3.0 Shell: bash v: 4.4.20 inxi: 3.0.27 S-TS ze

Sorry about this mess but I dont have internet on it so I cant copy paste

User avatar
kc1di
Level 14
Level 14
Posts: 5254
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Mint 19 not connecting to Wifi

Post by kc1di » Sat Aug 24, 2019 5:00 am

Does it show any networks in network manager?
It appears to be running an intel wireless card which are well support in the linux kernel.
Last edited by kc1di on Sat Aug 24, 2019 8:16 am, edited 1 time in total.
Easy tips : https://easylinuxtipsproject.blogspot.com/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

deepakdeshp
Level 15
Level 15
Posts: 5631
Joined: Sun Aug 09, 2015 10:00 am

Re: Mint 19 not connecting to Wifi

Post by deepakdeshp » Sat Aug 24, 2019 5:10 am

yazanalsoradi76 wrote:
Fri Aug 23, 2019 10:59 am
yazan@msi:-$ inxi -Fxz System: Host: msi Kernel: 4.15.0-20-generic x86 64 bits: 64 compiler: gcc v: 7.3.0
Desktop: Cinnamon 4.0.10 Distro: Linux Mint 19.1 Tessa
base: Ubuntu Machine: 18.04 bionic
Type: Laptop
serial: <filter Mobo: Micro-Star model: MS-16R3 v: REV:1.0 serial: <filter UEFI: American Megatrends v: E16R3IMS.303 date: 03/08/2019 Battery: ID-1: BATI charge: 21.2 Wh condition: 50.2/51.3 Wh (98%) model: MSI Corp. MS-16R3 status: Discharging System: Micro-Star product: GF63 Thin 8RCS v: REV:1.0 Topology: 6-Core model: Intel Core 17-8750H bits: 64 type: HT MCP arch: Kaby Lake rev: A L2 cache: 9216 KiB flags: tm nx pae sse sse2 sse3 sse4 1 sse4 2 sse3 Speed: 800 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 800 2: 800 3 801 4: 800 5:800 6: 801 7: 801 8: 800 9: 801 10: 802 11: 800 12: 800 Graphics: Device-1: Intel vendor: bus ID: 08:02.0 Device-2: NVIDIA vendor: Micro-Star MSI driver: N/A bus ID: 01:00.0 Display: x11 server: X.0rg 1.19.6 driver: modesetting unloaded: fbdev.vesa resolution: 1920x1086-60H2 OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake Vi 4.5 Mesa 19.0.8 direct render: Yes vmx bogomips: 52992 Micro-Star MSI driver: 1915 v: kernel 3x8 GT2) OTpny Device-1: Intel vendor: Micro-Star MSI driver: snd hda intel v: kernel bus ID: 00:1f.3 Sound Server: ALSA v: k4.15.0-20-generic Network: Device-1: Intel driver: iwlwifi v: kernel port: 6000 bus ID: 00:14.3 IF: wlol state: up mac: <filter Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI driver: r8169 V: 2.3LK-NAPI port: 3000 bus ID: 03:00.0 IF: enp3se state: down mac: <filter Drives: Local Storage: ID-1: /dev/nvmeenl vendor: Kingston model: RBUSNS8154P3128GJ size: 119.24 GiB total: 1.03 TiB used: 11.86 GiB (1.1%) ID-2: /dev/sda vendor: Western Digital model: WD10SPZX-17Z10T size: 931.51 GiB Partition: ID-1: size: 50.17 GiB used: 11.41 GiB (22.7%) fs: ext4 dev: /dev/sda4 ID-2: /boot size: 453.9 MiB used: 78.0 MiB (17.2 %) fs: ext4 dev: /dev/sda3 ID-3: /home size: 51.73 GiB used: 349.5 Mi8 (0.7% ) fs: ext4 dev: /dev/sda5 Sensors: System Temperatures: cpu: 54.0 C mobo: N/A Fan Speeds (RPM): N/A Info: u Processes: 303 Uptime: 2m Memory: 7.64 GiB used: 634.1 MiB (8.1%) Init: systemd runlevel: 5 Compilers: gcc: 7.3.0 Shell: bash v: 4.4.20 inxi: 3.0.27 S-TS ze

Sorry about this mess but I dont have internet on it so I cant copy paste
How did you manage to post results of inxi here?
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.2 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

yazanalsoradi76
Level 1
Level 1
Posts: 5
Joined: Thu Aug 22, 2019 7:33 pm

Re: Mint 19 not connecting to Wifi

Post by yazanalsoradi76 » Sat Aug 24, 2019 9:38 am

I used Google translate camera then copied the text and paste it here

yazanalsoradi76
Level 1
Level 1
Posts: 5
Joined: Thu Aug 22, 2019 7:33 pm

Re: Mint 19 not connecting to Wifi

Post by yazanalsoradi76 » Sat Aug 24, 2019 2:00 pm

After the installation directly I was able to connect towing but after sometime no

Yea there is in the networks in the network manager

User avatar
kc1di
Level 14
Level 14
Posts: 5254
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Mint 19 not connecting to Wifi

Post by kc1di » Sun Aug 25, 2019 4:53 am

Please issue this command in terminal and report out put:

Code: Select all

lspci | grep -i net
Easy tips : https://easylinuxtipsproject.blogspot.com/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

yazanalsoradi76
Level 1
Level 1
Posts: 5
Joined: Thu Aug 22, 2019 7:33 pm

Re: Mint 19 not connecting to Wifi

Post by yazanalsoradi76 » Sun Aug 25, 2019 9:27 am

yazan@msi:-$ 1spci | grep
i 00:14.3 Network controller: Intel Corporation Device a370 (rev 10) 03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 P CI Express Gigabit Ethernet Controller (rev 15)

User avatar
kc1di
Level 14
Level 14
Posts: 5254
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Mint 19 not connecting to Wifi

Post by kc1di » Sun Aug 25, 2019 5:26 pm

Ok there is a reported bug in kernel 4.15 for that card. It may work with kernel 5.0 so I would try that. You can install the 5.0 series kernel by clicking on the update icon in the system tray and selecting View then Kernels. It will give you a warning page select ok and then install the kernel. Once it's installed reboot see if wifi works.
Easy tips : https://easylinuxtipsproject.blogspot.com/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

JeremyB
Level 20
Level 20
Posts: 10861
Joined: Fri Feb 21, 2014 8:17 am

Re: Mint 19 not connecting to Wifi

Post by JeremyB » Sun Aug 25, 2019 5:59 pm

Take a look at https://ubuntuforums.org/showthread.php ... st13614520
I know it is posted on ubuntuforums but the advise is just as good for Mint users

Post Reply

Return to “Wireless”