Page 1 of 1

RTL8723B WIfi driver problem

Posted: Sun Sep 01, 2019 4:35 pm
by fraizor
Hello everyone

i am facing a weird wifi problem

i have low end laptop Chinese "Zed Air 2" RTL8723B

running Linux mint 19 based on Ubuntu 18.04

the wifi was running perfectly on stock windows 10 (photo atttached)

on linux mint direclty after instullation it does see wifi networks sometimes and sometimes it does not see any
when it does see wifi networks i cant connectat all.

i tried couple of posts but with no luck

this is the last thing i tried i did exactly as MR chili555 suggested

after couple of reboots i can successfully connect to my network but after another reboot it wont see wifi networks any more

Code: Select all

user@user-pc:~$ dmesg | grep -i rtl
[    7.343296] Bluetooth: hci0: rtl: examining hci_ver=06 hci_rev=000b lmp_ver=06 lmp_subver=8723
[    7.343300] Bluetooth: hci0: rtl: loading rtl_bt/rtl8723b_config.bin
[    7.349156] bluetooth hci0: Direct firmware load for rtl_bt/rtl8723b_config.bin failed with error -2
[    7.349163] Bluetooth: hci0: rtl: loading rtl_bt/rtl8723b_fw.bin
[    7.546818] usb 1-7: rtl8723bu_parse_efuse: dumping efuse (0x200 bytes):
[    7.546923] usb 1-7: RTL8723BU rev E (SMIC) 1T1R, TX queues 3, WiFi=1, BT=1, GPS=0, HI PA=0
[    7.546925] usb 1-7: RTL8723BU MAC: 54:c9:df:43:cf:8b
[    7.546928] usb 1-7: rtl8xxxu: Loading firmware rtlwifi/rtl8723bu_nic.bin
[    8.338913] usbcore: registered new interface driver rtl8xxxu
[    8.499026] RTL871X: module init start
[    8.499032] RTL871X: rtl8723bu v4.3.6.11_12942.20141204_BTCOEX20140507-4E40
[    8.499033] RTL871X: rtl8723bu BT-Coex version = BTCOEX20140507-4E40
[    8.499116] usbcore: registered new interface driver rtl8723bu
[    8.499117] RTL871X: module init ret=0
[   11.311774] rtl8xxxu 1-7:1.2 wlx54c9df43cf8b: renamed from wlan0

any help is highly appreciated

Re: RTL8723B WIfi driver problem

Posted: Sun Sep 01, 2019 5:18 pm
by JeremyB
Run these commands in terminal and post termbin URL after second command is finished

Code: Select all

wget -N -t 5 -T 10 && chmod +x wireless-info && ./wireless-info

Code: Select all

cat wireless-info.txt | nc 9999

Re: RTL8723B WIfi driver problem

Posted: Mon Sep 02, 2019 1:00 am
by fraizor