Page 1 of 1

[SOLVED] No Wifi Access Dell XPS 15 inch (linux mint 19.2 Cinnamon)

Posted: Tue Sep 03, 2019 6:11 am
by Sandcastle
I have installed linux mint Cinnamon fresh on dell xps 15 inch and cannot access wifi (currently connected via usb ethernet dongle).

I have tried looking in the device manager, but the only thing there is an nvidia driver. I have been browsing the forums but haven't found a solution. :(

I have also tried plugging in a wifi dongle. This also appears in the inxi (not below) but I still cannot connect to wifi with this.

Output from inxi -Fxz

Code: Select all

System:
  Host: FALCONKICK Kernel: 4.15.0-60-generic x86_64 bits: 64 compiler: gcc 
  v: 7.4.0 Desktop: Cinnamon 4.2.3 Distro: Linux Mint 19.2 Tina 
  base: Ubuntu 18.04 bionic 
Machine:
  Type: Laptop System: Dell product: XPS 15 7590 v: N/A serial: <filter> 
  Mobo: Dell model: 0VYV0G v: A00 serial: <filter> UEFI: Dell v: 1.2.3 
  date: 07/23/2019 
Battery:
  ID-1: BAT0 charge: 87.4 Wh condition: 87.4/97.0 Wh (90%) 
  model: SMP DELL GPM0365 status: Full 
CPU:
  Topology: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP 
  arch: Kaby Lake rev: A L2 cache: 12.0 MiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 62208 
  Speed: 801 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 5: 801 6: 801 7: 800 8: 800 9: 801 10: 802 11: 800 12: 801 
Graphics:
  Device-1: Intel vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 
  Device-2: NVIDIA vendor: Dell driver: N/A bus ID: 01:00.0 
  Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa 
  resolution: 3840x2160~60Hz 
  OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2) 
  v: 4.5 Mesa 19.0.8 direct render: Yes 
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel 
  v: kernel bus ID: 00:1f.3 
  Sound Server: ALSA v: k4.15.0-60-generic 
Network:
  Device-1: Intel vendor: Bigfoot Networks driver: N/A port: 3000 
  bus ID: 3b:00.0 
  Device-2: Realtek type: USB driver: r8152 bus ID: 2-2:2 
  IF: enx00e04c68ccfb state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 476.94 GiB used: 17.16 GiB (3.6%) 
  ID-1: /dev/nvme0n1 model: SSDPEMKF512G8 NVMe INTEL 512GB size: 476.94 GiB 
Partition:
  ID-1: / size: 467.96 GiB used: 17.16 GiB (3.7%) fs: ext4 
  dev: /dev/nvme0n1p2 
Sensors:
  System Temperatures: cpu: 44.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 269 Uptime: 27m Memory: 15.31 GiB used: 2.77 GiB (18.1%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.20 
  inxi: 3.0.32 

Re: No Wifi Access Dell XPS 15 inch (linux mint 19.2 Cinnamon)

Posted: Tue Sep 03, 2019 7:03 am
by BG04PF
Hi,

But does the voice "Wireless Connection" appear in the list of Connection (Ethernet, wifi, usb-cable Ethernet, etc.)?

I have more or less the same problem, because initialy for me It starts work, but After a few minutes It stops working and It shows me "Wireless Connection not Avaible", and sometimes this voice doesn't appear at all.

I try to link Here a little solution that I tried but didn't work, maybe for you It could work...

viewtopic.php?t=204172

Let me know if It worked for you :D

Re: [SOLVED] No Wifi Access Dell XPS 15 inch (linux mint 19.2 Cinnamon)

Posted: Tue Sep 03, 2019 7:22 am
by Sandcastle
Hello BG04PF

The wireless connection didnt appear at all for me. However I solved the issue just now with this thread below:

viewtopic.php?t=298884

Going into the BIOS and turning off the secure boot, and then downloading and installing that git stuff seems to have fixed it all!

Re: [SOLVED] No Wifi Access Dell XPS 15 inch (linux mint 19.2 Cinnamon)

Posted: Tue Sep 03, 2019 8:05 am
by BG04PF
Good! Let's see if It works also for me... Thanks!