Wavlink 600M Wifi Adapter doesn't work

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
Svetlana
Level 1
Level 1
Posts: 12
Joined: Tue Aug 13, 2019 10:45 pm

Wavlink 600M Wifi Adapter doesn't work

Post by Svetlana » Mon Sep 23, 2019 9:49 pm

Hi,

I have a Wavlink 600M Wifi Adapter but I try to find a driver to use it. Unfortunately, I didn't find it :-(

when I run the command "sudo lsusb":

Code: Select all

svetlana@svetlana-HP-ZBook-15:~$ sudo lsusb
[sudo] Mot de passe de svetlana :                     
Bus 002 Device 002: ID 8087:8000 Intel Corp. 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8008 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 005: ID 0951:1666 Kingston Technology DataTraveler G4
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 04ca:7025 Lite-On Technology Corp. HP HD Webcam
Bus 003 Device 002: ID 138a:003f Validity Sensors, Inc. VFS495 Fingerprint Reader
Bus 003 Device 004: ID 8087:07da Intel Corp. 
Bus 003 Device 071: ID 0e8d:7610 MediaTek Inc. 
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


It's the line "Bus 003 Device 071: ID 0e8d:7610 MediaTek Inc"

This command dooesn't show much informations but I don't have others ideas to find the solution

If you can help me, thanks :)

User avatar
catweazel
Level 19
Level 19
Posts: 9733
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Wavlink 600M Wifi Adapter doesn't work

Post by catweazel » Tue Sep 24, 2019 2:02 am

Svetlana wrote:
Mon Sep 23, 2019 9:49 pm
If you can help me, thanks :)
Well, I'll try...

That device seems to use the Realtek 8812au chipset, so in a terminal:

Code: Select all

sudo apt update
sudo apt install rtl8812au-dkms
"There is, ultimately, only one truth -- cogito, ergo sum -- everything else is an assumption." - Me, my swansong.

User avatar
Pjotr
Level 21
Level 21
Posts: 13744
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Wavlink 600M Wifi Adapter doesn't work

Post by Pjotr » Tue Sep 24, 2019 6:44 am

This is a chipset that has caused WiFi guru chili555 a headache:
https://ubuntuforums.org/showthread.php ... st13727611

However, it might be that it works out of the box from kernel 5.1 and upward:
https://ubuntuforums.org/showthread.php ... st13862043

So I advise to do this:

1. Install the reliable Canonical Kernel Team PPA:
https://easylinuxtipsproject.blogspot.c ... t.html#ID8
(item 8 )

2. Update Manager - panel: View - Linux kernels
Install the latest kernel of the 5.2 series.
Then reboot.
Tip: 10 things to do after installing Linux Mint 19.2 Tina
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

Svetlana
Level 1
Level 1
Posts: 12
Joined: Tue Aug 13, 2019 10:45 pm

Re: Wavlink 600M Wifi Adapter doesn't work

Post by Svetlana » Thu Oct 17, 2019 9:59 pm

Hi

Sorry for this late response :/

The Pjotr's solution works :) but I don't have 5.2 kernel as option, only 5.0. And the 5.0 kernel is deprecated in february :'(
kernel.png
I have a new issue, with my dual boot windows and others devices, I have a download of 70/80 Mbps whereas on my linux, only 14/15, any idea ?

User avatar
Pjotr
Level 21
Level 21
Posts: 13744
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Wavlink 600M Wifi Adapter doesn't work

Post by Pjotr » Fri Oct 18, 2019 3:54 am

I repeat: enable the Canonical Kernel Team PPA as described in my previous message, and install the latest kernel it has to offer (currently already the 5.3.x).
Tip: 10 things to do after installing Linux Mint 19.2 Tina
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

JeremyB
Level 20
Level 20
Posts: 11023
Joined: Fri Feb 21, 2014 8:17 am

Re: Wavlink 600M Wifi Adapter doesn't work

Post by JeremyB » Fri Oct 18, 2019 5:54 am

Is something wrong with the internal wifi?

Svetlana
Level 1
Level 1
Posts: 12
Joined: Tue Aug 13, 2019 10:45 pm

Re: Wavlink 600M Wifi Adapter doesn't work

Post by Svetlana » Sun Oct 20, 2019 10:59 pm

Hi,

Now, I have the 5.3 kernel but It's worse than before :'(

My kernel:
k.png
Indeed, now my internet speed isn't 14/15 Mbps ( 70/80 on windows ) but only 0.4 ....
v.png
And sometimes, my connection stops

I tried to do catweazel's solution with the 5.3 kernel but it's not enough apparently

Code: Select all

sudo apt install rtl8812au-dkms

User avatar
kelebek333
Level 3
Level 3
Posts: 181
Joined: Sat Jun 25, 2011 11:57 am

Re: Wavlink 600M Wifi Adapter doesn't work

Post by kelebek333 » Mon Oct 21, 2019 12:43 pm

Could You post outputs of following commands.

Code: Select all

inxi -Nnxxz | nc termbin.com 9999

Code: Select all

lsmod | nc termbin.com 9999

Code: Select all

iwconfig | nc termbin.com 9999

Svetlana
Level 1
Level 1
Posts: 12
Joined: Tue Aug 13, 2019 10:45 pm

Re: Wavlink 600M Wifi Adapter doesn't work

Post by Svetlana » Mon Oct 21, 2019 6:36 pm

Here are the returns

Code: Select all

svetlana@svetlana-MS-7B87:~$ inxi -Nnxxz | nc termbin.com 9999
https://termbin.com/o5tt
svetlana@svetlana-MS-7B87:~$ lsmod | nc termbin.com 9999
https://termbin.com/rpw27
svetlana@svetlana-MS-7B87:~$ iwconfig | nc termbin.com 9999
enp37s0   no wireless extensions.

lo        no wireless extensions.

https://termbin.com/lf6k
Last edited by JeremyB on Mon Oct 21, 2019 6:37 pm, edited 1 time in total.
Reason: removed code tags to make URLs clickable

User avatar
kelebek333
Level 3
Level 3
Posts: 181
Joined: Sat Jun 25, 2011 11:57 am

Re: Wavlink 600M Wifi Adapter doesn't work

Post by kelebek333 » Tue Oct 22, 2019 1:47 pm

mt76 53248 5 mt76_usb,mt76x02_lib,mt76x02_usb,mt76x0_common,mt76x0u
Your wifi device using mt76 kernel build driver, now. This driver supported since kernel 4.19.x for your device. Before 4.19.x, you had to install mt7610u_sta driver for supporting this device.

You can try to install mt7610u_sta (alternative) driver (based this source branch) for this device with below commands. This package auto-adds mt76 driver to blacklist for avoid conflict. Reboot your PC after installation. You must disable secureboot from BIOS/EFI settings for activate dkms added driver.

Code: Select all

sudo add-apt-repository ppa:kelebek333/kablosuz
sudo apt update
sudo apt install mt7610u-dkms

If you want to remove this driver, you can try below commands.

Code: Select all

sudo apt purge mt7610u-dkms
sudo add-apt-repository -r ppa:kelebek333/kablosuz
sudo apt update

modinfo mt7610u_sta
filename: /lib/modules/5.3.7-050307-generic/kernel/drivers/net/wireless/mt7610u_sta.ko
version: 3.0.0.2
license: GPL
description: RT2870 Wireless Lan Linux Driver
author: Paul Lin <paul_lin@ralinktech.com>
license: GPL
srcversion: 7A3E4F9318249AE3CE43E95
alias: usb:v0E8Dp7650d*dc*dsc*dp*icFFisc02ipFFin*
alias: usb:v0E8Dp7630d*dc*dsc*dp*icFFisc02ipFFin*
alias: usb:v20F4p806Bd*dc*dsc*dp*ic*isc*ip*in*
alias: usb:v2019pAB31d*dc*dsc*dp*ic*isc*ip*in*
alias: usb:v293Cp5702d*dc*dsc*dp*ic*isc*ip*in*
alias: usb:v057Cp8502d*dc*dsc*dp*ic*isc*ip*in*
alias: usb:v04BBp0951d*dc*dsc*dp*ic*isc*ip*in*
alias: usb:v07B8p7610d*dc*dsc*dp*ic*isc*ip*in*
alias: usb:v0586p3425d*dc*dsc*dp*ic*isc*ip*in*
alias: usb:v2001p3D02d*dc*dsc*dp*ic*isc*ip*in*
alias: usb:v0DF6p0075d*dc*dsc*dp*ic*isc*ip*in*
alias: usb:v0B05p17DBd*dc*dsc*dp*ic*isc*ip*in*
alias: usb:v0B05p17D1d*dc*dsc*dp*ic*isc*ip*in*
alias: usb:v2357p0105d*dc*dsc*dp*ic*isc*ip*in*
alias: usb:v148Fp760Ad*dc*dsc*dp*ic*isc*ip*in*
alias: usb:v2357p010Bd*dc*dsc*dp*ic*isc*ip*in*
alias: usb:v148Fp761Ad*dc*dsc*dp*ic*isc*ip*in*
alias: usb:v7392pC711d*dc*dsc*dp*ic*isc*ip*in*
alias: usb:v7392pB711d*dc*dsc*dp*ic*isc*ip*in*
alias: usb:v7392pA711d*dc*dsc*dp*ic*isc*ip*in*
alias: usb:v13B1p003Ed*dc*dsc*dp*ic*isc*ip*in*
alias: usb:v0E8Dp7610d*dc*dsc*dp*ic*isc*ip*in*
alias: usb:v148Fp7610d*dc*dsc*dp*ic*isc*ip*in*
depends: cfg80211
retpoline: Y
name: mt7610u_sta
vermagic: 5.3.7-050307-generic SMP mod_unload
parm: mac:wireless mac addr (charp)

Svetlana
Level 1
Level 1
Posts: 12
Joined: Tue Aug 13, 2019 10:45 pm

Re: Wavlink 600M Wifi Adapter doesn't work

Post by Svetlana » Tue Oct 22, 2019 7:49 pm

There are problems yet :'(

My speed connection isn't the same on windows and linux (dualboot), at 8pm with peoples on network, I have 35 Mbps on my phone/windows and only 10/15 on linux

And sometimes my connection drops/stops

Too, I have a new issue, I think it's linked to solutions I tried, I want do updates but I have this error:
m.png
In english: "impossible to apply the changes. Repair broken packages first "

And the package in image is "kernel linux 5.3.0.19.85"

User avatar
kelebek333
Level 3
Level 3
Posts: 181
Joined: Sat Jun 25, 2011 11:57 am

Re: Wavlink 600M Wifi Adapter doesn't work

Post by kelebek333 » Wed Oct 23, 2019 7:17 am

Svetlana wrote:
Tue Oct 22, 2019 7:49 pm

In english: "impossible to apply the changes. Repair broken packages first "

And the package in image is "kernel linux 5.3.0.19.85"
Because of this issue is not related to the wireless network issue, it is more appropriate to open a new topic. You can try to solve the problem with the following command.

Code: Select all

sudo apt install -f
sudo dpkg --configure -a
But if the problem is not solved, you can create a new topic with the following outputs of commands on this forum section.

Code: Select all

sudo apt install -f
inxi -Sr

Svetlana
Level 1
Level 1
Posts: 12
Joined: Tue Aug 13, 2019 10:45 pm

Re: Wavlink 600M Wifi Adapter doesn't work

Post by Svetlana » Wed Oct 23, 2019 4:16 pm

Thanks, I'll try to run these commands :)

and for the issue about drops/stops of my connection, have you ideas ?

User avatar
kelebek333
Level 3
Level 3
Posts: 181
Joined: Sat Jun 25, 2011 11:57 am

Re: Wavlink 600M Wifi Adapter doesn't work

Post by kelebek333 » Thu Oct 24, 2019 6:41 am

Svetlana wrote:
Wed Oct 23, 2019 4:16 pm
Thanks, I'll try to run these commands :)

and for the issue about drops/stops of my connection, have you ideas ?
Could you post output of wireless script for see the latest status.

Svetlana
Level 1
Level 1
Posts: 12
Joined: Tue Aug 13, 2019 10:45 pm

Re: Wavlink 600M Wifi Adapter doesn't work

Post by Svetlana » Thu Oct 24, 2019 8:38 pm

svetlana@svetlana-MS-7B87:~$ cat wireless-info.txt

########## wireless info START ##########

Report from: 24 Oct 2019 20:29 EDT -0400

Booted last: 24 Oct 2019 00:00 EDT -0400

Script from: 22 Oct 2018 03:34 UTC +0000

##### release ###########################

Distributor ID: LinuxMint
Description: Linux Mint 19.2 Tina
Release: 19.2
Codename: tina

##### kernel ############################

Linux 5.3.0-18-generic #19~18.04.2-Ubuntu SMP Wed Oct 16 13:24:55 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Parameters: ro, quiet, splash, usbcore.autosuspend=-1, vt.handoff=1

##### desktop ###########################

Cinnamon

##### lspci #############################

25:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)
Subsystem: Micro-Star International Co., Ltd. [MSI] RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [1462:7b87]
Kernel driver in use: r8169

##### lsusb #############################

Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 046d:c248 Logitech, Inc. G105 Gaming Keyboard
Bus 003 Device 002: ID 046d:c07d Logitech, Inc.
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 046d:082b Logitech, Inc. Webcam C170
Bus 001 Device 002: ID 0e8d:7610 MediaTek Inc.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

##### PCMCIA card info ##################

##### rfkill ############################

0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

##### secure boot #######################

SecureBoot disabled

##### lsmod #############################

mac80211 847872 6 mt76,mt76_usb,mt76x02_lib,mt76x02_usb,mt76x0_common,mt76x0u
cfg80211 708608 5 mt76,mt76x02_lib,mac80211,mt7610u_sta,mt76x02_usb
libarc4 16384 1 mac80211
wmi_bmof 16384 0
wmi 32768 1 wmi_bmof

##### interfaces ########################

[/etc/network/interfaces]
auto lo
iface lo inet loopback

##### ifconfig ##########################

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback <MAC address> brd <MAC address>
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: enp37s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
link/ether <MAC 'enp37s0' [IF1]> brd <MAC address>
3: wlx<IF from MAC [IF2]>: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
link/ether <MAC 'wlx<IF from MAC [IF2]>' [IF2]> brd <MAC address>
inet xxx brd xxx scope global dynamic noprefixroute wlx<IF from MAC [IF2]>
valid_lft 43047sec preferred_lft 43047sec
inet6 xxx scope link noprefixroute
valid_lft forever preferred_lft forever

##### iwconfig ##########################

lo no wireless extensions.

enp37s0 no wireless extensions.

wlx<IF from MAC [IF2]> IEEE 802.11 ESSID:"Workhard_5GHz"
Mode:Managed Frequency:5.22 GHz Access Point: <MAC 'xxx' [AN3]>
Bit Rate=130 Mb/s Tx-Power=16 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Power Management:off
Link Quality=50/70 Signal level=-60 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:7 Invalid misc:47 Missed beacon:0

##### route #############################

default via 192.168.0.1 dev wlx<IF from MAC [IF2]> proto dhcp metric 600
xxx dev wlx<IF from MAC [IF2]> scope link metric 1000
xxx dev wlx<IF from MAC [IF2]> proto kernel scope link src xxx metric 600

##### resolv.conf #######################

[777 root '/etc/resolv.conf' -> '../run/systemd/resolve/stub-resolv.conf']

nameserver 127.0.0.53
options edns0

##### network managers ##################

Installed:

NetworkManager

Running:

root 962 1 0 20:25 ? 00:00:00 /usr/sbin/NetworkManager --no-daemon

##### NetworkManager info ###############

GENERAL.DEVICE: wlx<IF from MAC [IF2]>
GENERAL.TYPE: wifi
GENERAL.NM-TYPE: NMDeviceWifi
GENERAL.VENDOR: MediaTek
GENERAL.PRODUCT: WiFi
GENERAL.DRIVER: usb
GENERAL.DRIVER-VERSION: 5.3.0-18-generic
GENERAL.FIRMWARE-VERSION: N/A
GENERAL.HWADDR: <MAC 'wlx<IF from MAC [IF2]>' [IF2]>
GENERAL.MTU: 1500
GENERAL.STATE: 100 (connected)
GENERAL.REASON: 0 (No reason given)
GENERAL.UDI: /sys/devices/pci0000:00/0000:00:01.3/0000:03:00.0/usb1/1-1/net/wlx<IF from MAC [IF2]>
GENERAL.IP-IFACE: wlx<IF from MAC [IF2]>
GENERAL.IS-SOFTWARE: no
GENERAL.NM-MANAGED: yes
GENERAL.AUTOCONNECT: yes
GENERAL.FIRMWARE-MISSING: no
GENERAL.NM-PLUGIN-MISSING: no
GENERAL.PHYS-PORT-ID: --
GENERAL.CONNECTION: xxx automatique
GENERAL.CON-UUID: xxx
GENERAL.CON-PATH: /org/freedesktop/NetworkManager/ActiveConnection/1
GENERAL.METERED: no (guessed)
CAPABILITIES.CARRIER-DETECT: no
CAPABILITIES.SPEED: 130 Mb/s
CAPABILITIES.IS-SOFTWARE: no
CAPABILITIES.SRIOV: no
WIFI-PROPERTIES.WEP: yes
WIFI-PROPERTIES.WPA: yes
WIFI-PROPERTIES.WPA2: yes
WIFI-PROPERTIES.TKIP: yes
WIFI-PROPERTIES.CCMP: yes
WIFI-PROPERTIES.AP: yes
WIFI-PROPERTIES.ADHOC: yes
WIFI-PROPERTIES.2GHZ: yes
WIFI-PROPERTIES.5GHZ: yes
IP4.ADDRESS[1]: xxx
IP4.GATEWAY: xxx
IP4.ROUTE[1]: dst = 0.0.0.0/0, nh = xxx, mt = 600
IP4.ROUTE[2]: dst = xxx, nh = 0.0.0.0, mt = 600
IP4.ROUTE[3]: dst = xxx, nh = 0.0.0.0, mt = 1000
IP4.DNS[1]: xxx
IP4.DNS[2]: xxx
IP4.DNS[3]: xxx
DHCP4.OPTION[1]: requested_subnet_mask = 1
DHCP4.OPTION[2]: requested_rfc3442_classless_static_routes = 1
DHCP4.OPTION[3]: subnet_mask = 255.255.255.0
DHCP4.OPTION[4]: domain_name_servers = xxxxxxxxx
DHCP4.OPTION[5]: ip_address = xxx
DHCP4.OPTION[6]: requested_static_routes = 1
DHCP4.OPTION[7]: dhcp_server_identifier = xxx
DHCP4.OPTION[8]: requested_time_offset = 1
DHCP4.OPTION[9]: broadcast_address = xxx
DHCP4.OPTION[10]: dhcp_rebinding_time = 37800
DHCP4.OPTION[11]: requested_interface_mtu = 1
DHCP4.OPTION[12]: requested_domain_name_servers = 1
DHCP4.OPTION[13]: dhcp_message_type = 5
DHCP4.OPTION[14]: requested_broadcast_address = 1
DHCP4.OPTION[15]: dhcp_renewal_time = 21600
DHCP4.OPTION[16]: routers = xxx
DHCP4.OPTION[17]: requested_domain_name = 1
DHCP4.OPTION[18]: requested_routers = 1
DHCP4.OPTION[19]: expiry = 1571991997
DHCP4.OPTION[20]: host_name = svetlana-MS-7B87
DHCP4.OPTION[21]: requested_wpad = 1
DHCP4.OPTION[22]: requested_netbios_scope = 1
DHCP4.OPTION[23]: interface_mtu = 1500
DHCP4.OPTION[24]: requested_ms_classless_static_routes = 1
DHCP4.OPTION[25]: requested_netbios_name_servers = 1
DHCP4.OPTION[26]: network_number = xxx
DHCP4.OPTION[27]: requested_domain_search = 1
DHCP4.OPTION[28]: next_server = xxx
DHCP4.OPTION[29]: requested_ntp_servers = 1
DHCP4.OPTION[30]: dhcp_lease_time = 43200
DHCP4.OPTION[31]: requested_host_name = 1
IP6.ADDRESS[1]: xxx
IP6.GATEWAY: --
IP6.ROUTE[1]: dst = ff00::/8, nh = ::, mt = 256, table=255
IP6.ROUTE[2]: dst = fe80::/64, nh = ::, mt = 256
IP6.ROUTE[3]: dst = fe80::/64, nh = ::, mt = 600
CONNECTIONS.AVAILABLE-CONNECTION-PATHS: /org/freedesktop/NetworkManager/Settings/{1}
CONNECTIONS.AVAILABLE-CONNECTIONS[1]: xxx | xxx

GENERAL.DEVICE: enp37s0
GENERAL.TYPE: ethernet
GENERAL.NM-TYPE: NMDeviceEthernet
GENERAL.VENDOR: Realtek Semiconductor Co., Ltd.
GENERAL.PRODUCT: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
GENERAL.DRIVER: r8169
GENERAL.DRIVER-VERSION: --
GENERAL.FIRMWARE-VERSION: --
GENERAL.HWADDR: <MAC 'enp37s0' [IF1]>
GENERAL.MTU: 1500
GENERAL.STATE: 20 (unavailable)
GENERAL.REASON: 2 (Device is now managed)
GENERAL.UDI: /sys/devices/pci0000:00/0000:00:01.3/0000:03:00.2/0000:20:04.0/0000:25:00.0/net/enp37s0
GENERAL.IP-IFACE: --
GENERAL.IS-SOFTWARE: no
GENERAL.NM-MANAGED: yes
GENERAL.AUTOCONNECT: yes
GENERAL.FIRMWARE-MISSING: no
GENERAL.NM-PLUGIN-MISSING: no
GENERAL.PHYS-PORT-ID: --
GENERAL.CONNECTION: --
GENERAL.CON-UUID: --
GENERAL.CON-PATH: --
GENERAL.METERED: unknown
CAPABILITIES.CARRIER-DETECT: yes
CAPABILITIES.SPEED: unknown
CAPABILITIES.IS-SOFTWARE: no
CAPABILITIES.SRIOV: no
WIRED-PROPERTIES.CARRIER: off
CONNECTIONS.AVAILABLE-CONNECTION-PATHS: --

SSID BSSID MODE CHAN FREQ RATE SIGNAL BARS SECURITY ACTIVE IN-USE
xxx <MAC 'xxx' [AN1]> Infra 6 2437 MHz 195 Mbit/s 77 ▂▄▆_ WPA2 no
xxx <MAC 'xxx' [AN2]> Infra 1 2412 MHz 195 Mbit/s 70 ▂▄▆_ WPA1 WPA2 no
xxx <MAC 'xxx' [AN3]> Infra 44 5220 MHz 405 Mbit/s 60 ▂▄▆_ WPA1 WPA2 yes *
xxx <MAC 'xxx' [AN4]> Infra 11 2462 MHz 405 Mbit/s 59 ▂▄▆_ WPA2 no
xxx <MAC 'xxx' [AN5]> Infra 1 2412 MHz 540 Mbit/s 57 ▂▄▆_ WPA2 no
xxx <MAC 'xxx' [AN6]> Infra 10 2457 MHz 130 Mbit/s 55 ▂▄__ WPA1 WPA2 no
xxx <MAC 'xxx' [AN7]> Infra 1 2412 MHz 195 Mbit/s 54 ▂▄__ WPA1 WPA2 no
-- <MAC '--' [AN8]> Infra 104 5520 MHz 540 Mbit/s 49 ▂▄__ WPA2 no
xxx <MAC 'xxx' [AN9]> Infra 104 5520 MHz 540 Mbit/s 49 ▂▄__ WPA2 no

##### NetworkManager.state ##############

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true

##### NetworkManager config #############

[[/etc/NetworkManager/conf.d/default-wifi-powersave-on.conf]]
[connection]
wifi.powersave = 3

[[/etc/NetworkManager/NetworkManager.conf]]
[main]
plugins=ifupdown,keyfile
[ifupdown]
managed=false
[device]
wifi.scan-rand-mac-address=no

[[/usr/lib/NetworkManager/conf.d/10-dns-resolved.conf]]
[main]
dns=systemd-resolved

[[/usr/lib/NetworkManager/conf.d/10-globally-managed-devices.conf]]
[keyfile]
unmanaged-devices=*,except:type:wifi,except:type:wwan

[[/usr/lib/NetworkManager/conf.d/20-connectivity-ubuntu.conf]]
[connectivity]
uri=http://connectivity-check.ubuntu.com/

[[/usr/lib/NetworkManager/conf.d/no-mac-addr-change.conf]]
[device-mac-addr-change-wifi]
match-device=driver:rtl8723bs,driver:rtl8189es,driver:r8188eu,driver:8188eu,driver:eagle_sdio,driver:wl
wifi.scan-rand-mac-address=no
wifi.cloned-mac-address=preserve
ethernet.cloned-mac-address=preserve

##### NetworkManager profiles ###########

[[/etc/NetworkManager/system-connections/xxx automatique]] (600 root)
[connection] id=Workhard_5GHz automatique | type=wifi | permissions=
[wifi] mac-address=<MAC 'wlx<IF from MAC [IF2]>' [IF2]> | mac-address-blacklist= | ssid=xxx
[ipv4] method=auto
[ipv6] method=auto

##### Netplan config ####################

[/etc/netplan/1-network-manager-all.yaml]
network:
version: 2
renderer: NetworkManager

##### iw reg get ########################

Region: America/Toronto (based on set time zone)

global
country US: DFS-FCC
(2402 - 2472 @ 40), (N/A, 30), (N/A)
(5170 - 5250 @ 80), (N/A, 23), (N/A), AUTO-BW
(5250 - 5330 @ 80), (N/A, 23), (0 ms), DFS, AUTO-BW
(5490 - 5730 @ 160), (N/A, 23), (0 ms), DFS
(5735 - 5835 @ 80), (N/A, 30), (N/A)
(57240 - 63720 @ 2160), (N/A, 40), (N/A)

##### iwlist channels ###################

lo no frequency information.

enp37s0 no frequency information.

wlx<IF from MAC [IF2]> 32 channels in total; available frequencies :
Channel 01 : 2.412 GHz
Channel 02 : 2.417 GHz
Channel 03 : 2.422 GHz
Channel 04 : 2.427 GHz
Channel 05 : 2.432 GHz
Channel 06 : 2.437 GHz
Channel 07 : 2.442 GHz
Channel 08 : 2.447 GHz
Channel 09 : 2.452 GHz
Channel 10 : 2.457 GHz
Channel 11 : 2.462 GHz
Channel 36 : 5.18 GHz
Channel 40 : 5.2 GHz
Channel 44 : 5.22 GHz
Channel 48 : 5.24 GHz
Channel 52 : 5.26 GHz
Channel 56 : 5.28 GHz
Channel 60 : 5.3 GHz
Channel 64 : 5.32 GHz
Channel 100 : 5.5 GHz
Channel 104 : 5.52 GHz
Channel 108 : 5.54 GHz
Channel 112 : 5.56 GHz
Channel 116 : 5.58 GHz
Channel 120 : 5.6 GHz
Channel 124 : 5.62 GHz
Channel 128 : 5.64 GHz
Channel 132 : 5.66 GHz
Channel 136 : 5.68 GHz
Channel 140 : 5.7 GHz
Channel 149 : 5.745 GHz
Channel 153 : 5.765 GHz
Current Frequency:5.22 GHz (Channel 44)

##### iwlist scan #######################

lo Interface doesn't support scanning.

wlx<IF from MAC [IF2]> Failed to read scan data : Resource temporarily unavailable

enp37s0 Interface doesn't support scanning.

##### module infos ######################

[mac80211]
filename: /lib/modules/5.3.0-18-generic/kernel/net/mac80211/mac80211.ko
license: GPL
description: IEEE 802.11 subsystem
srcversion: E5BAEB02C080FB4E3226D5B
depends: cfg80211,libarc4
retpoline: Y
intree: Y
name: mac80211
vermagic: 5.3.0-18-generic SMP mod_unload
signat: PKCS#7
signer:
sig_key:
sig_hashalgo: md4
parm: minstrel_vht_only:Use only VHT rates when VHT is supported by sta. (bool)
parm: max_nullfunc_tries:Maximum nullfunc tx tries before disconnecting (reason 4). (int)
parm: max_probe_tries:Maximum probe tries before disconnecting (reason 4). (int)
parm: beacon_loss_count:Number of beacon intervals before we decide beacon was lost. (int)
parm: probe_wait_ms:Maximum time(ms) to wait for probe response before disconnecting (reason 4). (int)
parm: ieee80211_default_rc_algo:Default rate control algorithm for mac80211 to use (charp)

[cfg80211]
filename: /lib/modules/5.3.0-18-generic/kernel/net/wireless/cfg80211.ko
description: wireless configuration support
license: GPL
author: Johannes Berg
srcversion: B40A287A6D5CAB8457D0FD4
depends:
retpoline: Y
intree: Y
name: cfg80211
vermagic: 5.3.0-18-generic SMP mod_unload
signat: PKCS#7
signer:
sig_key:
sig_hashalgo: md4
parm: bss_entries_limit:limit to number of scan BSS entries (per wiphy, default 1000) (int)
parm: ieee80211_regdom:IEEE 802.11 regulatory domain code (charp)
parm: cfg80211_disable_40mhz_24ghz:Disable 40MHz support in the 2.4GHz band (bool)

##### module parameters #################

[mac80211]
beacon_loss_count: 7
ieee80211_default_rc_algo: minstrel_ht
max_nullfunc_tries: 2
max_probe_tries: 5
minstrel_vht_only: Y
probe_wait_ms: 500

[cfg80211]
bss_entries_limit: 1000
cfg80211_disable_40mhz_24ghz: N
ieee80211_regdom: 00

##### /etc/modules ######################

##### modprobe options ##################

[/etc/modprobe.d/amd64-microcode-blacklist.conf]
blacklist microcode

[/etc/modprobe.d/blacklist-ath_pci.conf]
blacklist ath_pci

[/etc/modprobe.d/blacklist.conf]
blacklist evbug
blacklist usbmouse
blacklist usbkbd
blacklist eepro100
blacklist de4x5
blacklist eth1394
blacklist snd_intel8x0m
blacklist snd_aw2
blacklist i2c_i801
blacklist prism54
blacklist bcm43xx
blacklist garmin_gps
blacklist asus_acpi
blacklist snd_pcsp
blacklist pcspkr
blacklist amd76x_edac

[/etc/modprobe.d/blacklist-mt76.conf]
blacklist mt76

[/etc/modprobe.d/blacklist-rare-network.conf]
alias net-pf-3 off
alias net-pf-6 off
alias net-pf-9 off
alias net-pf-11 off
alias net-pf-12 off
alias net-pf-19 off
alias net-pf-21 off
alias net-pf-36 off

[/etc/modprobe.d/intel-microcode-blacklist.conf]
blacklist microcode

[/etc/modprobe.d/iwlwifi.conf]
remove iwlwifi \
(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
&& /sbin/modprobe -r mac80211

##### rc.local ##########################

grep: /etc/rc.local: No such file or directory

##### pm-utils ##########################

##### udev rules ########################

Svetlana
Level 1
Level 1
Posts: 12
Joined: Tue Aug 13, 2019 10:45 pm

Re: Wavlink 600M Wifi Adapter doesn't work

Post by Svetlana » Thu Oct 24, 2019 8:39 pm

And this is final return if you need

Code: Select all

svetlana@svetlana-MS-7B87:~$ cat wireless-info.txt | nc termbin.com 9999
https://termbin.com/i0jd

User avatar
kelebek333
Level 3
Level 3
Posts: 181
Joined: Sat Jun 25, 2011 11:57 am

Re: Wavlink 600M Wifi Adapter doesn't work

Post by kelebek333 » Thu Oct 24, 2019 9:24 pm

mac80211 847872 6 mt76,mt76_usb,mt76x02_lib,mt76x02_usb,mt76x0_common,mt76x0u
cfg80211 708608 5 mt76,mt76x02_lib,mac80211,mt7610u_sta,mt76x02_usb
Could you try to run following command to avoid conflicts between mt76x0u and mt7610u_sta drives. After reboot your PC.

Code: Select all

echo "blacklist mt76x0u" | sudo tee -a /etc/modprobe.d/blacklist-mt76.conf

Svetlana
Level 1
Level 1
Posts: 12
Joined: Tue Aug 13, 2019 10:45 pm

Re: Wavlink 600M Wifi Adapter doesn't work

Post by Svetlana » Thu Oct 24, 2019 10:00 pm

Hmm, I think my adapter is no longer recognized :/

My mint isn't trying to connect to my network or detect another one now


Before commands, the file "/etc/modprobe.d/blacklist-mt76.conf" contains

Code: Select all

blacklist mt76
and after

Code: Select all

blacklist mt76
blacklist mt76x0u
I tried to put only "blacklist mt76x0u" but no result :/

I have a connection (light) only when I put "blacklist mt76"

Post Reply

Return to “Wireless”