[SOLVED] Connected to router but no internet

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Celine
Level 1
Level 1
Posts: 16
Joined: Tue Jan 07, 2020 4:44 pm

[SOLVED] Connected to router but no internet

Post by Celine »

Hello,

Until yesterday I never had any wifi issues and I moved to a new place where internet is shared with several flats.
I entered the wifi password, got a "connection established" but no internet.
I have no access to the router to modify or restart it.

Any idea? any solution?

I am running Mint 19.2 on an old Macbook 4.1 and I am rather new on Linux. So please be precised when giving instructions.
Many thanks!

Celine
Last edited by Celine on Fri Jan 24, 2020 2:36 pm, edited 1 time in total.

User avatar
caf4926
Level 7
Level 7
Posts: 1875
Joined: Mon Mar 22, 2010 3:21 pm
Location: UK Lake District

Re: Connected to router but no internet

Post by caf4926 »

Is this your only device that you have that is connecting to this shared network?
In other words, can say for example that your phone is connected to it and that is fine?
Linux Mint 19.3 Cinnamon

Celine
Level 1
Level 1
Posts: 16
Joined: Tue Jan 07, 2020 4:44 pm

Re: Connected to router but no internet

Post by Celine »

Thanks for your answer.
My old iphone 3G is connected and works fine. My husband's laptop is working fine too.

User avatar
caf4926
Level 7
Level 7
Posts: 1875
Joined: Mon Mar 22, 2010 3:21 pm
Location: UK Lake District

Re: Connected to router but no internet

Post by caf4926 »

So this old Mac has worked in your old place
It's connected to the router in this new place - but no internet.

It's odd

Hopefully someone has an idea, I'm not sure. And I have to sleep now
Linux Mint 19.3 Cinnamon

Celine
Level 1
Level 1
Posts: 16
Joined: Tue Jan 07, 2020 4:44 pm

Re: Connected to router but no internet

Post by Celine »

Yep! It was working fine before.
Could the issue be coming from a more recent wireless standards (802.11b/n/g)? is my driver not compatible?

PussyCat
Level 4
Level 4
Posts: 288
Joined: Tue Mar 03, 2009 1:41 pm

Re: Connected to router but no internet

Post by PussyCat »

Before what?

Anyway, Step 1 - log into the router's admin page from your browser. Does it show that you have an internet connection?

Celine
Level 1
Level 1
Posts: 16
Joined: Tue Jan 07, 2020 4:44 pm

Re: Connected to router but no internet

Post by Celine »

Before I move to my new place.
Like mentioned in my initial post, I cannot log into the router.
If I type 192.168.0.1 on my computer, it says "unable to connect".

PussyCat
Level 4
Level 4
Posts: 288
Joined: Tue Mar 03, 2009 1:41 pm

Re: Connected to router but no internet

Post by PussyCat »

Sorry - the link took me straight to your latest reply and didn't twig the earlier dialogue!

So the bars on the tray icon indicate a connection and reasonably good connection strength?

If you click on the tray icon (or hover the mouse pointer) does your router ssid show up as connected?

Celine
Level 1
Level 1
Posts: 16
Joined: Tue Jan 07, 2020 4:44 pm

Re: Connected to router but no internet

Post by Celine »

No problem :wink:
And yes, I have a very good connection strength and it says that I am connected at least to the router.

HAWR
Level 5
Level 5
Posts: 996
Joined: Thu Jun 06, 2019 1:15 pm

Re: Connected to router but no internet

Post by HAWR »

Hello Celine,

can you please show the terminal output of the following command to see, what wifi card is in use and what driver:

Code: Select all

lspci -nnk | grep -i net -A3
Which router is used?

Celine
Level 1
Level 1
Posts: 16
Joined: Tue Jan 07, 2020 4:44 pm

Re: Connected to router but no internet

Post by Celine »

Hello HAWR,
So sorry for my late reply
The router is a D-Link DIR-822 and my driver is Broadcom BCM4321 802.11a/b/g/n. Impossible to post the terminal output since I am typing this from a different computer. So sorry.

HAWR
Level 5
Level 5
Posts: 996
Joined: Thu Jun 06, 2019 1:15 pm

Re: Connected to router but no internet

Post by HAWR »

Hello Celine,

thank you for your answer. It is also important to know, which driver is in use. Can you please answer again if you use the computer in question?

Celine
Level 1
Level 1
Posts: 16
Joined: Tue Jan 07, 2020 4:44 pm

Re: Connected to router but no internet

Post by Celine »

That's my terminal output. Hope it is helpful.

home@Mac ~ $ lspci -nnk | grep -i net -A3
02:00.0 Network controller [0280]: Broadcom Inc. and subsidiaries BCM4321 802.11a/b/g/n [14e4:4328] (rev 03)
Subsystem: Apple Inc. AirPort Extreme [106b:0088]
Kernel driver in use: wl
Kernel modules: ssb, wl
03:00.0 Ethernet controller [0200]: Marvell Technology Group Ltd. 88E8058 PCI-E Gigabit Ethernet Controller [11ab:436a] (rev 13)
Subsystem: Marvell Technology Group Ltd. Imac 8,1 Wired Ethernet Adapter [11ab:00ba]
Kernel driver in use: sky2
Kernel modules: sky2
04:03.0 FireWire (IEEE 1394) [0c00]: LSI Corporation FW322/323 [TrueFire] 1394a Controller [11c1:5811] (rev 61)

HAWR
Level 5
Level 5
Posts: 996
Joined: Thu Jun 06, 2019 1:15 pm

Re: Connected to router but no internet

Post by HAWR »

Hello Celine,

thanks you again. You are using the recommended driver/module wl, but as can be seen in that output, there is another kernel module ssb. If other things don't work, we could try it with the other module. The router is a dual band router (2,4 GHz and 5 GHz). Maybe there can also be difficulties. But for the beginning please try the instructions of the following short video. Although it's for Ubuntu, it also works with Linux Mint, because Ubuntu is a base for it. Maybe the solution is as simple as that.

https://www.youtube.com/watch?v=YJpPltoXpIs

Celine
Level 1
Level 1
Posts: 16
Joined: Tue Jan 07, 2020 4:44 pm

Re: Connected to router but no internet

Post by Celine »

Hello HAWR,

I tried the solution you sent but it didn't work :cry:
When I add the two new lines (nameserver 8.8.8.8 & nameserver 8.8.4.4), save the file and then restart the service network manager. If I check the file, it didn't save the changes. It is back to:
# Generated by NetworkManager
search tlb sympatico ca
nameserver 127.0.0.53

Any idea why?

HAWR
Level 5
Level 5
Posts: 996
Joined: Thu Jun 06, 2019 1:15 pm

Re: Connected to router but no internet

Post by HAWR »

Hello Celine,

did you run the commands with administrator rights. Under the video the used commands are shown:
commands used in the video:
cd /etc/
sudo nano resolv.conf
sudo service network-manager restart
You have to uncomment the existing nameserver entries with a # at the beginning of each line (see video from 1:00 on) and then make the new entries. To save the changes in the editor use Ctrl+O and to close the editor use Ctrl+X.

Celine
Level 1
Level 1
Posts: 16
Joined: Tue Jan 07, 2020 4:44 pm

Re: Connected to router but no internet

Post by Celine »

So, I ran the commands in root. I noticed that each time I am using "sudo service network-manager restart", it deletes the new lines I entered.
What could be the issue there?

HAWR
Level 5
Level 5
Posts: 996
Joined: Thu Jun 06, 2019 1:15 pm

Re: Connected to router but no internet

Post by HAWR »

Hello Celine,

I've found that the restart of the network manager overwrites the changes as well as a reboot or new system start, but apparently not always for everyone as can be seen in the video and many comments. But without the restart command you can test it. Make the changes in resolv.conf, save and close the file and then open your browser and test the internet. If the changes works for you, I will search for a way to make the changes permanent.

Celine
Level 1
Level 1
Posts: 16
Joined: Tue Jan 07, 2020 4:44 pm

Re: Connected to router but no internet

Post by Celine »

Hello HAWR,

I had tried earlier on to make the changes in resolv.conf, save it and open firefox to see if I had internet but there was nothing happening :(
Back on my computer after a couple of hours and now internet is workng great :D
So, it seems the solution you suggested worked! Many thanks!!!
So how do I please make it permanent?

Celine
Level 1
Level 1
Posts: 16
Joined: Tue Jan 07, 2020 4:44 pm

Re: Connected to router but no internet

Post by Celine »

Well, it didn't last :cry:
I was surfing the web and suddenly back to "looking up www..."
Any suggestion?

Post Reply

Return to “Wireless”