Page 1 of 2

Wifi not working on my HP Laptop [partially SOLVED)

Posted: Sat Mar 07, 2020 10:01 am
by linux4mint
Hello everybody,

I am not able to enable wifi netwok on my HP laptop.
My Os ver is 19.3.

Please help me...


Thanks

Re: Wifi not working on my HP Laptop

Posted: Sat Mar 07, 2020 10:10 am
by HAWR
Hello linux4mint,

in order to help you, we need more informations about your system. Please opne the terminal, run the following commands and show the results:

Code: Select all

inxi -Fxz

Code: Select all

lspci

Re: Wifi not working on my HP Laptop

Posted: Sat Mar 07, 2020 11:08 am
by linux4mint
Thanks for your reply

here is the output of "inxi -Fxz"

System: Host: hardityapc Kernel: 5.3.0-40-generic x86_64 bits: 64 compiler: gcc v: 7.4.0 Desktop: Cinnamon 4.4.8
Distro: Linux Mint 19.3 Tricia base: Ubuntu 18.04 bionic
Machine: Type: Laptop System: Hewlett-Packard product: HP 15 Notebook PC v: 0991100000000000000600087 serial: <filter>
Mobo: Hewlett-Packard model: 2212 v: 86.56 serial: <filter> UEFI [Legacy]: Insyde v: F.45 date: 06/27/2018
Battery: ID-1: BAT1 charge: 24.6 Wh condition: 24.8/24.8 Wh (100%) model: 11-85 OA04041 status: Charging
CPU: Topology: Dual Core model: Intel Core i5-4210U bits: 64 type: MT MCP arch: Haswell rev: 1 L2 cache: 3072 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19156
Speed: 839 MHz min/max: 800/2700 MHz Core speeds (MHz): 1: 1489 2: 1686 3: 1534 4: 1211
Graphics: Device-1: Intel Haswell-ULT Integrated Graphics vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0
Device-2: NVIDIA GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M] vendor: Hewlett-Packard
driver: nvidia v: 340.107 bus ID: 09:00.0
Display: x11 server: X.Org 1.19.6 driver: modesetting,nvidia unloaded: fbdev,nouveau,vesa resolution: 1366x768~60Hz
OpenGL: renderer: GeForce 820M/PCIe/SSE2 v: 4.4.0 NVIDIA 340.107 direct render: Yes
Audio: Device-1: Intel Haswell-ULT HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:03.0
Device-2: Intel 8 Series HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1b.0
Sound Server: ALSA v: k5.3.0-40-generic
Network: Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Hewlett-Packard driver: r8169 v: kernel port: 4000
bus ID: 08:00.0
IF: enp8s0 state: down mac: <filter>
Device-2: Ralink RT3290 Wireless 802.11n 1T/1R PCIe vendor: Hewlett-Packard driver: rt2800pci v: 2.3.0 port: 3000
bus ID: 0a:00.0
IF: wlp10s0f0 state: down mac: <filter>
IF-ID-1: enp0s20u1 state: unknown speed: N/A duplex: N/A mac: <filter>
Drives: Local Storage: total: 931.51 GiB used: 43.57 GiB (4.7%)
ID-1: /dev/sda vendor: Toshiba model: MQ01ABD100 size: 931.51 GiB
Partition: ID-1: / size: 9.10 GiB used: 1.73 GiB (19.0%) fs: ext4 dev: /dev/sda5
ID-2: /boot size: 1.34 GiB used: 388.4 MiB (28.2%) fs: ext4 dev: /dev/sda7
ID-3: /home size: 25.63 GiB used: 4.36 GiB (17.0%) fs: ext4 dev: /dev/sda13
ID-4: /opt size: 4.61 GiB used: 182.2 MiB (3.9%) fs: ext4 dev: /dev/sda9
ID-5: /tmp size: 6.72 GiB used: 31.1 MiB (0.5%) fs: ext4 dev: /dev/sda10
ID-6: /usr size: 25.63 GiB used: 5.88 GiB (23.0%) fs: ext4 dev: /dev/sda12
ID-7: /var size: 9.10 GiB used: 1.85 GiB (20.4%) fs: ext4 dev: /dev/sda11
ID-8: swap-1 size: 7.45 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda6
Sensors: System Temperatures: cpu: 45.0 C mobo: N/A gpu: nvidia temp: 40 C
Fan Speeds (RPM): N/A
Info: Processes: 204 Uptime: 9m Memory: 3.78 GiB used: 1.02 GiB (27.0%) Init: systemd runlevel: 5 Compilers: gcc: 7.4.0
Shell: bash v: 4.4.20 inxi: 3.0.32

***************************************************************************************************************************************************************


and the output of "lspci" is

00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 0b)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 0b)
00:14.0 USB controller: Intel Corporation 8 Series USB xHCI HC (rev 04)
00:16.0 Communication controller: Intel Corporation 8 Series HECI #0 (rev 04)
00:1b.0 Audio device: Intel Corporation 8 Series HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 1 (rev e4)
00:1c.1 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 2 (rev e4)
00:1c.2 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 3 (rev e4)
00:1c.4 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 5 (rev e4)
00:1c.5 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 6 (rev e4)
00:1d.0 USB controller: Intel Corporation 8 Series USB EHCI #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation 8 Series LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 8 Series SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 8 Series SMBus Controller (rev 04)
02:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5229 PCI Express Card Reader (rev 01)
08:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL810xE PCI Express Fast Ethernet controller (rev 07)
09:00.0 3D controller: NVIDIA Corporation GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M] (rev a1)
0a:00.0 Network controller: Ralink corp. RT3290 Wireless 802.11n 1T/1R PCIe
0a:00.1 Bluetooth: Ralink corp. RT3290 Bluetooth

THANKS

Re: Wifi not working on my HP Laptop

Posted: Sat Mar 07, 2020 11:37 am
by HAWR
Hello linux4mint,

thank you for the informations. You have an Ralink wifi and the right driver is loaded. So the problem can be, that something blocks your wifi. Please show the result of the following command:

Code: Select all

rfkill list all
By the way: when you paste terminal outputs as text here, you can highlight the text, press the </> button above the text box, so it will appear in a better readable codeblock. You can also edit your previous post in that way.

Re: Wifi not working on my HP Laptop

Posted: Sat Mar 07, 2020 11:45 am
by linux4mint
Dear HAWR

the output is

Code: Select all

$ rfkill list all
0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: yes
Thanks

Re: Wifi not working on my HP Laptop

Posted: Sat Mar 07, 2020 12:05 pm
by HAWR
Hello linux4mint,

it is a hard block. When I've found the right manual, you have a wireless key at F12 or around with the typical wireless sign. Please try for example Fn+F12 (or the key with the wireless sign) to enable wifi.

Another possibilty is, that wifi is disabled in Setup Utility/BIOS. Please reboot and when the new boot begins, press immediately Esc and then F10.

Re: Wifi not working on my HP Laptop

Posted: Sat Mar 07, 2020 12:28 pm
by linux4mint
Dear HAWR
Thanks for your reply
it is a hard block. When I've found the right manual, you have a wireless key at F12 or around with the typical wireless sign. Please try for example Fn+F12 (or the key with the wireless sign) to enable
Already tried , but nothing happend.. the strange part is, the wifi can easily working on Windows 10 OS...
Another possibilty is, that wifi is disabled in Setup Utility/BIOS. Please reboot and when the new boot begins, press immediately Esc and then F10.
Didn't find any option to enable the same on BIOS settings..

By the way my Laptop model is Hp 15-r007tx.

Thanks

Re: Wifi not working on my HP Laptop

Posted: Sat Mar 07, 2020 12:47 pm
by HAWR
Hello linux4mint,

do you have a dual boot with Windows 10? If yes, it is possible, that Windows holds the wifi in an unclear state, so it isn't accessible in Linux. You should
try disable "Fast Startup" in Windows:

https://www.isumsoft.com/windows-10/tur ... ws-10.html

Make a complete shutdown and wait a few minutes before powering back up again and boot to Linux.

Re: Wifi not working on my HP Laptop

Posted: Sat Mar 07, 2020 1:16 pm
by linux4mint
Hi HAWR,
do you have a dual boot with Windows 10? If yes, it is possible, that Windows holds the wifi in an unclear state, so it isn't accessible in Linux. You should
try disable "Fast Startup" in Windows:
Already disabled the same in my Windows OS.

another thing i have marked in my Linux Mint os is my Bluetooth connection also not working along with Wifi....

Thanks

Re: Wifi not working on my HP Laptop

Posted: Sat Mar 07, 2020 1:32 pm
by HAWR
Hello linux4mint,

did the wifi worked, when you've tested it in the live system before installing Linux Mint? Did it work directly after the installation? I ask because of a possible problem with the 5.3 kernels.

I've seen a case with a hard blocked wifi, where the solution was to shutdown the laptop, remove the power cable, remove the battery, wait about 10 minutes and start again.

Re: Wifi not working on my HP Laptop

Posted: Sat Mar 07, 2020 1:40 pm
by sleeper12
It wouldn't hurt to try:

Code: Select all

 rfkill unblock all 
Or

Code: Select all

 rfkill unblock wifi 

Re: Wifi not working on my HP Laptop

Posted: Sat Mar 07, 2020 2:17 pm
by linux4mint
HAWR wrote:
Sat Mar 07, 2020 1:32 pm
Hello linux4mint,

did the wifi worked, when you've tested it in the live system before installing Linux Mint? Did it work directly after the installation? I ask because of a possible problem with the 5.3 kernels.

I've seen a case with a hard blocked wifi, where the solution was to shutdown the laptop, remove the power cable, remove the battery, wait about 10 minutes and start again.
Dear HAWR

Yeah.. tested with live media.....nothing happened

Thanks

Re: Wifi not working on my HP Laptop

Posted: Sat Mar 07, 2020 2:21 pm
by linux4mint
Dear sleeper12,
sleeper12 wrote:
Sat Mar 07, 2020 1:40 pm
It wouldn't hurt to try:

Code: Select all

 rfkill unblock all 
Or

Code: Select all

 rfkill unblock wifi 
Thanks for your reply.....
Already used these commands...
Nothing happened..

Thanks

Re: Wifi not working on my HP Laptop

Posted: Sat Mar 07, 2020 3:06 pm
by kelebek333
Can you try the suggestions here? It is very similar to your device issue.

Re: Wifi not working on my HP Laptop

Posted: Sat Mar 07, 2020 3:13 pm
by sleeper12
Does 'rfkill list all' still say hard blocked? Maybe it's unblocked now & there's a different problem?

Re: Wifi not working on my HP Laptop

Posted: Sat Mar 07, 2020 11:03 pm
by linux4mint
sleeper12 wrote:
Sat Mar 07, 2020 3:13 pm
Does 'rfkill list all' still say hard blocked? Maybe it's unblocked now & there's a different problem?
The output is
$ rfkill list all
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes

Thanks

Re: Wifi not working on my HP Laptop

Posted: Sat Mar 07, 2020 11:17 pm
by sleeper12
Did you try what HAWR suggested:

'I've seen a case with a hard blocked wifi, where the solution was to shutdown the laptop, remove the power cable, remove the battery, wait about 10 minutes and start again."

You might also try holding the power button down for a minute before you start again.

Re: Wifi not working on my HP Laptop

Posted: Sun Mar 08, 2020 5:15 am
by linux4mint
sleeper12 wrote:
Sat Mar 07, 2020 11:17 pm
Did you try what HAWR suggested:

'I've seen a case with a hard blocked wifi, where the solution was to shutdown the laptop, remove the power cable, remove the battery, wait about 10 minutes and start again."

You might also try holding the power button down for a minute before you start again.
Dear sleeper12,

I have already performed several-time this procedure, but nothing happened.

Thanks

Re: Wifi not working on my HP Laptop

Posted: Sun Mar 08, 2020 6:15 am
by HAWR
Hello linux4mint,

have you tried kelebek333 suggestion from above?

viewtopic.php?p=1772973#p1772973

Re: Wifi not working on my HP Laptop

Posted: Sun Mar 08, 2020 7:23 am
by linux4mint
HAWR wrote:
Sun Mar 08, 2020 6:15 am
Hello linux4mint,

have you tried kelebek333 suggestion from above?

viewtopic.php?p=1772973#p1772973
Thanks HAWR for your reply....

Yes i have followed every steps as described by kelebek333 link...

But nothing changed.....

Thanks