Page 1 of 1

After suspend WIFI works and finds other networks, but most of the time not mine.

Posted: Tue Jun 30, 2020 9:47 pm
by agatha_christie
I come out of suspend and my wifi adapter works just fine, finding nearby networks, but failing to find mine. My current solution is to use:

Code: Select all

systemctl restart network-manager
Sometimes I need to do this 3-4 times in order to get it to respond, while on occasion I'll need to wait 10-15 seconds before trying it. There doesn't seem to be a pattern with how many times or the time I need to wait in order to get it find my network.

My current solutions have included:
  • Removing and reinstalling drivers (realtek from the lwfinger/rtlwifi-new repo - using rtl8723de).
  • Creating a script that reloads the network-manager coming out of suspend
  • Putting into suspend using systemctl -i suspend
  • Changing power management options (disabling, enabling)
Almost every solution I've found is people who can't get their network card to work, but mine works just fine, it just can't always find my network right away.

Any ideas?

Re: After suspend WIFI works and finds other networks, but most of the time not mine.

Posted: Tue Jun 30, 2020 10:14 pm
by sleeper12
Is that an HP laptop by any chance?

Re: After suspend WIFI works and finds other networks, but most of the time not mine.

Posted: Tue Jun 30, 2020 10:24 pm
by agatha_christie
sleeper12 wrote:
Tue Jun 30, 2020 10:14 pm
Is that an HP laptop by any chance?
Yes it is.

Re: After suspend WIFI works and finds other networks, but most of the time not mine.

Posted: Tue Jun 30, 2020 10:28 pm
by sleeper12

Re: After suspend WIFI works and finds other networks, but most of the time not mine.

Posted: Wed Jul 01, 2020 1:15 am
by agatha_christie
sleeper12 wrote:
Tue Jun 30, 2020 10:28 pm
Try #2 here for your rtl8723de :
https://easylinuxtipsproject.blogspot.c ... k.html#ID2
Thanks for the help. I checked this and I'm already using the second antenna and have signal strength. I tried it anyways, and when reloading with modprobe I had to switch on/off wifi again in order to get it to connect.

It feels like something is blocking/not releasing whatever I was previously connected to and something gets switched after I restart the wifi a number of times.

EDIT:

Oddly, I just noticed that my ssh connection retained connection to my raspberrypi throughout the process. Not sure how that works.

Re: After suspend WIFI works and finds other networks, but most of the time not mine.

Posted: Wed Jul 01, 2020 10:10 am
by sleeper12
Post results of:

Code: Select all

 inxi -Fxz 

Re: After suspend WIFI works and finds other networks, but most of the time not mine.

Posted: Thu Jul 02, 2020 4:46 am
by agatha_christie
Sorry for the delay:

Code: Select all

System:
  Host: mbox Kernel: 5.3.0-59-generic x86_64 bits: 64 compiler: gcc 
  v: 7.5.0 Desktop: Cinnamon 4.4.8 Distro: Linux Mint 19.3 Tricia 
  base: Ubuntu 18.04 bionic 
Machine:
  Type: Laptop System: HP product: HP Laptop 17-by1xxx 
  v: Type1ProductConfigId serial: <filter> 
  Mobo: HP model: 8530 v: 17.16 serial: <filter> UEFI: Insyde v: F.32 
  date: 12/14/2018 
Battery:
  ID-1: BAT0 charge: 36.7 Wh condition: 36.7/36.7 Wh (100%) 
  model: Hewlett-Packard Primary status: Full 
CPU:
  Topology: Quad Core model: Intel Core i5-8265U bits: 64 type: MT MCP 
  arch: Kaby Lake rev: B L2 cache: 6144 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28800 
  Speed: 801 MHz min/max: 400/3900 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 5: 800 6: 801 7: 800 8: 800 
Graphics:
  Device-1: Intel vendor: Hewlett-Packard driver: i915 v: kernel 
  bus ID: 00:02.0 
  Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1600x900~60Hz 
  OpenGL: renderer: Mesa DRI Intel UHD Graphics (Whiskey Lake 3x8 GT2) 
  v: 4.5 Mesa 19.2.8 direct render: Yes 
Audio:
  Device-1: Intel vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
  bus ID: 00:1f.3 
  Sound Server: ALSA v: k5.3.0-59-generic 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: kernel port: 4000 bus ID: 02:00.0 
  IF: eno1 state: down mac: <filter> 
  Device-2: Realtek vendor: Hewlett-Packard driver: rtl8723de v: kernel 
  port: 3000 bus ID: 03:00.0 
  IF: wlo1 state: up mac: <filter> 
  IF-ID-1: br-78cce3a7d3ec state: down mac: <filter> 
  IF-ID-2: docker0 state: down mac: <filter> 
Drives:
  Local Storage: total: 238.47 GiB used: 159.38 GiB (66.8%) 
  ID-1: /dev/sda model: SPCC Solid State Disk size: 238.47 GiB 
RAID:
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci 
  v: 3.0 bus ID: 00:17.0 
Partition:
  ID-1: / size: 233.24 GiB used: 159.37 GiB (68.3%) fs: ext4 dev: /dev/sda2 
Sensors:
  System Temperatures: cpu: 50.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 269 Uptime: 6h 25m Memory: 15.53 GiB used: 6.65 GiB (42.8%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.5.0 Shell: bash v: 4.4.20 
  inxi: 3.0.32 

Re: After suspend WIFI works and finds other networks, but most of the time not mine.

Posted: Thu Jul 02, 2020 6:22 am
by Pjotr

Re: After suspend WIFI works and finds other networks, but most of the time not mine.

Posted: Sat Jul 04, 2020 8:06 am
by agatha_christie
Power management is already turned and set to 2, unfortunately.

Re: After suspend WIFI works and finds other networks, but most of the time not mine.

Posted: Mon Jul 06, 2020 2:34 pm
by sleeper12
Can you update the kernel?