[SOLVED] Wireless USB Adapter not detected

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
Dribble3100
Level 1
Level 1
Posts: 3
Joined: Wed Jul 08, 2020 10:21 am

[SOLVED] Wireless USB Adapter not detected

Post by Dribble3100 »

Hello everyone,

I could not find a solution for this specific problem on the forums but sorry if it has been asked before.

Mint 20 64-bit does not detect a USB WiFi adapter that according to the packaging is supposed to work for Linux. Windows 10 picks it up straight away.

Model of adapter is NPEVO-AC600USB

Any help much appreciated.
Last edited by Dribble3100 on Wed Jul 08, 2020 2:23 pm, edited 1 time in total.
sleeper12
Level 13
Level 13
Posts: 4767
Joined: Thu May 25, 2017 3:22 pm

Re: Wireless USB Adapter not detected

Post by sleeper12 »

With the adapter plugged in, post the results of:

Code: Select all

 lsusb 

Code: Select all

 inxi -Fxz 
Dribble3100
Level 1
Level 1
Posts: 3
Joined: Wed Jul 08, 2020 10:21 am

Re: Wireless USB Adapter not detected

Post by Dribble3100 »

These are the results. Realtek Semiconductor Corp. 802.11ac NI is the adapter.

Linux.Mint:~$ lsusb
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 04ca:0064 Lite-On Technology Corp. Wireless Device
Bus 003 Device 002: ID 093a:2510 Pixart Imaging, Inc. Optical Mouse
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 0bda:c811 Realtek Semiconductor Corp. 802.11ac NIC
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Linux.Mint:~$ inxi -Fxz
System:
Kernel: 5.4.0-40-generic x86_64 bits: 64 compiler: gcc v: 9.3.0
Desktop: Cinnamon 4.6.6 Distro: Linux Mint 20 Ulyana
base: Ubuntu 20.04 focal
Machine:
Type: Desktop Mobo: Micro-Star model: B450M MORTAR MAX (MS-7B89) v: 1.0
serial: <filter> UEFI: American Megatrends v: 2.60 date: 12/30/2019
CPU:
Topology: 6-Core model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+
rev: 2 L2 cache: 3072 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
bogomips: 81588
Speed: 1375 MHz min/max: 1550/3400 MHz Core speeds (MHz): 1: 1376 2: 1377
3: 1269 4: 2597 5: 1377 6: 1268 7: 1269 8: 2343 9: 1374 10: 1373 11: 1371
12: 1272
Graphics:
Device-1: NVIDIA GM206 [GeForce GTX 950] vendor: ZOTAC driver: nvidia
v: 440.100 bus ID: 26:00.0
Display: x11 server: X.Org 1.20.8 driver: nvidia
unloaded: fbdev,modesetting,nouveau,vesa resolution: 1920x1080~60Hz
OpenGL: renderer: GeForce GTX 950/PCIe/SSE2 v: 4.6.0 NVIDIA 440.100
direct render: Yes
Audio:
Device-1: NVIDIA GM206 High Definition Audio vendor: ZOTAC
driver: snd_hda_intel v: kernel bus ID: 26:00.1
Device-2: AMD Family 17h HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel bus ID: 28:00.3
Sound Server: ALSA v: k5.4.0-40-generic
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI driver: r8169 v: kernel port: f000 bus ID: 22:00.0
IF: enp34s0 state: down mac: <filter>
Device-2: Realtek 802.11ac NIC type: USB driver: usb-network bus ID: 1-8:2
Drives:
Local Storage: total: 704.24 GiB used: 18.36 GiB (2.6%)
ID-1: /dev/nvme0n1 vendor: Western Digital
model: PC SN720 SDAPNTW-256G-1006 size: 238.47 GiB
ID-2: /dev/sda vendor: Western Digital model: WD5000LPVX-75V0TT0
size: 465.76 GiB
Partition:
ID-1: / size: 166.45 GiB used: 18.33 GiB (11.0%) fs: ext4
dev: /dev/nvme0n1p5
Sensors:
System Temperatures: cpu: 34.0 C mobo: N/A gpu: nvidia temp: 32 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:
Processes: 274 Uptime: 9m Memory: 15.65 GiB used: 921.3 MiB (5.7%)
Init: systemd runlevel: 5 Compilers: gcc: 9.3.0 Shell: bash v: 5.0.16
inxi: 3.0.38
sleeper12
Level 13
Level 13
Posts: 4767
Joined: Thu May 25, 2017 3:22 pm

Re: Wireless USB Adapter not detected

Post by sleeper12 »

Try this, one line at a time:

Code: Select all

sudo apt update
sudo apt install build-essential git dkms
git clone https://github.com/brektrou/rtl8821CU.git
cd rtl8821CU
chmod +x dkms-install.sh
sudo ./dkms-install.sh
sudo modprobe 8821cu 
Reboot
Dribble3100
Level 1
Level 1
Posts: 3
Joined: Wed Jul 08, 2020 10:21 am

Re: Wireless USB Adapter not detected

Post by Dribble3100 »

Problem solved!

Thanks very much for your help.
sleeper12
Level 13
Level 13
Posts: 4767
Joined: Thu May 25, 2017 3:22 pm

Re: [SOLVED] Wireless USB Adapter not detected

Post by sleeper12 »

Great, glad that worked for you. :)
polloco2009
Level 1
Level 1
Posts: 2
Joined: Fri Oct 16, 2020 5:23 pm

Re: [SOLVED] Wireless USB Adapter not detected

Post by polloco2009 »

GREAT!!!! Funtion whit not problem! thanks
User avatar
mortal
Level 1
Level 1
Posts: 21
Joined: Sun Oct 18, 2020 9:42 am

Re: [SOLVED] Wireless USB Adapter not detected

Post by mortal »

sleeper12 wrote:
Wed Jul 08, 2020 2:53 pm
Great, glad that worked for you. :)
this method didnt worked for me can you sugget something else?
the post is old so i will post specs after you reply
sleeper12
Level 13
Level 13
Posts: 4767
Joined: Thu May 25, 2017 3:22 pm

Re: [SOLVED] Wireless USB Adapter not detected

Post by sleeper12 »

mortal wrote:
Mon Oct 19, 2020 3:10 pm
sleeper12 wrote:
Wed Jul 08, 2020 2:53 pm
Great, glad that worked for you. :)
this method didnt worked for me can you sugget something else?
the post is old so i will post specs after you reply
You'll get better help if you start your own thread & post your specs there.
Post Reply

Return to “Wireless”