Archer T3U not working after installing drivers

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
azizmint
Level 1
Level 1
Posts: 3
Joined: Thu Oct 08, 2020 9:35 pm

Archer T3U not working after installing drivers

Post by azizmint »

My T3U isn't lighting up and doesn't work, it's fine on w10 btw.
this is it's lsusb thingy : Bus 003 Device 005: ID 2357:012d TP-Link USB Keyboard

I've used this forum post to resolve my problem but no good
viewtopic.php?p=1900272#p1900272

these are the commands i used from that forum post.

Code: Select all

sudo apt install git dkms
git clone https://github.com/cilynx/rtl88x2bu.git
sudo dkms add ./rtl88x2bu
sudo dkms install rtl88x2bu/5.6.1 


Linux Mint 20 Cinnamon
Cinnamon version 4.6.7
Kernel 5.4.0-48-generic
CPU Intel© Core™ i5-4690 CPU @ 3.50GHz × 4
RAM 7.7GiB
GPU NVIDIA Corporation GP106 [GeForce GTX 1060 3GB]
azizmint
Level 1
Level 1
Posts: 3
Joined: Thu Oct 08, 2020 9:35 pm

Re: Archer T3U not working after installing drivers

Post by azizmint »

also, for a strange reason i plugged my usb controller and it was not detected, i also plugged a usb drive and still not detected. i ran lsusb and as if they weren't plugged in the first place. what is going on :?
sleeper12
Level 13
Level 13
Posts: 4730
Joined: Thu May 25, 2017 3:22 pm

Re: Archer T3U not working after installing drivers

Post by sleeper12 »

Can we see:

Code: Select all

 rfkill list && mokutil --sb-state 
User avatar
RamBurner
Level 3
Level 3
Posts: 174
Joined: Wed Nov 23, 2011 7:31 pm

Re: Archer T3U not working after installing drivers

Post by RamBurner »

This is what worked for me for this adapter.

Code: Select all

sudo apt-get install build-essential git dkms linux-headers-$(uname -r)
git clone https://github.com/cilynx/rtl88x2bu
sudo dkms add rtl88x2bu
sudo dkms build rtl88x2bu/5.6.1
sudo dkms install rtl88x2bu/5.6.1

sudo reboot


To remove it 

sudo dkms remove rtl88x2bu/5.6.1 --all


To disable power management of the driver

echo "options 88x2bu rtw_power_mgnt=0" | sudo tee /etc/modprobe.d/88x2bu.conf
sudo rmmod 88x2bu
sudo modprobe 88x2bu
sudo service network-manager restart
Post Reply

Return to “Wireless”