Cannot get old Linksys WUSB54G v4 USB Wifi adapter working in Linux Mint 20

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
lpb331
Level 1
Level 1
Posts: 2
Joined: Sun Oct 11, 2020 1:46 pm

Cannot get old Linksys WUSB54G v4 USB Wifi adapter working in Linux Mint 20

Post by lpb331 »

I've been struggling to get this device to work in Linux Mint 20 64-bit. Unfortunately, I had to move my router to the other side of the house after upgrading from using coax cable to get internet to fiber optic. Now, I can't use ethernet for my desktop, and it's old enough that it didn't come with a wireless card built in, thus no internet at all for it at the moment. However, I did find an old Linksys WUSB54G v4 USB wifi adapter in my attic, so I hoped I could get it working. I was eventually able to in Windows 10, but Linux Mint has proved to be quite stubborn. When I plug it in, Linux Mint does see it, as lsusb returns, among other things,

Bus 002 Device 005: ID 13b1:000d Linksys WUSB54G v4 802.11g Adapter [Ralink RT2500USB]

At first, I just plugged it in, and the kernel loaded the rt2500usb module. Network Manager sees it, sees my wifi network, and after entering the password, it connects. But the connection to the internet seems to last for roughly half a second, and then it refuses to connect to any site whatsoever. I tried disabling power management and ipv6, but neither improved the situation.

So then I tried ndiswrapper. While I have it working on Windows 10, it's my understanding that ndiswrapper cannot work with Windows 10 drivers, so I couldn't just copy those drivers. (I tried, and ndiswrapper complained about not being able to understand some symbols in the driver's code.) I believe I found some older Windows XP 64-bit driver on Microsoft's Windows Update site, but after installing it via ndiswrapper, the driver does not seem to recognize that the adapter has been plugged in, and thus no wireless interface is created, as only lo and eth0 exist after looking at the iwconfig output.

Any ideas on how to get it working? I will do my best to give any additional info as needed. Thanks in advance!
User avatar
Larry78723
Level 10
Level 10
Posts: 3145
Joined: Wed Jan 09, 2019 7:01 pm
Location: Jasper County, SC, USA

Re: Cannot get old Linksys WUSB54G v4 USB Wifi adapter working in Linux Mint 20

Post by Larry78723 »

Please post an inxi -Fxxxz report. This will give us a concise overview of your hardware and on how Mint sees it.

Here is how to generate the report and post it:

Open a terminal window (Ctrl-Alt-t) with the WUSB54G plugged in . Make it fullscreen to avoid unneeded linebreaks or chopped lines. Execute the command

Code: Select all

 inxi -Fxxxz 
exactly as it has been typed here.

Mark the complete text output which the command will display with your mouse.
Press the keyboard shortcut <Shift><Ctrl>C to copy the marked text into the clipboard.
Enclose the results between the code markers by selecting </> from the mini toolbar above the textbox where you type your reply then paste <Ctrl>V them in your reply between the code markers.

The results will help us to help you.

Larry
Image
DAMIEN1307
Level 10
Level 10
Posts: 3494
Joined: Tue Feb 21, 2017 8:13 pm
Location: Alamogordo, New Mexico, USA

Re: Cannot get old Linksys WUSB54G v4 USB Wifi adapter working in Linux Mint 20

Post by DAMIEN1307 »

viewtopic.php?t=276111

This may or may not be of some help to you...DAMIEN
ORDO AB CHAO
"I refuse to be assimilated, I refuse to become one with the Borg Collective"
lpb331
Level 1
Level 1
Posts: 2
Joined: Sun Oct 11, 2020 1:46 pm

Re: Cannot get old Linksys WUSB54G v4 USB Wifi adapter working in Linux Mint 20

Post by lpb331 »

@Larry Unfortunately the desktop with the wireless adapter issue has no internet at all, so copy/paste is a no go, as I have to type this output on a laptop with internet access. That being said, I'll type up as much output from that command as I can here:

Code: Select all

System:     Kernel: 5.4.0-48-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: Cinnamon 4.6.7 dm: LightDM 1.30.0 Distro: Linux Mint 20 Ulyana
                   base: Ubuntu 20.04 focal
Machine:  Type: Desktop System: Dell product: Inspiron 518 v: 00 serial: <filter> Chassis: type: 3 serial: <filter> Mobo: Dell model: 0K068D v: A00
                   serial: <filter> BIOS: Dell v: 1.0.8 date: 03/30/2009
CPU:          Topology: Quad Core model: Intel Core2 Quad Q6600 bits: 64 type: MCP arch: Core Merom rev: B L2 cache: 4096 KiB flags: lm nx pae sse
                   sse2 sse3 ssse3 vmx bogomips: 19151 Speed: 1597 MHz min/max: 1600/2400 MHz Core speeds (MHz): 1: 1596 2: 1596 3: 1596 4: 1596
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] RV620 LE [Radeon HD 3450] vendor: Dell driver: radeon v: kernel bus ID: 01:00.0
                   chip ID: 1002:95c5
                   Display: x11 server: X.Org 1.20.8 driver: radeon resolution: 1366x768~60Hz, 1280x1024~60Hz
                   OpenGL: renderer: AMD RV620 (DRM 2.50.0 / 5.4.0-48-generic LLVM 10.0.0) v: 3.3 Mesa 20.0.8 compat-v: 3.0 direct render: Yes
Audio:       Device-1: Intel 82801I HD Audio vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:293e
                  Device-2: Advanced Micro Devices [AMD/ATI] RV620 HDMI Audio [Radeon HD 3450/3470/3550/3570] vendor: Dell driver: snd_hda_intel
                  v: kernel bus ID: 01:00.1 chip ID: 1002:aa28 Sound Server: ALSA v: k5-4-0.48-generic
Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell driver: r8169 v: kernel port: ce00 bus ID: 03:00.0
                  chip ID: 10ec:8168 IF: eth0 state: down mac: <filter>
                  Device-2: Linksys WUSB54G v4 80211g Adapter [Ralink RT2500USB] type: USB driver: usb-network bus ID: 2-2:7 chip ID: 13b1:000d
Drives:     Local Storage: total: 1.20 TiB used: 306.27 GiB (24.9%)
                 ID-1: /dev/sda vendor: Seagate model: ST1000DM003-1CH162 size: 931.51 GiB speed: 3.0 Gb/s rotation: 7200 rpm serial: <filter> rev: CC49
                 scheme: MBR
Partition: ID-1: / size: 106.15 GiB used: 55.65 GiB (52.4%) fs: ext4 dev: /dev/sda5
                 ID-2: swap-1 size: 8.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda6
Sensors: System Temperatures: cpu: 40.0 C mobo: N/A gpu: radeon temp: 79 C Fan Speeds (RPM): cpu: 1650 mobo: 1129
Info:        Processes: 197 Uptime: 2h 47 m Memory: 7.77 GiB used: 797.0 MiB (10.0%) Init: systemd v: 245 runlevel: 5 default: 2
                Compilers: gcc: 9.3.0 alt: 4.8/5/7/9 Shell: bash v: 4.0.17 running in: gnome-terminal inxi: 3.0.38
Hope this helps! At the moment, it's trying to load the ndiswrapper module I installed, and I blacklisted rt2500usb. I can restart without that if the resulting info would be useful.

@Damien: Not sure recompiling this kernel module would work. If I wasn't blacklisting rt2500usb, it would load, and even connect to my SSID. (If I misread something, let me know.
Post Reply

Return to “Wireless”