Bluetooth is "Dead" help please!

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
jd-the-fourth
Level 1
Level 1
Posts: 5
Joined: Wed Oct 14, 2020 6:29 am

Bluetooth is "Dead" help please!

Post by jd-the-fourth »

Hi!

im currently using cinnamon 20
my bluetooth is no longer working ive been looking around for a couple weeks now to try and figure out the problem i cant seem to find it. i am fairly new to linux but ive had bluetooth on this device before. anyway ive tried a couple of things restarting the bluetooth any way i try it doesnt help and my adapter doesnt even show up anywhere even tho i have an aorus pro-wifi board that has a wifi-blutooth card on it already. rfkill list only shows

Code: Select all

@josh-B450-AORUS-PRO-WIFI:~$ rfkill list
0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
and i tried this as well

Code: Select all

josh@josh-B450-AORUS-PRO-WIFI:~$ systemctl status bluetooth
● bluetooth.service - Bluetooth service
     Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor pre>
     Active: inactive (dead)
       Docs: man:bluetoothd(8)

Oct 14 03:18:46 josh-B450-AORUS-PRO-WIFI systemd[1]: Condition check resulted i>
Oct 14 03:19:14 josh-B450-AORUS-PRO-WIFI systemd[1]: Condition check resulted i>
Oct 14 03:20:47 josh-B450-AORUS-PRO-WIFI systemd[1]: Condition check resulted i>
Oct 14 03:22:23 josh-B450-AORUS-PRO-WIFI systemd[1]: Condition check resulted i>

and finally i the output of

Code: Select all

josh@josh-B450-AORUS-PRO-WIFI:~$ lsusb; dmesg | egrep -i 'blue|firm'
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 011: ID 054c:09cc Sony Corp. DualShock 4 [CUH-ZCT2x]
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
[    0.419976] ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
[    0.434557] acpi PNP0A08:00: [Firmware Info]: MMCONFIG for domain 0000 [bus 00-3f] only partially covers this bridge
[    0.910521] [drm] Found VCN firmware Version ENC: 1.9 DEC: 1 VEP: 0 Revision: 28
[    0.910522] [drm] PSP loading VCN firmware
[   23.558980] iwlwifi 0000:04:00.0: loaded firmware version 29.1654887522.0 op_mode iwlmvm
[   58.670208] audit: type=1400 audit(1602670654.443:55): apparmor="DENIED" operation="connect" profile="snap.bluez.obex" name="/run/dbus/system_bus_socket" pid=1117 comm="obexd" requested_mask="wr" denied_mask="wr" fsuid=0 ouid=0
[   58.834869] audit: type=1400 audit(1602670654.611:56): apparmor="DENIED" operation="create" profile="snap.bluez.bluez" pid=1116 comm="bluetoothd" family="bluetooth" sock_type="raw" protocol=1 requested_mask="create" denied_mask="create"
[   58.913875] audit: type=1400 audit(1602670654.687:57): apparmor="DENIED" operation="connect" profile="snap.bluez.bluez" name="/run/dbus/system_bus_socket" pid=1116 comm="bluetoothd" requested_mask="wr" denied_mask="wr" fsuid=0 ouid=0
[   59.030941] audit: type=1400 audit(1602670654.807:58): apparmor="DENIED" operation="connect" profile="snap.bluez.obex" name="/run/dbus/system_bus_socket" pid=1338 comm="obexd" requested_mask="wr" denied_mask="wr" fsuid=0 ouid=0
[   59.070696] audit: type=1400 audit(1602670654.847:59): apparmor="DENIED" operation="create" profile="snap.bluez.bluez" pid=1361 comm="bluetoothd" family="bluetooth" sock_type="raw" protocol=1 requested_mask="create" denied_mask="create"
[   59.070912] audit: type=1400 audit(1602670654.847:60): apparmor="DENIED" operation="connect" profile="snap.bluez.bluez" name="/run/dbus/system_bus_socket" pid=1361 comm="bluetoothd" requested_mask="wr" denied_mask="wr" fsuid=0 ouid=0
[   59.281248] audit: type=1400 audit(1602670655.055:61): apparmor="DENIED" operation="connect" profile="snap.bluez.obex" name="/run/dbus/system_bus_socket" pid=1386 comm="obexd" requested_mask="wr" denied_mask="wr" fsuid=0 ouid=0
[   59.282277] audit: type=1400 audit(1602670655.059:62): apparmor="DENIED" operation="create" profile="snap.bluez.bluez" pid=1385 comm="bluetoothd" family="bluetooth" sock_type="raw" protocol=1 requested_mask="create" denied_mask="create"
[   59.282435] audit: type=1400 audit(1602670655.059:63): apparmor="DENIED" operation="connect" profile="snap.bluez.bluez" name="/run/dbus/system_bus_socket" pid=1385 comm="bluetoothd" requested_mask="wr" denied_mask="wr" fsuid=0 ouid=0
[   59.530994] audit: type=1400 audit(1602670655.307:64): apparmor="DENIED" operation="create" profile="snap.bluez.bluez" pid=1430 comm="bluetoothd" family="bluetooth" sock_type="raw" protocol=1 requested_mask="create" denied_mask="create"

so yeah...no idea what i could have possibly done but any help at all would be greatly appreciated
User avatar
Larry78723
Level 10
Level 10
Posts: 3072
Joined: Wed Jan 09, 2019 7:01 pm
Location: Jasper County, SC, USA

Re: Bluetooth is "Dead" help please!

Post by Larry78723 »

Please post the results for each of the following commands. Here is how:

Open a terminal window (Ctrl-Alt-t). Make it fullscreen to avoid unneeded linebreaks or chopped lines. Execute the following commands, one at a time.

Code: Select all

inxi -Fxxxz

Code: Select all

mokutil --sb-state	

Code: Select all

rfkill list all

Code: Select all

 iwconfig

Code: Select all

lsusb

Code: Select all

 lspci 
Mark the complete text output which each command will display with your mouse.
Press the keyboard shortcut <Shift><Ctrl>C to copy the marked text into the clipboard.
Enclose the results for each command between the code markers by selecting </> from the mini toolbar above the textbox where you type your reply then paste <Ctrl>V them in your reply between the code markers.

The results will help us to help you.
Image
jd-the-fourth
Level 1
Level 1
Posts: 5
Joined: Wed Oct 14, 2020 6:29 am

Re: Bluetooth is "Dead" help please!

Post by jd-the-fourth »

inxi -fxxxz

Code: Select all

System:
  Host: josh-B450-AORUS-PRO-WIFI Kernel: 5.4.0-52-generic x86_64 bits: 64 
  compiler: gcc v: 7.5.0 Desktop: Cinnamon 4.4.8 wm: muffin 4.4.4 
  dm: LightDM 1.26.0 Distro: Linux Mint 19.3 Tricia 
  base: Ubuntu 18.04 bionic 
Machine:
  Type: Desktop System: Gigabyte product: B450 AORUS PRO WIFI v: N/A 
  serial: N/A 
  Mobo: Gigabyte model: B450 AORUS PRO WIFI-CF v: x.x serial: N/A 
  UEFI [Legacy]: American Megatrends v: F41 date: 07/22/2019 
Battery:
  Device-1: hidpp_battery_0 
  model: Logitech Wireless Touch Keyboard K400 Plus serial: <filter> 
  charge: 100% rechargeable: yes status: Discharging 
  Device-2: sony_controller_battery_ac:fd:93:b9:b2:8a model: N/A serial: N/A 
  charge: N/A status: Charging 
CPU:
  Topology: Quad Core model: AMD Ryzen 5 3400G with Radeon Vega Graphics 
  bits: 64 type: MT MCP arch: Zen rev: 1 L1 cache: 384 KiB 
  L2 cache: 2048 KiB L3 cache: 4096 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 59091 
  Speed: 1281 MHz min/max: 1400/3700 MHz boost: enabled Core speeds (MHz): 
  1: 1256 2: 1556 3: 1256 4: 1253 5: 1257 6: 2134 7: 1258 8: 1256 
Graphics:
  Device-1: AMD Picasso driver: amdgpu v: kernel bus ID: 07:00.0 
  chip ID: 1002:15d8 
  Display: server: X.Org 1.20.8 driver: amdgpu,ati 
  unloaded: fbdev,modesetting,vesa tty: N/A 
  OpenGL: renderer: AMD RAVEN (DRM 3.35.0 5.4.0-52-generic LLVM 10.0.0) 
  v: 4.6 Mesa 20.0.8 direct render: Yes 
Audio:
  Device-1: AMD driver: snd_hda_intel v: kernel bus ID: 07:00.1 
  chip ID: 1002:15de 
  Device-2: AMD vendor: Gigabyte driver: snd_hda_intel v: kernel 
  bus ID: 07:00.6 chip ID: 1022:15e3 
  Sound Server: ALSA v: k5.4.0-52-generic 
Network:
  Device-1: Intel I211 Gigabit Network vendor: Gigabyte driver: igb 
  v: 5.6.0-k port: f000 bus ID: 03:00.0 chip ID: 8086:1539 
  IF: eno1 state: down mac: <filter> 
  Device-2: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi 
  v: kernel port: f000 bus ID: 04:00.0 chip ID: 8086:24fb 
  IF: wlp4s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 2.04 TiB used: 145.63 GiB (7.0%) 
  ID-1: /dev/nvme0n1 vendor: KingDian model: NV480 240GB size: 223.57 GiB 
  speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: R0420B scheme: MBR 
  ID-2: /dev/sda vendor: Seagate model: ST2000DM008-2FR102 size: 1.82 TiB 
  speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: 0001 temp: 40 C 
  scheme: GPT 
Partition:
  ID-1: / size: 218.57 GiB used: 10.39 GiB (4.8%) fs: ext4 
  dev: /dev/nvme0n1p2 
  ID-2: /home size: 1.78 TiB used: 135.24 GiB (7.4%) fs: ext4 dev: /dev/sda2 
  ID-3: swap-1 size: 9.31 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda1 
Sensors:
  System Temperatures: cpu: 45.1 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 341 Uptime: 1h 46m Memory: 13.68 GiB used: 2.98 GiB (21.8%) 
  Init: systemd v: 237 runlevel: 5 Compilers: gcc: 7.5.0 alt: 7 
  Shell: bash (sudo) v: 4.4.20 running in: gnome-terminal inxi: 3.0.32 
mokutill --sb-state

Code: Select all

EFI variables are not supported on this system
  
rfkill list all

Code: Select all

0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
iwconfig

Code: Select all

eno1      no wireless extensions.

wlp4s0    IEEE 802.11  ESSID:"Luna"  
          Mode:Managed  Frequency:5.22 GHz  Access Point: 9C:34:26:17:65:7C   
          Bit Rate=325 Mb/s   Tx-Power=22 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=49/70  Signal level=-61 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:261   Missed beacon:0

lo        no wireless extensions.
lspci

Code: Select all

00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15d0
00:00.2 IOMMU: Advanced Micro Devices, Inc. [AMD] Device 15d1
00:01.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) PCIe Dummy Host Bridge
00:01.2 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 15d3
00:08.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) PCIe Dummy Host Bridge
00:08.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 15db
00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD] FCH SMBus Controller (rev 61)
00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD] FCH LPC Bridge (rev 51)
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15e8
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15e9
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15ea
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15eb
00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15ec
00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15ed
00:18.6 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15ee
00:18.7 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15ef
01:00.0 USB controller: Advanced Micro Devices, Inc. [AMD] Device 43d5 (rev 01)
01:00.1 SATA controller: Advanced Micro Devices, Inc. [AMD] Device 43c8 (rev 01)
01:00.2 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 43c6 (rev 01)
02:00.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 43c7 (rev 01)
02:01.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 43c7 (rev 01)
02:04.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 43c7 (rev 01)
02:08.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 43c7 (rev 01)
03:00.0 Ethernet controller: Intel Corporation I211 Gigabit Network Connection (rev 03)
04:00.0 Network controller: Intel Corporation Dual Band Wireless-AC 3168NGW [Stone Peak] (rev 10)
06:00.0 Non-Volatile memory controller: Silicon Motion, Inc. Device 2263 (rev 03)
07:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Picasso (rev c8)
07:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Device 15de
07:00.2 Encryption controller: Advanced Micro Devices, Inc. [AMD] Device 15df
07:00.3 USB controller: Advanced Micro Devices, Inc. [AMD] Device 15e0
07:00.4 USB controller: Advanced Micro Devices, Inc. [AMD] Device 15e1
07:00.6 Audio device: Advanced Micro Devices, Inc. [AMD] Device 15e3
lsusb

Code: Select all

Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 020: ID 054c:05c4 Sony Corp. DualShock 4
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
there is everything you asked for sorry for the late reply had work and such haha. anyway am i just stupid here? lol because i know i had bluetooth on this computer not too long ago.
jd-the-fourth
Level 1
Level 1
Posts: 5
Joined: Wed Oct 14, 2020 6:29 am

Re: Bluetooth is "Dead" help please!

Post by jd-the-fourth »

oh also i know i put i was using mint 20 but i dialed it back to 19.3 and the problem still persists i dont know if thats important but i guess that would mean either the issue isnt the version and something else? or that the problem just exists on both...im not entirely sure honestly
User avatar
Larry78723
Level 10
Level 10
Posts: 3072
Joined: Wed Jan 09, 2019 7:01 pm
Location: Jasper County, SC, USA

Re: Bluetooth is "Dead" help please!

Post by Larry78723 »

It might be that the Logitech Unifying Receiver may be interfering. If you have a wired mouse, connect it and remove the Logitech Unifying Receiver then reboot. Also, you might want to put new batteries in the wireless mouse.
Image
jd-the-fourth
Level 1
Level 1
Posts: 5
Joined: Wed Oct 14, 2020 6:29 am

Re: Bluetooth is "Dead" help please!

Post by jd-the-fourth »

I don't have a wired mouse or anything currently I'm using a wireless keyboard with a trackpad haha I can try that when I do get one also I recently replaced the batteries? And ive had the dongle installed as long as ive had the pc and it recently(last month) had no issues with bluetooth, would it just randomly become a problem?
User avatar
Larry78723
Level 10
Level 10
Posts: 3072
Joined: Wed Jan 09, 2019 7:01 pm
Location: Jasper County, SC, USA

Re: Bluetooth is "Dead" help please!

Post by Larry78723 »

Then disregard my last post. I have no other ideas.
Image
jd-the-fourth
Level 1
Level 1
Posts: 5
Joined: Wed Oct 14, 2020 6:29 am

Re: Bluetooth is "Dead" help please!

Post by jd-the-fourth »

Damn lol thanks anyway man I appreciate you trying to help me!!
Post Reply

Return to “Wireless”