Tenda w311mi not working

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
satya
Level 1
Level 1
Posts: 4
Joined: Mon Oct 19, 2020 11:18 am

Tenda w311mi not working

Post by satya »

Hello Guys
Hope everyone is keeping well and fit these days

I bought a tenda w311mi usb wifi adapter for laptop but it seems it is not able to create network interface for itself and hence not able to use it
i tried to fllow other posts related to somwhat similar problems but failed to make it work for me

below are some details required to understand the problem

Code: Select all

$ inxi -Nn
Network:   Device-1: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169 
           IF: enp1s0 state: down mac: f4:30:b9:85:56:4c 
           Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter driver: rtl8723be 
           IF: wlo1 state: up mac: f8:28:19:45:f1:cb 
           Device-3: Realtek 802.11n WLAN Adapter type: USB driver: option,option1 

Code: Select all

 lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 04f2:b56c Chicony Electronics Co., Ltd HP TrueVision HD
Bus 001 Device 003: ID 0bda:b008 Realtek Semiconductor Corp. Bluetooth Radio 
Bus 001 Device 005: ID 413c:301a Dell Computer Corp. Dell MS116 USB Optical Mouse
Bus 001 Device 009: ID 0bda:b711 Realtek Semiconductor Corp. 802.11n WLAN Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Code: Select all

$ rfkill list all
0: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
1: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
when i plug it in it doesnt create network interface and i think thats where the issue is but i'm not able to figure that out

i also tried to install the dirvers available https://www.tendacn.com/in/download/detail-2536.html but was getting below error while performing make

Code: Select all

$ sudo make
make -C tools
make[1]: Entering directory '/home/useradmin/Downloads/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/tools'
gcc -g bin2h.c -o bin2h
make[1]: Leaving directory '/home/useradmin/Downloads/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/tools'
/home/useradmin/Downloads/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/tools/bin2h
cp -f os/linux/Makefile.6 /home/useradmin/Downloads/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/os/linux/Makefile
make -C /lib/modules/5.4.0-26-generic/build SUBDIRS=/home/useradmin/Downloads/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/os/linux modules
make[1]: Entering directory '/usr/src/linux-headers-5.4.0-26-generic'
make[2]: *** No rule to make target 'arch/x86/tools/relocs_32.c', needed by 'arch/x86/tools/relocs_32.o'.  Stop.
make[1]: *** [arch/x86/Makefile:232: archscripts] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-5.4.0-26-generic'
make: *** [Makefile:389: LINUX] Error 2
please suggest any possible solution for this issue

THanks!!
User avatar
Larry78723
Level 10
Level 10
Posts: 3145
Joined: Wed Jan 09, 2019 7:01 pm
Location: Jasper County, SC, USA

Re: Tenda w311mi not working

Post by Larry78723 »

Try the solutions at https://easylinuxtipsproject.blogspot.c ... k.html#ID3 to try and get your internal wifi working without the Tenda plugged in.
Image
satya
Level 1
Level 1
Posts: 4
Joined: Mon Oct 19, 2020 11:18 am

Re: Tenda w311mi not working

Post by satya »

Hey Larry thank you for responding

THe problem is my laptop wifi works only when it's near to router else it just doesnt show networks, i mean thats very strange on widnows it works fine :lol:

I tried given link and it works only for ant_sel=1 and 2 or 3 number didnt work for me

any suggestion to make it work on either of the devices laptop wifi or usb wifi
sleeper12
Level 13
Level 13
Posts: 4767
Joined: Thu May 25, 2017 3:22 pm

Re: Tenda w311mi not working

Post by sleeper12 »

Can we see:

Code: Select all

 iwconfig 
satya
Level 1
Level 1
Posts: 4
Joined: Mon Oct 19, 2020 11:18 am

Re: Tenda w311mi not working

Post by satya »

Sure here's the output

Code: Select all

$ iwconfig 
lo        no wireless extensions.

enp1s0    no wireless extensions.

wlo1      IEEE 802.11  ESSID:"VIBE K5 Note"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 66:DB:43:50:61:FC   
          Bit Rate=72.2 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off
          Link Quality=24/70  Signal level=-86 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:23   Missed beacon:0
now it's connected to my cellphone
sleeper12
Level 13
Level 13
Posts: 4767
Joined: Thu May 25, 2017 3:22 pm

Re: Tenda w311mi not working

Post by sleeper12 »

User avatar
Larry78723
Level 10
Level 10
Posts: 3145
Joined: Wed Jan 09, 2019 7:01 pm
Location: Jasper County, SC, USA

Re: Tenda w311mi not working

Post by Larry78723 »

I just checked and the linux driver for the Tenda w311mi hasn't been updated since October, 2012 and has to be compiled. Designed for linux kernel 3.4 - 3.6.
Image
sleeper12
Level 13
Level 13
Posts: 4767
Joined: Thu May 25, 2017 3:22 pm

Re: Tenda w311mi not working

Post by sleeper12 »

I found this too:

"You are probably out of luck: (lwinger is the one person who collects pretty much all realtek drivers)
https://github.com/lwfinger/rtl8188gu wrote:

IMPORTANT - PLEASE READ:

I have not found a Linux driver for the RTL8188GU.

This one will build, but it will fail on your device."
sleeper12
Level 13
Level 13
Posts: 4767
Joined: Thu May 25, 2017 3:22 pm

Re: Tenda w311mi not working

Post by sleeper12 »

Larry,

Do you suppose the rtl8192cu driver might work?
User avatar
Larry78723
Level 10
Level 10
Posts: 3145
Joined: Wed Jan 09, 2019 7:01 pm
Location: Jasper County, SC, USA

Re: Tenda w311mi not working

Post by Larry78723 »

This may sound crazy but there's a reason for my asking. Do you have a cell phone? If so, can you connect to your wifi from it? The reason I'm asking is that your iwconfig Link Quality and Signal level are low. I'm trying to determine if your router might be dying.
Image
User avatar
Larry78723
Level 10
Level 10
Posts: 3145
Joined: Wed Jan 09, 2019 7:01 pm
Location: Jasper County, SC, USA

Re: Tenda w311mi not working

Post by Larry78723 »

@sleeper12 - I doubt the rtl8192cu driver would work.
Image
sleeper12
Level 13
Level 13
Posts: 4767
Joined: Thu May 25, 2017 3:22 pm

Re: Tenda w311mi not working

Post by sleeper12 »

Larry78723 wrote:
Tue Oct 20, 2020 1:44 pm
@sleeper12 - I doubt the rtl8192cu driver would work.
I saw it listed as a possible alternate driver, but ok.
User avatar
Larry78723
Level 10
Level 10
Posts: 3145
Joined: Wed Jan 09, 2019 7:01 pm
Location: Jasper County, SC, USA

Re: Tenda w311mi not working

Post by Larry78723 »

I'd wait for his reply to my query. With numbers like this: Link Quality=24/70 Signal level=-86 dBm his router might be dying. If his router is dying it doesn't matter what driver is in his machine.
Image
sleeper12
Level 13
Level 13
Posts: 4767
Joined: Thu May 25, 2017 3:22 pm

Re: Tenda w311mi not working

Post by sleeper12 »

Exactly.
satya
Level 1
Level 1
Posts: 4
Joined: Mon Oct 19, 2020 11:18 am

Re: Tenda w311mi not working

Post by satya »

Guys it's the device i replaced that with tp-link usb wifi device and that worked instantly

Thanks you for all your responses
User avatar
Larry78723
Level 10
Level 10
Posts: 3145
Joined: Wed Jan 09, 2019 7:01 pm
Location: Jasper County, SC, USA

Re: Tenda w311mi not working

Post by Larry78723 »

Glad you found an adapter that works.

Please edit the subject of your original post and add [Solved] to it.
Image
Post Reply

Return to “Wireless”