Mint Linux (BEA) and Broadcom 4306

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
User avatar
woopud
Level 1
Level 1
Posts: 9
Joined: Wed Dec 20, 2006 11:00 am
Location: Colorado

Mint Linux (BEA) and Broadcom 4306

Post by woopud » Tue Dec 26, 2006 10:45 pm

Okay, I installed Mint Linux on my HP laptop. Then followed all the instructions to install the BCM4306 driver but it still doesn't work. Here some outputs if it helps.

Code: Select all

woopud@woopud-laptop:~$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      IEEE 802.11b/g  ESSID:""  Nickname:"Broadcom 4306"
          Mode:Managed  Access Point: Invalid   
          RTS thr:off   Fragment thr:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

woopud@woopud-laptop:~$ sudo ndiswrapper -l
Installed drivers:
bcmwl5          driver installed, hardware present 
woopud@woopud-laptop:~$ sudo iwconfig eth1 essid galaxy
woopud@woopud-laptop:~$ sudo ifconfig eth1 up
SIOCSIFFLAGS: No such file or directory
woopud@woopud-laptop:~$ sudo dhclient
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

SIOCSIFFLAGS: No such file or directory
SIOCSIFFLAGS: No such file or directory
Listening on LPF/eth1/00:90:4b:a3:68:8a
Sending on   LPF/eth1/00:90:4b:a3:68:8a
Listening on LPF/eth0/00:0f:b0:47:92:2e
Sending on   LPF/eth0/00:0f:b0:47:92:2e
Sending on   Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
receive_packet failed on eth1: Network is down
DHCPOFFER from 192.168.0.1
DHCPREQUEST on eth0 to 255.255.255.255 port 67
DHCPACK from 192.168.0.1
bound to 192.168.0.5 -- renewal in 37502 seconds.
woopud@woopud-laptop:~$ sudo ndiswrapper  -m
modprobe config already contains alias directive

woopud@woopud-laptop:~$ 


scorp123
Level 8
Level 8
Posts: 2277
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Re: Mint Linux (BEA) and Broadcom 4306

Post by scorp123 » Tue Dec 26, 2006 11:12 pm

woopud wrote:Okay, I installed Mint Linux on my HP laptop. Then followed all the instructions to install the BCM4306 driver but it still doesn't work.

Which HP laptop is it? And did you see this thread?
http://lt.k1011.nutime.de/forum/viewtop ... =2367#2367

User avatar
woopud
Level 1
Level 1
Posts: 9
Joined: Wed Dec 20, 2006 11:00 am
Location: Colorado

Post by woopud » Tue Dec 26, 2006 11:40 pm

It's a HP Pavilion zv5466cl
I installed the firmware according to your suggestion then I got this output:

Code: Select all

woopud@woopud-laptop:~$ sudo rmmod bcm43xx
woopud@woopud-laptop:~$ sudo modprobe bcm43xx
woopud@woopud-laptop:~$ dmesg | grep bcm
[17179610.916000] bcm43xx driver
[17179612.360000] bcm43xx: Error: Microcode "bcm43xx_microcode5.fw" not available or load failed.
[17179612.368000] bcm43xx: Error: Microcode "bcm43xx_microcode5.fw" not available or load failed.
[17179627.752000] bcm43xx: Error: Microcode "bcm43xx_microcode5.fw" not available or load failed.
[17182601.220000] bcm43xx driver
woopud@woopud-laptop:~$ 
Bert

User avatar
woopud
Level 1
Level 1
Posts: 9
Joined: Wed Dec 20, 2006 11:00 am
Location: Colorado

Post by woopud » Tue Dec 26, 2006 11:42 pm

I forgot to mention that my wireless does show up under System -> Administration -> Networking but not under the Network-Manager

Bert

User avatar
woopud
Level 1
Level 1
Posts: 9
Joined: Wed Dec 20, 2006 11:00 am
Location: Colorado

Post by woopud » Thu Dec 28, 2006 1:42 am

Got it all working now, was fighting with this in Ubuntu for a month!
Mint Linux rocks !

Bert

User avatar
jml
Level 1
Level 1
Posts: 20
Joined: Sat Dec 23, 2006 1:03 am
Location: Albert Lea, Minnesota, USA

Broadcom Wireless

Post by jml » Thu Dec 28, 2006 4:22 pm

woopud, would you please post the steps you took to make the Broadcom adapter work, please? I have an HPnx6110 and it uses the same Broadcom chip set. Thanks.

Joe

User avatar
woopud
Level 1
Level 1
Posts: 9
Joined: Wed Dec 20, 2006 11:00 am
Location: Colorado

Post by woopud » Sat Dec 30, 2006 2:50 pm

Joe,

I used theseinstructions to get mine to work, hope it helps you.
http://linuxmint.com/forum/viewtopic.php?t=458

Bert

User avatar
jml
Level 1
Level 1
Posts: 20
Joined: Sat Dec 23, 2006 1:03 am
Location: Albert Lea, Minnesota, USA

Thanks

Post by jml » Mon Jan 01, 2007 7:00 pm

Thanks for the info, Bert. I'll give it a go.

Joe

User avatar
manishk
Level 3
Level 3
Posts: 178
Joined: Wed Nov 29, 2006 4:19 pm
Location: India

Post by manishk » Thu Jan 04, 2007 5:06 am

I too have a HP laptop (nx6325) and all I needed to do was uninstall the driver that comes by default and install the Windows driver that HP gave using NDISwrapper.

It never worked in Ubuntu...but it just did in Mint. It really does rock.

mondomunchies
Level 1
Level 1
Posts: 1
Joined: Mon Feb 05, 2007 1:04 am

Post by mondomunchies » Mon Feb 05, 2007 1:14 am

That link is broken. I was having the same problem. I fixed it by getting the firmware at http://www.essetee.be/downloads/bcm-firmware.tar.bz2 and extracting that to /lib/firmware/2.6.17-10-generic. Then I used:

sudo iwconfig eth1 enc open
sudo iwconfig eth1 mode auto
sudo iwconfig eth1 essid my_essid
sudo ifconfig eth1 up

And to finish I had to go to Preferences > Network Proxy, under the Proxy Configuration tab I chose Automatic Proxy Configuration, URL: 192.168.1.1.

That finally fixed everything. I hope that helps.

robdob
Level 1
Level 1
Posts: 1
Joined: Mon Feb 05, 2007 4:57 am

Post by robdob » Mon Feb 05, 2007 5:08 am

I extracted the files to the specified directory, and have followed all of the other steps, but I'm still receiving error messages. Here's what I'm getting:
robby@robby-laptop:~$ sudo iwconfig eth1 enc open
Password:
robby@robby-laptop:~$ sudo iwconfig eth1 mode auto
robby@robby-laptop:~$ sudo iwconfig eth1 essid laptop
robby@robby-laptop:~$ sudo ifconfig eth1 up
SIOCSIFFLAGS: No such file or directory
I've tried different combinations of the other commands, including the ones listed in the mint wifi page and the commands listed above, but I always receive that error message after the eth1 up command. Anybody got any ideas?

Lustwicht
Level 1
Level 1
Posts: 2
Joined: Mon Feb 12, 2007 12:29 pm
Location: Grevenbroich, Germany
Contact:

How's it...

Post by Lustwicht » Wed Feb 14, 2007 3:21 pm

Hey!
I have the same chip, but in a Fujitsu Siemens notebook. I'm currently using Kubuntu 6.06 but the Mint download is running :D (already at 15%, heheh). I have a WEP encrypted WLAN network with a hidden ESSID. The sad thing is that Kubuntu can't handle with the hidden ESSID and doesn't find my network. Does anyone know whether this works under Linux Mint Bea or Bianca?
Thanks!

Post Reply

Return to “Wireless”