Page 1 of 1

madwifi drivers dont work right

Posted: Mon Jan 01, 2007 9:52 pm
by katasuka
greetings,

just wanted to note the madwifi drivers on boot doesnt work right. to get them working i have to modprobe ath_pci and dhclient ath0 to get my atheros based wifi card working. might wanna check on that and see if something has a minor config error.

on xubuntu using madwifi my card works out of the box without having to configure it.

problems with madwifi in Bea

Posted: Sat Jan 06, 2007 10:17 pm
by Nashty
I too am having problems with madwifi in Bea. dmesg output says something about unknown symbols (even if I manually modprobe ath_pci).

Has this been resolved or should I wait to install Linux Mint on my laptop (I have integrated ethernet as well, so if there's an update available then it's no big deal)?

Posted: Fri Jan 12, 2007 6:31 am
by katasuka
well if u can get temporary access to the net on the affected machine, u can try to compile the madwifi drivers from source although i wouldnt suggest this unless u know the basics of whats involved.

other than that, all i can suggest is to try this in this order after first boot up:
sudo modprobe -r ath_pci
sudo modprobe ath_pci
sudo iwconfig ath0 essid ESSIDOFROUTER
sudo dhcpcd ath0

if sudo dhcpcd ath0 doesnt work then its sudo dhclient ath0
i cant remember which one it is as the hard drive that has my linux mint installed on is packed up ready to be shipped to where im moving. im on my file server which i quickly modded into a desktop.

if those dont work then u might have to wait till a developer looks into it and sees whats going on.

Posted: Sun Jan 14, 2007 6:35 pm
by Nashty
Yeah that doesn't do it for me, just more unresolved symbols errors. :(

Athros madwifi

Posted: Sat Feb 17, 2007 11:41 pm
by jimslinux
ThinkPad A22m with Netgear wg-511t pcmcia. Works with madwifi drivers on other distros. Not currently with mint. I hope the output below can help. I am running mint live and will try on hard drive later. It appears that there is no, or no communication of mad wifi-hal to see the card. Ideas anyone?

>mint@mint:~$ sudo modprobe -r ath_pci
>mint@mint:~$ sudo modprobe ath_pci
>WARNING: Error inserting ath_rate_sample (/lib/modules/2.6.17
-10-generic/madwifi/ath_sample.ko): Unknown symbol in modul >e, or unknown parameter (see dmesg)
>FATAL: Error inserting ath_pci (/lib/modules/2.6.17-10-generic/
madwifi/ath_pci.ko): Unknown symbol in module, or unknown p
arameter (see dmesg)

Below is dmesg's of possible interest.--------------------------------
>mint@mint:~$ dmesg
>[17179569.184000] linux version 2.6.17-10-generic (root@verna
dsky) (gcc version 4.1.2 20060928 (prerelease) (Ubuntu 4.1.1-1
3ubuntu5)) #2 smp fri oct 13 18:45:35 UTC 2006 (Ubuntu 2.6.17
-10.33-generic)
Later at the end of dmesg
>[17179706.812000] pccard: CardBus card inserted into slot 1
>[17179707.124000] wlan: 0.8.4.2 (0.9.2.1)
>[17179707.128000] ath_rate_sample: Unknown symbol ath_hal_
computetxtime
>[17179707.188000] gameport: CS46xx Gameport is pci0000:00:
05.0/gameport0, speed1807khz
>[17179707.244000] ath_pci: Unknown symbol ath_rate_tx_complete
>[17179707.244000] ath_pci: Unknown symbol _ath_hal_attach
>[17179707.244000] ath_pci: Unknown symbol ath_rate_attach
>[17179707.244000] ath_pci: Unknown symbol ath_rate_newassoc
>[17179707.244000] ath_pci: Unknown symbol ath_hal_computetxtime
>[17179707.244000] ath_pci: Unknown symbol ath_rate_dynamic_
proc_register
>[17179707.248000] ath_pci: Unknown symbol ath_hal_mhz2ieee
>[17179707.248000] ath_pci: Unknown symbol ath_hal_detach
>[17179707.248000] ath_pci: Unknown symbol ath_hal_probe
>[17179707.248000] ath_pci: Unknown symbol ath_rate_node_cleanup
>[17179707.248000] ath_pci: Unknown symbol ath_rate_detach
>[17179707.252000] ath_pci: Unknown symbol ath_rate_node_init
>[17179707.252000] ath_pci: Unknown symbol ath_rate_findrate
>[17179707.252000] ath_pci: Unknown symbol ath_hal_init_channels
>[17179707.252000] ath_pci: Unknown symbol ath_rate_newstate
>[17179707.252000] ath_pci: Unknown symbol ath_rate_setupxtxdesc
>[17179707.252000] ath_pci: Unknown symbol ath_hal_getwirelessmodos
Later in dmesg ----------------------------------------------------------
>[17179936.484000] ath_rate_sample: Unknown symbol ath_hal_
computetxtime
>[17179936.488000] ath_pci: Unknown symbol ath_rate_tx_complete
>[17179936.488000] ath_pci: Unknown symbol _ath_hal_attach
>[17179936.488000] ath_pci: Unknown symbol ath_rate_newassoc
>[17179936.492000] ath_pci: Unknown symbol ath_hal_computetxtime
>[17179936.492000] ath_pci: Unknown symbol ath_rate_dynamic_
proc_register
>[17179936.492000] ath_pci: Unknown symbol ath_hal_mhz2ieee
>[17179936.492000] ath_pci: Unknown symbol ath_hal_detach
>[17179936.496000] ath_pci: Unknown symbol ath_hal_probe
>[17179936.496000] ath_pci: Unknown symbol ath_rate_node_cleanup
>[17179936.496000] ath_pci: Unknown symbol ath_rate_detach
>[17179936.496000] ath_pci: Unknown symbol ath_rate_node_init
>[17179936.500000] ath_pci: Unknown symbol ath_rate_findrate
>[17179936.500000] ath_pci: Unknown symbol ath_hal_init_channels
>[17179936.500000] ath_pci: Unknown symbol ath_rate_newstate
>[17179936.500000] ath_pci: Unknown symbol ath_rate_setupxtxdesc
>[17179936.500000] ath_pci: Unknown symbol ath_hal_getwirelessmodes
>[17179996.276000] wlan: driver unloaded
>[17180038.316000] wlan: 0.8.4.2 (0.9.2.1)
>[17180038.316000] ath_rate_sample: Unknown symbol ath_hal_co
mputetxtime
>[17180038.320000] ath_pci: Unknown symbol ath_rate_complete
>[17180038.324000] ath_pci: Unknown symbol _ath_hal_attach
>[17180038.324000] ath_pci: Unknown symbol ath_rate_attach
>[17180038.324000] ath_pci: Unknown symbol ath_rate_newassoc
>[17180038.324000] ath_pci: Unknown symbol ath_hal_computetxtime
>[17180038.324000] ath_pci: Unknown symbol ath_rate_dynamic_
proc_register
>[17180038.328000] ath_pci: Unknown symbol ath_hal_mhz2eee
>[17180038.328000] ath_pci: Unknown symbol ath_hal_detach
>[17180038.328000] ath_pci: Unknown symbol ath_hal_probe
>[17180038.328000] ath_pci: Unknown symbol ath_rate_node_cleanup
>[17180038.328000] ath_pci: Unknown symbol ath_rate_detach
>[17180038.332000] ath_pci: Unknown symbol ath_rate_node_init
>[17180038.332000] ath_pci: Unknown symbol ath_rate_findrate
>[17180038.332000] ath_pci: Unknown symbol ath_hal_init_channels
>[17180038.332000] ath_pci: Unknown symbol ath_rate_newstate
>[17180038.332000] ath_pci: Unknown symbol ath_rate_setupxtxdesc
>[17180038.332000] ath_pci: Unknown symbol ath_hal_getwirelessmodes
>mint@mint:~$
Sorry for misprints if any >>END