problem with wireless Ethernet on Compaq Presario CQ61-420US

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
linuxluvr
Level 1
Level 1
Posts: 5
Joined: Wed Sep 22, 2010 1:16 pm

problem with wireless Ethernet on Compaq Presario CQ61-420US

Post by linuxluvr »

Greetings. I am presently experiencing a problem in using my new Compaq
CQ61 laptop's wireless communications circuitry. I found a posting from
a year ago at http://ubuntuforums.org/showthread.php?p=7717667 that
describes the problem with another model of the CQ61 and gives a
solution, which involves installing a package called "linux-backports-
modules-jaunty," which I can't find, and probably doesn't apply to newer
versions of Ubuntu Linux anyway, to say nothing of Linux Mint.

I'm wondering whether finding a more recent version of this package
could be expected to fix the problem also, or if "all bets are off" at
this point. I did find something called "linux-backports-modules-
wireless-2.6.32-24-generic," but it fails to install, apparently due to
dpkg not liking the downloaded module (see http://pastebin.ca/1943245
for the details of what happens when I try doing that installation).

Has anyone heard of this problem, and/or does someone maybe have any
suggestions for approaching it?

Thanks much in advance!


"mintwifi" produces (run with wifi enabled, but with an Ethernet
cable plugged into my router and wifi turned off on the router,
though it was enabled for the later tests shown below):

lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off

eth0 Link encap:Ethernet HWaddr 00:26:9e:bf:c1:1d
inet6 addr: fe80::226:9eff:febf:c11d/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:198573 errors:0 dropped:0 overruns:0 frame:0
TX packets:304369 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:106730371 (106.7 MB) TX bytes:292321135 (292.3 MB)
Interrupt:27

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:3845 errors:0 dropped:0 overruns:0 frame:0
TX packets:3845 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:284096 (284.0 KB) TX bytes:284096 (284.0 KB)

wlan0 Link encap:Ethernet HWaddr 90:4c:e5:37:e2:c5
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

Internet Systems Consortium DHCP Client V3.1.3
Copyright 2004-2009 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/wlan0/90:4c:e5:37:e2:c5
Sending on LPF/wlan0/90:4c:e5:37:e2:c5
Listening on LPF/eth0/00:26:9e:bf:c1:1d
Sending on LPF/eth0/00:26:9e:bf:c1:1d
Sending on Socket/fallback
DHCPREQUEST of 192.168.2.12 on eth0 to 255.255.255.255 port 67
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 6
DHCPACK of 192.168.2.12 from 192.168.2.1
bound to 192.168.2.12 -- renewal in 2147483648 seconds.
Server: 192.168.2.1
Address: 192.168.2.1#53

Non-authoritative answer:
Name: google.com
Address: 173.194.34.104

-------------------------
* I. scanning WIFI PCI devices...
-- Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
==> PCI ID = 168c:002b (rev 01)
-------------------------
* II. querying ndiswrapper...
-------------------------
* III. querying iwconfig...
-------------------------
* IV. querying ifconfig...
-------------------------
* V. querying DHCP...
-------------------------
* VI. querying nslookup google.com...

--

"iwconfig" produces:

| lo no wireless extensions.
|
| eth0 no wireless extensions.
|
| wlan0 IEEE 802.11bgn ESSID:off/any
| Mode:Managed Access Point: Not-Associated Tx-Power=off
| Retry long limit:7 RTS thr:off Fragment thr:off
| Power Management:off

"lspci" says:

| 00:00.0 Host bridge: Advanced Micro Devices [AMD] RS780 Host Bridge Alternate
| 00:01.0 PCI bridge: Hewlett-Packard Company Device 9602
| 00:05.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 1)
| 00:06.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 2)
| 00:11.0 SATA controller: ATI Technologies Inc SB700/SB800 SATA Controller [AHCI mode]
| 00:12.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
| 00:12.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller
| | wlan0 IEEE 802.11bgn ESSID:off/any
| 00:12.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
| 00:13.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
| 00:13.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller
| 00:13.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
| 00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 3c)
| 00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
| 00:14.3 ISA bridge: ATI Technologies Inc SB700/SB800 LPC host controller
| 00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
| 00:18.0 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] HyperTransport Configuration
| 00:18.1 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Address Map
| 00:18.2 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] DRAM Controller
| 00:18.3 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Miscellaneous Control
| 00:18.4 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Link Control
| 01:05.0 VGA compatible controller: ATI Technologies Inc M880G [Mobility Radeon HD 4200]
| 02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
| 03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)


lsusb:

| Bus 006 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
| Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
| Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
| Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
| Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
| Bus 001 Device 003: ID 046d:c517 Logitech, Inc. LX710 Cordless Desktop Laser
| Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

ifconfig:

| eth0 Link encap:Ethernet HWaddr 00:26:9e:bf:c1:1d
| inet addr:192.168.2.12 Bcast:192.168.2.255 Mask:255.255.255.0
| inet6 addr: fe80::226:9eff:febf:c11d/64 Scope:Link
| UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
| RX packets:8918904 errors:0 dropped:0 overruns:0 frame:0
| TX packets:7194461 errors:0 dropped:0 overruns:0 carrier:0
| collisions:0 txqueuelen:1000
| RX bytes:10896896641 (10.8 GB) TX bytes:1614876717 (1.6 GB)
| Interrupt:27 Base address:0x2000
|
| lo Link encap:Local Loopback
| inet addr:127.0.0.1 Mask:255.0.0.0
| inet6 addr: ::1/128 Scope:Host
| UP LOOPBACK RUNNING MTU:16436 Metric:1
| RX packets:929734 errors:0 dropped:0 overruns:0 frame:0
| TX packets:929734 errors:0 dropped:0 overruns:0 carrier:0
| collisions:0 txqueuelen:0
| RX bytes:11629535731 (11.6 GB) TX bytes:11629535731 (11.6 GB)
|
| wlan0 Link encap:Ethernet HWaddr 90:4c:e5:37:e2:c5
| UP BROADCAST MULTICAST MTU:1500 Metric:1
| RX packets:0 errors:0 dropped:0 overruns:0 frame:0
| TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
| collisions:0 txqueuelen:1000
| RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
|
| wlan0:avahi Link encap:Ethernet HWaddr 90:4c:e5:37:e2:c5
| inet addr:169.254.11.29 Bcast:169.254.255.255 Mask:255.255.0.0
| UP BROADCAST MULTICAST MTU:1500 Metric:1

ifconfig -a:

| eth0 Link encap:Ethernet HWaddr 00:26:9e:bf:c1:1d
| inet addr:192.168.2.12 Bcast:192.168.2.255 Mask:255.255.255.0
| inet6 addr: fe80::226:9eff:febf:c11d/64 Scope:Link
| UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
| RX packets:8920635 errors:0 dropped:0 overruns:0 frame:0
| TX packets:7196588 errors:0 dropped:0 overruns:0 carrier:0
| collisions:0 txqueuelen:1000
| RX bytes:10897146449 (10.8 GB) TX bytes:1616088591 (1.6 GB)
| Interrupt:27 Base address:0x2000
|
| lo Link encap:Local Loopback
| inet addr:127.0.0.1 Mask:255.0.0.0
| inet6 addr: ::1/128 Scope:Host
| UP LOOPBACK RUNNING MTU:16436 Metric:1
| RX packets:930486 errors:0 dropped:0 overruns:0 frame:0
| TX packets:930486 errors:0 dropped:0 overruns:0 carrier:0
| collisions:0 txqueuelen:0
| RX bytes:11638366706 (11.6 GB) TX bytes:11638366706 (11.6 GB)
|
| wlan0 Link encap:Ethernet HWaddr 90:4c:e5:37:e2:c5
| UP BROADCAST MULTICAST MTU:1500 Metric:1
| RX packets:0 errors:0 dropped:0 overruns:0 frame:0
| TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
| collisions:0 txqueuelen:1000
| RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
|
| wlan0:avahi Link encap:Ethernet HWaddr 90:4c:e5:37:e2:c5
| inet addr:169.254.11.29 Bcast:169.254.255.255 Mask:255.255.0.0
| UP BROADCAST MULTICAST MTU:1500 Metric:1

the output of "iwlist wlan0 scan" is fairly long, so it's at http://pastebin.ca/1945985 .

"dhclient" (with the appropriate SSID) says:

| Internet Systems Consortium DHCP Client V3.1.3
| Copyright 2004-2009 Internet Systems Consortium.
| All rights reserved.
| For info, please visit https://www.isc.org/software/dhcp/
|
| Listening on LPF/wlan0/90:4c:e5:37:e2:c5
| Sending on LPF/wlan0/90:4c:e5:37:e2:c5
| Listening on LPF/eth0/00:26:9e:bf:c1:1d
| Sending on LPF/eth0/00:26:9e:bf:c1:1d
| Sending on Socket/fallback
| DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
| DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 5
| DHCPOFFER of 192.168.2.12 from 192.168.2.1
| DHCPREQUEST of 192.168.2.12 on eth0 to 255.255.255.255 port 67
| DHCPACK of 192.168.2.12 from 192.168.2.1
| bound to 192.168.2.12 -- renewal in 2147483648 seconds.

/etc/network/interfaces contains:

| # The loopback network interface
| auto lo
| iface lo inet loopback
|
| # The primary network interface
| allow-hotplug eth0
| iface eth0 inet dhcp

/etc/resolv.conf:

| nameserver 192.168.2.1

"lsmod" gives a bunch of output. But since I don't know which bit is
relevant for our purposes, I'll omit it for now.

I hope this info helps. Please let me know if there is anything else I
can do to provide more details and/or point me to sources of what might
be useful in the way of background reading.

Thanks again!

dawgdoc
Level 9
Level 9
Posts: 2743
Joined: Mon Oct 05, 2009 12:53 am
Location: Formerly of Kentucky, the land of Mint Juleps

Re: problem with wireless Ethernet on Compaq Presario CQ61-4

Post by dawgdoc »

I probably overlooked this, but I did not see which version of Mint you are using. If you are using Mint 8, Helena, a fix similar to what you found is HERE, but it is backports for Karmic, which corresponds to Helena. See post # 13.

If you are using Mint 9, Isadora, I found an incomplete reference to slow transfer rate problems with your wireless chipset HERE. It says
I have also installed "Linux-backports-modules-wireless-lucid-generic" which has been reported by some users to fix this
this works for some, but not all.
SYSTEMS:
HP 15-bw0017cl -- Mint 19.3 Cinnamon
Compaq Presario CQ62 -- Mint 17 Cinnamon (support for 80 y/o family members 1st install)
READING:
The Secret of the Ninth Planet by Donald A. Wollheim

linuxluvr
Level 1
Level 1
Posts: 5
Joined: Wed Sep 22, 2010 1:16 pm

Re: problem with wireless Ethernet on Compaq Presario CQ61-4

Post by linuxluvr »

Dawgdoc writes:

> ...If you are using Mint 9, Isadora, I found an incomplete reference
> to slow transfer rate problems with your wireless chipset...

Sorry, I should have said - I am using Isadora, newly installed. I don't
even get a listing of available hosts, so I can't even make a connection.
At this point, I'd be happy to have even a slow connection, though, of
course, fast is better. :)

Thanks for the reply!

linuxluvr
Level 1
Level 1
Posts: 5
Joined: Wed Sep 22, 2010 1:16 pm

Re: problem with wireless Ethernet on Compaq Presario CQ61-4

Post by linuxluvr »

The problem is now solved, thanks to the assistance of Marco Braida, who replied to a copy of this posting I placed in an Ubuntu forum:

https://answers.launchpad.net/ubuntu/+question/126770/

Please see that forum for a description of the procedure I followed, which Marco suggested. Just after the problem was solved, another mostly-unrelated one emerged, which is described toward the end of the thread. However that issue was ancillary to my main problem, though it was quite vexing while it lasted.

dawgdoc
Level 9
Level 9
Posts: 2743
Joined: Mon Oct 05, 2009 12:53 am
Location: Formerly of Kentucky, the land of Mint Juleps

Re: problem with wireless Ethernet on Compaq Presario CQ61-4

Post by dawgdoc »

It pays that you are persistent in searching and not impatient. That was just posted and would not have been found by either of us when you first requested help.

I am glad you have it working now.
SYSTEMS:
HP 15-bw0017cl -- Mint 19.3 Cinnamon
Compaq Presario CQ62 -- Mint 17 Cinnamon (support for 80 y/o family members 1st install)
READING:
The Secret of the Ninth Planet by Donald A. Wollheim

Post Reply

Return to “Wireless”