Enable wireless by default?

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
Eric
Level 1
Level 1
Posts: 13
Joined: Mon Dec 07, 2009 9:10 pm

Enable wireless by default?

Post by Eric » Sat Oct 23, 2010 9:22 pm

I just installed Mint 10 and now every time I turn on my laptop, I have to right-click the network icon on the taskbar and select "Enable Wireless." Then everything works fine. Is there anyway I can save myself this process and just have it enabled by default? I didn't have this problem with previous versions of Linux Mint.

Thanks for the help.

User avatar
tdockery97
Level 14
Level 14
Posts: 5064
Joined: Sun Jan 10, 2010 8:54 am
Location: Salem, Oregon
Contact:

Re: Enable wireless by default?

Post by tdockery97 » Sun Oct 24, 2010 12:04 am

When you right-click on the network icon and select edit connections, and then select your wireless and press edit, is there a box near the top left of the next window that needs to be checked for automatically connect?
Mint Cinnamon 19.1

Eric
Level 1
Level 1
Posts: 13
Joined: Mon Dec 07, 2009 9:10 pm

Re: Enable wireless by default?

Post by Eric » Sun Oct 24, 2010 2:36 am

It automatically connects to the wireless network, I just have to right-click on the network icon and enable wireless first every time I turn on the computer.

User avatar
tdockery97
Level 14
Level 14
Posts: 5064
Joined: Sun Jan 10, 2010 8:54 am
Location: Salem, Oregon
Contact:

Re: Enable wireless by default?

Post by tdockery97 » Sun Oct 24, 2010 2:54 am

That's strange. Hopefully someone will come along who knows what config file that is controlled by.
Mint Cinnamon 19.1

pdjetlic
Level 1
Level 1
Posts: 4
Joined: Mon Aug 16, 2010 12:03 pm

Re: Enable wireless by default?

Post by pdjetlic » Mon Nov 29, 2010 9:17 am

Exact same problem here, everything works but i have to enable wireless manually at every startup.
Mint Julia on a Lenovo S12. Maybe its the Broadcom drivers but they worked fine on Mint 9.

marcdilnutt
Level 1
Level 1
Posts: 46
Joined: Wed Sep 16, 2009 5:57 am

Re: Enable wireless by default?

Post by marcdilnutt » Tue Nov 30, 2010 3:36 am

I have the same problem with Mint 9. Never had it before but reinstalled with the same .iso which was working previously, now every time I start the machine up I need to manually enable wireless. 'Tis very strange.

FYI I am using an Acer AspireOne 531H with Atheros 5700 card.

pdjetlic
Level 1
Level 1
Posts: 4
Joined: Mon Aug 16, 2010 12:03 pm

Re: Enable wireless by default?

Post by pdjetlic » Tue Nov 30, 2010 2:33 pm

Maybe there has been a change in broadcom drivers.
Is there a simple way of trying older versions of wireless drivers?

cmedina
Level 1
Level 1
Posts: 3
Joined: Tue Nov 16, 2010 6:08 pm

Re: Enable wireless by default?

Post by cmedina » Sat Dec 11, 2010 1:01 am

Hi. This is what I did and it is working for me now:

Just open /etc/rc.local with gedit (newbies: open a terminal and type sudo gedit /etc/rc.local) and copy/paste the following line:

Code: Select all

dbus-send --system --type=method_call --dest=org.freedesktop.NetworkManager /org/freedesktop/NetworkManager org.freedesktop.DBus.Properties.Set string:org.freedesktop.NetworkManager string:WirelessEnabled variant:boolean:true
This is an equivalent command as right-clicking 'Enable Wireless' on NetworkManager. Newbies (like me) Remember to insert this command after the commented lines on this file and before exit 0

This is my first contribution to this great community. Just changed from Window$ about a month ago and everything I was using before there is all set here in Linux and never going back... I love mint!

User avatar
rivenathos
Level 6
Level 6
Posts: 1072
Joined: Wed May 06, 2009 7:32 am
Location: USA

Re: Enable wireless by default?

Post by rivenathos » Sat Dec 11, 2010 7:15 am

One thing I have noted previously in regards to this issue is when the computer is set to boot automatically and skip the password screen, that sometimes keeps the wireless from automatically connecting. In the wireless section, putting a check in the box to allow all users seems to be one fix. It is worth a shot to see if it works for you.
Current hardware: a Dell OptiPlex 3010 desktop, a Dell Inspiron 531 desktop, and a Dell Inspiron 1545 laptop.
Current OS: LMDE 3

patnaik7
Level 1
Level 1
Posts: 8
Joined: Thu Dec 23, 2010 11:52 am

Re: Enable wireless by default?

Post by patnaik7 » Thu Dec 30, 2010 5:18 am

cmedina wrote:Hi. This is what I did and it is working for me now:

Just open /etc/rc.local with gedit (newbies: open a terminal and type sudo gedit /etc/rc.local) and copy/paste the following line:

Code: Select all

dbus-send --system --type=method_call --dest=org.freedesktop.NetworkManager /org/freedesktop/NetworkManager org.freedesktop.DBus.Properties.Set string:org.freedesktop.NetworkManager string:WirelessEnabled variant:boolean:true
This is an equivalent command as right-clicking 'Enable Wireless' on NetworkManager. Newbies (like me) Remember to insert this command after the commented lines on this file and before exit 0

This is my first contribution to this great community. Just changed from Window$ about a month ago and everything I was using before there is all set here in Linux and never going back... I love mint!
This is it...finally wireless auto connects after reboot. Thanks a million cmedina :D

Post Reply

Return to “Wireless”