Buffalo Air Station PCMCIA wireless Not working completely

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 1
Joined: Sun Jan 07, 2007 8:40 am

Buffalo Air Station PCMCIA wireless Not working completely

Post by LeCrow »

Lspci -n results:
03:00.0 0280: 14e4:4318 (rev 02)

Lspci results:
03:00.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)

If I install one of the drivers from the Buffalo CD ndisgtk will say that the HW is present when the card is inserted and the opposite when its not so I know its seeing the card, but I still get nothing from my card, no lights or activity of any kind. Found one other driver on the web that reacts the same way, the card works great in windows, which is really disappointing I might add, but that tells me its not my hardware.

I dont know what else to try, i even tried using ndiswrapper to link the driver with the PCI ID, the command was successfull, it said that the driver was being used for the 14e4:4318 PCI ID, but still nothing from my card. I dont understand why according to linux it should be working fine, but its not.


User avatar
Level 12
Level 12
Posts: 4147
Joined: Wed Nov 15, 2006 8:34 am

Post by clem »

Maybe it is working fine and you just need to configure it... did you try to set the essid via iwconfig and up the interface using ifconfig ??


Level 1
Level 1
Posts: 4
Joined: Sun Feb 11, 2007 12:34 pm

Post by FreakShow! »


I have a similar card and using Ndiswrapper installed the correct driver. The lights on the card are off, and the device manager has the card installed as a broadcom device.

Also, the network icon says there are nonetwork devices installed.

What setting up is required? Do I need to input information about DNS Servers and the like?

EDIT: If you still need help then follow this guide. It's from Ubuntu Forums, but I doubt there will be any differences really.

It worked straight off even though it complained about not understanding what version I was using :D

Post Reply

Return to “Wireless”