Wireless disabled on startup

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
phishsauce
Level 1
Level 1
Posts: 20
Joined: Tue Jan 04, 2011 7:18 pm

Wireless disabled on startup

Post by phishsauce » Tue Jan 04, 2011 7:28 pm

Hey Everyone,

I am experiencing a problem in which my wireless is disabled on start up. Once I am into the network, I am able to just click on the network icon in the tray and click Enable wireless and it turns on.

I searched around these boards quite a bit and found something about rfkill, and do do rfkill unblock all or unblock wifi. I tried this and when I run that command it disables my wireless but it is still blocked.

The result of my rfkill list command is

Code: Select all

0: acer-wireless: Wireless LAN
	Soft blocked: yes
	Hard blocked: no
1: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
and my wireless card reading from lspci is

Code: Select all

04:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g LP-PHY (rev 01)
The wireless works perfectly fine once I enable it, its just on start up it is disabled (apparently blocked by something).

Can anyone shed some light on what is causing this problem?

Thanks

PS: Here is the result of running the mintWifi script incase it contains any useful info..

Code: Select all


-------------------------
* I. scanning WIFI PCI devices...
  -- Broadcom Corporation BCM4313 802.11b/g LP-PHY (rev 01)
      ==> PCI ID = 14e4:4727 (rev 01)
-------------------------
* II. querying ndiswrapper...
-------------------------
* III. querying iwconfig...
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      IEEE 802.11  ESSID:"mhmmm"  
          Mode:Managed  Frequency:2.427 GHz  Access Point: 00:18:E7:CB:C2:30   
          Bit Rate=1 Mb/s   Tx-Power:24 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=5/5  Signal level=-20 dBm  Noise level=-89 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

vboxnet0  no wireless extensions.

-------------------------
* IV. querying ifconfig...
eth0      Link encap:Ethernet  HWaddr 5c:ff:35:07:99:5c  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:46 

eth1      Link encap:Ethernet  HWaddr 00:26:82:98:ec:2a  
          inet addr:192.168.0.194  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::226:82ff:fe98:ec2a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:9867 errors:0 dropped:0 overruns:0 frame:272373
          TX packets:8700 errors:72 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:9002161 (9.0 MB)  TX bytes:1569744 (1.5 MB)
          Interrupt:17 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:3264 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3264 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:284424 (284.4 KB)  TX bytes:284424 (284.4 KB)

-------------------------
* V. querying DHCP...
Internet Systems Consortium DHCP Client V3.1.3
Copyright 2004-2009 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/vboxnet0/0a:00:27:00:00:00
Sending on   LPF/vboxnet0/0a:00:27:00:00:00
Listening on LPF/eth0/5c:ff:35:07:99:5c
Sending on   LPF/eth0/5c:ff:35:07:99:5c
Listening on LPF/eth1/00:26:82:98:ec:2a
Sending on   LPF/eth1/00:26:82:98:ec:2a
Sending on   Socket/fallback
DHCPDISCOVER on vboxnet0 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 3
DHCPOFFER of 192.168.0.194 from 192.168.0.1
DHCPREQUEST of 192.168.0.194 on eth1 to 255.255.255.255 port 67
DHCPACK of 192.168.0.194 from 192.168.0.1
bound to 192.168.0.194 -- renewal in 40304 seconds.
-------------------------
* VI. querying nslookup google.com...
Server:		192.168.0.1
Address:	192.168.0.1#53

Non-authoritative answer:
Name:	google.com
Address: 173.194.43.104

phishsauce
Level 1
Level 1
Posts: 20
Joined: Tue Jan 04, 2011 7:18 pm

Re: Wireless disabled on startup

Post by phishsauce » Thu Jan 06, 2011 12:53 pm

For the sanctity of other, I did find a work around to this problem.. however I would not consider it a solution as it doesn't explain why it is not working the first place.

I found this on: http://forums.linuxmint.com/viewtopic.php?f=53&t=58107

I basically just added

Code: Select all

dbus-send --system --type=method_call --dest=org.freedesktop.NetworkManager /org/freedesktop/NetworkManager org.freedesktop.DBus.Properties.Set string:org.freedesktop.NetworkManager string:WirelessEnabled variant:boolean:true
to /etc/rc.local, and it apparently is "like" enabling the wireless once start up has occurred.

It would be really interesting to know what is causing this in the first place, but since I implemented this work around, I haven't noticed any problems.

myrjon1
Level 2
Level 2
Posts: 60
Joined: Thu Dec 23, 2010 10:07 am

Re: Wireless disabled on startup

Post by myrjon1 » Thu Jan 06, 2011 10:30 pm

this sounds like the very same problem I had. in tray click on wireless icon right click-edit connections-wireless-click on your network name-edit (on right)````````````````````under connections click on connect automatic.hope this was :arrow: your problem/chris

phishsauce
Level 1
Level 1
Posts: 20
Joined: Tue Jan 04, 2011 7:18 pm

Re: Wireless disabled on startup

Post by phishsauce » Sat Jan 15, 2011 3:21 pm

It wasnt a question of connecting automatically.. the problem was that the wireless was actually disabled entirely. I had to enable it and then find and connect to my network.

gartenschlauch
Level 1
Level 1
Posts: 1
Joined: Tue Feb 15, 2011 6:29 pm

Re: Wireless disabled on startup

Post by gartenschlauch » Tue Feb 15, 2011 6:36 pm

i had the same problem as you and fixed it with your workaround, thank your for this!

Post Reply

Return to “Wireless”