Network "not managed" after hibernation

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
nemarona
Level 1
Level 1
Posts: 8
Joined: Tue Jan 18, 2011 10:08 am

Network "not managed" after hibernation

Post by nemarona »

Hi all. I'm running Linux Mint 9 KDE on a HP 6735s laptop. Wired internet connection worked out of the box; for wireless I had to install some propietary wireless drivers (Broadcom) before I could connect to my home wifi.
Last night the laptop stayed on while running on batteries, and it eventually shut itself down when the batteries ran out. Today I have no connectivity whatsoever; not wired, not wireless. The network tray icon says "not managed".
There are a couple of suggestions in the Forums (one about modyfing /etc/NetworkManager/nm-system-settings.conf and the other about /etc/network/interfaces), but none solved my problem.
Any help would be greatly appreciated!
nemarona
Level 1
Level 1
Posts: 8
Joined: Tue Jan 18, 2011 10:08 am

Re: Network "not managed" after hibernation

Post by nemarona »

Here's the output to /usr/lib/linuxmint/mintWifi/mintWifi.py:

Code: Select all

sudo /usr/lib/linuxmint/mintWifi/mintWifi.py 
-------------------------
* I. scanning WIFI PCI devices...
-------------------------
* II. querying ndiswrapper...
-------------------------
* III. querying iwconfig...
lo        no wireless extensions.

eth0      no wireless extensions.

-------------------------
* IV. querying ifconfig...
eth0      Link encap:Ethernet  direcciónHW 00:24:81:4b:98:8e  
          ACTIVO DIFUSIÓN MULTICAST  MTU:1500  Métrica:1
          Paquetes RX:0 errores:0 perdidos:0 overruns:0 frame:0
          Paquetes TX:0 errores:0 perdidos:0 overruns:0 carrier:0
          colisiones:0 long.colaTX:1000 
          Bytes RX:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupción:16 

eth0:avahi Link encap:Ethernet  direcciónHW 00:24:81:4b:98:8e  
          Direc. inet:169.254.8.46  Difus.:169.254.255.255  Másc:255.255.0.0
          ACTIVO DIFUSIÓN MULTICAST  MTU:1500  Métrica:1
          Interrupción:16 

lo        Link encap:Bucle local  
          Direc. inet:127.0.0.1  Másc:255.0.0.0
          Dirección inet6: ::1/128 Alcance:Anfitrión
          ACTIVO BUCLE FUNCIONANDO  MTU:16436  Métrica:1
          Paquetes RX:1292 errores:0 perdidos:0 overruns:0 frame:0
          Paquetes TX:1292 errores:0 perdidos:0 overruns:0 carrier:0
          colisiones:0 long.colaTX:0 
          Bytes RX:99388 (99.3 KB)  TX bytes:99388 (99.3 KB)

-------------------------
* V. querying DHCP...
There is already a pid file /var/run/dhclient.pid with pid 2070
killed old client process, removed PID file
Internet Systems Consortium DHCP Client V3.1.3
Copyright 2004-2009 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/eth0/00:24:81:4b:98:8e
Sending on   LPF/eth0/00:24:81:4b:98:8e
Sending on   Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 9
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 15
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 19
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
-------------------------
* VI. querying nslookup google.com...
;; connection timed out; no servers could be reached
dungbeetle
Level 1
Level 1
Posts: 41
Joined: Mon Dec 03, 2007 2:10 pm
Location: Lincolnshire, England
Contact:

Re: Network "not managed" after hibernation

Post by dungbeetle »

This may sound elemetary, but have you checked if your wifi is switched on? If your battery ran down completely, the wifi card may need to be re-activated either by a switch or by something like Fn +F9 on the keyboard.
PCSpecialist Lafite ultrabook with Skybridge i5
nemarona
Level 1
Level 1
Posts: 8
Joined: Tue Jan 18, 2011 10:08 am

Re: Network "not managed" after hibernation

Post by nemarona »

The wifi is switched on/off by a button that turns blue when activated. The button is orange right now, and pressing it has no effect. When I boot into Windows it turns blue automatically.
dungbeetle
Level 1
Level 1
Posts: 41
Joined: Mon Dec 03, 2007 2:10 pm
Location: Lincolnshire, England
Contact:

Re: Network "not managed" after hibernation

Post by dungbeetle »

Just re-read your first post and realise that your wired connection is also no longer working. I also had this problem which appeared to be related to Networkmanager in my case, and installing wicd resolved matters. Not sure if that would help you though. I see now that you have posted in my thread on that problem. Maybe someone else will have a different solution.
PCSpecialist Lafite ultrabook with Skybridge i5
nemarona
Level 1
Level 1
Posts: 8
Joined: Tue Jan 18, 2011 10:08 am

Re: Network "not managed" after hibernation

Post by nemarona »

I managed to install wicd (which is rather cumbersome without an Internet connection, because one must care about the dependencies), but it found no wifi networks. Haven't tried yet if wired connection works with wicd. As far as I can see, the problem is not knetworkmanager, but the fact that somehow networking is not "turned on" while booting Linux.
dungbeetle
Level 1
Level 1
Posts: 41
Joined: Mon Dec 03, 2007 2:10 pm
Location: Lincolnshire, England
Contact:

Re: Network "not managed" after hibernation

Post by dungbeetle »

I seem to remember that wicd used to remove all of network manager and it's config files once upon a time, but I had to manually find them and remove them in order to get wicd to work. I also seem to remember having to reboot after cleaning out the dross network manager left behind. Make sure wicd-daemon is running.
PCSpecialist Lafite ultrabook with Skybridge i5
nemarona
Level 1
Level 1
Posts: 8
Joined: Tue Jan 18, 2011 10:08 am

Re: Network "not managed" after hibernation

Post by nemarona »

Here's the solution that worked for me:
http://www.linuxquestions.org/questions ... on-857073/
dungbeetle
Level 1
Level 1
Posts: 41
Joined: Mon Dec 03, 2007 2:10 pm
Location: Lincolnshire, England
Contact:

Re: Network "not managed" after hibernation

Post by dungbeetle »

Interesting idea. As a matter of interest, are you now using wicd or networkmanager?
PCSpecialist Lafite ultrabook with Skybridge i5
nemarona
Level 1
Level 1
Posts: 8
Joined: Tue Jan 18, 2011 10:08 am

Re: Network "not managed" after hibernation

Post by nemarona »

I tried wicd, but it made no difference regarding my problem. Now I'm back with knetworkmanager again.
dungbeetle
Level 1
Level 1
Posts: 41
Joined: Mon Dec 03, 2007 2:10 pm
Location: Lincolnshire, England
Contact:

Re: Network "not managed" after hibernation

Post by dungbeetle »

OK, it would be interesting to see if the problem and fix were both re-producable.
PCSpecialist Lafite ultrabook with Skybridge i5
Post Reply

Return to “Wireless”