Problems with wi fi after standby

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
geocarneiro
Level 1
Level 1
Posts: 3
Joined: Fri May 27, 2011 2:35 pm

Problems with wi fi after standby

Post by geocarneiro »

Hello, I am a new linux user (started using linux mint 10, 4 days ago). I had some problems (because is the first time i'm not using windows) but I was able to fix almost all of them searching in other forums. The only problem is not fixed yet is the wireless conection. Everytime I put the computer on standby for more then 5 minutes, when it comes back the wireless conection is not working. So, I followed some instructions I found, and I would like to know if someone think I did something wrong, or if someone knows if there is another better way to do the things to fix this problem.
These were my actions, following other forums instructions:
To identify the wireless chipset i did

Code: Select all

lspci | grep -i wireless
The output was 'Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)'.
After that, I created a file, '11-iwl3945.sh' with the following code:

Code: Select all

case $1 in
hibernate)
/sbin/modprobe -r iwl3945
;;
suspend)
/sbin/modprobe -r iwl3945
;;
resume)
/sbin/modprobe iwl3945
;;
thaw)
/sbin/modprobe iwl3945
;;
esac
After that I put it on the folder '/etc/pm/sleep.d', and then run the following code:

Code: Select all

sudo chmod +x '/etc/pm/sleep.d/11_iwl3945.sh' 
So I restarted the computer, and put on standby to see if it was working (and it aparently worked once, but i think it was because i left it on standby just for 2 minutes. Finally, I left the computer on standby for 20 minutes and it didn't work.

rdonnelly
Level 5
Level 5
Posts: 527
Joined: Thu Nov 27, 2008 9:38 pm

Re: Problems with wi fi after standby

Post by rdonnelly »

Had the same problem, this is what I had to do for a work around.

http://forums.debian.net/viewtopic.php? ... 7&start=15
Using Mint since 2008
*Mint 18.2 KDE
*ASUS 970 PRO GAMING/AURA AM3+ AMD 970 + SB 950 SATA 6Gb/s USB 3.1
*AMD FX-8370 with AMD Wraith cooler Vishera 8-Core 4.0 GHz (4.3 GHz Turbo)
*G.SKILL Ripjaws X Series 16GB DDR3 SDRAM
*nVIDIA GEFORCE GT 610 2GB

geocarneiro
Level 1
Level 1
Posts: 3
Joined: Fri May 27, 2011 2:35 pm

Re: Problems with wi fi after standby

Post by geocarneiro »

Thanks for the post. Basically, that is what I did previously. I used these two posts, but until now wireless is not working when i put the computer on standby / awake.
http://ubuntuforums.org/showthread.php?t=1469609
http://forums.debian.net/viewtopic.php? ... 7&start=15
I also tried to intall the drivers that I used with windows vista, but then the wireless conection didn't work at all.
As it worked for other people, I just thought that the code I wrote has some mistakenly wrong text. But also the following code didn't work.

Code: Select all

su
modprobe -r iwl3945
modprobe iwl3945
So I think that, if there is a solution for this, it should be another way. In other forums, the instructions are to install another network manager, but I don't now how to come back to the previous one if it doesn't work.

geocarneiro
Level 1
Level 1
Posts: 3
Joined: Fri May 27, 2011 2:35 pm

Re: Problems with wi fi after standby

Post by geocarneiro »

It seems to be working now! I've installed another package (linux-backports-modules-compat-wireless-2.6.36-2.6.35-28-generic-pae) following another forum. I let my computer on standby for more then 12 hours and the wireless is working perfectly now. http://forum.ubuntuusers.de/topic/kein- ... l-corpora/

rdonnelly
Level 5
Level 5
Posts: 527
Joined: Thu Nov 27, 2008 9:38 pm

Re: Problems with wi fi after standby

Post by rdonnelly »

[SOLVED] :mrgreen:
Using Mint since 2008
*Mint 18.2 KDE
*ASUS 970 PRO GAMING/AURA AM3+ AMD 970 + SB 950 SATA 6Gb/s USB 3.1
*AMD FX-8370 with AMD Wraith cooler Vishera 8-Core 4.0 GHz (4.3 GHz Turbo)
*G.SKILL Ripjaws X Series 16GB DDR3 SDRAM
*nVIDIA GEFORCE GT 610 2GB

beatink
Level 1
Level 1
Posts: 24
Joined: Thu May 26, 2011 7:10 pm

Re: Problems with wi fi after standby

Post by beatink »

I've got the same problem on our Acer Aspire laptop. Installed the (linux-backports-modules-compat-wireless-2.6.36-2.6.35-28-generic-pae) package. Initially appeared to do the trick, but after leaving the laptop in suspend mode overnight, it couldn't connect to the Internet again this morning. The wireless connection re-establishes no problem, but the browser session times out - complaining that it can't find the DNS server. I tried with the static DNS server IP addresses defined for the IPv4 settings for the wireless connection, but that hasn't fixed the problem either.

User avatar
AdamS
Level 5
Level 5
Posts: 508
Joined: Sat May 28, 2011 10:47 pm
Location: Hinckley Utah USA

Re: Problems with wi fi after standby

Post by AdamS »

It really is advisable to NOT use standby.

Very hard on ram and the system and rarely works every time.

It really is advisable to just shut it down, done right Linux has a 41 to 46 second boot to use as it is.
Proud owner of a 99.5 % Linux based Pc - laptop - netbook - tablet - networking business.
Do your self a favor, stop paying for imperfection. Once you know Linux, you never go back.

beatink
Level 1
Level 1
Posts: 24
Joined: Thu May 26, 2011 7:10 pm

Re: Problems with wi fi after standby

Post by beatink »

I did see some other comments that Suspend is not a reliable feature with Linux Mint. I tried Hibernate but doesn't really seem much faster than Shutdown. Bit disappointing.

rdonnelly
Level 5
Level 5
Posts: 527
Joined: Thu Nov 27, 2008 9:38 pm

Re: Problems with wi fi after standby

Post by rdonnelly »

Gúrú Linux ríomhaire wrote:It really is advisable to NOT use standby.

Very hard on ram and the system and rarely works every time.

It really is advisable to just shut it down, done right Linux has a 41 to 46 second boot to use as it is.
What about the time to start up apps that you normally have open, such as email, browser, windoze in a virutualbox, plus what ever is running in that box. My suspend works fine, and when it is not, I only put the display to sleep and leave the CPU running.
Using Mint since 2008
*Mint 18.2 KDE
*ASUS 970 PRO GAMING/AURA AM3+ AMD 970 + SB 950 SATA 6Gb/s USB 3.1
*AMD FX-8370 with AMD Wraith cooler Vishera 8-Core 4.0 GHz (4.3 GHz Turbo)
*G.SKILL Ripjaws X Series 16GB DDR3 SDRAM
*nVIDIA GEFORCE GT 610 2GB

Post Reply

Return to “Wireless”