no window-borders after login

Forum rules
Before you post please read how to get help
Post Reply
nadir
Level 3
Level 3
Posts: 142
Joined: Fri Oct 02, 2009 2:25 pm

no window-borders after login

Post by nadir »

its easy to explain: it looks the same if compiz didnt start correctly, i run metacity --replace & and i get my borders. The funny part is: i aint running compiz (thats what appereance, effects say).
Where may i configure that/ solve that little problem?
thanks
User avatar
Kaye
Level 5
Level 5
Posts: 933
Joined: Fri Feb 06, 2009 5:05 pm
Location: Boston College
Contact:

Re: no window-borders after login

Post by Kaye »

Without more information it'll be hard to actually fix the problem. But you could always add metacity --replace & as a startup program so you don't have to do it yourself.
"In somnis veritas"
Antivirus or defragging?
Image
User avatar
DrHu
Level 17
Level 17
Posts: 7522
Joined: Wed Jun 17, 2009 8:20 pm

Re: no window-borders after login

Post by DrHu »

nadir wrote:The funny part is: i aint running compiz (thats what appereance, effects say).
Does mint menu>Control center>Look and feel>Simple compiz config setup
  • --show as [ ] None
--means no compiz settings are being run
Also I would check the full Compiz settings manager applications
mint menu>Control center>Look and feel>compiz Settings manager>Effects TAB

Check compiz functionality, even if no effects are being run
In terminal, check
  • compiz --check
Linux mint 7 (gloria) main edition (Gnome desktop)
In terminal, check
  • apt search compiz
    i compiz-gnome - OpenGL window and compositing manager - GN
    i compiz-plugins - OpenGL window and compositing manager - pl
    i compiz-wrapper - OpenGL window and compositing manager, wra
    i compizconfig-backend-gconf - Settings library for plugins - OpenComposi
    i compizconfig-settings-manager - Compiz configuration settings manager
nadir
Level 3
Level 3
Posts: 142
Joined: Fri Oct 02, 2009 2:25 pm

Re: no window-borders after login

Post by nadir »

Dr.Hu:
Does mint menu>Control center>Look and feel>Simple compiz config setup

--show as [ ] None
under the first tab (info) its shown as none.

compiz-config-settings-manager looks like a fully configured compiz.

compiz --check:

Code: Select all

xepanche@xepanche-desktop ~ $ compiz --check
Checking for Xgl: not present. 
xset q doesn't reveal the location of the log file. Using fallback /var/log/Xorg.0.log 
No whitelisted driver found
aborting and using fallback: /usr/bin/metacity 
metacity: Unknown option --check
--
Kaye:
mh, more info: i couldnt think of what one would need... let me know and i`ll post it.
adding the command to autostart might be a choice, but samewise i could run it manually.
--
Im pretty sure that it also works if i login for a second time.
I think i`ll try removing all the compiz-stuff now...

yes its:
Linux mint 7 (gloria) main edition (Gnome desktop)

thanks
Post Reply

Return to “MATE”